Introduction for DOPSoft V2.00.04 new
function




AISELTJI Change Default Screen for DOP-B and DOP-W

O Meter

M ® Multiple Colors
M ® Adjustable Scales

There is

®Target Line
®Low Range

@®High Range

and it could be
variables
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4\ nELTA Multi-Language Setting

M Multi-language is only support DOP-W Series.

i Into Options > Multi-Lang Setting, enable this function and select wanted
language. Also create Input > Multi-Lang Input element, after download then it
could use this function.

M Multi-Language is not support online and offline simulators.

IGptionsI wWindow Help
Configuration ...
= ]
Communication Setting Q Button R
A Setup &R Meter
etors . . N B0 Bar »
Password setting ﬁ P1p3 »
Tag Table ...
_ Ch Pie »
Print Typesetting .. [¥] Enable P
Sound Setting Q' Indicater ’
Support Langs .
Real Time Clock Setting 6 13 Display r
Video Lists Cutput Setting English l:‘ Japan D Spanish é G-raphic *

I hiulti-Lang Setting I I:‘ Traditional Chinsze |ﬁ Iﬂput I |ﬁ Numeric Entry
HMI Identifier Setting o . h -
Global KeyPad Setting ] Simplified Chinese Curve *|[A& Character Entry
FileSlot File Mhianagement I:‘ French W‘ Samphng 4 Eig
DewviceTable D Gierman -‘IE.- Alarm 3
Recipe [7] Russian B Keypad 4
32 bits recipe »

Enhanced Recipe [T Hebrew 3 Analog

= »
Picture Bank List
Text Bank [_LI Frame »
Submacro {% Bazic Shape »
Initial MAacro @ Drawing »
Background Niacro Multimedi »
Clock hiacro Multimedia

Enviromment
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A\ nELTA ffmpeg Tool

M ffmpeg tool only support at Video element with DOP-W.

M User could via export video to USB and SD, and then set resolutions with
default 320x240. The resolution is support to 640x480.

M Video elements support format is WMV.

Video List
m Save Iml Video Name Source Add
1 USBE 9600 DOHMIWAV file\ 9600, wmv
2 |uss 115200 D EIMIWMYV file' 115200 wmv
3 UsB Timer D HMIWMV filel Timer wmv
4 UsBE Toml D HMIVWILY file! Tom1 wmv
3 USE Tom2 D HMWIWMV file! Tom2 wmv
6 USB iPad E:MOV02418 wmv
Movie resclution setting
Width 320
Height 240
| oK ] [ Cancel ]
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AMELTA Historical Overview Table

M Select Element > Sampling > Historical Overview Table

IEIemerrtl Screen Tools Options ‘Window Help
@ Button B 2 Q [100% |t
Eh Meter
0 Bar
=] Pipe
£ Pie

0 Indicator
e Display
E Graphic
N Input

Curve
A" Sampling W Historical Trend Graph

& Alam I Historical Data Table

B Keypad = Historical Event Table

I Anatog

E& List

m Frame

£ Basic Shape

»@ Drawing
Multimedia

@432

T v w w ¥ W v w v

.P‘ Historical Owverview Table

v v w v W W w v
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AlsELTa Historical Overview Table

K Historical Overview Table is only different that it has file browser
and function button to operate and view passed history data with
History Trend Graph.

in Text Details Coordinates

File Browser f File ElrowserFunciunE_ Trend Graph Funciuna_

MUup [¥] Previous

[¥] Down [¥] Forward

[ Page Up [[]Page Prev.
[C] Page Down [ Page Fwd.
@] View [¥] Expand Switch

| o [[oom [ ver | ] e [ o SRR
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Al\ELTA Historical Overview Table

M Historical Overview Table provide Save as Multi-page
and Savmg Trigger functlon

el Only set Non-volatile
Sl bt to USB Disk or SD, then
Addres could use Save as Multi-
5100 () | @Nonvolie [USBDik o page function
TeeLacn T :} Auto Stop
Sample Number 10 [lEsport CSVEile |  FieldName |
Trigger () Save As Single
| Timer -| File Nare (0001 |
® sapiocyto a T . : When Saving Trigger
I i o o is on, no matter sample
Nowe o | A | L A number achieve or not,
Fie Time i FC it will save history data
S Timend e (T YRR CER | | immediately.
TieFormat  |thamss < File Name HO001
Date Format (mmddyy Saving Trigzer  None miL .
EES
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A AELTA

M Enhance Recipe supported data type is Word or Double Word and its data format can be BCD, Signed Decimal,
Unsigned Decimal, Hex, Floating and Char.

M The read length of Char format can up to 32 Words ( is equal to 64 bits).

| )

Enhance Recipe

p
Configuration ‘

Control Block

Control Address  {Link2}1@D0

[

Status Block

Status Address  {Link2}1@D10

[7] Screen No || General Control
[7] General Control [7] Serzen No
[7] Curve Control [7] Curve Control
[ Sampling History Buffer [ Sampling History Buffer
[ Clearing History Buffer [ Clearing History Buffer | L-Ef%th
Default [C] Recipe Control [C] Recipe Control
5& [7] Recipe Group Number [C] Recipe Group Number 1
[l LIEE [] System Control [7] System Control
@ Enhanced Recipe Control DO Enhanced Recipe Control D10 2
Netwaork App Enhanced Recipe Group NuD1 Enhanced Recipe Group M1 D11
Sample time 300 55 (me)
[7] Auto Reset Flags
Memory Format Unsigned Decimal

J |
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A\ nELTA Enhance Recipe

M Enhance recipe has its own register, including ENRCP, ENRCPNO, ENRCPG and *ENRCP.

ENRCP- Enhance recipe register-

ENRCPNO+ Enhance recipe number registers

ENRCPG- Enhance recipe group registers

*ENRCP+< | Enhance indirect recipe index register- |

Jlj 5 | B% |[s10000 > ([7)|usB Disk -

Il | Bl-3x3 |B2-5x10
Groups | 13 ’ < Back ] [ Forward > ]
| Unsigned Decimal| ~ Floating |  Hexadecimal | Char Signed Decimal
1 Word 2 Word 1 Word 10 Word 1 Word

1 65335 25363.95 ABCD Delta 25368
2 12336 12345.88 FFF Tinz 1380
3 33680 §852.12 cc Daisy 32768
4 6580 99999 99 DD Ray 32767
5 41562 14785.23 EE Lanturn 12345

M It also provide EXENRCP  IMENRCP macro to import and export enhance recipe.
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A AELTA

¥ Provide HMI Identifier to protect HMI and screen data.
¥ Download HMI Identifier is only download HMI Machine ID.

¥ Download all data is only download Screen Machine ID.
eleafiMachine ID data.

Machine ID

Enable Protection

&

‘}urwnlmd HMI Identifie

S5

¥ Only execute Reset HMI ¢

Delta Confidential

Options | Window Help

Configuration ...

Commumnication Setting

Alarm Setup

History Buffer Sstup ...
Password setting

Tag Table ...

Print Typesetting ..
Sound Setting

Reeal Time Clock Setting

Wideo Lists Output Setting
Miulti-Lane Setting

HDNAT Identifier Setting

Global EewPad Setting

FileSlot File Nanagement
Drevice Table

Recipe

32 bits recipe

Enhanced Fecipe

Picturs Banlk

Text Bank
Submacro

Initial Mhiacro
Background Mhiacro
Clock Mhwiacro

Envircnment



AlsELTA Machine ID

¥ HMI comparison Machine ID has three rules as below.

» HMI has Machine ID, but not screen, it will display Check HMI Machine ID
Failed 1.

» Screen has Machine ID, but not HMI, it will display Check HMI Machine ID
Failed 2.

» Both have Machine ID, but inconsistent, it will display Check HMI
Machine ID Failed 3.

¥ When download HMI Identifier at HMI default screen, it
will not display any error message like Check HMI
Machine ID Falled
(€)\ NELTA
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Al\ELTA Boot Screen file

M Select Options > Configuration > Default, it could change Power on screen file.

" ™
|
& System Default Value
1 Main Power on screen o
Default Format Unsipned Decimal hd
|
B e
Control Block Default Sereen Background Color | |
[=] System Error Display Time 3 = (&)
Print Syztem Key Use Mode Uncheck Password -
_—77‘ System Key Password 12345678
Default System Default Font Verdana -
% [7] Speed up HMI page changing
&
Others
Element Deefault Value
@ Auto wrap text
Metwork App
Test Color I
Seroll Size (if Element has ) |20 pincs -
Sequence of updating value while changing [Updahﬂ.g values, then commurnicatior ]
I | ok || Caneal
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AISELTII Boot Screen file

¥ Power on Screen function do not support as below model type.
B04S211, B05S100, B05S101, B07S201, BO7S211.

i After enable power on screen and select file, users could use Tools >

Download Boot Screen to change boot screen. ——

4 Compile Ctel+E7
i Rebuild All
¥ Oruse Download All data to download boot screen directly. & pemecamom:  currs
¥ After download boot screen, please restart the HMI. o J S
Upload recipe
Download Recipe
: Upload Logic Data
hE LTA Download Boot Screen

@ On-line Simulation Ctri+F4
BY Off Line Simulation Chel+F3

Fimware update
Get Firmovars Information
Resst HMI

Delta Confidential



4\ nELTA Reset Default Logo

¥ Reset Default Logo function do not support as below model type.
B04S211, BO5S100, B0O5S101, BO7S201, BO7S211.

¥ When replaced with HMI boot screen, user could via execute Tools > Reset

default logo to restore HMI to default logo. [FooF] Options Window Help
£ Compile Cte+F7
i After reset default logo, please restart the HMI. Rebid Al

EY Download All Data Ctel+F8
Uplead all Data

E‘ Dowenload Scraen Ctl+F2
Upload recipe
Download Recipe
Uplead Logic Data

c . Download Boot Screen
hE LTA Reeset defanlt logo
@ On-line Simulation Ctr+F4
BE Off Line Simulation Ctel+F3

Fumware update
(zet Firmwars Information
Fe=zet HMI
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A AELTA

M Select Options > Global Keypad Setting, it could set Decimal,
Binary, Hexadecimal, ASCII format keypad.

Delta Confidential

F}ptl'ortsl Window Help

Configuration ...
Communication Setting

Alarm Setup

Hiztory Buffer Setup ...
Pazsword sstting

Tag Table ...

Print Typesatting ..
Sound Setting

F.eal Time Clock Setting
Video Lists Output Setting
Multi-Lang Setting

HMWI Identifier Setting

Global KeyPad Setting_|

FileSlot File Management
DeviceTable

Recipe
32 bits recipe
Enhanced Recipe

Picture Bank
Text Bank

Submacro

Initial Macro
Background Macro
Clock Macro

Environment

Global keypad Settings

~ - = = ™
e D ==
|

Decimal KeyPad Hezxadecimal KeyPad

i@ System Keypad [:] @ System Keypad E

Apply Settings ’ﬁpply MNone - Apply Settings [Apply None -

Binary KeyPad ASCTI KeyPad

i@ System Keypad D @ System Keypad E

Apply Settings ’APPIY None - Apply Settings [Apply None L ]




4\ nELTA Global keypad Settings

KM This function will help users customize keypad style and select
apply to all or apply to new by users edit.

M Select apply to all, means replace all exist keypad.

M Select apply to new, means only replace new create keypad.
Keypad settings 77 I, =~ ==

Decimal KeyPad Hezxadecimal KeyPad

@ System Keypad E @ System Keypad E

Apply Settings Apply None - Apply Settings ’Appl}r None -

Binary KeyPad Apply to new ASCII KeyPad
@ System Keypad E @ System Keypad E
Apply Settings ’AP‘PIII" None - Apply Settings ’Appl},r None A ]
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A AELTA

M Create a independence execution without open DOPSoft in next download.
M Every execution will according to download mode in project to decide next download

way.

M If it has password setting in execution of project, when execution this file that will ask

Make Execution of Screen Download Data

password for download.

Edit View Element Screen Tools

|j Mew. ..

5 Open.
Clozz

et Save Ctl+5
Sawve A=

MMake Ext. Memory Data ...
Make Auto Update Data .
Ext. M Dlata .. Cirlt]

Miake Exz of Screen Download Data

Paz=word Protect

Brint. . Ctrl+P
Print Preview
Print Setup

B

X Y distribution W.dps

Standard Test - Element W _Sreenlock.dps
FHMI-000'.. EDITOR.DPE
C:\Usersitina. q.lee' Deskiop' 111 .dps

Ezit
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1. Customize Executable file name
2. Customize the Output folder

-
Make download scr

Exscutable file name

Output folder C: B

(




AlsELTa Screen Lock Address

i Into screen properties, it could set Screen Lock address.
¥ This function only effective on sub screen.
¥ Constant as 1 means always lock, constant as 0 means always unlock.

¥ When trigger on screen lock address, below this sub screen will locked and
cannot operate.

(@ General View Scresn ! Apply Print Screen

[ Keypad Sereen v Hus CopyRegion ——
Tpleft [0 0| S CERE
s - __

Center on display

[[] Need Base Screen

oo x[0 Jr[o B & gme [
e Mltipie

Display Title Bar

Language Nar Caption
Languagel




Al\ELTtI Write and Read Offset Address

M Numeric Entry, Button elements provide write and read offset address.

Preview B | = : :
Main Text Details Macro Coordinates
g ;ﬂ Memary Detail
Q \:Sﬁ[ i Write Address: T, =
Lapmeniary” T H Nome ata Type for -
@ Maintsined N Numeric Entry § B P
Q Multiztate E Character ECI‘.'I.[I}" 1:3::‘1&355: E] (@) Use the system keyboard B
@ set Value [B Barcode e -
o Sat Constant |ﬁ £ Write Offset Addr:
0 None E]
g Increment Langnage: Fead Offset Addr: LS 0
Deeremen Languagel None E] Maximum 9999
¥ Read address elements also provide read offset address, like Display and
Pie. Pie(1)

Preview | Main . Text  Coordinates

Memaory
5 Numeric Dizplay

BBC  Character Display Read Address:
Nons E]

Read Offzet Addr:

Mone E]
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AlsELTa Write and Read Offset Address

i1 Please create Numeric Entry element as $100 with Write address, and set
$200 with Write offset address and Read offset address.

Write Address
$100

Write Offset Address
$200

Read Offset Address
$200

,

Preview _ L Main  Text Details Macro Coordinates

E} i Detail - e

DaaType  [Word -]
ELTAA Memory Format | Unsigaed Decimal _ ~ |
5

"""""""" .' @ Use the system keyboard E]
State: Write Offset Addr-
0 -] | 's200 ®
o 0
Language: Read Offset Addr: T
Delta Confidential |ngmgel - | $200 E] Maximum 9999




AnELTa Write and Read Offset Address

M Please create Numeric Entry elements as $200, $100 to $103
with Write address.

$200

W.’ilm Wm
W-5101
W:5102
W:5103
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AlsELm Write and Read Offset Address

¥ Execute compile and run offline simulator, please input 100, 200, 300, 400 at
$100 to $103.

i Input 1 value at $200, and then the $100 with write offset address and read
offset address will display 200. So when $200 is 2, $100 will display 300.

Fﬂ Delta Soft Simulator V224 Kernel Ver- R 2.82 l = | |ﬁ]
$200
$100 100
1
$101 200
Write Address
$102 300 $100
200 Write Offset Address
$200
$103 400
Read Offset Address

$200
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AMELTA Cancel Action Address

M Goto Screen button add Cancel Action Address.

M After trigger on cancel action address, goto screen action will
Ineffective.

Preview v Text Picture | Details |~ Macro Coordinates
Other I
| InterLock State: |On -|
Interlock Address: None E]
Trigger Type: ’Befure Writing - ]
State: Trigger: None E]
Language: Tnvisible Address: None )
Lanmagel User Sacurity Level: "I:I v]
Confirm Window: [No -
Cancel Act Addr: None E]
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A AELTA

External ASCII

M Character Entry, Barcode, Character Display add support EXASCII function.

M Input Mode needs to set as Touch Non-Popup or Active Non-Popup and pair up the
keypad elements.

Delta Confidentiatl

Preview - Main Text | Defails, | Macro Coordinates
Other
S J‘ Input Mode: ’Tnuch Popup v] User Security Level: 0 - 'KeyPadG] — _ u
‘ InterLock State: [on =] | set Low Security: Ne v Preaes N | waing, Te¢ | Picure
Interlock Address: ~ Nome [ | Display Asterisk(*): . —
State: Trigger Type: ’Befme“n’rib.ng V] I Support EASCIL: ’Nn VI o Display =
Foreground Color: 1~ Mode
Trigger: Non: E] ) <ESC> () <Insert>
Language: | e © <ENT> (D) <Page Up>
Language! Tnvisible Address: Non ) State: ©<ar> © <Page Down>
. ® <DEL> ® <Left>
Character Entry I (©) <BKSP> © <Right>
5 i Lan, : () <Home> © <Up>
Freee O uain | Ted o Details | Macro  Coordinate LMT .;.ﬁt © <Down>
<AILT>
Other
| © <ASCII> H |
‘ Ty J‘ Input MMode: [Tnuch Non-Popup v]
loockSoie: 9 z) @ External ASCII do not support as below
Interlock Address: None ) model type.
e B e — B04S211, B0O5S100, B05S101, B07S201,
BO7S211.



£\ nELTA STATIONCHK Macro

M Add STATIONCHK macro, it provide users to check COM link
status.

M Only refresh the link status when screen data access the PLC
address. s commans P [ |

Edit Command
T 1 44x|*

53000 = STATIONCHK (53001, $3002)

Double Word Sipned
Command [7] |STA'I’ID.\'CHK
Variables | Contents Description
Varl 33000 Return Value, 0: Fail, 1: Succead
Varl 33001 COMN Port, 0:COMI, 1: COM2, 2:
Var3 53002 Station 0-235

Update
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A AELTA

M Add STRCAT macro command to connect string.

STRCAT Macro

-

Macro Command B I N
|

A=)

Edit Command
| 70 4 & x|#

K400 = STRCAT($100, $200, $300)

Double Word Signed
Command [ ISTRCAT
Variables | Contents Description
Varl 5400 Feturn Value, 0: Fail, 1: Succesd
Varl 5100 Destination
Var3 5200 Source
Vard 5300 Source Max Length

Update

-
B Screen_7 Maintained_084 ISTRCAT]} [After Execute Macru.

J

S EMER XD D EEE @ | Sereen 7 Maintained 064

1 FILLASC ($100, "ABC")
FILLASC (§200, "9993")
5400 = STRCAT($100, $200, $300)

$400 $100 $200 $300

Delta Confidential

STRCAT I

1 J | aBcog99 JJ 9999 J“ 20 J

After execute STRCAT macro command, $100 will
combine string "ABC" and string "9999" as "ABC9999".



AlsEL'm Horizontal and Vertical Line

M History and alarm add draw vertical and horizontal line.
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4\ nELTA Penetrate of Rectangle

M Rectangle add Penetrate function.

» When penetrate is on, it means ignore rectangle and could press the
button as below rectangle.

» When penetrate is off, it means cannot press the button as below

rectangle.
P ™
Preview - in lain Picture Details Coordinates
Style
Line Color: I -
Line Size:
Round Radins: 0 =
«we ||
Foreground Color: I
Transzparent: Mo -
Languags:
Penetrate: oM w7
Languagel
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A AELTA

M Alarm Moving Sign add Up and Down direction display.

Alarm Moving Sign

Alarm Moving Sign

Preview -l . Main Coordinates
Style - Detail -
Eorder Color: 1~ Interval(ms): Right |
: o
Background Color: L 1~ Moving Foi ]I:}D“m
ring Foint
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A\ nELTA Paste the Specified Screen

i Add Paste the specified screen function, it provide to
customize after which screen to paste.

Copy o .
Paste Copy Screen u

Delete Screen starting E

Fename [ = l | — |
Set Default Screen - i

Auxiliary Key ] Z
Screen Saver Screen hE LTA

21
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A AELTA

M Into Options> Configuration>0Others, add some system
parameters like as below figures out.

M It could set USB Download mode, Brightness, Touch Panel
Delay and Touch Panel Force.

Delta Confidential

System Parameters

Configuration

E =

=
g
=1

Cantral B

ock

e
5 P ¢

N

)
1Y
o

=
=3

e

=
=0
45}
=
[{r]

C

Metwork App

HMI System Setting | Langu.age|

Screen Saver Setup

Enable touch =
O © tonc curser [] Enable Screen Saver  eenSaver 10 + (hfin)

It wiill display initial screen at start

[] Bead Controller Addrs | Mone

Biue Led mode | Disable v

Transition time 1 (=)
USB Download [cDe - |
After screen saver prog
Erightness ' D 1. @ Return to Original
TP Detay _ D 2. () Choose screen
TP Foree " D




A\ hELTA Change color for Pipe(6) ~ Pipe(7)

M Pipe(6) and Pipe(7) add Cursor Color with variables.

M Change the Variable color to Yes and set variable
address to change the pipe flow color.

B | [ M)
il Preview - . Main_  Coordinates
Memory | Stle |
| w— Read Address: Pipe Gange: E -
| — | (& Variable Color: | ¥es -

Rizad Offzet Addr:
Nome E] Cursor Color $50000 [3

State:
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AISELTA Non-current screen background processing permit

M  Add Non-current screen background processing permit function for X-Y Distribution.

M If enable this function, users could sampling at other screen. For example, screen ID 1 has X-Y distribution, but
screen ID 2 has not. After enable this function, in screen ID 2 still could sampling.

M If disable auto clear, please set to off after trigger on sampling in other screen without X-Y distribution.

il [
|| Freview - . Main_  Coordinates
|
Style Dietail
= | | |
% Border Color: -
- oresseor — Coatrol 51910 B
—y Grid Line Color: e -
-I .- [] Auto clear
Hori=: 2 =
o= as Address
Shate: Vert. Line Number: 2 = [¥] Continuous Address
........................................................... Sample 0 | Sample 1
Language:
- Backeground Color 1~ £ s1911
English Y 51912
Color WRGE©. 128. 1)
s e
) . X Min. 1
3 Max, 10
Dot Width: T Min. 0
Y Max 1000

Non-current screen background processing permit

| ox || camcat |
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A AELTA

M Multi-Language support to 32.
M When set over 32 languages, it will display error message.

=
B
=]

Control Block

N F e

[}
=
o
=,
=

32

EE

MNetwork App

Multi-Language support to 32

HMI System Setting | Language

| -

No |Lenguage Name | Detait Setup [ Enable | Defautt Font Style
014 Languageld 13 Arial

[015 Languagel3 14 Arial

016 Lanmapels 13 Agial

[017 Languagel? 16 Arial

018 Languageld 17 Agial

[012 Languagel? 18 Arial

020 Language20 200 Foottight MT Light
[021 Language2l 20 Arial

022 Language22 pi| Arial

[123 Language23 2 Arial

(024 Language2d 23 Arial

[025 Language23 100 Segoe Script
(026 Language26 25 Agial

[027 Language2? 26 Arial

(128 Language28 27 Agial

[02¢ Lanpuage2 28 Arial

[030 Language30 29 Arial

031 Language3i 30 Aial

[032 Language32 233 Showeard Gothic

Ea
=

-
DOPSoft
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£\ nELTa BO/5410 Support other PLC

M B07S410 model type could select other PLC to connect.
Communication Setting IS0 e, &

BE Comtumiaton St
-
COomM i
Link Name Liakl
ST 7 Delta DVP PLC hd
-7 Allen Bradley i
-7 Ciman
-7 Copley
‘_| -7 Danfoss
@1 Emersan E|
Communication Parameter -3 Facon
-1 Festo ——
HIMI Station -7 FuFeng E
. -7 Fuji Electric R —
terface -1 GE Fanuc 2343678
Data Bit -7 Hitachi =2
1tz e E
Stop Bits Timeout(ms) 1000 [
Baud Rate 2600 M Retry Count 2 E
Paity
[¥] Optimize

[T Comm. Interrupt times then ignore

Delta Confidential gK l ’ Canc]




Smarter. Greener. Together.

To learn more about Delta, please visit www.deltaww.com. A hEL 4
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