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Preface 

Thank you very much for purchasing DELTA’s DOP-B Series Human Machine Interface 

(hereinafter “HMI” ) products.  

This manual will be helpful in the installation, operation and specifications of Delta HMI 

product and HMI Screen Editor software program. Before using the product, please read this 

user manual to ensure correct use.  

You should thoroughly understand all safety precautions (DANGERS, WARNINGS and STOPS) 

before proceeding with the installation, wiring and operation. If you do not understand please 

contact your local Delta sales representative. Place this user manual in a safe location for 

future reference. 

 

 Using This Manual 

 Contents of this manual 

 This manual is a user guide that provides the information on how to install 

and operate Delta HMI products and Screen Editor software program.  

 Who should use this manual 

This user manual is intended for the following users: 

 Those who are responsible for designing. 

 Those who are responsible for installing or wiring. 

 Those who are responsible for operating or programming. 

 Important precautions 

Before using the product, please read this user manual thoroughly to ensure correct 

use and store this manual in a safe and handy place for quick reference whenever 

necessary. Besides, please observe the following precautions:  

 Install the product in a clean and dry location free from corrosive and 

inflammable gases or liquids. 

 Ensure that HMI is correctly connected to a ground. The grounding method 

must comply with the electrical standard of the country. 

 Do not modify or remove wiring when power is applied to HMI. 

 Before starting the operation, make sure the emergency stop equipment can 

be energized and work at any time. 

 Do not touch the power supply during operation. Otherwise, it may cause 

electric shock. 
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NOTE  

The content of this manual may be revised without prior notice. Please consult our distributors or 

download the most updated version at http://www.delta.com.tw/industrialautomation. 
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About this Manual… 

User Information 

Be sure to store this manual in a safe place. 

Due to constantly growing product range, technical improvement and alteration or changed 

texts, figures and diagrams, we reserve the right of this manual contained information change 

without prior notice. 

Coping or reproducing any part of this manual, without written consent of Delta Electronics 

Inc. is prohibited. 

 

Technical Support and Service 

Welcome to contact us or visit our web site (http://www.delta.com.tw/industrialautomation/) 

if you need any technical support, service and information, or, if you have any question in 

using the product. We are looking forward to serve you needs and willing to offer our best 

support and service to you. Reach us by the following ways. 
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TEL: 1-919-767-3813 
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Sales Office/ 

DELTA SHIBADAIMON BLDG. 

2-1-14 SHIBADAIMON, MINATO-KU,  

TOKYO, 105-0012, JAPAN 

TEL: 81-3-5733-1111 

FAX: 81-3-5733-1211 

 

 

EUROPE 

DELTRONICS (NETHERLANDS) B.V. 

Sales Office/ 

DE WITBOGT 15, 5652 AG EINDHOVEN,  

THE NETHERLANDS 

TEL: 31-40-259-2860 

FAX: 31-40-259-2851 

 

 

 

http://www.delta.com.tw/industrialautomation/


Table of Contents  

This page intentionally left blank. 

 

 

 

xiv  Revision May, 2010 



Chapter 1  Introduction 

1.1 DOP-B Series Human Machine Interface (HMI) 

DOP-B series HMI is manufactured by adopting easy-to-use software and high-speed hardware 

to provide a powerful and stable programmable interface. Screen Editor software program is a 

user-friendly program editor of DOP-B series HMI for Windows. Please refer to the following 

section for an introduction to its features and functions. 

 

1.2 Features 

 External Controller Serial Drivers Support 

DOP-B series HMIs support more than twenty brands of external controllers, including 

Delta, Omron, Siemens, Mitsubishi, etc. All of the newly supported communication 

protocol information could be found on our website 

(http://www.delta.com.tw/industrialautomation/) for upgrade to meet the users’ 

requirements. (All other trademarks in this manual are property of their respective 

companies.) 

 Windows® Fonts Support  

Screen Editor software program also provides all fonts used by Windows®. 

 Quick Execution and Communication Macro 

Screen Editor software program is able to handle complicated calculations by executing 

macros. In addition, the users can create a communication protocol by using 

communication macro command and connect to the specific system or the controller via 

the COM port. 

 Rapid USB Upload/Download  

Not only RS-232, the users also can use Screen Editor to upload and download screen data 

and programs via USB interface. Screen Editor software program shortens the upload / 

download time by using USB interface. 

 Recipes 

Screen Editor software program provides a useful recipe editor that is similar to Microsoft 

Excel for the users to edit recipe easily and input multiple recipes simultaneously. When 

the users need to download multiple recipes simultaneously, the recipe function can swap 
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internal memory of HMI. After the users finish editing the recipes, the users can download 

the recipes individually. 

 Direct Communication with Three External Controllers 

DOP-B series HMI is capable of connecting to three different or the same controllers 

directly via three communication ports.  

 Support Multiple Controllers Connections 

One DOP-B series HMI is able to connect to multiple controllers in serial through RS-485 

interface of COM2 and COM3 ports. (NOTE 1).  

 Simulation Function (NOTE 2) 

Screen Editor software program provides simulation feature which allows the users to 

develop and debug software on a PC connected to DOP-B series HMI before downloading it 

to DOP-B series HMI. 

Off-line Simulation: When the editing and compile operation is completed, the users can 

use off-line simulation function to simulate HMI operation and check if it is correct on a 

stand-alone a PC directly without connecting to the controller. 

On-line Simulation: When the editing and compile operation is completed, the users can 

use on-line simulation function to simulate HMI operation and check if it is correct on a 

stand-alone PC directly with connecting to the controller. 

 USB Host Port (USB Host) Equipped 

DOP-B series HMI has a built-in USB Host interface for the connection to USB disk, card 

reader and printer with a USB socket. The users can save data, copy programs, print the 

screen immediately and increase the data storage space. 

 Print Function 

DOP-B series HMI supports the printers which have COM port or USB interface. 

 Multiple Security Protection  

DOP-B series HMI provides passwords to protect the designer’s intellectual property rights 

and also for the users to set the user priority for important elements. Only the users 

whose priority is higher than the element can use the element. 

 Multi-language Support 

Up to 16 languages can be selected and used without installing a multilingual operating 

system. A multi-language environment is very important and enables the users to work 

more efficiently. 
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NOTE  
1) The controller should provide RS-485 interface. 

2) Off-line/On-line simulation functions are only provided for some parts of the controllers. Also, 

the execution time of on-line simulation only can continue 30 minutes. After the simulation 

time has finished, HMI will return to the main screen of Screen Editor V2.0 software program 

from simulation window automatically. 

3) When executing simulation function, the resolution of PC screen should be set to 24bit and 

higher, otherwise the simulation function may not work normally. 
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Chapter 2  Working with Hardware Devices 

2.1 Usage of SD Card and USB Disk 

 SD Card 

SD card (supports SDHC) can be used to save and transmit data. The supporting file 

format is FAT32. Before using a SD card, reformatting (FAT32) via HMI is needed. Only SD 

card that formatted by HMI can be used on both HMI and Windows® OS system. (Even it 

can be read/written in some format, but faults may occur due to different format among 

Win95/98/2000/XP versions) 

 USB Disk  

USB disk can be used to save data. It also can be used to copy data from HMI and its 

format is FAT32 as well. When using USB disk to save data, we recommend that the 

storage capacity should be less than 2GB and the users should enter system screen first 

and then remove the USB disk. Follow this process can ensure that the data is saved 

completely in USB disk. 

There are two kinds of methods for removing the USB disk: 

1. Press SYS button for 3 seconds to enter intro the system setting screen. Then, the 

users could choose the function to remove the USB disk. 

2. Create a “Remove storage” button on the screen first. After settings and compile 

operation is completed, pressing this button is able to remove the USB disk. For more 

information on “Remove storage” button, please refer to section 3.8.2.7 in Chapter 3. 

 

Please use the above two methods to remove the USB disk to ensure that the data is saved 

completely in USB disk. 
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Chapter 3  Creating and Editing Screens 

In this chapter, it will introduce general functions of Screen Editor software program with 

Windows. The user can use it to design what he wants. Detail information for each function 

will be discussed in following chapters. 

3.1 Screen Editor Setup 

 Recommended System Requirements 

 CPU: Intel® Pentium 4.1 or greater  

 Memory: 1GB RAM or greater 

 Hard Disk: 400MB and above free hard disk space 

 Monitor Display: 1024 × 768 resolution higher full-color display recommended 

 Printer: Printer compatible with Windows® 2000 / Windows® XP 

 Operation System: Windows® 2000 / Windows® XP / Windows® Vista / Windows® 7 

 

 Software installation 

The user can download the Screen Editor software program via the link below: 

http://www.delta.com.tw/product/em/download/download_main.asp?act=3&pid=3&cid=2&tpi

d=3   

 

To start the Delta HMI Screen Editor software program setup, please refer to the following 

steps: 

Step 1: Please start-up your computer to Win2000/WinXP system (Fig. 3-1-1). 
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Fig. 3-1-1 Open Microsoft Windows 

 

Step 2: Execute setup.exe from Windows taskbar by clicking “Start” > “Run”. After pressing 

OK, system will setup automatically and you will get the following dialog box to select 

the desired display language (Fig. 3-1-2).  

 

Fig. 3-1-2 Select Language 
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After pressing OK, system will setup automatically and you will get the following 

dialog box to choose destination location (Fig. 3-1-3).  

 

Fig. 3-1-3 Directory for installing Screen Editor software program 

 

To select the default directory C:\Program Files\Delta Industrial Automation\Screen 

Editor 2.00.XX\, click Next> for the next step. Setup will install in the directory 

indicated in the Destination Directory box at the bottom of the dialog box. 

To select a directory other than the default directory, click Browse. A list of available 

directories appears. Highlight the desired directory for Screen Editor and click OK, 

then Next> for the next step. If necessary, click < Back button to take you back 

through Setup dialog boxes one by one. 

Please remember the location of the destination directory.  If the destination directory 

is missing or changed, the user cannot upgrade the software successfully. 

 

Step 3: After pressing Next, system will ask you to select the installation software, i.e. Screen 

Editor (Fig. 3-1-4). 
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Fig. 3-1-4 Select Screen Editor software program 

Step 4: Then click Install button to start Screen Editor Installation (Fig. 3-1-5, Fig. 3-1-6). 

 

Fig. 3-1-5 Starting Screen Editor installation 
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Fig. 3-1-6 Finish installing Screen Editor 

Step 5: After finish installing Screen Editor software program (Fig. 3-1-6), the system will ask 

you to install HMI USB driver, please click Yes to install. 

 

Fig. 3-1-7 Install HMI USB driver 
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Step 6: After installing HMI USB driver, click Close to complete the installation. After the 

installation is completed, connect HMI and PC by communication cable via USB port. 

Wait for few seconds and activate Screen Editor software program. Then choose Tools 

> Get Firmware Information. At this time, if there is no error message and the 

firmware information shows up successfully, it indicates that Screen Editor software 

program has been installed and the user can use PC to communicate with HMI via USB 

port without problem.  

 Software upgrade (ScrEdit-Path Setup) 

When receiving the software upgrade technical announcement, the user can download the 

upgrade software program, Patch_DOPB_yyyymmdd at Delta’s website. The upgrade software 

program includes the firmware and the enhanced functions. Before installing the upgrade 

software program, the user needs to confirm if the software destination directory is the 

default setting, i.e. C:\Program Files\Delta Industrial Automation\Screen Editor 2.00.XX. 

Please ensure that the destination directory is the default setting or the user could not 

perform the upgrade successfully. 

[Installation methods of Patch_DOPB_yyyymmdd] 

Step 1: Click Patch_DOPB_yyyymmdd direcly under Windows and the system will start the 

installation (Fig. 3-1-8). The user can click Install button to upgrade your Screen Editor. 

Step 2: During installation, the user can click Show details button to see the detailed items 

(Fig. 3-1-9). 

 

Fig. 3-1-8 Install Patch_DOPB_yyyymmdd 
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Fig. 3-1-9 Starting installation 

 
Fig. 3-1-10 Show details 

 
Fig. 3-1-11 Finish upgrading 
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Fig. 3-1-12 Finish installation 

Step 3: After upgrading is finished, click Close to complete the installation. 
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3.2 How to Start Screen Editor  

1. After setup, you can start Screen Editor software program by clicking Screen Editor 

2.00.XX shortcut on the desk (Fig. 3-2-1) or from Windows taskbar, click Start > 

Programs > Delta Industrial Automation > HMI > Screen Editor 2.00.XX. 

 
Fig. 3-2-1 

 

 
Fig. 3-2-2 Start-up display 
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When Screen Editor software program is activated for the first time, the first window to show 

up is as follows. There are only File, View, Tools, Options and Help on the toolbar. 

 

Fig. 3-2-3 Screen without editing file 

2. After pressing  or click File > New, it can create a new project and you will get a dialog 

box as shown in the following (Fig. 3-2-4). 

 

Fig. 3-2-4 Creating a New project 
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3. Enter the project name, screen name, screen No. and select connected HMI, controller or 

printer. Then, click OK. It can create a new project in Screen Editor software program as 

shown in the following (Fig. 3-2-5). 

 

Fig. 3-2-5 New project screen of Screen Editor 

 

There are five parts in the following for editing window of Screen Editor software program.  

 Menu Bar 

There are nine functions for selection: File, Edit, View, Element, Screen, Tools, Options, 

Window, and Help. 

 

 Toolbar  

Toolbar (Fig. 3-2-6) is like those toolbar in Windows® program. It is easy to use for editing 

and the user can arrange its position freely. For example, the user can move the Toolbar 

to the left side of the screen. Also, the user can arrange the toolbar position by their 

usage. The followings are the available toolbar on Screen Editor software program. 

1. Standard Toolbar 

 

2. Zoom Toolbar 
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3. Text Toolbar 

 

4. Bitmap Toolbar 

 

5. Element Toolbar 

 

6. Layout Toolbar 

 
 

 

7. Drawing Toolbar 

 

 

Fig. 3-2-6 Toolbar of Screen Editor  
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Position of toolbar 
can be moved. 

Fig. 3-2-7 Element Toolbar has been moved 

 Element Tool Window 

The Element Tool window provides various kinds of element icons for selection (Fig. 3-2-8). 

The user can use the mouse to select the desired element icon and drag it onto the work 

place to create a new element. In addition, the user can save the element in the Element 

Bank for editing the element next time (Fig. 3-2-9). 

           

 Fig. 3-2-8 Fig. 3-2-9 
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 Property Table  

The Property Table displays the element property settings for each element (Fig. 3-2-10 & 

Fig. 3-2-11).  

 

All elements on the current 
editing screen 

 

 

Element state selection 

 
 

 

 

Fig. 3-2-10 Property Table and Editing Screen Preview 
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 Record and Output Window 

The Record and Output Window displays all the editing actions and output message when 

compile function is enabled (Fig. 3-2-11). When HMI program is compiled, the system will 

detect the program automatically. Once error occurs, the error messages will be displayed 

in Output Window. To get to the error element window, click on the error message. 

     

Fig. 3-2-11 Record and Output window 

 Work Place 

Following is an editing example display (Fig. 3-2-12). 

 

Editing Area 

Fig. 3-2-12 Work Place of Screen Editor 
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 Status Bar 

Following is the status bar of Screen Editor (Fig. 3-2-13).  

 

 
 
 
 

Download 
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Fig. 3-2-13 Status Bar of Screen Editor 
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3.3 Internal Memory 

There are six kinds of registers for selection. They are internal register $, Non-volatile Internal 

Register $M, Indirect Address Register *$, Recipe Number Register RCPNO, Recipe Group 

Register RCPG and Recipe Register RCP (Fig. 3-3-1). For more details on settings, please refer to 

the following descriptions.  

 

Fig. 3-3-1 HMI Internal Memory 

3.3.1 Internal Register (Read / Write) : $ 

Word Access : $n  ( n : 0-65535 ) 

Bit Access   : $n.b( n : 0-65535, b : 0-15 ) 

Delta DOP-B series HMI provides 65536 16-bit internal registers ($0.0 - $65535.15). 

Note: The setting values of this register are not retained when power is off. 

 Non-volatile Internal Register (R/W): $M 

Word access:  $Mn (n:  0~1023) 

Bit access:  $Mn.b (n:  0~1023, b: 0~15) 

Delta DOP series HMI provides 1024 16-bit non-volatile internal registers ($M0 ~ $M1023). 

 

3.3.2 Non-volatile Internal Register (Read / Write) : $M 

Word Access : $Mn   ( n : 0-1023 ) 

Bit Access   : $Mn.b( n : 0-1023, b : 0-15 ) 

Delta DOP-B series HMI provides 1024 16-bit non-volatile internal registers($M0.0 - 

$M1023.15). As the setting values of this register are retained when power is off, the user 

can use this register to store the important data or records. 
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3.3.3 Indirect Address Register (Read / Write) : *$ 

Word Access：*$n( n : 0-65535 ) 

Indirect address register is an area where an address is stored. The user must get the 

address from *$n and then get the values stored in this address.  

For example: if $7 = 20; $20 = 39; then *$7 = 39. 

The general formula：if $n = m; $m = x, then *$n = x (m : 0-65535)。 

The value of m must not be more than 65535. 

Note: The setting values of this register are not retained when power is off. 

 

3.3.4 Recipe Number Register (Read / Write) : RCPNO 

This register is used to specify the recipe data number (Fig. 3-3-2). When upload/download 

the data to HMI or the external controller, HMI or the external controller uses the settings of 

recipe number register to read/write the data of recipe. If RCPNO is set to 1, it indicates it is 

defined as 1st number of recipe data. If RCPNO is set to 4, it indicates it is defined as 4th 

number of recipe data. In addition, when editing the recipe data, the user can set the size of 

each number of recipe data. For more details, please refer to the descriptions of Recipe 

Register RCP.  

Note: The setting values of this register are not retained when power is off. 

 

1st Number, RCPNO = 1 

4th Group, RCPNO = 4 

Fig. 3-3-2 Recipe Editing Screen 
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3.3.5 Recipe Group Register (Read / Write) : RCPG 

This register is used to specify the 32-bit recipe group (Fig. 3-3-3). It is different than RCPNO. 

The difference is that when using RCPG, not only the recipe number, the recipe group also 

must be set. When the user wants to upload/download the recipe data of 1st number of 1st 

group, RCPG must be set to 1 and RCPNO must be set to 1. If HMI or the external controller 

needs to read/write the recipe data of 4th number of 3rd group, RCPG must be set to 3 and 

RCPNO must be set to 4. The recipe group number is determined when editing the recipe 

table. For more details, please refer to the descriptions of Recipe Register RCP.  

Note: The setting values of this register are not retained when power is off. 

 1st Group, RCPG = 1 3rd Group, RCPG = 3 

 

1st Number, RCPNO = 1

Fig. 3-3-3 Recipe Group Editing Screen 

 

3.3.6 Recipe Register (Read / Write) : RCP 

This register is used to save the recipe data that the user downloaded from HMI after exiting 

Screen Editor software program. There are two kinds of recipe register, 16-bit recipe register 

and 32-bit recipe register.  

16-bit Recipe Register 

The size of this register is 16bit (1 Word). If the data storage area is an external memory, i.e. 

a USB disk or SM card is connected, the data space of 16-bit recipe register is 4MB words. If 

the data storage area is an internal memory, the data space of 16-bit recipe register is 64K 

words. 
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Assume that the data size is L and the recipe number is N, and the actual recipe data space is 

equal to L x N words, i.e. L x N recipe registers are occupied. Delta DOP-B series has a recipe 

buffer area (Table 3-3-2) which stores the selected recipe data by the user. The size of this 

buffer area is the same as the data size of the selected recipe. It also means that L recipe 

registers are occupied in recipe buffer area. Therefore, there will be L x (N+1) registers 

occupied in one recipe table. Use the following method to access data that set with recipe. 

Word Access： RCPn ( n : 0-L*(N+1)-1 ) 

Note: -1 indicates that the number of RCP starts from 0. 

 
RCP0 

36
RCP1 

42

RCP2 
36

RCP3 
42

RCP4 
12

RCP5 
33

RCP6 RCP7 
5127

Recipe Buffer 
Area

 

RCPNO = 1 
1st Number of Recipe

Data 

 

 Table 3-3-1 Recipe Table           Table 3-3-2 Layout of Recipe Registers  

 

Example 1: 

Table 3-3-1 is an example of how to access data. The size L is set to 2 and the number N is 

set to 3 with the recipe data. Thus the layout of the recipe data will be shown as Table 3-3-2, 

i.e. RCP0~RCP7 are occupied. When RCPNO is set to 1 and the recipe buffer area will show the 

1st number of recipe data. If RCPNO is change to 3, the recipe buffer area will show 3rd 

number of recipe data shown as in Table 3-3-4.  

 

RCP0 
27

RCP1 
51

RCP2 
36

RCP3 
42

RCP4 
12

RCP5 
33

RCP6 
27

RCP7 
51

 
Recipe Buffer 

Area 
RCPNO = 3

 

 

3rd Number of Recipe
Data 

Table 3-3-3 Recipe Table           Table 3-3-4 Layout of Recipe Registers  
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Example 2: 

In Table 3-3-5, the size L is set to 3 and the number N is set to 2 with the recipe data. Thus 

the layout of the recipe data will be shown as Table 3-3-6, i.e. RCP0~RCP8 are occupied. 

When RCPNO is set to 2 and the recipe buffer area will show the 2nd number of recipe data.  

 

 

 

 

     Table 3-3-5 Recipe Table        Table 3-3-6 Layout of Recipe Registers  

 

32-bit Recipe Register 

The size of this register is 32bit (2 Words or Double Word, DW). If the data storage area is an 

external memory, i.e. a USB disk or SM card is connected, the data space of 32-bit recipe 

register is 50MB words. If the data storage area is an internal memory, the data space of 

32-bit recipe register depends on the specification of HMI flash memory. The user can refer 

to the specifications shown on DOP-B series catalogue. Please note that not only recipe data, 

there are also other screen data stored in flash memory. It indicates the total memory size of 

the recipe data space must be less than the space of the flash memory. For more details, 

please refer to HMI Memory dialog by clicking View > Memory List (Fig. 3-3-4). 

 

RCP0 
12

RCP1 
33

RCP2 
76 

RCP3 
36

RCP4 
42

RCP5 
1 

RCP6 
12

RCP7 
33

RCP8 
76 

RCPNO = 2

Recipe Buffer 
Area

2nd Number of 
Recipe Data 

Fig. 3-3-4 HMI Memory 
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Assume that the data size is L and the recipe number is N, and the actual recipe data space is 

equal to L x N DW words, i.e. L x N recipe registers are occupied. Delta DOP-B series has a 

recipe buffer area (Table 3-3-8) which stores the selected recipe data by the user. The size of 

this buffer area is the same as the data size of the selected recipe. It also means that L recipe 

registers are occupied in recipe buffer area. Therefore, there will be L x (N+1) registers 

occupied in one recipe table. Use the following method to access data that set with recipe. 

Double Word Access: RCPn ( n : 0-L*(N+1)-1 ) 

Note: -1 indicates that the number of RCP starts from 0. 

 

 

 

 

 

RCPNO = 1

RCP0 
1

RCP1 
2 

RCP3 
1

RCP4 
2 

RCP6 
4

RCP7 
5 

RCP9 
7

RCP10 
8 

RCP2 
3

RCP5 
3

RCP8 
6

RCP11 
9

RCP13 
11 

RCP14 
12

RCP12 
10

Recipe Buffer 
Area 

1st Number of 
Recipe Data

     Table 3-3-7 Recipe Table                  Table 3-3-8 Layout of Recipe Registers  

 

Example 1: 

Table 3-3-7 is an example of how to access data which is built in the first group (RCPG=1). 

The size L is set to 3 and the number N is set to 4 with the recipe data. Thus the layout of the 

recipe data will be shown as Table 3-3-8, i.e. RCP0~RCP14 are occupied. When RCPNO is set 

to 1 and the recipe buffer area will show the 1st number of recipe data. If RCPNO is change to 

3, the recipe buffer area will show 3rd number of recipe data shown as in Table 3-3-10.  

 

 

 

 

 

RCP0 
7

RCP1 
8 

RCP3 
1

RCP4 
2 

RCP6 
4

RCP7 
5 

RCP9 
7

RCP10 
8 3rd Number of 

Recipe Data 

RCPNO = 3

RCP2 
9

RCP5 
3

RCP8 
6

RCP11 
9

RCP12 
10

RCP13 
11 

RCP14 
12

Recipe Buffer 
Area 

     Table 3-3-9 Recipe Table                   Table 3-3-10 Layout of Recipe Registers  
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Example 2: 

In Table 3-3-11, suppose that it is built in the first group (RCPG=1). The size L is set to 2 and 

the number N is set to 3 with the recipe data. Thus the layout of the recipe data will be shown 

as Table 3-3-12, i.e. RCP0~RCP7 are occupied. When RCPNO is set to 3 and the recipe buffer 

area will show the 3rd number of recipe data.  

RCP0 
14

RCP1 
15

RCP2 
10

RCP3 
11

RCP4 
12

RCP5 
13

RCP6 
14

RCP7 
15

 
Recipe Buffer 

Area  
RCPNO = 3

 

 
3rd Number of 

Recipe Data 
    

Table 3-3-11 Recipe Table         Table 3-3-12 Layout of Recipe Registers  
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3.4 Control Block and Status Block 

For two-way communication between Delta DOP series HMI and all other brands of PLCs, the 

address of the control block and status block must be defined. These settings are located in the 

Configuration dialog box (Fig. 3-4-2) by clicking Options > Configuration (Fig. 3-4-1). For 

more details on settings, please refer to the following descriptions. 

  
Fig. 3-4-1 Clicking Configuration Command 

   
Fig. 3-4-2 Configuration Dialog Box 
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Note: Checking of Auto reset flags will reset the control block flags (Bits) automatically after 

the desired procedure has been executed. If this box is not checked, the system will ask the 

user to reset the flags. 

 

3.4.1 Control Block 

The control block is the way a PLC is used to control the HMI. Through the settings set in the 

registers, the controller which is connected to HMI can know HMI internal operation, i.e. 

screen switch, backlight on and off, current priority, curve sampling data and clear flag, etc. 

information and the user can also get the current system status of HMI. The register is a 

continuous data block and its length is from 0 to 8 words (Fig. 3-4-2). When using control 

block features, the actual length of control block is determined by the used control block 

features. For example, when Screen Switch feature (Screen Number Designation Register) is 

used, the control block must be set to a length of 1 or more. At this time, only Screen Number 

Designation Register can be used. One more example, when using History Buffer features 

(Sampling History Buffer Register), the control block must be set to a length of 4 or more. At 

this time, only Sampling History Buffer Register can be used. In addition, when using the 

function of Multi-language Setting Value Bit (System Control Flag Register), it is best that the 

length of the control block be set to 8 words. At this time, all the register in control block can 

be used. When the control block is set to a length of zero, the control block is disabled. 

The function and explanation of each WORD is listed as Table 3-4-1 below. In the following 

table, in the following example 1 we assume that the user uses a Delta PLC, so the available 

starting addresses in control block are Dn ~ Dn+7 (D0 ~ D7). In the following example 2, we 

assume that the user uses HMI internal register $, so the available starting address in control 

block is$n ~ $n+7 ($15 ~ $22). The user can choose if the control block designations are 

stored in PLC or HMI. 

Example 1 
(PLC register) 

Example 2 
(HMI register) Word 

Number Register Number 
Address Example Address Example 

1 Screen Number Designation Register (SNIR) Dn D0 $n $15 

2 Control Flag Register (CFR) Dn+1 D1   $n+1 $16 

3 Curve Control Register (CUCR) Dn+2 D2 $n+2 $17 

4 Sampling History Buffer Register (HBSR) Dn+3 D3 $n+3 $18 

5 Clearing History Buffer Register (HBCR) Dn+4 D4 $n+4 $19 

6 Recipe Control Register (RECR) Dn+5 D5 $n+5 $20 

7 Recipe Number Designation Register (RBIR) Dn+6 D6 $n+6 $21 

8 System Control Flag Register Dn+7 D7 $n+7 $22 

Table 3-4-1 Control Block Designations 
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Screen Number Designation Register (SNIR) 

To use this register, write a value of the screen number that the user desires to have 

displayed into this register; then HMI will change to that screen. For example (refer to 

Table 3-4-1), if set D0 or $15.0 to 1, HMI will change to the 1st screen. If set D0 or $15.0 to 

7, HMI will change to 7th screen. 

Control Flag Register (CFR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Enable / Disable Communication 

1 0000 0000 0000 00x0 Enable / Disable Backlight 

2 0000 0000 0000 0x00 Enable / Disable Buzzer 

3 0000 0000 0000 x000 Clear Alarm Buffer 

4 0000 0000 000x 0000 Clear Alarm Counter 

5 0000 0000 00x0 0000 Update USB Data 

6-7 0000 0000 xx00 0000 Reserved 

8 0000 000x 0000 0000 Set User Security Level (Level 1) 

9 0000 00x0 0000 0000 Set User Security Level (Level 2) 

10 0000 0x00 0000 0000 Set User Security Level (Level 4) 

11-15 xxxx x000 0000 0000 Reserved 

 Enable / Disable Communication 

Bit 0 controls the HMI communication. When bit 0 is turned ON, HMI communication is 

disabled. When bit 0 is turned OFF, HMI communication is enabled. By checking 

Communication Interrupt check box (Fig. 3-4-3) under the Communication tab of 

the Configuration dialog box when communication between one certain PLC is lost 

this bit will be turned ON and disable the communication automatically and the 

communication fault message will not display (this will not affect the communications 

between other PLCs). Then, the user can clear it to enable the communication again. If 

this check box is not checked, this flag is disabled (To disable and enable the 

communication manually, the user can use OPENCOM/CLOSECOM macro commands. 

For more details on macro commands, please refer to section 3.14) 

For example (refer to Table 3-4-1 and Fig. 3-4-4), if the PLC which is connected via 

COM2 port has communication error and communication retry time has reached three 

times, HMI will disable the communication between that PCL automatically (but will 

not disable the communication between other PLCs) and will not show communication 

errors. At this time, if D1 or $16.0 is set to 0, i.e. the communication flag is turned 

OFF, the communication will be enabled again and HMI will communicate with that 

PLC again. If the communication is lost for three times, this flag will be ON again. 

When D1=0, it indicates that Bit 0 of D1 is 0 (0000 0000 0000 0000). 
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Fig. 3-4-3 Communication tab            Fig. 3-4-4 PLC Connections 

Communication retry times 
is 3 times 

 Enable / Disable Backlight 

Bit 1 controls the backlight of HMI. When bit 1 is turned ON, the HMI backlight turns 

OFF. When bit 1 is turned OFF, the HMI backlight turns ON. For example (refer to Table 

3-4-1), if D1 is set to 2 or $16.1 is set to 1, this flag is enabled and the HMI backlight 

turns OFF. When D1 = 2, it indicates that Bit 1 of D1 is 1(0000 0000 0000 0010). 

 Enable / Disable Buzzer 

Bit 2 controls the buzzer of HMI. When bit 2 is turned ON, the HMI buzzer turns OFF. 

When bit 2 is turned OFF, the HMI buzzer turns ON. For example (refer to Table 3-4-1), 

if D1 is set to 4 or $16.2 is set to 1, the HMI buzzer turns ON. At this time, if an alarm 

occurs, it will sound. When D1 = 4, it indicates that Bit 2 of D1 is 1 (0000 0000 0000 

0100). 

 Clear Alarm Buffer 

Bit 3 clears the alarm buffer. When an alarm history table is used, setting this bit is 

able to clear all data inside of that table. When bit 3 is turned ON, the alarm buffer is 

cleared. To clear the alarm buffer again, this flag must be turned OFF and then ON 

again. For example (refer to Table 3-4-1), if D1 is set to 8 or $16.3 is set to 1, this flag 

is turned ON and the alarm buffer will be cleared. When D1 = 8, it indicates that Bit 3 

of D1 is 1 (0000 0000 0000 1000). 

 Clear Alarm Counter 

Bit 4 clears the alarm counter. When an alarm frequency table is used, setting this bit 

is able to clear the values for the alarms. When bit 4 is turned ON, the alarm counter is 

cleared. To clear the alarm counter again, this flag must be turned OFF and then ON 

again. For example (refer to Table 3-4-1), if D1 is set to 16 or $16.4 is set to 1, this flag 

is turned ON and the alarm counter will be cleared. When D1 = 16, it indicates that Bit 

4 of D1 is 1 (0000 0000 0001 0000). 
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 Update USB Data 

Bit 5 updates the USB data. When this flag is used, the user can update the stored data 

in alarm buffer area into the USB disk. If one of alarm buffer, history buffer or recipe 

function is activated and the non-volatile memory area is set to USB disk, when this 

flag is enable, HMI will backup and update the data that is stored in buffer area into 

USB disk in real-time. Please note that all the data will be stored in the buffer area first. 

Before reaching the limit of the buffer memory (the memory capacity of buffer area is 

64KB and it can be user-defined as well in Configuration dialog box), the system will 

not backup and update the data into USB disk. The purpose is not to frequently 

overwrite the USB disk and avoid the damage to USB disk. Therefore, if the amount of 

data is less than the memory capacity, to avoid the data may be lost, the user can 

enable this flag and update the data into USB disk. 

For example (refer to Table 3-4-1), if D1 is set to 32 or $16.5 is set to 1, this flag is 

turned ON and the function of update USB data will be enabled. When D1 = 32, it 

indicates that Bit 5 of D1 is 1 (0000 0000 0010 0000). 

 Set User Security Level 

Bits 8 to 10 set the user security level. The HMI security level settings are divided into two 

parts: one is level 0 (lowest) to level 7 and the other is highest level. Bits 8 to 10 controls 

the level 0 (lowest) to level 7 but cannot control the highest level. When Bit 8 is turned ON, 

the user security level is 1. When Bit 9 is turned ON, the user security level is 2. When Bit 

10 is turned ON, the user security level is 4. For more details on settings, please refer to 

the following descriptions.  

Flag Control 
Level 

ON OFF 
Binary Display 

Level 0  Bit 8, Bit 9, Bit 10 0000 0000 0000 0000 

Level 1 Bit 8 Bit 9, Bit 10 0000 0001 0000 0000 

Level 2 Bit 9 Bit 8, Bit 10 0000 0010 0000 0000 

Level 3 Bit 8, Bit 9 Bit 10 0000 0011 0000 0000 

Level 4 Bit 10 Bit 8, Bit 9 0000 0100 0000 0000 

Level 5 Bit 8, Bit 10 Bit 9 0000 0101 0000 0000 

Level 6 Bit 9, Bit 10 Bit 8 0000 0110 0000 0000 

Level 7 Bit 8, Bit 9, Bit 10  0000 0111 0000 0000 

For example (refer to Table 3-4-1), if D1 is set to 1280 or $16.8 and $16.10 is set to 1, 

this flag is enabled and the user security level is 5. When D1 = 1280, it indicates that 

Bit 8 and Bit 10 of D1 are both 11(0000 0101 0000 0000). 
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Curve Control Register (CUCR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Curve Sampling Flag 1 

1 0000 0000 0000 00x0 Curve Sampling Flag 2 

2 0000 0000 0000 0x00 Curve Sampling Flag 3 

3 0000 0000 0000 x000 Curve Sampling Flag 4 

4-7 0000 0000 xxxx 0000 Reserved 

8 0000 000x 0000 0000 Curve Clear Flag 1 

9 0000 00x0 0000 0000 Curve Clear Flag 2 

10 0000 0x00 0000 0000 Curve Clear Flag 3 

11 0000 x000 0000 0000 Curve Clear Flag 4 

12-15 xxxx 0000 0000 0000 Reserved 

 Curve Sampling Flag 

Bits 0 to 3 (flags 1 to 4) control the curve (Trend Graph, X-Y Chart, X-Y distribution or 

Curve Input) sampling. When this flag is turned ON, HMI will read continuous data 

from the set PLC address to sample once, changes the data to the graph and shows it 

on HMI screen (For more details on the settings of curve element, please refer to 

section 3.8.10). To control the curve sampling flag again, this flag must be turned OFF 

and then ON again. 

Each curve element has to be assigned to a sampling flag where the sample flag is 

setup in the detail property of the element. To enable the curve element, set the 

corresponding bit in this register. For example (refer to Table 3-4-1 and Fig. 3-4-5), if 

D2 or $17.0 is set to 1, the curves of figure 1 and 2 will be activated and show on the 

screen and the curves of figure 3 and 4 will not. When D2=1, it indicates that Bit 0 of 

D2 is 0 (0000 0000 0000 0001). 
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Fig. 3-4-5 Curve Elements on HMI Screen 

 Curve Clear Flag 

Bits 8 to 11 (flags 1 to 4) clear the curve (Trend Graph, X-Y Chart, X-Y distribution or 

Curve Input) when this flag is turned ON (For more details on the settings of curve 

element, please refer to section 3.8.10). To control the curve clear flag again, this flag 

must be turned OFF and then ON again. 

For example (refer to Table 3-4-1 and Fig. 3-4-5), if D2 is set to 512 or $17.9 is set to 

1, the curves of figure 3 will be cleared and the curves of figure 1, 2 and 4 will not. 

When D2=512, it indicates that Bit 9 of D2 is 1(0000 0010 0000 0000). 

 

Sampling History Buffer Register (HBSR) 

Delta DOP-B series has 12 Bits that control the sampling address of history buffer (refer to 

Fig. 3-4-6 and the following table). Not only Timer, the history buffer can be controlled by 

a PLC if the Trigger Source in the History Buffer setup is set to a PLC from Timer. For more 

details on History Buffer setup, please refer to section 3.11.3. 

Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of Relative 

Position (x) 
Function 

Buffer Area 1 0 0000 0000 0000 000x Sampling History Buffer 1 

Buffer Area 2 1 0000 0000 0000 00x0 Sampling History Buffer 2 

Buffer Area 3 2 0000 0000 0000 0x00 Sampling History Buffer 3 
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Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of Relative 

Position (x) 
Function 

Buffer Area 4 3 0000 0000 0000 x000 Sampling History Buffer 4 

Buffer Area 5 4 0000 0000 000x 0000 Sampling History Buffer 5 

Buffer Area 6 5 0000 0000 00x0 0000 Sampling History Buffer 6 

Buffer Area 7 6 0000 0000 0x00 0000 Sampling History Buffer 7 

Buffer Area 8 7 0000 0000 x000 0000 Sampling History Buffer 8 

Buffer Area 9 8 0000 000x 0000 0000 Sampling History Buffer 9 

Buffer Area 10 9 0000 00x0 0000 0000 Sampling History Buffer 10 

Buffer Area 11 10 0000 0x00 0000 0000 Sampling History Buffer 11 

Buffer Area 12 11 0000 x000 0000 0000 Sampling History Buffer 12 

 12-15 xxxx 0000 0000 0000 Reserved 

 Sampling History Buffer Flag 

Bits 0 to 11 control the sampling history buffer operation of HMI by the PLC. When this 

flag is turned ON, HMI performs sampling one time. To control the sampling history 

buffer flag again, this flag must be turned OFF and then ON again.  
 

 
Fig. 3-4-6 History Setup 
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Clearing History Buffer Register (HBCR) 

The history buffer when controlled by a PLC can also be cleared by the PLC.  

Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of Relative 

Position (x) 
Function 

Buffer Area 1 0 0000 0000 0000 000x Clearing History Buffer Flag 1 

Buffer Area 2 1 0000 0000 0000 00x0 Clearing History Buffer Flag 2 

Buffer Area 3 2 0000 0000 0000 0x00 Clearing History Buffer Flag 3 

Buffer Area 4 3 0000 0000 0000 x000 Clearing History Buffer Flag 4 

Buffer Area 5 4 0000 0000 000x 0000 Clearing History Buffer Flag 5 

Buffer Area 6 5 0000 0000 00x0 0000 Clearing History Buffer Flag 6 

Buffer Area 7 6 0000 0000 0x00 0000 Clearing History Buffer Flag 7 

Buffer Area 8 7 0000 0000 x000 0000 Clearing History Buffer Flag 8 

Buffer Area 9 8 0000 000x 0000 0000 Clearing History Buffer Flag 9 

Buffer Area 10 9 0000 00x0 0000 0000 Clearing History Buffer Flag 10 

Buffer Area 11 10 0000 0x00 0000 0000 Clearing History Buffer Flag 11 

Buffer Area 12 11 0000 x000 0000 0000 Clearing History Buffer Flag 12 

 12-15 xxxx 0000 0000 0000 Reserved 

 Clearing History Buffer Flag 

Bits 0 to 11 clear the history buffer. When this flag is turned ON, HMI clears the history 

buffer one time. To control the clearing history buffer flag again, this flag must be 

turned OFF and then ON again.  

Recipe Control Register (RECR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Change Recipe Number Flag 

1 0000 0000 0000 00x0 
Read Recipe Flag (PLC → HMI): 

Read recipe data from PLC and store it in HMI 

2 0000 0000 0000 0x00 
Write Recipe Flag (PLC ← HMI) 

Write recipe data from HMI into PLC  

3 0000 0000 0000 x000 Change Recipe Group Number Flag  

4-7 0000 0000 xxxx 0000 Reserved 

8-15 xxxx xxxx 0000 0000 Designate Recipe Group Number  

 Change Recipe Number Flag 

To change recipe number, the user can use Recipe Number Register RCPNO directly or 

use this flag. To specify the recipe number, write the recipe number into the Recipe 

Number Designation Register (RBIR) and then turn ON this flag (Bit 0). After the above 
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settings, the RCPNP can change to the designated recipe number automatically. To 

control the change recipe number flag again, this flag must be turned OFF and then 

ON again.  

For example (refer to Table 3-4-1), if set D6 to 3 and set D5 or $20.0 to 1 

simultaneously, the recipe number will become 3 (RCPNO=3). When D6 = 3, it 

indicates that the designated recipe number is 3. When D5 = 1, it indicates that Bit 0 of 

D5 is 1(0000 0000 0000 0001). 

 Read Recipe Flag 

Bit 1 reads the recipe data from PLC and stores the recipe data in the specified area of 

HMI. To read and store the recipe data, specify the recipe number and turn this flag to 

be ON. To control the read recipe flag again, this flag must be turned OFF and then ON 

again. 

For example (refer to Table 3-4-1), if the designated recipe number is 4 (RCPNO=4), 

set D5 to 2 or $20.1 to 1 and the recipe data saved in PLC will be read and stored in 

the 4th recipe register. The original data saved in the 4th recipe register will be 

updated as well. When D5 = 2, it indicates that Bit 1 of D5 is 1(0000 0000 0000 0010). 

 Write Recipe Flag 

Bit 2 write the recipe data from HMI into PLC. To write the recipe data, specify the 

recipe number and turn this flag to be ON. To control the write recipe flag again, this 

flag must be turned OFF and then ON again. 

For example (refer to Table 3-4-1), if the designated recipe number is 2 (RCPNO=2), 

set D5 to 4 or $20.2 to 1 and the recipe data saved in HMI will be written into the PLC 

register immediately. The original data saved in the PLC register will be updated as 

well. When D5 = 4, Bit 2 of D5 is 1(0000 0000 0000 0100). 

 Change Recipe Group Number 

To change the recipe group number, the user can use Recipe Group Register RCPG 

directly or use this flag. To specify the recipe group number, write the recipe group 

number into the Designate Recipe Group Number Register (Bits 8 to 15) and then turn 

ON this flag. After the above settings, when HMI detects the change recipe group 

number flag, it will change the value of RCPG and change recipe group number 

automatically. To control the change recipe group number flag again, this flag must 

be turned OFF and then ON again.  

For example (refer to Table 3-4-1), if set D5 to 520 or set$20.3 and $20.9 to 1 

simultaneously, the recipe group number will become 2 (RCPG=2). When D5 = 520, it 

indicates that Bit 3 and Bit 9 of D5 are both 1(0000 0010 0000 1000). 
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 Designate Recipe Group Number 

Bits 8 to Bit 15 designate the recipe group number. When the recipe group number is 

designated and turn ON this control flag, HMI will change the value of RCPG and 

change the recipe group number automatically.  

For example (refer to Table 3-4-1), if set D5 to 520 or set$20.3 and $20.9 to 1 

simultaneously, the recipe group number will become 2 (RCPG=2). When D5 = 520, it 

indicates that Bit 3 and Bit 9 of D5 are both 1(0000 0010 0000 1000). 

For more detailed settings, please refer to the following descriptions. 

How to designate recipe group number: 

D5 = 520(0000 0010 0000 1000) 

High Byte 

(Recipe Group Designation Register) 

0000 0010 

Low Byte 

(Other control flags relevant to Recipe) 

0000 1000 

If dividing D5 into high byte and low byte, it is easily to see that high byte determines 

the recipe group number (regardless of low byte). When the high byte setting is set to 

0000 0010, it indicates that the designated group number is the 2nd group. If the 

high byte setting is changed to 0000 0011, it indicates that the designated group 

number is changed to 3rd group and vise versa.  

Recipe Number Designation Register (RBIR) 

This register is used to specify the recipe. When this flag is turned ON, the system will write 

the designated recipe group number into Recipe Number Designation Register (RBIR). After 

Change Recipe Number Flag is turned ON, HMI will change the value of RCPNO and change 

the recipe number as well.  

For example (refer to Table 3-4-1), if set D6 to 3 and set D5 or $20.0 to 1 at the same time, 

the recipe number will become 3 (RCPNO=3) When D6 is set to 3, it indicates that the 

designated recipe number is 3. When D5 = 1, it indicates that Bit 0 of D5 is 1(0000 0000 

0000 0001). 

System Control Flag Register 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0-7 0000 0000 xxxx xxxx Multi-language Setting Value 

8 0000 000x 0000 0000 Printer Flag 

9 0000 00x0 0000 0000 Printer Form Feed Flag 

10-15 xxxx xx00 0000 0000 Reserved 
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 Multi-language Setting Value 

Bits 0 to 7 save the designated multi-language setting values (Fig. 3-4-7). These 

setting values control HMI to switch to the specified language (For more details on 

multi-language settings, please refer to section 3.10). 

For example (refer to Table 3-4-1 and Fig. 3-4-7), if language setting value 1 is Chinese, 

and D7 or $22.0 is set to 1, all the text in HMI will change to the text in Chinese. When 

D7 =1, it indicates that Bit 0 of D7 is 1(0000 0000 0000 0001).  

For more detailed settings, please refer to the following descriptions. 

How to designate the multi-language: 

D7 = 1(0000 0000 0000 0001) 

High Byte 

(Other control flags relevant to System 

Control) 

0000 0000 

Low Byte 

(Multi-language Setting Value Register) 

0000 0001 

If dividing D7 into high byte and low byte, it is easily to see that low byte determines 

the multi-language setting value (regardless of high byte). When the low byte setting is 

set to 0000 0001, it indicates that the multi-language setting value is 1, i.e. the 

language setting is Chinese. If the low byte setting is changed to 0000 0011, it 

indicates that the multi-language setting value is 2, i.e. the language setting is 

Japanese. Please note that the range of multi-language setting value is from 0 to 255. 

 

Fig. 3-4-7 Multi-language Settings 
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 Printer Flag 

When this flag is turned ON, the current display (Hard Copy) or the editing screen can 

be printed out. When this flag is turned OFF, the printer function is disabled.  

For example (refer to Table 3-4-1), if D7 is set to 256 or set $22.8 to 1, HMI will 

perform printing function. When D7 = 256, it indicates that Bit 8 of D7 is 1(0000 0001 

0000 0000). 

 Printer Form Feed Flag 

When this flag is turned ON, the printer will retract the paper and align the paper for 

the next run automatically. When this flag is set to OFF, the printer form feed function 

is disabled.  

For example (refer to Table 3-4-1), if D7 is set to 512 or set $22.9 to 1, HMI will retract 

the paper and align the paper for the next run automatically. When D7 = 512, it 

indicates that Bit 9 of D7 is 1(0000 0010 0000 0000). 

 

3.4.2 Status Block 

The status block is the way a PLC is used to get feedback from the HMI. Through the settings 

set in the registers, the controller which is connected to HMI can know HMI internal operation, 

i.e. screen switch, backlight on and off, current priority, curve sampling data and clear flag, 

etc. information. The status block consists of 8 continuous words and this cannot be changed 

(Fig. 3-4-2) When the user set the address in Status Block, PLC can read the status of DOP-B 

series HMI. Please note that when the function Control Block is disabled, the function of 

Status Block is disabled as well. In addition, ensure that the addresses of Control Block and 

Start Block must be different. 

The function and explanation of each WORD is listed as Table 3-4-2 below. In the following 

table, in the following example 1 we assume that the user uses a Delta PLC, so the available 

starting addresses in status block are Dm ~ Dm+7 (D10 ~ D17). In the following example 2, 

we assume that the user uses HMI internal register $, so the available starting address in 

control block is$m ~ $m+7 ($25 ~ $32). The user can choose if the status block designations 

are stored in PLC or HMI. 

Example 1 
(PLC register) 

Example 2 
(HMI register) Word Control Register 

Address Example Address Example 

0 General Control Status Register (GCSR) Dm D10 $m $25 

1 Screen Number Status Register (SNSR) Dm+1 D11   $m+1 $26 

2 Curve Control Status Register (CCSR) Dm+2 D12 $m+2 $27 

3 Sampling History Buffer Status Register (HSSR) Dm+3 D13 $m+3 $28 

4 Clearing History Buffer Status Register (HCSR) Dm+4 D14 $m+4 $29 

5 Recipe Status Register (RESR) Dm+5 D15 $m+5 $30 

6 Recipe Number Status Register (RBSR) Dm+6 D16 $m+6 $31 
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Example 1 
(PLC register) 

Example 2 
(HMI register) Word Control Register 

Address Example Address Example 

7 General Control Status Register 2 (GCSR2) Dm+7 D17 $m+7 $32 

Table 3-4-2 Status Block Designations 

General Control Status Register (GCSR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Screen Switch Status Flag 

1-2 0000 0000 0000 0xx0 Reserved 

3 0000 0000 0000 x000 Clear Status of Alarm Buffer  

4 0000 0000 000x 0000 Clear Status of Alarm Counter 

5-7 0000 0000 xxx0 0000 Reserved 

8 0000 000x 0000 0000 User Security Level Flag (Level 1) 

9 0000 00x0 0000 0000 User Security Level Flag (Level 2) 

10 0000 0x00 0000 0000 User Security Level Flag (Level 4) 

11-15 xxxx x000 0000 0000 Reserved 

 Screen Switch Status Flag 

When HMI switches the screen, this flag is turned ON. After the screen switch is 

completed, this flag is turned OFF.  

 Clear Status of Alarm Buffer 

When HMI clears the alarm buffer, this flag is turned ON. After this function is 

completed, this flag is turned OFF.  

 Clear Status of Alarm Counter 

When HMI clears the alarm counter, this flag is turned ON. After this function is 

completed, this flag is turned OFF.  

 User Security Level Flag 

Bits 8 to 10 hold the current user security level. 

Flag Control 
Level 

ON  
Binary Display 

Level 0  Bit 8, Bit 9, Bit 10 0000 0000 0000 0000 

Level 1 Bit 8 Bit 9, Bit 10 0000 0001 0000 0000 

Level 2 Bit 9 Bit 8, Bit 10 0000 0010 0000 0000 

Level 3 Bit 8, Bit 9 Bit 10 0000 0011 0000 0000 

Level 4 Bit 10 Bit 8, Bit 9 0000 0100 0000 0000 

Level 5 Bit 8, Bit 10 Bit 9 0000 0101 0000 0000 
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Flag Control 
Level 

ON  
Binary Display 

Level 6 Bit 9, Bit 10 Bit 8 0000 0110 0000 0000 

Level 7 Bit 8, Bit 9, Bit 10  0000 0111 0000 0000 

Screen Number Status Register (SNSR) 

This register stores the last screen number (includes sub screen) that the user opened 

(refer to D11 or $26 of Table 3-4-2).  

Curve Control Status Register (CCSR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Curve Sampling Status Flag 1 

1 0000 0000 0000 00x0 Curve Sampling Status Flag 2 

2 0000 0000 0000 0x00 Curve Sampling Status Flag 3 

3 0000 0000 0000 x000 Curve Sampling Status Flag 4 

4-7 0000 0000 xxxx 0000 Reserved 

8 0000 000x 0000 0000 Curve Clear Status Flag 1 

9 0000 00x0 0000 0000 Curve Clear Status Flag 2 

10 0000 0x00 0000 0000 Curve Clear Status Flag 3 

11 0000 x000 0000 0000 Curve Clear Status Flag 4 

12-15 xxxx 0000 0000 0000 Reserved 

 Curve Sampling Status Flag 

When the HMI samples a trend graph or X-Y chart, the curve sampling status flag (bits 

0 to 3) is turned ON. After the sampling operation is completed, the curve sampling 

status flag is turned OFF. Curve Sampling Flag 1 of control block corresponds to Curve 

Sampling Status Flag 1 of status block, Curve Sampling Flag 2 of control block 

corresponds to Curve Sampling Status Flag 2 of status block and vise versa.  

 Curve Clear Status Flag 

When the HMI clears trend graph or X-Y chart, the curve clear status flag (bits 8 to 11) 

is turned ON. After the clear operation is completed, the curve clear status flag is 

turned OFF. Curve Clear Flag 1 of control block corresponds to Curve Clear Status Flag 

1 of status block, Curve Clear Flag 2 of control block corresponds to Curve Clear 

Status Flag 2 of status block and vise versa.  
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Sampling History Buffer Status Register (HSSR) 

Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of 

Relative Position (x) 
Function 

Buffer Area 1 0 0000 0000 0000 000x Sampling History Buffer Status Flag 1 

Buffer Area 2 1 0000 0000 0000 00x0 Sampling History Buffer Status Flag 2 

Buffer Area 3 2 0000 0000 0000 0x00 Sampling History Buffer Status Flag 3 

Buffer Area 4 3 0000 0000 0000 x000 Sampling History Buffer Status Flag 4 

Buffer Area 5 4 0000 0000 000x 0000 Sampling History Buffer Status Flag 5 

Buffer Area 6 5 0000 0000 00x0 0000 Sampling History Buffer Status Flag 6 

Buffer Area 7 6 0000 0000 0x00 0000 Sampling History Buffer Status Flag 7 

Buffer Area 8 7 0000 0000 x000 0000 Sampling History Buffer Status Flag 8 

Buffer Area 9 8 0000 000x 0000 0000 Sampling History Buffer Status Flag 9 

Buffer Area 10 9 0000 00x0 0000 0000 Sampling History Buffer Status Flag 10 

Buffer Area 11 10 0000 0x00 0000 0000 Sampling History Buffer Status Flag 11 

Buffer Area 12 11 0000 x000 0000 0000 Sampling History Buffer Status Flag 12 

 12-15 xxxx 0000 0000 0000 Reserved 

 Sampling History Buffer Status Flag 

When sampling the history buffer, the sampling history buffer status flag will be set to 

be ON (Bits 0 to 11 is set to ON). After the sampling operation is completed, the 

sampling history buffer status flag will be OFF. 

Clearing History Buffer Status Register (HCSR) 

Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of 

Relative Position (x) 
Function 

Buffer Area 1 0 0000 0000 0000 000x Clearing History Buffer Status Flag 1 

Buffer Area 2 1 0000 0000 0000 00x0 Clearing History Buffer Status Flag 2 

Buffer Area 3 2 0000 0000 0000 0x00 Clearing History Buffer Status Flag 3 

Buffer Area 4 3 0000 0000 0000 x000 Clearing History Buffer Status Flag 4 

Buffer Area 5 4 0000 0000 000x 0000 Clearing History Buffer Status Flag 5 

Buffer Area 6 5 0000 0000 00x0 0000 Clearing History Buffer Status Flag 6 

Buffer Area 7 6 0000 0000 0x00 0000 Clearing History Buffer Status Flag 7 

Buffer Area 8 7 0000 0000 x000 0000 Clearing History Buffer Status Flag 8 

Buffer Area 9 8 0000 000x 0000 0000 Clearing History Buffer Status Flag 9 

Buffer Area 10 9 0000 00x0 0000 0000 Clearing History Buffer Status Flag 10 

Buffer Area 11 10 0000 0x00 0000 0000 Clearing History Buffer Status Flag 11 

Buffer Area 12 11 0000 x000 0000 0000 Clearing History Buffer Status Flag 12 

 12-15 xxxx 0000 0000 0000 Reserved 
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 Clearing History Buffer Status Flag 

When clearing the history buffer, the clearing history buffer status flag will be set to 

be ON (Bits 0 to 11 is set to ON). After the clearing operation is completed, the 

clearing history buffer status flag will be OFF. 

Recipe Status Register (RESR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Change Status of Recipe Number 

1 0000 0000 0000 00x0 Recipe Read Status (PLC → HMI) 

2 0000 0000 0000 0x00 Recipe Write Status (PLC ← HMI) 

3 0000 0000 0000 x000 Change Status of Recipe Group Number 

4~7 0000 0000 xxxx 0000 Reserved 

8~15 xxxx xxxx 0000 0000 Designate Status of Recipe Group Number  

 Change Status of Recipe Number 

When the recipe number is changed, this flag is turned ON. After the recipe number is 

changed and the value of RCPNO is updated, this flag is turned OFF.  

 Recipe Read Status 

When HMI reads one number of recipe data from PLC, this flag is turned ON. After read 

operation is completed and the recipe data is stored in HMI, this flag is turned OFF.  

 Recipe Write Status 

When HMI sends one number of recipe data to PLC, this flag is turned ON. After write 

operation is completed and the recipe data is written into PLC, this flag is turned OFF.  

 Change Status of Recipe Group Number 

When the recipe group number is changed, this flag is turned ON. After the recipe 

group number is changed and the value of RCPG is updated, this flag is turned OFF.  

 Designate Status of Recipe Group Number 

No matter the value of RCPG is designated by PLC or HMI, when the designated recipe 

group number is changed, this flag is turned ON so that the system can echo back the 

updated recipe group number to the Designate Recipe Group Number Register. 

Recipe Number Status Register (RBSR) 

No matter the value of RCPNO is designated by PLC or HMI, when the designated recipe 

number is changed, this flag is turned ON so that the system can feedback the updated 

recipe group number to the Designate Recipe Number Register. 
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General Control Status Register 2 (GCSR2) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0-7 0000 0000 xxxx xxxx Multi-language Status Value 

8 0000 000x 0000 0000 Printer Status Flag 

9 0000 00x0 0000 0000 Printer Form Feed Status Flag 

10-15 xxxx xx00 0000 0000 Reserved 

 Multi-language Status Value 

Bits 0 to 7 read the current language that HMI shows from the multi-language status 

value. 

 Printer Status Flag 

When this flag is turned ON, it indicates that the printer is printing the current display 

or editing screen. When this flag is turned OFF, the printer function is disabled.  

 Printer Form Feed Status Flag 

When this flag is turned ON, it indicates that the printer is retracting the paper and 

aligning the paper for the next run automatically. When this flag is turned OFF, the 

printer form feed function is disabled.  
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3.5 Menu Bar and Toolbar (File) 

 
 

3.5.1 New 

Create a New Project. Creates a new project by choosing File > New (Fig. 2.3.2) or clicking the 

New icon  from toolbar (Fig. 2.3.3), or pressing Ctrl + N.  

If this is the first time use and there is no old project, the following dialog box (Fig. 3-5-1) will 

show up for the user to input project name, screen name, screen number, HMI type and 

connecting base port controller after creating a new project.  

 
Fig. 3-5-1 New project dialog box 

3-42 Revision May, 2010 



 Chapter 3 Creating and Editing Screens 

If other project files already exist and are open, the user will get the following dialog box to 

remind the user of saving project (Fig. 3-5-2) before creating new project. Press Yes button to 

save the existed file, press No button not to save the file and press Cancel button to cancel 

the save operation. After the user press the Yes or No button, the new project dialog box will 

appear again (Fig. 3-5-1).  

 

圖 3-5-2 Saving dialog box 

Input project name, screen name, select HMI model and connecting base port controller (Fig. 

3-5-3), and then press OK button.  

 

 

 

 

 

 

 

 

 

圖 3-5-3 HMI model and base port controller options 

 

3.5.2 Open 

Open Old Project. Open current project by choosing File > Open (Fig. 3-5-4) or clicking the 

Open icon  from toolbar, or pressing Ctrl + O.  
If other project files exist before opening an old project, the user will get the Saving dialog 

box (Fig. 3-5-2) to remind the user of saving file and then get the following dialog box for 

opening existing dop file (Fig. 3-5-4).   

If save operation is complete or there is no old project files, the following dialog box for 

opening existing dop file (Fig. 3-5-4) will show up directly. 
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Fig. 3-5-4 Open an old project in ScrEdit 

3.5.3 Close 

Close Project. Closes project by clicking File > Close. 

If project didn’t get saved before issuing the command of closing project, the user will get 

saving dialog box (Fig. 3-5-5) to remind the user of saving project. The user can press Yes 

button to close the project. 

 

Fig. 3-5-5 Saving dialog box 

3.5.4 Save 

Save the File. Save current project into hard disk with extension file “dop” by choosing File > 

Save or clicking the Save icon , or pressing Ctrl + S. If the project is a new file, the Save as 

dialog box will show up (Fig. 3-5-6). If the project is an old file, the Save function will perform 

immediately and the Save as dialog box will not show up. 
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3.5.5 Save as  

Save current project to another file name by clicking File > Save As. The user will get Save as 

dialog box (Fig. 3-5-6) to input project name with extension file dpb. This dialog also appears 

automatically when the first time any project file is saved no matter whether Save As or Save 

command is used.  

 
Fig. 3-5-6 Save as dialog box 

 

3.5.6 Make Ext. Memory Data 

Before using this command, ensure to compile the editing screen data. If not execute the 

compilation first, the ScrEdit cannot make screen data and an error message dialog box will 

show up (Fig. 3-5-7). Please execute the compilation first and then clicking File > Make Ext. 

Memory Data to copy the compiled HMI program into SD card or a USB disk (Fig. 3-5-8). If the 

SD card or USB disk with compiled HMI program stored inside is inserted into HMI, HMI will 

startup by reading the data of SD card or USB disk directly. 

 

Fig. 3-5-7 Error message dialog box when making ext. memory data 
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Fig. 3-5-8 Make Ext. Memory Data dialog box 

 

3.5.7 Open Ext. Memory Data 

To open the screen data, select File > Open Ext. Memory Data or press Ctrl+I. A dialog box 

is displayed and the user selects the file that the user wants to open.  

 

3.5.8 Password Protect 

The user can enable and disable password protect function (Fig. 3-5-9 & Fig. 3-5-10) by 

clicking File > Password protect. Once password protect function is enabled, the user will 

get Fig. 3-5-9 dialog box and  symbol before “Password Protect” command. If the  

symbol shows before “Password Protect” command from File menu, it indicates that this dpb 

file is password protected and the user will need to input password before opening dpb file. 

The password is set by clicking Options > Configuration > General > Security) (Fig. 3-5-11). 

If the password protect function is disabled, the Fig. 3-5-10 dialog box will show up.  

 

Fig. 3-5-9 Password protect function is enabled 
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Fig. 3-5-10 Password protect function is disabled 

 

Fig. 3-5-11 Password settings – Security 

 

3.5.9 Print 

Print current screen by choosing File > Print, or clicking the Print icon  from toolbar, or 

pressing Ctrl + P.  

 

3.5.10 Print Preview 

To preview the screen print before sending the image to the printer, select File > Print 

Preview (Fig. 3-5-12).  
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Fig. 3-5-12 Print Preview dialog box 

 

3.5.11 Print Setup 

To choose the printer and paper options, select File > Print Setup (Fig. 3-5-13). 

 

Fig. 3-5-13 Print Setup dialog box 
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3.5.12 File Quick Access 

By default, ScrEdit presents a list of the four most recent used files on the File menu for quick 

access (Fig. 3-5-14). Just click the file name to open the file. This function is similar to the 

Open command and the user can refer to the description of Open command on the page 3-43. 

If the saving path is too long, the too long path will display as “….”. The user still can see the 

complete dpb file name. 

 

Fig. 3-5-14 Most recent used files 

 

3.5.13 Exit 

Exit function is to close all open editing files and save those that have not been save yet and 

finally exit the ScrEdit. Select this function by clicking File > Exit. If the file has been changed 

or not saved yet, the saving dialog box (Fig. 3-5-2) will show up to remind the user of saving 

project. If the user press Cancel button at this time, the exit command is cancelled. Either 

pressing Yes button to save the file, or pressing No button not to save the file can exit the 

ScrEdit. After the user press the Yes button, the Save As dialog box will appear (Fig. 3-5-4) for 

saving the file. 
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3.6 Menu Bar and Toolbar (Edit) 

Adopt pull-down menu similar to Microsoft Office style and provide user-friendly Edit pull-down 

menu. 

  
 

3.6.1 Undo 

Undo the last action. Select this function by choosing Edit > Undo or clicking the Undo icon 

 from toolbar, or pressing Ctrl + Z. All actions are recorded in output window.  

 

3.6.2 Redo 

Redo the undo action. Select this function by choosing Edit > Redo or clicking the Redo icon 

 from toolbar, or pressing Ctrl + Y. All actions are recorded in output window.  

 

3.6.3 Cut 

Deletes the selected element and save it in clipboard to paste to other place. Select this 

function by choosing Edit > Cut from menu bar or clicking the Cut icon  from toolbar, or 

pressing Ctrl + X.  
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3.6.4 Copy 

Copy the selected element to the clipboard. Select this function by choosing Edit > Copy 

from menu bar or clicking the Copy icon  from toolbar, or pressing Ctrl + C.  

 

3.6.5 Paste 

Paste element from clipboard. Select this function by choosing Edit > Paste from menu bar or 

clicking the Paste icon  from toolbar, or pressing Ctrl + V. 

  

3.6.6 Delete 

Delete selected element. Select this function by choosing Edit > Delete from menu bar or 

pressing Del key.  

 

3.6.7 Select All 

This command selects all elements. To select all elements to remove everything, select Edit > 

Select All from menu bar or press Ctrl + A. When the user uses Select All, the element in the 

upper left corner will be filled with a blue and white border as a base element. Additional 

elements will be filled with a white and black border. The base element is used to align or 

resize.  

 

3.6.8 Find 

To find content that matches the find criteria, select Edit > Find, or click the , or press 

Ctrl + F. The user can find element text, read address, write address or memory address on 

the current screen or all screens (Fig. 3-6-1). Once the content is located, the found content is 

displayed in the output window. To go to actual location of the found content, click in the 

output window and HMI will move to the location of the found content. (Fig. 3-6-2).  
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Find 

Find What: This field is where the user enters the word or phase that the user is looking for. 

 

Fig. 3-6-1 Find dialog box 

Options:  

Current Screen 

This causes ScrEdit to navigate the current screen only and find the matching 

word or phase that the user is looking for. The output window will display all 

matching words or phases. When the user double clicks the word or phase, 

ScrEdit will jump to that location of the matching word or phase. Please refer to 

the example screen below.  

 

Fig. 3-6-2 
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All Screen 

This causes ScrEdit to navigate all screens and find the word or phase that the 

user is looking for. The output window will display all matching words or 

phases. When the user double clicks the word or phase, ScrEdit will also jump to 

that location of the matching word or phase. 

Type:  

Text 

To specify the data type as Text, click the Text button 

Read Address 

To specify the data type as Read Address, click the Read Address button. 

Write Address 

To specify the data type as Write Address, click the Write Address button. 

All Address 

To specify the search to look for all data types, click the All Address button. 

Check Box: 

By checking Match whole word only check box, the system finds only the 

words or phrases that the user entered. If the user does not select this option, 

the system finds all contents that include the words or phrases that the user 

entered.  

By checking Support Multi-Language Finding check box, the system finds all 

multi-language contents that include the words or phrases that the user 

entered. The user can use the Support Multi-Language Finding option when 

finding texts. 

  

3.6.9 Replace 

To replace the content that matches the replace criteria, select Edit > Replace or press Ctrl + 

R. The user can replace element text, read address, or write address on the current screen or 

all screens. The replacement data type can be Bit, Word or Double Word. The user can change 

the data type only for read addresses and write addresses. The replacement data may exists 

in Element, Macro, Control Block, Status Block, History Buffer, Alarm and Recipe. When read 

addresses and write addresses are selected, the user can choose where to find and replace 

the content that matches the replace criteria (the items for replacement). 
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Replace  

Find What: This field is where the user enters the word or phase that the user is looking for. 

Replace With: This field is where the user enters the word or phase that the user wants to 

replace with. 

 

Fig. 3-6-3 Replace dialog box 

Options:  

Current Screen 

This causes ScrEdit to navigate the current screen only, find the matching word 

or phase that the user is looking for and replace it. 

 

All Screen 

This causes ScrEdit to navigate all screens and find the matching word or phase 

that the user is looking for and replace it. 

Type:  

Text 

To specify the data type as Text, click the Text button 

Read Address 

To specify the data type as Read Address, click the Read Address button. 

Write Address 

To specify the data type as Write Address, click the Write Address button. 
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Data Type:  

Bit, WORD, DWORD 

If the Read Address or Write Address button is selected, it is needed to select if 

the replacing data type is Bit, Word, or Double Word. 

Filter (Replace Criteria) 

Element, Macro, Control Block, Status Block, History Buffer, Alarm and Recipe  

If the Read Address or Write Address button is selected, it is needed to select if 

the replace criteria are Element, Macro, Control Block, Status Block, History 

Buffer, Alarm and Recipe. 

Replace / Replace All 

If the user only wants to replace a single instance of the data, click the Replace 

button. 

If the user wants to replace all instances of the specified data automatically, 

click the Replace All button.  

For example, the user wants to replace the read address from $0 to $1234, 

enter $0 in Find What field, enter $1234 in Replace With field and press Replace 

button (Fig. 3-6-4). ScrEdit will find the matching criteria (Fig. 3-6-5) and 

perform the replacement.  

 

Fig. 3-6-4 Replace dialog box 
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Fig. 3-6-5 

 

3.6.10 Station Replace 

This function is used to replace the designated station number (PLC unit number).  

 

Fig. 3-6-6 

 

3.6.11 Group 

This command groups the selected elements. When the user groups two or more elements, 

they will become one unit. Thus, when the user moves or changes the elements, the user will 

move or change them together. To group the elements, select Edit > Group from menu bar or 

clicking the Group icon  from toolbar. 
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3.6.12 Ungroup 

This command ungroups selected elements. To ungroup the elements, select Edit > Ungroup 

from menu bar or clicking the Ungroup icon  from toolbar.  
 

3.6.13 Order 

This command changes the stacking order of the selected elements. To change the order, 

select Edit > Order, or select one of the specific order icons  from the toolbar.  

The Order icons include: 

 Bring to Top: Moves the selected element to the front. 

 Send to Bottom: Moves the selected element to the behind. 

 Bring Forward: Moves the selected element to the behind. 

 Send Backward: Moves the selected element one step to the behind. 
 

3.6.14 Align 

This command aligns the elements. The user can use this command only when more than one 

element are selected. The Screen Editor refers to the base element to align the elements. 

To align the elements, select Edit > Align, or click one of the Align icons on the toolbar  

: Align Left. Move an element to the left. 

: Align Right. Move an element to the right. 

: Align Top. Move an element to the top. 

: Align Bottom. Move an element to the bottom. 

: Align Center Vertically. Center an element vertically. 

: Align Center Horizontally. Center an element horizontally. 

: Across Space Evenly. Space selected elements evenly across the window. 

: Down Space Evenly. Space selected elements evenly from top to bottom. 

Align Left, Align Right, Align Top and Align Bottom commands are available when two or 

more elements are selected. That is because the element only can be left, right, top and 

bottom aligned relative to another element. Align Center Vertically and Align Center 

Horizontally commands are available when one or more elements are selected. Across Space 

Evenly and Down Space Evenly are available when three or more elements are selected. After 

Align commands are used, the coordinates of the elements will changed to the coordinates of 

the new position. 
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3.6.15 Make Same Size 

This command makes the element to be the same size. The users must select one element 

first as reference object, and then select other elements. To use this function, select Edit > 

Make Same Size or click the make same size icons in the toolbar. 

 

3.6.16 Text Process 

This command aligns the text. To use this function, select Edit > Text Process or click the 

text process icons in the toolbar. In the Import Text dialog box, the user can decide if use 

Text Bank Edit Font or not. If the user checks the box next to Text Bank Edit Font, the 

imported text will be display by adopting the fonts of Text Bank. For the settings of Text Bank, 

please refer to Options > Text Bank. 

 

3.6.17 Picture 

 next to the Picture command represents that this function is enabled. To use this function, 

select Edit > Picture or click the picture icons in the toolbar. The users can also use the 

functions of Bitmap Toolbar to perform Picture commands.  

 

3.6.18 Duplicate 

To copy one or more elements at the same time, select Edit > Duplicate. After the user has 

selected this command, the Duplicate dialog box is displayed (Fig. 3-6-7). The user can enter 

the number of columns and rows to get the total copy numbers. The minimum entry number 

must be more than 2 as the original element is included in the total copy number. 

If the user wants to copy only the rows, uncheck the box next to columns. If the user wants to 

copy only the columns, uncheck the box to rows. 

To set the spacing between every element, set the pixel count in the Spacing field. 

To place the copied element by ascending or descending address, click the Increase Address 

or Decrease Address button. The unit of the address can be Word or Bit. To place the copied 

element by the horizontal (X-direction) or vertical (Y-direction) direction, click the X-Direction 

or Y-Direction button (Please refer to the example 1 and 2 in Fig. 3-6-8 and Fig. 3-6-9). 

 

3-58 Revision May, 2010 



 Chapter 3 Creating and Editing Screens 

 

Fig. 3-6-7 Duplicate dialog box 

 
Fig. 3-6-8 Duplicate Example 1 
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Fig. 3-6-9 Duplicate Example 2 
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3.7 Menu Bar and Toolbar (View) 

 

In View option, the user can decide how toolbars and docking windows display. Once the user clicks 

on it, it will have icon  in front of it and display on screen. The user can also arrange these 

toolbars and docking windows by themselves. If  not show in front of the toolbar, it indicates 

that the toolbar is hided and not display on the screen. The description of each toolbar is introduced 

in the following sections. 

 

3.7.1 Tools 

Standard Toolbar 

 

Icon Function Description 

 New Create a new project 

 Open Open an old project 

 Save Save current edited project 

 Export Export an project to BMP format 

 Undo Undo an action (some actions cannot be undone) 

 Redo Redo an action 

 Cut Cut selected elements 

 Copy Copy selected elements 

 Paste Paste the element the user copy or cut 

 Find Find specific text, write address or read address 
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Icon Function Description 

 New Screen Create a new screen 

 Open Screen Open an old screen 

 Print Print current project 

 About Screen editor version 

Table 3-7-1 Standard Toolbar  

 

Status Bar 

Following is the status bar of Screen Editor (Fig. 3-7-1).  

 

 
 

 

 

 

 

 

 

 

 

 
Fig. 3-7-1 Status Bar  

 

 

Text Toolbar 

 

Icon Function Description 

 Font Size Display and change text size 

 Font Name Display and change text font 

 Align Txt to Left Align text to left 

 Text Center Horizontally 
The space at the right/left sides of text 

will be the same. 

 Align Text to Right Align text to right 

Download 
Interface 

Mouse is moving 
 

Element Coordinate 
and Size 

Function Connecting 
HMI Model  

CAP LOCK 

NUM LOCK 

SCROLL LOCK 
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Icon Function Description 

 Align Text to Top Align text to top 

 Text Center Vertically 
The space at the top/bottom sides of 

text will be the same. 

 Align Text to Bottom Align text to bottom 

 Text Color Change text color 

 Bold Text bold 

 Italic Text Italic 

 Underline Add line under text 

Table 3-7-2 Text Toolbar 

Bitmap Toolbar 

 

Icon Function Description 

 
Select Transparent 

Color 

Use the suction tool to remove the color of the picture and 

determine the transparent color of the picture  

 

Chang Mode for 

process all state 

pictures 

If this function is enabled (this icon is pressed), not only the 

current picture with current state but also all pictures with 

all states are stretched, resized or aligned  

 Picture Stretch All 
Stretch the selected picture to the whole range of the 

element. 

 Picture Stretch 1: 1 Scale the picture relative to original picture size  

 Original Picture Resize the selected picture to the actual picture size 

 Picture Align Left Align the selected picture to left 

 
Picture Center 

Horizontally 

The space at the right/left sides of the selected picture are 

the same 

 Picture Align Right Align the selected element to right 

 Picture Align Top Align the selected element to top 

 
Picture Center 

Vertically 

The space at the top/bottom sides of the selected element 

are the same 

 Picture Align Bottom Align the selected element to bottom 

Table 3-7-3 Bitmap Toolbar 
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Element Toolbar 

 

Icon Function Description 

 Button 

 

 Meter 

 

 Bar 
 

 Pipe 

 

 Pie 
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Icon Function Description 

 Indicator 

 

 Display 

 

 Graphic 

 

 Input 

 

 Curve 

 

 Sampling 

 

 Alarm 

 

 Keypad 

 

Table 3-7-4 Element Toolbar 
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Drawing Toolbar 

 

 

Icon Function Description 

 Line Draw a line 

 Rectangle Draw a rectangle 

 Circle Draw a circle 

 Polygon Draw a polygon 

 Arc Draw an arc 

 Text Add paragraph text  

 Scale Draw a scale drawing 

 Table Create a table  

Table 3-7-5 Drawing Toolbar 

 
Layout Toolbar 1 

 

Icon Function Description 

 Current Element State Text on selected element 

 View State OFF/0 Switch and view current state OFF/0 

 View State ON/1 Switch and view current state ON/1 

 
Display All Read/Write 

Address 

Display all read/write addresses of all 

elements 

 Previous windows Select previous windows 

 Next windows Select the next windows 

 Compile Compile current element 
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Icon Function Description 

 
Download Screen and 

Recipe 
Download screen data and recipe 

 Download Screen Download screen data 

 On-line Simulation 
Test editing file at PC side and 

connected to the controller 

 Off-line Simulation 
Test editing file at PC side and not 

connected to the controller 

Table 3-7-6 Layout Toolbar 1 

Layout Toolbar 2 

 

Icon Function Description 

 Group Group the selected elements 

 Ungroup Ungroup the selected elements 

 Bring to Front 
Move the selected element to the front of 

all other elements 

 Send to Bottom 
Move the selected element behind all 

other elements 

 Bring Forward 
Move the selected element forward one 

position 

 Send Backward 
Move the selected element behind one 

position 

 Align Left Align the selected elements to left 

 Align Right Align the selected elements to right 

 Align Top Align the selected elements to top 

 Align Bottom Align the selected elements to bottom 

 
Align Center 

Vertically 

Set the element to be the vertical position 

of the work place 

 
Align Center 

Horizontally 

Set the element to be the horizontal 

position of the work place 

 Across Space Evenly 
Make all the elements align in a consistent 

width 
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Icon Function Description 

 Down Space Evenly 
Make all the elements align in a consistent 

height 

 Make Same Width 
Make the selected elements to be the 

same width 

 Make Same Height 
Make the selected elements to be the 

same height 

 Make Same Size 
Make the selected elements to be the 

same size 

Table 3-7-7 Layout Toolbar 2 

Zoom Toolbar 

 

Icon Function Description 

 Display Level 

Lets the user set a zoom level, including 

25%, 50%, 75%, 100%, 150%, 200% and 

300% 

 Zoom In 
Lets the user change the magnification 

level, including 150%, 200% and 300%. 

 
Zoom Out 

Lets the user reduce the magnification 

level, including 25%, 50% and 75%. 

 
1:1 

Lets the user change element size to 

actual size (100%). 

Table 3-7-8 Zoom Toolbar 
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3.7.2 Property Table 

The Property Table displays the element property settings for each element (Fig. 3-7-2). 

 

All elements on the current 

editing screen 

 

 

Element state selection 

 

 

 

 

Fig. 3-7-2 Property Table and Editing Screen Preview 
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3.7.3 Record and Output Window 

c ys all the editing actions and output message when 

 

4, 

The Re ord and Output Window displa

compile function is enabled. When HMI program is compiled, the system will detect the 

program automatically. Once error occurs, the error messages will be displayed in Output

Window. To get to the error element window, click on the error message (Fig. 3-7-3, Fig. 3-7-

Fig. 3-7-5, Fig. 3-7-6). 

         

Fig. 3-7-3 Record Window  Fig. 3-7-4 Output Window 

         

Fig. 3-7-5 Compile Result  Fig. 3-7-6 Error Message 
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3.7.4 Zoom In 

Zoom in to get a close look at the elements on ScrEdit work place (Fig. 3-7-7, Fig. 3-7-8). 

 
Fig. 3-7-7 Zoom level = 100% (Before Choosing Zoom In command) 

 

Fig. 3-7-8 Zoom level = 125% (After Choosing Zoom In command) 
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3.7.5 Zoom Out 

Zoom out to see more look of the elements on ScrEdit work place (Fig. 3-7-9). 

 
Fig. 3-7-9 Zoom level = 75% (After Choosing Zoom Out command) 

 

3.7.6 Actual Size 

Return to actual size (100%). This size is relative to the screen size of HMI. 

No matter zoom in or zoom out command, the zoom level could be 20%, 50%, 75%, 100%, 

150%, 200% or 300%. The user can also zoom in or out by clicking  or  or selecting 

the Zoom level (Fig. 3-7-10). 

 

Fig. 3-7-10 Zoom Level 
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3.7.7 Full Screen 

Refer to Fig. 3-7-11. Full screen provides maximum view to edit in ScrEdit. Full screen view 

will hide all toolbars and docking windows other than the ScrEdit work place itself. Fig. 3-7-11 

full screen also shows the reference macro command.  

 
Fig. 3-7-11 Full Screen (Pressing Esc key or left-click the mouse can exit Full screen) 

3.7.8 I/O Screen 

Refer to Fig. 3-7-12. I/O screen also provides maximum view to edit in ScrEdit just like Full 

screen. But the difference is that I/O Screen will show the read and write addresses of the 

element and also shows the set macro commands. 

 

Fig. 3-7-12 I/O Screen (Pressing Esc key or left-click the mouse can exit Full screen) 
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3.7.9 Grid Setup 

Grid Setup is a function that can help the user to align and position the element more easily 

and precisely. The distance (spacing) between the grid dots can be set by the user freely (Fig. 

3-7-13 and Fig. 3-7-14). 

Show Grid: Show the grid dots on the screen. 

Snap to Grid: Make the elements snap to grid so that the elements can jump between grid 

lines when the user moves them.  

 
Fig. 3-7-13 Grid Setup dialog box 

 

Fig. 3-7-14 Show Grid screen 
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3.7.10 Cross Reference Table 

When creating and editing various kinds of elements, often the same address is reused. 

To avoid this situation, HMi provides the cross reference table function for user’s 

convenience and quick reference. The user can view the read/write addresses of the selected 

element and see its relationship or connection with the addresses of other elements, macro 

commands or the system control area. The first row of the cross reference table displays the 

referred element that the user selected. The following rows display the elements which have 

the same write address. The user can double-click a specific row and HMi will switch to the 

corresponding screen of the referred address. In Fig. 3-7-15, we can see that alarm address 

and macro command use the same internal memory $50. 

 

Fig. 3-7-15 Cross Reference Table 

 

3.7.11 Element Part List 

When the Element Part List function is enabled, HMi sorts out and classifies all the elements 

on the current screen. The user can click the tab to switch to the classification that the user 

wants to view. The related addresses and corresponding properties are listed in each 

classification (Name, Describe, Write / Read address, Trigger address, Trigger type, Interlock 

and Level) in each tab. The user can double-click the column to let HMi select the element 

automatically and allow the user to edit the detailed property of the selected element in the 

property table.  
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Fig. 3-7-16 Element Part List dialog box 

 

3.7.12 Memory List  

There are four items in memory list: 

1. ROM: It is the location where recipe data and screen data are stored.  

2. SRAM: It is the location where non-volatile data is stored.  

When there are history and alarm, etc. data in the project, the user can check the 

memory space in this area.  

3. SDARM: It is the location where HMI executes the project. To get this information, the 

user must create a project and compile it first.  

4. External Storage: It indicates the external memory is used. When the non-volatile data is 

stored in external memory, i.e. USB disk, the data stored in SRAM will be moved to 

external memory area. 
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See below example. 

 

(1). See the memory space after a picture is imported.  

(2). See the memory space after a history data is created.  

 

(1). Import a picture 

When importing a picture on HMI screen, the memory space of ROM and SDRAM changes.  

When the user create a new project, the calculated memory space by the system is shown 

as:  

ROM=3.13% 

SDAM=0.71% 

 

After importing a picture on the screen, the memory space changes as shown as the figure 

below. 

 

At this time, the memory space is changed as: 

ROM=7.29% 

SDAM=3.98% 

The occupied ROM space increases 256K (384K-128K) and the occupied SDRAM space 

increases 600K (600K-0K). 
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(2). Create a history data 

In this case, the original occupied memory space is:  

ROM=7.29% 

SDAM=3.98% 

SRAM=0% 

External Storage=0% 

 

Create a two word history data as shown as the figure below. Ensure that this history data 

is stored in HMI (non-volatile area), i.e. Retained check box must be checked. 

 

 

After the history setting is completed, the memory space changes. 

Each saved date and time record occupied 6Byres 

Each saved history data occupied 2word (4Byres) 

SRAM=（6+4）x 10 +10 Byres (for system use) =110 Byres 

 

At this time, the memory space will become: 

ROM=7.29% 

SDAM=3.98% 

SRAM=0.03% 

External Storage=0% 
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If the history data is saved in USB Disk (External Storage), the occupied memory space is 

changed as follows:  

ROM=7.29% 

SDAM=3.98% 

SRAM=0% 

External Storage=110Bytes 

 

 

For more details setting on alarm and history data, please refer to the section 3.11.3 in 

Chapter 3. 
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3.8 Menu Bar and Toolbar (Element) 

3.8.1 Create an Element 

 

There are four methods for choosing elements when editing the screens: 

1. Right-click the mouse in the work place and a shortcut menu will display as Fig. 3-8-1. The 

user can choose the desired elements by the mouse. 

2. Choose Element command from menu bar as Fig. 3-8-2.  

3. Choose Element icon from toolbar as Fig. 3-8-3. 

4. Choose Element icon from Object dialog box as Fig. 3-8-4 

 
Fig. 3-8-1 Shortcut menu display 
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Fig. 3-8-2 Choose Element command from menu bar 

 

Fig. 3-8-3 Choose Element icon from toolbar 
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Fig. 3-8-4 Choose Element icon from Object dialog box 

After selecting an element, left-click and drag the mouse on work place, and then a new 

element is created.  

 
Fig. 3-8-5 Drag the mouse on work place to determine the element size 
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Fig. 3-8-6 Create an element 

How to Create an Element 

To create an element on HMI screen, first select a desired elemet from menu bar or toolbar 

and then click the starting point on the screen. While holding down the mouse button, move 

the mouse diagonally to the ending point of the element, then release the mouse button. The 

element will appear on the screen. Later set the property of the element (Fig. 3-8-7, Fig. 3-8-8, 

Fig. 3-8-9, Fig. 3-8-10). 

 
Fig. 3-8-7 Right-click the mouse to select a desired elemet  
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Fig. 3-8-8 Select a desired element from menu bar 

 

Fig. 3-8-9 Left-click and drag the mouse on work place then release the mouse button 
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Fig. 3-8-10 An element is created 

How to Move an Element 

The user can use the mouse to move an element. Mouse operation is the same as working in 

Windows® operating system. When the mouse cursor changes to a four-arrow icon , the 

user can left-click the mouse and move the element freely (Fig. 3-8-11).  

 
Fig. 3-8-11 Move an Element 
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How to Change Element Width 

The user can use the mouse to modify the width of an element. When the mouse cursor 

changes to a two-arrow icon , the user can left-click the mouse and modify the element 

width (Fig. 3-8-12). 

 
Fig. 3-8-12 Change Element Width 

How to Change Element Height 

The user can use the mouse to modify the height of an element. When the mouse cursor 

changes to a two-arrow icon , the user can left-click the mouse and modify the element 

height (Fig. 3-8-13). 

 
Fig. 3-8-13 Change Element Height 
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How to Change Element Width and Height Simultaneously 

The user can use the mouse to modify the width and height of an element simultaneously. 

When the mouse cursor changes to a two-arrow icon  or , the user can left-click the 

mouse and modify the element width and height at the same time (Fig. 3-8-14). 

 
Fig. 3-8-14 Change Element Width and Height Simultaneously 
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How to Input Characters 

The user can input a string of characters that Windows® operating system accepts in the 

property table. When the mouse cursor changes to an icon , the user can start to input any 

characters that Windows® operating system accepts where the cursor  blinks (Fig. 3-8-15). 

 

Fig. 3-8-15 Input Characters 
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Right-click the Mouse 

The user can find that different menu will pop up when right-clicking the mouse (Fig. 3-8-16, 

Fig. 3-8-17, Fig. 3-8-18). 

 

Fig. 3-8-16 Right-click the mouse on Toolbar - Toolbars docking window 
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Fig. 3-8-17 Right-click the mouse on Work Place - Element Selection  

 

Fig. 3-8-18 Right-click the mouse on the element - Editing options (Layout Toolbar)  
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3.8.2 Button Elements 

 

Fig. 3-8-19 Button Elements 

 

Table 3-8-1 Button Elements 

Button Type Macro Read Write Function 

Set ON V V 

After pressing this button, the state of the setting 

address (Bit) will always be set to ON. If there is an ON 

Macro, it will be executed simultaneously.  

Reset OFF V V 

After pressing this button, the state of the setting 

address (Bit) will always be set to OFF. If there is an OFF 

Macro, it will be executed simultaneously.  

Maintained 
ON 

OFF 
V V 

After pressing this button, the state of the setting 

address (Bit) will be set to ON and be OFF when releasing 

the button. If there is an ON or OFF Macro, it will be 

executed simultaneously. 
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Button Type Macro Read Write Function 

Momentary 
ON 

OFF 
V V 

After pressing this button, the state of the setting 

address (Bit) will be set to ON and execute ON Macro at 

the same time. When pressing the button again, the 

state of the setting address will be OFF and execute OFF 

Macro simultaneously. 

Multistate X V V 

There are 1~256 user-defined multi-states for setting. 

The user can set the execution sequence to the next 

state or the previous state.  

Set Value X X V 

After pressing this button, the “Numeric keypad” dialog 

box will pop up on HMI screen for the user to input the 

setting value directly. After inputting the setting value 

and pressing ENTER key, HMI will transmit the input 

value to the setting address. 

Set Constant X X V 
After pressing this button, HMI will write the specific 

value into the setting address.  

Increment X V V 

After pressing this button, HMI will add up the value 

contained within the setting address and the setting 

constant value, and store the addition result back into 

the setting address.  

Decrement X V V 

After pressing this button, HMI will subtract the setting 

constant value from the value contained within the 

setting address, and store the subtraction result back to 

the setting address.  

Goto Screen X X X 
After pressing this button, it will switch to the screen 

that the user designated. 

Previous Page X X X 

After pressing this button, it will go back to the previous 

screen. For example, suppose that there are three 

screens, screen 1, screen 2 and screen 3. If the user has 

switched the screen from screen 1, screen 2 to screen 3 

in order, when pressing “previous page” button on 

screen 3, HMI will switch to screen 2. When pressing 

“previous page” on screen 2 again, HMI will switch to 

screen 3. 

System 

DateTime 
O X X 

After pressing this button, it will set the system date and 

time of HMI (year-month-day, hours:minutes:seconds). 

Password 

Table Setup 
O X X 

After pressing this button, the user can set all the 

passwords of user security level. 
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Button Type Macro Read Write Function 

Enter 

Password 
O X X 

After pressing this button, the user can enter the 

password.  

Contrast 

Brightness 
O X X 

After pressing this button, the user can adjust the 

contrast brightness of HMI.  

Low Security O X X 
Press this button one time to change the user security 

level to the lowest level (LEVEL 0). 

System Menu O X X 
Press this button one time to switch to the HMI system 

menu. 

Report List O X X 

After pressing this button, the screen data can be output 

to the designated location. The user can use is function 

to print out the screen data.  

Screen 

Capture 
O X X 

After pressing this button, the screen data can be 

captured and output to USB disk. The file output 

designation is located on USB disk. If a USB disk is not 

connected, the captured data cannot be output by HMI 

successfully.  

Remove 

Storage 
O X X 

The user can press this button to remove the USB disk 

safely. 

Import/Export 

Recipe 
O X X 

Press this button to import or export the recipe data in 

CSV Excel format from or into external memory. 

Calibration O X X 
The user can press this button to perform calibration 

function.  

Language 

Changer 
O X X 

The user can press this button to change the display 

language. 

 

3.8.2.1 Set / Reset / Maintained / Momentary Buttons 

After pressing these buttons, HMI will transmit ON/OFF signal to PLC or the controller. 

There are four types of buttons: Set button, Reset button, Maintained and Momentary 

buttons. Please refer to the following table 3-8-2 for the property description of these 

four general buttons. 

Table 3-8-2 

Property Description of General Buttons 

Write Address 

Read Address 

The address can be internal memory, internal parameter or the 

controller address. If only the write address is set, HMI will read the 

value of the write address automatically. 

Pressing  button next to the “Write Address” or “Read Address” 

the user will enter into the following “Input” dialog box and select 

the write address or the read address. 
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Property Description of General Buttons 

Write Address 

Read Address 
 

The link type can be Base Port (Controller) or Internal Memory or 

Internal Parameter. If the user is connecting to multi connections, 

the new connections will be added into the “Link” drop-down list. 

After selecting the Link option and Device Type, and correct 

address, press the Enter key, the corresponding numeric value will 

be recorded on the element that the user selected. Device types 

are described as follows:  

$ Internal Memory RCP Recipe Register 

$M 
Non-volatile Internal 

Memory  
RCPNO Recipe Number Register 

*$ 
Indirect Address 

Memory 
RCPG 

Recipe Group Number 

Register 

  Other 

Other device name 

supported by other brands 

of controller. Please refer to 

DOP Series HMI Connection 

Manual.  
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Property Description of General Buttons 

Edit On/Off Macro 

Edit On and Off Macro is available. When pressing the button, the 

state of the button will be ON and the commands of ON Macro will 

be executed simultaneously. When pressing the button again, the 

state of the button will be changed to OFF and the commands of 

OFF Macro will be executed simultaneously. However, if the button 

is changed via macro or external signal, not by pressing the 

button, ON and OFF macro will not be executed at the same time. 

For the Macro function, please refer to section 3-1-14 for more 

details.  

The user can set the text, text size, fon and text color provided by 

Windows® to determine the text display on the element. When the 

user presses  button next to “Font”, the following “Font Detail 

Setting” dialog box will display. 

 

Text 

Text Size 

Font 

Text Color 

In “Font Detail Setting” dialog box, the user can select Font Name, 

Font Size and Ratio of the text and view the text format from the 

Preview window in advance. If the multi-language function is used, 

the user can see different language tabs and edit different 

language font setting in “Font Detail Setting” dialog box. Please 

refer to the example figure above. 
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Property Description of General Buttons 

Blink 

The element can blink to remind the user.  

The user can decide if the element blinks or not when the button is 

set to be ON or OFF state. The blinking color is the relative color of 

the button’s state. For the method for switching ON or OFF state of 

the button, please refer to the figure shown below. 

 

Bank (Picture Bank) 

Picture Name 

The user can determine the picture of the element by clicking 

“Bank”(Picture Bank). (If “Bank” has been selected, the user can 

click “Picture Name” to determine the picture of the element). The 

following dialog box will display when the user selects the existing 

Picture Bank Name from the drop-down list.  
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Property Description of General Buttons 

Bank 

Picture Name 

In this dialog box, the user can double click the mouse to select an 

element. The user can also press Ctrl and left key of the mouse to 

import several pictures into the designated element at the same 

time. The selected pictures will be stored in each state of the 

element in order. If the number of the selected pictures is more 

than the number of the element state, only the number of the 

element state will be imported and the remainder will be ignored 

and not be imported into the element.  

Transparent Effect 

Transparent Color 

Use the sucking tool  to remove the color of the element and 

determine the transparent color of the element.  

The user can click the sucking tool  on toolbar or choose the 

transparent color by using the drop-down list. However, if the 

selected transparent color is too close to the element color itself, it 

will make no difference to the element. For example, RGB(0,0,0) is 

black color, but RGB(1,1,1) is also black color. When the element 

color is RGB(0,1,0) (it is also black color visually), even if the user 

selects RGB(0,0,0) as the transparent color, the element will look 

almost the same still. At this time, we recommend the user use the 

removal tool  on toolbar and remove the color of the element 

directly. 

Please ensure to check whether the color of the selected element 

matches the color supported by HMI or not. This function is invalid 

and the color may not be removed successfully if the user applies 

this function on a 65536 colors element in a 256 colors editing 

environment.  
The effect on the element before and after this action happens is 
shown as the figures below.  

The effect before this action 

happens 

The effect after this action 

happens 

   

Foreground Color 

Style 

The user can specify the button style and foreground color as the 

figures below by using this option.  

Standard Raised Round Invisible 
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Property Description of General Buttons 

Function 

The user can modify the element characteristic directly without 

re-create a new element. The elements that their characteristics 

can be modified directly by using this option are: Set button, Reset 

button, Momentary button and Maintained button these four 

kinds of buttons.  

Push Time 

(second) 

Use this option to set the active time of the button. When this 

option is set, the button will be active after pressing the button 

longer than the setting time. Using this option can avoid 

malfunction. The range is within 0 ~ 10 seconds.  

User Security Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  

Set Low Security 

Use this option to force the current priority to be the lowest after 

the button is pressed. This can prevent the misoperation made by 

the user (operator).  

InterLock Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock Level”), this button can be enabled.  

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user everytime when the the button is pressed.  

 
Invisible Address When this option is set to On, this button element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.2.2 Multistate Button 

Property Description of Multistate Buttons 

Multistate buttons accept three kinds units, WORD, LSB and Bit and the state number 

will be different by the unit. There are 1-256 states if its unit is WORD, 16 states if its 

unit is LSB and 2 states if its unit is Bit. The unit of memory address will be different by 

the value unit. If the value unit is WORD or LSB, the unit of memory address will be 

WORD. If the value unit is Bit, the unit of memory address will be Bit. If it is needed to 

add or delete the total state numbers, add or delete the state numbers in only element 

property table.  

Write Address 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Blink 
The element can blink to remind the user (Please refer to Table 

3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

Style 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

User Security Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  

Bit Multistate button can have two states. 

Word Multistate button can have 256 states. Data Length 

LSB Multistate button can have 16 states.  

Data Format 
Provide BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to define the read memory content.  

Add/Remove  

State 

Used to set the state number of multistate button. There are 1-256 

states can be set if its unit is WORD, 16 states can be set if its unit 

is LSB and 2 states can be set if its unit is Bit.  

Sequence 
Used to switch the sequence of multistate state  

(Previous state/Next state). 
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Property Description of Multistate Buttons 

Set Low Security 

Use this option to force the current priority to be the lowest after 

the button is pressed. This can prevent the misoperation made by 

the user (operator).  

InterLock Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock Level”), this button can be enabled.  

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user everytime when the button is pressed.  

Invisible Address When this option is set to On, this button element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

Example of Multistate Buttons:  

When the data length is LSB (D100.0 ~ D100.3): 

 

    

S0=D100.0 ON S1=D100.1 ON S2=D100.2 ON S3=D100.3 ON 

 

 

 

 

 

 

 



Chapter 3 Creating and Editing Screens  

3-102 Revision May, 2010 

3.8.2.3 Set Value Button 

Property Description of Set Value Buttons 

After pressing this button on the screen, a system built-in numeric keypad (TEN-KEY) 

will show up and the user can use it to input the setting value directly. When ENTER key 

is pressed, HMI will send the input setting value to PLC corresponding register. The 

maximum and minimum input setting values are all user-defined. The user can also 

specify the trigger mode to trigger the designated PLC address before or after writing 

the setting value.  

Write Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided 

by Windows® to determine the text display on the element 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

Style 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Trigger 

Trigger Type 

The user can use this setting to trigger the designated controller 

address to be ON before or after writing the setting value. Please 

note that this function can only trigger the controller address to 

be ON. If the controller address needs to be triggered again, the 

user should set the address to be OFF manually. 

Range Setting 

 

Data Length: 

There are 16bits Word and 

32bits Double Word two 

options. 

Minimum/Maximum:  

The user can set the 

minimum and maximum of 

input setting value to 

determine the range of 

input setting value.  
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Property Description of Set Value Buttons 

It provides different kinds of data format for 

different data length:  

Word Double Word 

Data Format 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

7. Floating 

Integral Digits 

Fractional Digits 

Determine the digit number of integer and 

decimal fraction. The digit number is not a real 

digit number value. It is only the display 

format. The digit number will be a real decimal 

number only when the data format is selected 

as Floating. 

Range Setting 

Press OK when you have input the minimum and maximum value, 

and then HMI will examine the value by referring to the selected 

data length, data format, and integral and fractional digits. 

User Security Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  

Set Low Security 

Use this option to force the current priority to be the lowest after 

the button is pressed. This can prevent the misoperation made by 

the user (operator).  

InterLock Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock Level”), this button can be enabled. 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform 

the operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), 

the command of this macro will not be executed. 

After Execute Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute 

the command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), 

the command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user everytime when the button is pressed.  
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Property Description of Set Value Buttons 

Info the overrange 

message 

When this option is set, an Error dialog box will appear to prompt 

the user the input value has exceeded the limit of the range 

setting. 

 

Invisible Address 
When this option is set to On, this button element will be 

invisible.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

 

3.8.2.4 Set Constant Button 

Property Description of Set Constant Buttons 

After pressing this button on the screen, HMI will send the specified constant value to 

PLC corresponding register. It has the same function as Set Value button. The user can 

also specify the trigger mode to trigger the designated PLC address before or after 

writing the setting value. 

Write Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

Style 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 
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Property Description of Set Constant Buttons 

Trigger 

Trigger Type 

The user can use this setting to trigger the designated controller 

address to be ON before or after writing the setting value. Please 

note that this function can only trigger the controller address to be 

ON. If the controller address needs to be triggered again, the user 

should set the address to be OFF manually. 

 

Data Length There are 16bits Word and 32bits Double Word two 

options. 

Data Format 

There are following data format provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Detail Range 

Const Value 

Used to enter the constant value that the user wants 

to write. After pressing OK button, HMI will examine 

the value by referring to the selected data length 

and data format. 

User Security Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  

Set Low Security 

Use this option to force the current priority to be the lowest after 

the button is pressed. This can prevent the misoperation made by 

the user (operator).  

InterLock Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock Level”), this button can be enabled.  

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 
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Property Description of Set Constant Buttons 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user everytime when the button is pressed.  

Invisible Address When this option is set to On, this button element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.2.5 Increment / Decrement 

Property Description of Increment / Decrement Buttons 

After pressing this button on the screen, HMI will read the value from PLC (Controller) 

and add or subtract the set constant value. Then, write the result into PLC (Controller) 

corresponding register. If the addition or subtraction result exceeds the limit 

(minimum and maximum) set in HMI, HMI will save the limit value (minimum and 

maximum) into the PLC (Controller) corresponding address.  

Write Address 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

Style 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Function 

The user can modify the element characteristic directly without 

re-create a new element. The elements that their characteristics 

can be modified directly by using this option are: Increment button 

and Decrement button. 
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Property Description of Increment / Decrement Buttons 

Trigger 

Trigger Type 

The user can use this setting to trigger the designated controller 

address to be ON before or after writing the setting value. Please 

note that this function can only trigger the controller address to be 

ON. If the controller address needs to be triggered again, the user 

should set the address to be OFF manually. 

 

Data Length 
There are 16bits Word and 32bits Double Word 

two options. 

Memory 

There are following data format provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Inc/Dec 

Used to set the increasing and decreasing value 

when pressing the Increment and Decrement 

button every time. 

Range Setting 

Limit 

Used to set the limit of increment and decrement 

values. Press the OK button, and HMI will examine 

the increment and decrement values entered and 

limit the value, if necessary, by referring to the 

selected data length and data format.。 

User Security Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  

Set Low Security 

Use this option to force the current priority to be the lowest after 

the button is pressed. This can prevent the misoperation made by 

the user (operator).  

InterLock Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock Level”), this button can be enabled.  
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Property Description of Increment / Decrement Buttons 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user everytime when the button is pressed.  

Invisible Address When this option is set to On, this button element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.2.6 Goto Screen / Previous Page 

Property Description of Goto Screen / Previous Page Buttons 

Select one of the following to switch screens: 

1. Press the Goto button to go the screen specified. 

2. Press the Previous Page button to return to the previous screen. 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

Style 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Function 

The user can modify the element characteristic directly without 

re-create a new element. The elements that their characteristics 

can be modified directly by using this option are: Goto button, and 

Previous page and Previous view. 
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Property Description of Goto Screen / Previous Page Buttons 

Trigger 

Trigger Type 

The user can use this setting to trigger the designated controller 

address to be ON before or after writing the setting value. Please 

note that this function can only trigger the controller address to be 

ON. If the controller address needs to be triggered again, the user 

should set the address to be OFF manually. 

This dialog box will pop up only when the button function is “Goto 

screen”. 

 

Close Sub-Screen 

When this option is selected, it indicates that 

this Goto screen button is only valid in 

Sub-Screen. When pressing this button, the 

current (active) sub screen will be closed.  

Setting 

User’s security level 

will be set to Low 

Security after 

changing screen. 

When this option is selected, it will force the 

current user’s priority to be the lowest after 

the button is pressed. This can prevent the 

misoperation made by the user (operator). 

User Security Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  
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Property Description of Goto Screen / Previous Page Buttons 

Goto Screen 

When clicking this option, the following dialog box will pop up: 

 
In this “Open Screen” dialog box, the user can select the desired 

screen from left side and the preview screen will display on the 

right side. After selecting the screen and pressing OK button, HMI 

will record the designated screen to this Goto button element. 

InterLock Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock Level”), this button can be enabled.  

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user everytime when the button is pressed.  

Invisible Address When this option is set to On, this button element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.2.7 System DateTime/Password Table Setup/Enter Password/Contrast 

Brightness/Low Security/System Menu/Report List/Screen Capture/Remove 

Storage/Import&Export Recipe/Calibration/Language Changer 

Property Description of System Function Buttons 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

Style 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

System Date and 

Time 

Use this option to set the system date and time 

of HMI. This function is the same as the function 

of pressing SYS button on HMI panel. The user 

only needs to press SYS button on HMI panel to 

enter HMI system setting screen and edit the 

date & time as the figure below.  

 

Function 

Password Table 

Setup 

Password table can be completed via hardware 

and software settings. 

1. Hardware Settings: 

After selecting this option, determine the open 

level according to the User Security Level in 

property table. After downloading screen data to 

HMI, if the user security level is lower than the 

setting level, this “Password Table” will not be 

opened and only the “Password Keypad” dialog 

box will display. Password Table can be opened 

or not depends on whether the user security is 

higher than the setting level or not.  
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Property Description of System Function Buttons 

Function 
Password Table 

Setup 

Even though the user can open Password Table, it 

only indicates that the user can change the 

password that level is lower than the users’. The 

user still cannot change or view those passwords 

that are higher than the users’. Please refer to the 

figures below.  

  
Highest Priority 

 
Password Level 4  

2. Software Settings: 

Select Options > Password Setting, the following 

dialog box will show up for the user to complete 

the password settings.  
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Property Description of System Function Buttons 

Enter Password 

This button provides HMI a 

password input interface. It 

will open the corresponding 

priority by the input 

password. The higher level 

the user inputs, the higher 

priority the user has. Please 

refer to the figure at right. 

 

Contrast 

Brightness 

This button allows the user 

to adjust HMI LCD contrast 

and brightness settings. 

After pressing this button, 

the user will get the 

following pop-up window to 

adjust HMI LCD contrast and 

brightness settings. If the 

user presses “Set for default 

Contrast” button, it will set 

HMI LCD to the default 

settings. 

 

Low Security 

Using this button can set the user priority to the 

lowest (Level 0). This option makes the user 

priority level become the lowest to protect control 

system parameter not to be modified when the 

user exits the different screens. It can also avoid 

the misoperation that may cause system error. 

(This function is also provided for Goto screen 

button.)  

System Menu 

After pressing this button, HMI will be back to 

system menu screen. The user can return to 

operation screen just by activating “Run” function 

or startup HMI again. 

Function 

Report List 

This button has many functions. It can be used 

flexibly depending on the properties of the 

“Report List” option (Please refer to page 2-124 in 

Chapter 2 and the following description of Report 

Device). 
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Property Description of System Function Buttons 

Screen Capture 

After pressing this button, the screen data can be 

captured and output to USB disk (BMP files). The 

file output designation is located on USB disk. If a 

USB disk is not connected, the captured data 

cannot be output by HMI successfully.  

The output BMP files will be stored in a folder 

named with the current date, e.g. 20090101 (it 

indicates the download date of that file is year 

2009 January 1th). In the while, the following 

window will display on HMI screen. 

 
When this window shows up, it indicates that the 

downloading operation is processing and the 

screen data is written into USB disk.  

The BMP files will be saved in the folder in order. 

The first file will be named as 00001, the second 

file will be named as 00002 and so on.  

※ Please note that only FAT32 formatted USB disk 

can be connected. Please refer to the description 

of section 2.1. 

Remove 

Storage 

The user can press this button to remove the USB 

disk to ensure that the data is saved completely in 

USB disk. 

※ Please note that only FAT32 formatted USB disk 

can be connected. Please refer to the description 

of section 2.1. 

Import/Export 

Recipe 

The system is able to import and export 16bits 

Word and 32bits Double Word two kinds of data. 

Press this button is to import the recipe from 

external memory (USB disk) or export the data 

saved in HMI.  

※ Please note that only FAT32 formatted USB disk 

can be connected. Please refer to the description 

of section 2.1. 

Calibration Press this button to perform calibration function.  

Function 

Language 

Changer 
Press this button to change the display language. 
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Property Description of System Function Buttons 

Trigger 

Trigger Type 

The user can use this setting to trigger the designated controller 

address to be ON before or after writing the setting value. Please 

note that this function can only trigger the controller address to be 

ON. If the controller address needs to be triggered again, the user 

should set the address to be OFF manually. 

This option is provided in Report List button only. When the user 

selects a Report List button, the user can set this option in the 

property table. 

 
The Report Device window is shown as the figure above. The 

Report Device can be USB flash drive (USB disk), Printer and SD 

card.  

USB flash drive 
Output the history records and alarm data to USB 

disk. 

Printer 

HMI will check if Print Typesetting function is set 

or not first. If Print Typesetting function is set 

already, the screen data will be output to the 

printer directly. If HMI detects the Print 

Typesetting function is not set yet, the Hard Copy 

function will be enabled. 

Report Device 

SD 
Output the history records and alarm data to SD 

card. 

User Security Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  

InterLock Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock Level”), this button can be enabled.  
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Property Description of System Function Buttons 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user everytime when the button is pressed.  

Invisible Address When this option is set to On, this button element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

 



 Chapter 3 Creating and Editing Screens 

Revision May, 2010   3-117 

3.8.3 Meter Elements 

 
Fig. 3-8-20 Meter Elemets 

Property Description of Meter Elments 

The user can set meter appearance in the property table, such as the style, the color 

(including border color, background color, stitch color, scale color) and the scale region 

number, etc. Also, the max. & min. value and high & low limit can be defined in Detail Setup 

dialog box. It can be used to calculate the specified address and measure if it exceeds the 

limit or not. The user can also use various colors to show clearly and this is convenience for 

the user to recognize.  

Read Address 
The address can be internal memory or the controller address. (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Border Color Set the border color of the element 

Background Color Set the background color of the element 

Standard Raised Sunken 

Style 
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Property Description of Meter Elements 

When the user has input the target value, minimum and maximum value, 

after pressing OK button, HMI will examine the value by referring to the 

selected data length, data format, integral and fractional digits. 

 
Data Length There are 16bits Word and 32bits Double Word two 

options. 

Memory Format There are following data format provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

Setting 

Min. Value  

Max. Value 

Used to set the display minimum and maximum value. 

 

 

 

 

 



 Chapter 3 Creating and Editing Screens 

Revision May, 2010   3-119 

Property Description of Meter Elements 

Target Value 

Color 

The user can decide if the target value display or not 

by using this option. If this option is set, the target 

value and its color set by the user will display just like 

the figure shown below: (Here we set the target value 

is 60 and its color is in blue.) 

 

Ranges (Enable 

range setting) 

Please refer to the description of Low & High Region 

Color.  

Variable 

target/range 

limits 

When the target value and low & high limit is a variable 

value, the low limit address is Read Address+1, the 

high limit address is Read Address+2 and the address 

of target value is Read Address+3.  

Setting 

Integral Digits 

Fractional Digits 

Use this option to determine the digit number of 

integer and decimal fraction. The digit number is not a 

real digit number value. It is only the display format. 

Low Region Color 

High Region Color 

This option is available and displayed in the property table only when 

the “Ranges” option in the Detail Setup dialog box is selected. If the user 

sets the low limit value is 30 and the color of low limit region is in green, 

and then set the high limit value is 70 and the color of high limit region 

is in red, the meter element will be shown as the figure below: 

 

Stitch Color Set the stitch color of the meter element. 

Grid Color Set the grid color of the meter element. 

Scale 

Region 

Number 

It is used to set the scale region number of the meter element. The user 

can use the up or down buttons to increase or decrease the scale region 

number. The setting rang is within 1 ~ 10.  

Rule Color Set the rule color of the meter element. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.4 Bar Elements 

 
Fig. 3-8-21 Bar Elements 

3.8.4.1 Normal 

Property Description of Normal Bar Elements 

HMI reads the value of the corresponding PLC specific address (register) and converts 

the value to normal bar element and then displays it on the screen.  

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Border Color Set the border color of the element 

Foreground Color 

Background Color 

It is used to set the foreground and background color of the normal 

bar element. For example, the foreground color of the following 

example bar element is green and its background color is yellow.  

 

Standard Raised Sunken 

Style 

   

Left 
The display progressing direction is from right to the 

left. 

Right 
The display progressing direction is from left to the 

right. 

Top 
The display progressing direction is from bottom to 

the top. 

Display Format 

Bottom 
The display progressing direction is from top to the 

bottom. 
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Property Description of Normal Bar Elements 

When the user has input the target value, low & high limit, and 

minimum & maximum value, after pressing OK button, HMI will 

examine the value by referring to the selected data length and data 

format. 

 

Data Length: 

There are 16bits Word and 

32bits Double Word two 

options. 

 

Memory Format: 

here are following data format 

provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

 

Min. Value / Max. Value: 

Used to set the display 

minimum and maximum value. 

Target Value 

Color 

The user can decide if the target value display 
or not by using this option. If this option is 
set, the target value and its color set by the 
user will display on the screen. HMI will refer 
to the minimum and maximum value and 
draw the proper reference line on the bar 
element just like the figure shown below: 
(Here we set the target value is 50 and its 
color is in red. The maximum and minimum 
value is 100 and 0 respectively.) 

 

Ranges (Enable range 

setting) 

Please refer to the description of Low & High 

Region Color.  

Setting 

Variable target/range 

limits 

When the target value and low & high limit is 

a variable value, the low limit address is Read 

Address+1, the high limit address is Read 

Address+2 and the address of target value is 

Read Address+3.  
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Property Description of Normal Bar Elements 

Low Region 

Color 

High Region 

Color 

This option is available and displayed in the property table only when 

the “Ranges” option in the Detail dialog box is selected. If the user 

sets the low limit value is 30 and the color of low limit region is in 

green, and then set the high limit value is 70 and the color of high 

limit region is in red, the bar element will be shown as the figures 

below (The min. & max. input value is 0 and 100 respectively.): 

           

When the value is 20  When the value is 50  When the value is 80 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.4.2 Differential 

Property Description of Differential Bar Elements 

HMI reads the value of the corresponding PLC specific address (register). Subtract the 

setting standard value from this read value and the user has a differential value. Then, 

the user can convert the differential value to differential bar element and then display 

it on the screen. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Border Color Set the border color of the element 

Foreground Color 

Background 

Color 

It is used to set the foreground and background color of the 

deviation bar element. For example, the foreground color of the 

following example bar element is green and its background color is 

yellow. 
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Property Description of Differential Bar Elements 

Standard Raised Sunken 

Style 

   

Display Format 
Horizontal: The differential value display horizontally. 

Vertical: The differential value display vertically. 

 

Data Length: 

There are 16bits Word and 32bits 

Double Word two options. 

 

Memory Format: 

here are following data format 

provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Standard Value 
Used to set the standard value for calculating 

differential value 

Minimum Value 

Maximum Value 

The minimum and maximum value in the differential 

bar element. 

Display 

Deviation Limit 

The differential limit and color can be set only when 

this option is selected. Also, the differential value 

will display in the designated color set by the user. If 

this option is not selected, the differential value will 

be displayed in the foreground color directly on the 

screen. 

Variable 

Standard 

Value/Deviation 

Limit 

When standard value and high limit of differential 

value is variable. The address of standard value is 

Read Address+1 and the address of differential limit 

value is Read Address+2.  

Setting  

When the user has input the standard value, minimum & maximum 

value and differential limit, after pressing OK button, HMI will examine 

the value by referring to the selected data length and data format.  
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Property Description of Differential Bar Elements 

Setting 

For example, if the data length is set to Word, the data format is set to 

Unsigned Decimal, standard value is set to 50, minimum value is set 

to 0, maximum value is set to 100 and differential limit is set to 30, 

the differential bar element will be shown as the figures below:  

       

When the value is 10      When the value is 30 

      
When the value is 70      When the value is 90 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.5 Pipe Elements 

 

Fig. 3-8-22 Pipe Elements 

3.8.5.1 Pipe(1)/Pipe(2) 

Property Description of Pipe (1) / Pipe (2) Elements 

HMI reads the value of the corresponding address (register). Then, convert the value to 

Pipe (1) / Pipe (2) element and then display it on the screen. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

WaterMark Color 

Inside Tube Color 

Used to set the watermark color and inside tube color  of Pipe (1) 

and Pipe (2) element 

                                
           Pipe (1)                          Pipe (2) 

The watermark color is in blue.    The watermark color is in red. 

The inside tube color is in black.   The inside tube color is in white. 

Standard Rotation 180 

Style 
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Property Description of Pipe (1) / Pipe (2) Elements 

 

Data Length: 

There are 16bits Word and 32bits 

Double Word two options. 

 

Memory Format: 

here are following data format 

provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Minimum Value 

Maximum Value 

Used to set the minimum and maximum 

capacity of the pipe element. 

Target 

Value 

Color 

The user can decide if the target value 

displays or not by using this option. 

Ranges (Enable 

range setting)  

Please refer to the description of Low & High 

Region Color. 

Variable 

target/range limits 

When the target value and low & high limit is a 

variable value, the low limit address is Read 

Address+1, the high limit address is Read 

Address+2 and the address of target value is 

Read Address+3.  

Setting 

When the user has input the target value, low & high limit, and 

minimum & maximum value, after pressing OK button, HMI will 

examine the value by referring to the selected data length and data 

format. 
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Property Description of Pipe (1) / Pipe (2) Elements 

Low Region Color 

High Region 

Color 

This option is available and displayed in the property table only 

when the “Ranges” option in the Detail Setup dialog box is selected. 

If the user sets the low limit value is 20 and the color of low limit 

region is in green, and then set the high limit value is 80 and the 

color of high limit region is in red, the pipe element will be shown as 

the figures below: 

                   
  When the value is 20   When the value is 50  When the value is 80 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.5.2 Pipe(3) 

Property Description of Pipe (3) Element 

It is used to connect to water pipe element. Pipe (3) element is shown as the figure 

below:  

 

Pipe Gauge: 

Use this option to set the pipe gauge. The selectable range is from 1 ~ 5. The setting 

value 1 represents at least 13 pixels and the setting value 2 represents at least 26 

pixels and vise versa.  

X Used to set X coordinate 

Y Used to set Y coordinate 
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3.8.5.3 Pipe(4) 

Property Description of Pipe (4) Element 

It is used to connect to water pipe element. Pipe (4) element is shown as the figure 

below: 

 

Pipe Gauge: 

Use this option to set the pipe gauge. The selectable range is from 1 ~ 5. The setting 

value 1 represents at least 13 pixels and the setting value 2 represents at least 26 

pixels and vise versa. 

Style:    

Standard Rotation 90 Rotation 180 Rotation 270 

    

X Used to set X coordinate 

Y Used to set Y coordinate 

 

3.8.5.4 Pipe(5) 

Property Description of Pipe (5) Element 

It is used to connect to several pipes. Pipe (5) element is shown as the figure below: 

 

Pipe Gauge: 

Use this option to set the pipe gauge. The selectable range is from 1 ~ 5. The setting 

value 1 represents at least 13 pixels and the setting value 2 represents at least 26 

pixels and vise versa. 

Style:    

Standard Rotation 90 Rotation 180 Rotation 270 

    

X Used to set X coordinate 

Y Used to set Y coordinate 
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3.8.5.5 Pipe(6)/Pipe(7) 

Property Description of Pipe (6) / Pipe (7) Element 

Horizontal and vertical pipes. It is used to display the direction of water flow. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

The user can decide if the read address is set or not. If the read 

address is set, the mobile cursor will display and move, just like 

the water flowing through the pipe. For example, suppose that 

the internal memory address of HMI is $0, when $0 is 1, and the 

mobile cursor color is set, the direction of water flow is from 

right to the left; when $0 is 2, the direction of water flow is from 

left to the right. When $0 is set to other value than 1 and 2, the 

water will not flow. In the same way, when the user select Pipe (7) 

element, for example, suppose that the internal memory address 

of HMI is $1, when $1 is 1, the direction of water flow is from 

bottom to the top; when $1 is 2, the direction of water flow is 

from top to the bottom. When $1 is set to other value than 1 and 

2, the water will not flow. 

 

Mobile Cursor Color 

When there is any data occurred in the read address, the mobile 

cursor will display and move, just like the water flowing through 

the pipe. The user can use this option to set the mobile cursor 

color.  

Pipe Gauge 

Use this option to set the pipe gauge. The selectable range is 

from 1 ~ 5. The setting value 1 represents at least 13 pixels and 

the setting value 2 represents at least 26 pixels and vise versa.  

X Used to set X coordinate 

Y Used to set Y coordinate 
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3.8.6 Pie Elements 

 

Fig. 3-8-23 Pie Elements 

Property Description of Pie Elements 

There are four kinds of Pie elements for the user to select. The user can use the element 

property table to set the minimum & maximum value, low & high limit and element color, 

etc. It can be used to display the size of the set address and quickly judge its quantity by 

the increment and decrement measure of area. If the value of the address is less than the 

lower limit or higher than the high limit, it can change its color to show clearly for the user 

to recognize and give a warning to the user. 

Read Address 
The address can be internal memory or the controller address. (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Border Color 

Foreground 

Color 

Background 

Color 

It is used to set the border color, foreground and background color of the 

pie element. For example, the border color of the following example pie 

element is in blue, and the foreground color is set to green and its 

background color is in yellow. 

 

Standard Raised Sunken Transparent 

Style 
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Property Description of Pie Elements 

 

Data Length: 

There are 16bits Word and 32bits Double 

Word two options. 

 

Memory Format: 

here are following data format provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

 

Min. Value / Max. Value: 

Used to set the display minimum and 

maximum value.  

When the user has input the target value, low & high limit, and minimum & 

maximum value, after pressing OK button, HMI will examine the value by 

referring to the selected data length and data format. 

Target Value 

Color 

The user can decide if the target value display or not 

by using this option. If this option is set, the target 

value and its color set by the user will display on the 

screen. HMI will refer to the minimum and maximum 

value and draw the proper reference line on the bar 

element just like the figure shown below: (Here we 

set the target value is 80 and its color is in yellow.) 

 

Ranges (Enable 

range setting)  

Please refer to the description of Low & High Region 

Color. 

Setting  

Variable target 

/range limits 

When the target value and low & high limit is a 

variable value, the low limit address is Read 

Address+1, the high limit address is Read Address+2 

and the address of target value is Read Address+3.  
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Property Description of Pie Elements 

Low Region 

Color 

High Region 

Color 

This option is available and displayed in the property table only when the 

“Ranges” option in the Detail Setup dialog box is selected. If the user sets 

the low limit value is 20 and the color of low limit region is in green, and 

then set the high limit value is 80 and the color of high limit region is in 

red, the pie element will be shown as the figures below (The min. & max. 

input value is 0 and 100 respectively.): 

             

  When the value is 20    When the value is 50   When the value is 80 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.7 Indicator Elements 

 
Fig. 3-8-24 Indicator Elements 

3.8.7.1 Multistate Indicator 

Property Description of Multistate Indicator Element 

Multistate indicator provides a method to indicate the state of some specific address. 

It will send state changes message to user no matter it is Bit, LSB or WORD. If this 

address is an significant indicator or important message or important alarm, it can be 

used to inform the user immediately by changing state display method or different 

text setting. Or let the user know more information according to the changes of 

different states to make the user can also handle the corresponding situation at the 

first time. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

When the read address is set to the contact of the controller, i.e. 

PLC, the multistate indicator will change depending on the state 

(ON or OFF) of PLC corresponding contact. For example, the user 

can set that when the value is 1, the indicator will display the text 

“Start” and when the value is 0, the indicator will display the text 

“Stop”. The user also can add a picture into each state of the 

multistate indicator and then the corresponding picture will show 

when each state is activated. 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Blink 
The element can blink to remind the user. (Please refer to Table 

3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

Style 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 
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Property Description of Multistate Indicator Element 

Bit Indicator element can have two states. 

Word Indicator element can have 256 states. Data Length 

LSB Indicator element can have 16 states.  

Data Format 
It provides BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to display the read memory content. 

Add/Remove State 

It is used to set the state numbers of multistate indicator. If the 

data length of the value is in Word, 1~256 states can be set. If the 

data length of the value is in LSB, 16 states can be set. If the data 

length of the value is in Bit, only 2 states can be set.  

Invisible Address When this option is set to On, this button element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.7.2 Range Indicator 

Property Description of Range Indicator Element 

Range indicator provides a method to indicate the state of some specific address. HMI 

reads the value of the corresponding address (register) and uses this read value to 

correspond with the corresponding range indicator element and its setting value, and 

then display the corresponding state on HMI screen. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

The user also can add a picture into each state of the range 

indicator and then the corresponding picture will show when each 

state is activated. 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Blink 
The element can blink to remind the user. (Please refer to Table 

3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 
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Property Description of Range Indicator Element 

Foreground Color 

Style 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Add/Remove 

 State 

It is used to set the state numbers of range indicator. 1~256 states 

can be set.  

 

Data Length: 

There are 16bits Word and 

32bits Double Word two 

options. 

 

Memory Format: 

here are following data format 

provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

 

Selecting this option can use default 5 states to 

set the range. If there is n numbers of states, it 

indicates that there is Range n-1 for the user to 

use. The user can specify the foreground color of 

state 0, 1, 2, 3, and 4 as red, green, blue, yellow 

and purple respectively.  

Constant 

Limits 

Range 0 Range 1 Range 2 Range 3 

100 50 33 1  

 

When the value of read address is higher than 

100, the range indicator will display in red. When 

the value of the read address is higher than 50, 

the range indicator will display in green, and vise 

versa. 

Detail  

Range  

Variable 

Limits 

When this option is selected, there is Range n-1 

for the user to use. n represents the total state 

numbers and n-1 represents the total range 

numbers. For example, if the read address is $0, 

and the total state number of the element is 5, it 

indicates that there is Range 0~4 for the user to 

use. Then, the lower limit value of Range 0 is $1, 

the lower limit value of Range 1 is $2 and vise 

versa.  
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Property Description of Range Indicator Element 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.7.3 Simple Indicator 

Property Description of Simple Indicator Element 

For the user’s convenience, simple indicator provides two states (ON/OFF) to let the 

user change the XOR color of the base picture quickly.  

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

XOR Color Used to set XOR color of base picture. 

Redraw 

When this function is enabled, this simple indicator element can be 

overlapped and placed on the other dynamic elements to read and 

display the data of the dynamic element. When this function is 

disabled, the data of the dynamic element can not be read and 

displayed.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.8 Data Display Elements 

 

Fig. 3-8-25 Data Display Elements 

3.8.8.1 Numeric Display 

Property Description of Numeric Display Element 

This element will read the value of the setting address and display the read value 

immediately in the format set by the user. 

Read Address 
The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General Buttons.) 

Text Size 

Text Color 

The user can set the text size and text color that provided by HMI to 

determine the text display on the element. HMI provides 8~64 kinds 

of default text font for the user to use.  

Border Color 

Background 

Color 

Border Color option can be set only when the style of the numeric 

display element is selected as Raised and Sunken. The style of the 

element below is selected as “Sunken”. Its background color is set to 

green and its border color is set to red. 

 

(If the style of the element is set to Transparent, the Border Color 

and Background Color these two options are disabled.) 

Standard Raised Sunken Transparent 

Style 

    

Leading Zero 

The following figures show the difference if the user selects the 

Leading Zero option. (Please note that the integral digit is set to 4 

digits.) 

  (If YES is selected) 

  (If NO is selected) 
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Property Description of Numeric Display Element 

 

Date Length 
There are 16bits Word and 32bits Double Word 

two options. 

Data Format 

There are following data format provided: 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

 

Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

7. Floating  

Integral Digits 

Fractional Digits 

Use this option to determine the digit number of 

integer and decimal fraction. The digit number 

(Fractional Digits) here is not a real decimal 

value. It is only the display format. The digit 

number will be a real decimal only when the data 

format is selected as “Floating”. 

Setting  

Gain (a) 

Offset (b) 

Round off 

The user can use y = (a) x (read address value) + 

(b) this equation to determine the display 

numeric value (y). For example, if Gain value (a) 

is 2 and Offset value (b) is 3, when the read 

address value is 3, then the display numeric 

value will be equal to (2) x 3 + (3) = 9. 

If Gain and Offset value is a decimal, please set 

the data format as “Floating”. 

If Round off option is selected, after the 

operation of the equation above, all numeric 

values can be rounded off and display on the 

screen. 
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Property Description of Numeric Display Element 

Fast Refresh 

If this option is selected, the element can be displayed immediately 

when switching the screen. Please note that this function is designed 

to provide fast value refresh speed for the element which performs 

communication frequently. Therefore, only 4 elements (including 

display element and input element) can be fast refreshed on one 

screen. If the user uses this function on too many elements, it may 

affect the normal speed of HMI operation. So, we recommend the 

user not to activate this function if not necessary. The user can set 

the Fast Refresh Rate by clicking Screen > Screen Properties 

command. There are three levels of the Fast Refresh Rate and they 

are High, Medium and Low. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.8.2 Character Display 

Property Description of Character Display Element 

The user can use this element to read the value of the specific address, convert them 

to text or character and display on the screen. The read value must be in ASCII format 

or the user cannot see the display text or character. (The max. string length is 

28words.) 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text Size 

Text Color 

The user can set the text size and text color provided by HMI to 

determine the text display on the element. HMI provides 8~64 kinds 

of default text font for the user to use. 

Style (Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Border Color 

Background 

Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 
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Property Description of Character Display Element 

String Length 

The range is with 1 ~ 28 words. 

Set the read address as Internal Memory 0, i.e. $0, set the string 

length to 6, and create three Numeric Entry elements. Then, set the 

data format of these three Numeric Entry elements as hexadecimal 

and enter the value as follows: 

$0 = 4241(Hex) 
$1 = 4443(Hex) 
$2 = 4645(Hex) 

 

Then, the above screen will display. 

Please note that character display element reads the Byte value, and 

the data length of the internal memory $ address is Word, which is 

composed of two Bytes. Therefore, one Word can represent two 

Bytes. However, as the high byte and low byte of the value that read 

by the character display element will be exchanged, when reading 

the Internal Memory $0 (=4241 (Hex)), the real display character will 

become “AB” and vise versa. Please refer to the following table. 

ASCII Code / Hex Cross 
Reference 

ASCII Hex 

A 41 
B 42 
C 43 
D 44 
E 45 
F 46  
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Property Description of Character Display Element 

Fast Refresh 

If this option is selected, the element can be displayed immediately 

when switching the screen. Please note that this function is 

designed to provide fast value refresh speed for the element which 

performs communication frequently. Therefore, only 4 elements 

(including display element and input element) can be fast refreshed 

on one screen. If the user uses this function on too many elements, 

it may affect the normal speed of HMI operation. So, we recommend 

the user not to activate this function if not necessary. The user can 

set the Fast Refresh Rate by clicking Screen > Screen Properties 

command. There are three levels of the Fast Refresh Rate and they 

are High, Medium and Low. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.8.3 Date Display 

Property Description of Date Display Element 

Display HMI system date. There are several date formats selectable for the user to use. 

Text Size 

Text Color 

The user can set the text size and text color that provided by HMI to 

determine the text display on the element. HMI provides 8~64 

kinds of default text font for the user to use. 

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Date Format Provide MM/DD/YY, DD/MM/YY, DD.MM.YY three kinds of formats. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.8.4 Time Display 

Property Description of Time Display Element 

Display HMI system time. There are several time formats selectable for the user to use. 

Text Size 

Text Color 

The user can set the text size and text color that provided by HMI to 

determine the text display on the element. HMI provides 8~64 

kinds of default text font for the user to use. 

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Time Format Provide HH:MM:SS, HH:MM two kinds of formats. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.8.5 Day-of-week Display 

Property Description of Day-of-week Display Element 

Display the day (Sunday ~ Monday) of the week. The state default setting of the 

Day-of-week display element is set to 7. It indicates that there are 7 states for this 

element. The user can define the display text, font and color for each day directly in 

the property table. 

Text / Text Size 

Font / Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element. (Please 

refer to Table 3.2.2 Property Description of General Buttons.) 

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.8.6 Prestored Message 

Property Description of Prestored Message Element 

Display the state content of PLC corresponding contact or register directly. The user 

can set state number and text for each state. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Bit It can have two states. 

Word It can have 256 states. Data Length 

LSB It can have 16 states.  

Data Format 
It provides BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to define the read memory content. 

Add/Remove 

State 

It is used to set the state numbers of prestored message element. If 

the data length of the value is in Word, 1~256 states can be set. If 

the data length of the value is in LSB, 16 states can be set. If the 

data length of the value is in Bit, only 2 states can be set.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

 

3.8.8.7 Moving Sign 

Property Description of Moving Sign Element 

Moving sign is a sign that uses movement, lighting, or special display to depict and 

display the state content of the corresponding contact or register. The user can 

determine the display of the moving sign by the settings of the direction, moving 

points, and interval (ms) in the property table. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 
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Property Description of Moving Sign Element 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

 

Property Description of Moving Sign Element 

Bit It can have two states. 

Word It can have 256 states. Data Length 

LSB It can have 16 states.  

Data Format 
It provides BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to define the read memory content. 

Add/Remove 

State 

It is used to set the state numbers of moving sign element. If the 

data length of the value is in Word, 1~256 states can be set. If the 

data length of the value is in LSB, 16 states can be set. If the data 

length of the value is in Bit, only 2 states can be set. 

Left The display progressing direction is from right to the 

left. 

Right The display progressing direction is from left to the 

right. 

Top The display progressing direction is from bottom to the 

top. 

Direction 

Bottom The display progressing direction is from top to the 

bottom. 

Moving Points 
It is used to set the movement of the moving sign. The unit is Pixel 

and the range is within 1 ~ 50 Pixels. 

Interval(ms) 
It is used to set the interval time between two movements. The unit 

is ms and the range is within 50 ~ 3000 ms. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.9 Graph Display Elements 

 

Fig. 3-8-26 Graph Display Elements 

3.8.9.1 State Graphic 

Property Description of Static Graphic Element 

When HMI is connected to the controller, the user can create static graphic elements to 

read the value of several read addresses controlled by the controller. The read value of 

each state can be converted and transmitted to the static graphic elements and display 

respectively on the HMI screen. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color (Please refer to Table 3.2.2 Property Description of Numeric 

Display Elements.) 

Bit It can have two states. 

Word It can have 256 states. Data Length 

LSB It can have 16 states.  

Data Format 
It provides BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to define the read memory content. 

Add/Remove State 

It is used to set the state numbers of static graphic element. If the 

data length of the value is in Word, 1~256 states can be set. If the 

data length of the value is in LSB, 16 states can be set. If the data 

length of the value is in Bit, only 2 states can be set. 
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Property Description of Static Graphic Element 

No 

When this option is selected, the value of the read 

address will be regarded as the state number. It means 

that the state number is determined by the value of the 

read address. For example, if the value of the read 

address $0 is 0, it will switch to 0th state; if the value of 

the read address $0 is 5, it will switch to 5th state.  

Yes 

When this option is selected and the value of the read 

address is a non-zero value, the static graphic element 

will change automatically. For example, if the value of 

the read address $0 is 1 and higher (a non-zero value), 

the element will change the picture automatically 

according to the change time that the user set. When 

the value of the read address $0 is set to 0, the static 

graphic element will be back to the initial state and will 

not change the picture automatically.  Auto Change  

Variation 

When this option is selected, the property of the Read 

Address will be the condition of changing element 

picture. The element will change the picture 

automatically according to Read Address+1. For 

example, if $0 is set to display the address of the 

element and $1 is set to change the element picture, 

when the value of the read address $1is 0, the user 

needs to use the read address $0 to switch the state of 

the static graphic element. At this time, the static 

graphic element will not change automatically, like 

when “No” option is selected. When $1 is 1 and higher (a 

non-zero value), the static graphic element will change 

the picture automatically, like when “Yes” option is 

selected. 
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Property Description of Static Graphic Element 

Transparent 

If Yes is selected, it indicates that this element will be displayed in 

transparent color. It is usually used with the transparent color 

setting of the element. Please refer to the following example 

elements: 

   

The transparent 

color has not been 

set yet. 

The element 

transparent color 

has been set. 

The transparent 

color of the whole 

drawing has been 

set. 

Please note that if Yes option is selected (set to Transparent), the 

foreground color option is disabled. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

Example of Static Graphic element: 

The designated read address = D100. The internal memory value and each state 

should be as follows: 

   

D100=0 D100=1 D100=2 D100=3 D100=4 

 

3.8.9.2 Animated Graphic 

Property Description of Animated Graphic Element 

When HMI is connected to PLC, the user can create animated graphic elements to read 

the value of several read addresses controlled by PLC. The read value of each state can 

be converted and transmitted to the animated graphic elements and display on the 

HMI screen. The individual movement and moving position can also be controlled and 

show on the HMI screen. 

Read Address 
The address can be internal memory or the controller address. 

(Please refer to Table 3.2.2 Property Description of General 

Buttons.) 
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Property Description of Animated Graphic Element 

Read Address 
Use the value of Read Address to switch the 

state of animated graphic element.  

Read Address+1 

Use the value of Read Address+1 to be the 

horizontal axis position of the animated 

graphic element. 
Read Address 

Read Address+2 

Use the value of Read Address+2 to be the 

vertical axis position of the animated graphic 

element. 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Clear Picture 
Use this option to clear previous animated graphic element when 

moving the element or changing the state of the element. 

Word It can have 256 states. 
Data Length 

LSB It can have 16 states.  

Data Format 
It provides BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to define the read memory content. 

Add/Remove State 

It is used to set the state numbers of animated graphic. If the data 

length of the value is in Word, 1~256 states can be set. If the data 

length of the value is in LSB, 16 states can be set. If the data length 

of the value is in Bit, only 2 states can be set. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

Example of Animated Graphic element: 

The designated read address = D100.  The internal memory value and each state 

should be as follows: 

State control register D100 

    

                

 

 

 

X-axis control register D101 

Y-axis control register D102 
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3.8.9.3 Dynamic Line 

Property Description of Dynamic Line Element 

The dynamic line element can be changed and moved depending on the value of the 

corresponding contact or register. 

The address can be internal memory or the controller address. 

(Please refer to Table 3.2.2 Property Description of General 

Buttons.) 

Read Address 

The value of the Read Address can be used 

only when Variable Position option is set to 

Yes. It is used to represent the left-top 

horizontal position (Left) of the element, i.e. 

the first X coordinate on the screen (X
1
).  

Read Address +1 

The value of the Read Address+1 can be used 

only when Variable Position option is set to 

Yes. It is used to represent the left-top vertical 

position (Top) of the element, i.e. the first Y 

coordinate on the screen (Y
1
). 

Read Address +2 

The value of the Read Address+2 can be used 

only when Variable Position option is set to 

Yes. It is used to represent the right-bottom 

horizontal position (Right) of the element, i.e. 

the second X coordinate on the screen (X
2
). 

Read Address +3 

The value of the Read Address+3 can be used 

only when Variable Position option is set to 

Yes. It is used to represent the right-bottom 

vertical position (Bottom) of the element, i.e. 

the second Y coordinate on the screen (Y
2
).. 

Read Address +4 

The value of the Read Address+4 can be used 

only when Variable Color option is set to Yes. 

It is used to represent the line color. The 

range is different depending on selected HMI. 

The range for 16 shades of gray model is 

within 0 ~ 15, the range for 256 colors model 

is within 0 ~ 255 and the range for 65536 

colors is within 0 ~ 65536. 

Read Address 

Read Address +5 

The value of the Read Address+5 can be used 

only when Blink option is set to Yes. When the 

value is higher than 1, the dynamic line 

element will blink. If the value is 0, it will not 

blink.  
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Line Color Used to set the display color of the dynamic line element. 

Blink 
The element can blink to remind the user. (Please refer to Table 

3-8-2 Property Description of General Buttons.) 

Line Size The unit is Pixel and the range is within 1 ~ 8. 

Data Format 
It provides BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to define the read memory content. 

Line Style 

There are following line styles can be selected. 

 
Variable Position (Please refer to the description of Read Address above) 

Variable Color (Please refer to the description of Read Address above) 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.9.4 Dynamic Rectangle 

Property Description of Dynamic Rectangle Element 

The dynamic rectangle element, including element size and color can be changed and 

moved depending on the value of the corresponding contact or register.  

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Read Address 

The value of the Read Address can be used 

only when Variable Position option is set to 

Yes. It is used to represent the left-top 

horizontal position (Left) of the element, i.e. 

the first X coordinate on the screen (X
1
).  

Read Address 

Read Address +1 

The value of the Read Address+1 can be used 

only when Variable Position option is set to 

Yes. It is used to represent the left-top vertical 

position (Top) of the element, i.e. the first Y 

coordinate on the screen (Y
1
)..  
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Property Description of Dynamic Rectangle Element 

Read Address +2 

The value of the Read Address+2 can be used 

only when Variable Size option is set to Yes. It 

is used to represent the right-bottom 

horizontal position (Right) of the element, i.e. 

the width.  

Read Address +3 

The value of the Read Address+3 can be used 

only when Variable Size option is set to Yes. It 

is used to represent the right-bottom vertical 

position (Bottom) of the element, i.e. the 

height.  

Read Address +4 

The value of the Read Address+4 can be used 

only when Variable Color option is set to Yes. 

It is used to represent the line color. The 

range is different depending on selected HMI. 

The range for 16 shades of gray model is 

within 0 ~ 15, the range for 256 colors model 

is within 0 ~ 255 and the range for 65536 

colors is within 0 ~ 65535. 

Read Address +5 

The value of the Read Address+5 can be used 

only when Blink option is set to Yes. When the 

value is higher than 1, the dynamic line 

element will blink. If the value is 0, it will not 

blink.  

Read Address 

Please note that when Variable Position option is set to No, the 

internal memory address of Variable Size option will increase one 

(one increment) automatically. (Read Address will represent the 

right-bottom horizontal position (Right) of the element. Read 

Address+1 will represent the right-bottom vertical position 

(Bottom) of the element. Read Address+2 will represent the 

foreground color of the element.)  

Blink 
The element can blink to remind the user. (Please refer to Table 

3-8-2 Property Description of General Buttons.) 

Foreground Color 
Used to set the foreground color of the dynamic rectangle 

element. 

Line Size The unit is Pixel and the range is within 1 ~ 8. 

Data Format 
It provides BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to define the read memory content. 
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Transparent 

When this option is selected, the element will display only with the 

border and there is no color in the element. The Foreground Color 

option will be disabled also.  

Round Radius 

0~38 pixels round radius are provided for selection. 

 

Variable Position (Please refer to the description of Read Address above) 

Variable Size (Please refer to the description of Read Address above) 

Variable Color (Please refer to the description of Read Address above) 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.9.5 Dynamic Ellipse 

Property Description of Dynamic Ellipse Element 

The dynamic ellipse element, including element size and color can be changed and 

moved depending on the value of the corresponding contact or register. 

The address can be internal memory or the controller address. 

(Please refer to Table 3.2.2 Property Description of General 

Buttons.) 

Read Address 

The value of the Read Address can be used 

only when Variable Central Point option is set 

to Yes. It is used to represent the horizontal 

position of the element center point, i.e. the 

first X coordinate on the screen (X
1
).  

Read Address +1 

The value of the Read Address+1 can be used 

only when Variable Central Point option is set 

to Yes. It is used to represent the vertical 

position of the element center point, i.e. the 

first Y coordinate on the screen (Y
1
). 

Read Address 

Read Address +2 

The value of the Read Address+2 can be used 

only when Variable Radius option is set to Yes. 

It is used to represent the horizontal radius of 

the element, i.e. the width.  

 



 Chapter 3 Creating and Editing Screens 

Revision May, 2010   3-153 

Property Description of Dynamic Ellipse Element 

Read Address +3 

The value of the Read Address+3 can be used 

only when Variable Radius option is set to Yes. 

It is used to represent the vertical radius of 

the element, i.e. the height. 

Read Address +4 

The value of the Read Address+4 can be used 

only when Variable Color option is set to Yes. 

It is used to represent the line color. The 

range is different depending on selected HMI. 

The range for 16 shades of gray model is 

within 0 ~ 15, the range for 256 colors model 

is within 0 ~ 255 and the range for 65536 

colors is within 0 ~ 65536. 

Read Address +5 

The value of the Read Address+5 can be used 

only when Blink option is set to Yes. When the 

value is higher than 1, the dynamic line 

element will blink. If the value is 0, it will not 

blink.  

Read Address 

Please note that when Variable Central Point option is set to No, 

the internal memory address of Variable Radius option will 

increase one (one increment). (Read Address will represent the 

horizontal radius of the element. Read Address+1 will represent 

the vertical radius of the element. Read Address+2 will represent 

the foreground color of the element.) 

Line Color Used to set the display color of the dynamic ellipse element. 

Blink 
The element can blink to remind the user. (Please refer to Table 

3-8-2 Property Description of General Buttons.) 

Foreground Color Used to set the foreground color of the dynamic ellipse element. 

Line Size The unit is Pixel and the range is within 1 ~ 8. 

Data Format It provides BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to define the read memory content. 

Transparent When this option is selected, the element will display only with the 

border and there is no color in the element. The Foreground Color 

option will be disabled also.  

Variable Central 

Point 
(Please refer to the description of Read Address above) 

Variable Radius (Please refer to the description of Read Address above) 

Variable Color (Please refer to the description of Read Address above) 
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Property Description of Dynamic Ellipse Element 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.9.6 Real Image 

Property Description of Real Image Element 

1. This element provides a Dll Library which allows the user to transmit the 

user-defined image to HMI by using external programs through serial 

communication interface.  

2. One screen can have a real image element only.  

Foreground Color Used to set the foreground color of the real image element. 

Interface Used to set the communication protocol, RS232/RS-485。 

COM 
Used to set the HMI communication port. Please note that this COM 

port cannot be used for PLC communication at the same time.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

Example 

1. Load ImgTrans.dll (the file is saved in Utility folder under the 

location of the installation destination directory. (under 

destination directory \Utility) 
 
2. Data Structure: 

typedef struct _COMM_INFO 

{ 

 char  szCOM[8]; 

 } COMM_INFO; 

，szCOM is a string of characters and the sent values aire COM1, 

COM2, COM3, …。 

 
3. List of Commands: 

(1) int hmOpen(const COMM_INFO* pCommInfo); 

(2) int hmSendImageFromFile(LPCTSTR szFileName); 

(3) HANDLE hmAsyncSendImageFromFile(LPCTSTR 

szFileName); 

(4) int hmSendImage(HBITMAP hbmp); 

(5) HANDLE hmAsyncSendImage(HBITMAP hbmp); 
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Property Description of Real Image Element 

(6) int hmAbortAction(); 

(7) int hmClose(); 

Example 

4. Brief Explanation of the commands 

(1) Command: int hmOpen(const COMM_INFO* pCommInfo);  

Input Value: COMM_INFO structure 

Return Value: 1: Succeeded , 0: Failed 

Explanation: Enable HMI communication. Input the name 

of COM Port, such as COM1, COM2 etc. 

(2) Command: int SendImageFromFile(LPCTSTR szFileName); 

Input Value: File name of the image 

Return Value: 1: Succeeded , 0: Failed 

Explanation: After converting the input image format into 

the width and height of the element, and Bit value, the 

system will start to transmit the image to HMI. This 

command is a synchronous command. After the data 

transmission to HMI is completed, this command will 

return.  

(3) Command: HANDLE hmAsyncSendImageFromFile(LPCTSTR 

 szFileName); 

Input Value: File name of the image 

Return Value: 0: Failed, none zero value: Thread Handle 

Explanation: After converting the input image format into 

the width and height of the element, and Bit value, the 

system will start to transmit the image to HMI. This 

command is an asynchronous command. The user can 

perform relevant operation by using Thread Handle data. 

(4) Command: int hmSendImage(HBITMAP hbmp); 

Input Value: HBITMAP Handle in Window 

Return Value: 1: Succeeded , 0: Failed 

Explanation: After converting the input image format into 

the width and height of the element, and Bit value, the 

system will start to transmit the image to HMI. This 

command is a synchronous command. After the data 

transmission to HMI is completed, this command will 

return. 

(5) Command: HANDLE hmAsyncSendImage(HBITMAP hbmp); 

Input Value: HBITMAP Handle in Window 

Return Value: 0: Failed, none zero value: Thread Handle 
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Example 

Explanation: After converting the input image format into 

the width and height of the element, and Bit value, the 

system will start to transmit the image to HMI. This 

command is an asynchronous command. The user can 

perform relevant operation by using Thread Handle data. 

(6) Command: int hmAbortAction(); 

Input value: None 

Return Value: 0: Succeeded , 1: Failed 

Explanation: This command is used to terminate the image 

transmission via asynchronous command.  

(7) Command:int hmClose();  

Input value: None 

Return Value: 1: Succeeded , 0: Failed 

Explanation: This command is used to terminate the 

communication of HMI (When DLL ends up, this command 

will be activated automatically.)  
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3.8.10 Input Elements 

 
Fig. 3-8-27 Input Elements 

3.8.10.1 Numeric Entry 

Property Description of Numeric Entry Elements 

After pressing this numeric entry element on the screen, a system built-in numeric 

keypad (TEN-KEY) will show up and the user can use it to input the setting value 

directly. When ENTER key is pressed, HMI will send the input setting value to the 

corresponding register. The maximum and minimum input setting values are all 

user-defined. The user can also specify the trigger mode to trigger the designated PLC 

address before or after writing the setting value. 

Write Address 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text Size 

Text Color 

The user can set the text size and text color that provided by HMI to 

determine the text display on the element. HMI provides 8~64 kinds 

of default text font for the user to use. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the numeric 

entry element is selected as Raised and Sunken. The style of the 

element below is selected as “Rasied”. Its background color is set to 

blue and its border color is set to red. 

 
(If the style of the element is set to Transparent, the Border Color 

and Background Color these two options are disabled.) 

Standard Raised Sunken Transparent 

Style 

    

Leading Zero 

The following figures show the difference if the user selects the 

Leading Zero option. (Please note that the integral digits are set to 

4.) 

   (If Yes is selected) 

   (If NO is selected) 
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Trigger 

Trigger Type 

The user can use this setting to trigger the designated controller 

address to be ON before or after writing the setting value. Please 

note that this function can only trigger the controller address to be 

ON. If the controller address needs to be triggered again, the user 

should set the address to be OFF manually. 

 

Date 

Length 

There are 16bits Word and 32bits Double Word two 

options. 

There are following data format provided: 

Data 

Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

7. Floating 

Setting 

Edit System 

Keypad 

When the input mode is Touch Popup, the user can 

define the style of the keypad, including title, font, font 

size, font color and keypad color. The position that the 

system keypad cannot display will be placed in the 

center of the screen.  
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Property Description of Numeric Entry Elements 

Edit System 

Keypad 

 Adjust the system keypad 

size 

 Set the height of the title bar 

 Set the font size 

Set the font 

 Set the font color 

 Set the background color 

 Return to the default setting  

Minimum 

Maximum 

The user can set the minimum and maximum of input 

setting value to determine the range of input setting 

value.  

Integral 

Digits 

Fractional 

Digits 

Use this option to determine the digit number of integer 

and decimal fraction. The digit number is not a real digit 

number value. It is only the display format. The digit 

number will be a real decimal number only when the 

data format is selected as “Floating”.  

When Variable Minimum/Maximum Value option is selected, it 

indicates that the minimum value is determined by Read Address+1 

and the maximum value is determined by Read Address+2. 

Gain(a) 

Offset(b) 

Round off 

The user can use y = (a) x (read address value) + (b) 

this equation to determine the display numeric value (y). 

For example, if Gain value (a) is 2 and Offset value (b) is 

3, when the read address value is 3, then the display 

numeric value will be equal to (2) x 3 + (3) = 9. 

If Gain and Offset value is a decimal, please set the data 

format as “Floating”. 

If Round off option is selected, after the operation of the 

equation above, all numeric values can be rounded off 

and display on the screen. 

Setting 

When the user have input the minimum and maximum value, after 

pressing OK button, HMI will examine the value by referring to the 

selected data length, data format, integral and fractional digits. 

Input Mode 

There are Touch Popup, Active Non-Popup and Touch Non-Popup 

three options. The default setting is Touch Popup. For the 

description of Active Non-Popup and Touch Non-Popup mode, 

please refer to section 3.8.14 Keypad Elements.  
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Property Description of Numeric Entry Elements 

User Security 

Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  

Display Asterisk 

(*) 

If YES is selected, the screen will show as the following figure when 

inputting the setting value. 

 

Fast Refresh 

If this option is selected, the element can be displayed immediately 

when switching the screen. Please note that this function is 

designed to provide fast value refresh speed for the element which 

performs communication frequently. Therefore, only 4 elements 

(including display element and input element) can be fast refreshed 

on one screen. If the user uses this function on too many elements, 

it may affect the normal speed of HMI operation. So, we recommend 

the user not to activate this function if not necessary. The user can 

set the Fast Refresh Rate by clicking Screen > Screen Properties 

command. There are three levels of the Fast Refresh Rate and they 

are High, Medium and Low. 

Set Low Security 

Use this option to force the current priority to be the lowest after the 

button is pressed. This can prevent the misoperation made by the 

user (operator).  

InterLock 

Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock Level”), this button can be enabled.  

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 
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Property Description of Numeric Entry Elements 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Info the 

overrange 

message 

When this option is set, an Error dialog box will appear to prompt 

the user the input value has exceeded the limit of the range setting. 

Invisible Address When this option is set to On, this button element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.10.2 　 Character Entry 

Property Description of Character Entry Elements 

The user can set write and read address to input the data of the specific address by 

text or character and display them on the screen. The input and display text or 

character must be in ASCII format. Write and read address can be the same or 

different. (The max. string length is 28words.) 

Write Address 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text Size 

Text Color 

The user can set the text size and text color that provided by HMI to 

determine the text display on the element. HMI provides 8~64 kinds 

of default text font for the user to use. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the character 

entry element is selected as Raised and Sunken. The style of the 

element below is selected as “Raised”. Its background color is set to 

blue and its border color is set to gray. 

 

(If the style of the element is set to Transparent, the Border Color 

and Background Color these two options are disabled.) 

Standard Raised Sunken Transparent 

Style 
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Character Length The range is with 1 ~ 28 words. The default setting is 4words. 

Trigger 

Trigger Type 

The user can use this setting to trigger the designated controller 

address to be ON before or after writing the setting value. Please 

note that this function can only trigger the controller address to be 

ON. If the controller address needs to be triggered again, the user 

should set the address to be OFF manually. 

When the input mode is Touch Popup, the user can define the style 

of the keypad, including title, font, font size, font color and keypad 

color. The position that the system keypad cannot display will be 

placed in the center of the screen.  

 

Edit System 

Keypad 

 Adjust the system keypad size 

 Set the height of the title bar 

 Set the font size 

 Set the font 

 Set the font color 

 Set the background color 

 Return to the default setting  

Input Mode 

There are Touch Popup, Active Non-Popup and Touch Non-Popup 

three options. The default setting is Touch Popup. For the 

description of Active Non-Popup and Touch Non-Popup mode, 

please refer to section 3.8.14 Keypad Elements.  

User Security 

Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  
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Display Asterisk 

(*) 

If YES is selected, the screen will show as the following figure when 

inputting the setting value. 

 

Fast Refresh 

If this option is selected, the element can be displayed immediately 

when switching the screen. Please note that this function is 

designed to provide fast value refresh speed for the element which 

performs communication frequently. Therefore, only 4 elements 

(including display element and input element) can be fast refreshed 

on one screen. If the user uses this function on too many elements, 

it may affect the normal speed of HMI operation. So, we recommend 

the user not to activate this function if not necessary. The user can 

set the Fast Refresh Rate by clicking Screen > Screen Properties 

command. There are three levels of the Fast Refresh Rate and they 

are High, Medium and Low. 

Set Low Security 

Use this option to force the current priority to be the lowest after the 

button is pressed. This can prevent the misoperation made by the 

user (operator).  

InterLock 

Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock Level”), this button can be enabled.  

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

 

 

 

 



Chapter 3 Creating and Editing Screens  

3-164 Revision May, 2010 

Property Description of Character Entry Elements 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Invisible Address When this option is set to On, this button element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.10.3 Barcode Input 

Property Description of Character Barcode Input Elements 

The user can set write and read address to input the data of the specific address by 

text or character and display them on the screen. The input and display text or 

character must be in ASCII format. Write and read address can be the same or 

different. (The max. string length is 127words.)  

Write Address 

Read Address 

The address can be internal memory or the controller address. If 

only write address is set, HMI will read the the value of write address 

automatically. (Please refer to Table 3-8-2 Property Description of 

General Buttons.) 

Text Size 

Text Color 

The user can set the text size and text color that provided by HMI to 

determine the text display on the element. HMI provides 8~64 kinds 

of default text font for the user to use. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the character 

entry element is selected as Raised and Sunken. The style of the 

element below is selected as “Raised”. Its background color is set to 

blue and its border color is set to gray.  

 

(If the style of the element is set to Transparent, the Border Color 

and Background Color these two options are disabled.) 

Standard Raised Sunken Transparent 

Style 

    

Character Length The range is with 1 ~ 127 words. The default setting is 4words. 
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Trigger 

Trigger Type 

The user can use this setting to trigger the designated controller 

address to be ON before or after writing the setting value. Please 

note that this function can only trigger the controller address to be 

ON. If the controller address needs to be triggered again, the user 

should set the address to be OFF manually. 

When the input mode is Touch Popup, the user can define the style 

of the keypad, including title, font, font size, font color and keypad 

color. The position that the system keypad cannot display will be 

placed in the center of the screen.  

 

Edit System 

Keypad 

 Adjust the system keypad size 

 Set the height of the title bar 

 Set the font size 

 Set the font 

 Set the font color 

 Set the background color 

 Return to the default setting  

Input Mode 

There are Touch Popup, Active Non-Popup and Touch Non-Popup 

three options. The default setting is Touch Popup. For the 

description of Active Non-Popup and Touch Non-Popup mode, 

please refer to section 3.8.14 Keypad Elements.  

User Security 

Level 

Use this option to set the user priority for pressing this element. 

Only the priority that is equal to or higher than the current setting 

can use this element.  
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Display Asterisk 

(*) 

If YES is selected, the screen will show as the following figure when 

inputting the setting value. 

 

Fast Refresh 

If this option is selected, the element can be displayed immediately 

when switching the screen. Please note that this function is designed 

to provide fast value refresh speed for the element which performs 

communication frequently. Therefore, only 4 elements (including 

display element and input element) can be fast refreshed on one 

screen. If the user uses this function on too many elements, it may 

affect the normal speed of HMI operation. So, we recommend the 

user not to activate this function if not necessary. The user can set 

the Fast Refresh Rate by clicking Screen > Screen Properties 

command. There are three levels of the Fast Refresh Rate and they 

are High, Medium and Low. 

Set Low Security 

Use this option to force the current priority to be the lowest after the 

button is pressed. This can prevent the misoperation made by the 

user (operator).  

InterLock 

Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined by 

the property of “InterLock Level”), this button can be enabled.  

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 
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Property Description of Character Barcode Input Elements 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Invisible Address When this option is set to On, this button element will be invisible.  

Popup Bit When this bit is turned to ON, the user can edit it manually. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.11 Curve Elements 

 

Fig. 3-8-28 Curve Elements 

3.8.11.1 Trend Graph 

Property Description of Trend Graph Elements 

The first step for setting trend graph is to set the curve number in “Curve Field Total” 

option (range is 1~4) in property table. Then, setting the read address, read format, 

curve width and color in “Detail Setup” option to complete the setup. 

The trend graph will continuously read numbers of addresses from the read address 

set by the user, convert the read data into trend graph and display on HMI screen. The 

numbers of the addresses is determined by the setting of “Sample Number”. 

This function is used to read the values of the internal memory addresses and display 

on HMI screen statically. After setting, the user needs to set the specific address of the 

control block to trigger the drawing and clear operation of the trend graph. For the 

settings of the control block, please refer to Chapter 5. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the trend graph 

element is selected as Raised and Sunken. The style of the element 

below is selected as “Raised”. Its background color is set to black and 

its border color is set to gray.  

 

Standard Raised Sunken 

Style 

   
Curve Field 

Total 

1~4 curves can be set and displayed. 
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Property Description of Trend Graph Elements 

 

Setting 

Sample Number 

Max. Sample 

Number 

Sample Number can be set to a constant or a 

variable value. 

When Sample Number is a constant:  

The sample number represents a curve which is 

composed of the data of several addresses 

(registers). When the sample number exceeds the 

width range that the element can draw, the 

following warning dialog box will display.  

  

It means that if the allowable width range of the 

created element is 10 sample numbers, when the 

sample number set by the user is higher than 10, 

the warning dialog box above will display. 
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Property Description of Trend Graph Elements 

Sample Number 

Max. Sample 

Number 

Please note that when the sample number is a 

constant, the Max. Sample Number option is 

disabled.  

When Sample Number is a variable value: 

When the sample number is set to the address 

(register), the sample number is a variable value. 

The user can change the value of the address to 

modify the sample number at the same time. When 

the sample number is a variable value, the Max. 

Sample Number option must be set. If the read 

value is more than the set Max. Sample Number, the 

system will take the set Max. Sample Number as the 

actual maximum sample number. 

Data Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Read Address 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.) 

The trend graph will continuously read numbers of 

addresses from the read address set by the user, 

convert the read data into trend graph and display 

on HMI screen. The numbers of the addresses is 

determined by the setting of “Sample Number”. 

Sample Flag 

It is used to set trigger and clear flag. When sample 

flag is triggered, it will start to read data and draw 

the graph. This sample flag is located within the 

control block. Please refer to section 3.4 in Chapter 

3 for the settings of the control block.  

Setting 

Minimum 

Maximum 

It is used to set the minimum and maximum value 

of the display data, i.e. the minimum and maximum 

value of Y-axis. If the read value is more the 

maximum or less than the minimum, the system 

will display the minimum and maximum value still. 
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Property Description of Trend Graph Elements 

Line Size 
Used to the display line width. The range is within 1 

~ 8 and the unit is pixel. Setting 

Line Color Used to set the display line color. 

Grid Line Color 

Grid Number in 

Horiz. 

Please refer to the figure below. The grid color is set to red and the 

grid number in horizontal direction is set to 3. 

 
X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.11.2 X-YChart 

Property Description of X-Y Chart Elements 

HMI will read and convert a series value of setting address to a X-Y chart on the screen. 

This function is used to read the values of the internal memory addresses and display 

on HMI screen statically. After setting, the user needs to set the specific address of the 

control block to trigger the drawing and clear operation of the trend graph, i.e. Trend 

Draw and Trend Clear. For the settings of the control block, please refer to section 3.4 

in Chapter 3. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the X-Y chart 

element is selected as Raised and Sunken. The style of the element 

below is selected as “Raised”. Its background color is set to yellow and 

its border color is set to gray. 

 

Standard Raised Sunken 

Style 

   

Connect Two 

Points 

If Yes option is selected, when drawing the X-Y chart on the screen, the 

space between two points on the X-Y chart will be connected by lines. 

Curve Field 

Total 

1~4 curves can be set and displayed. 



Chapter 3 Creating and Editing Screens  

3-172 Revision May, 2010 

Property Description of X-Y Chart Elements 

 
Setting 

Sample Number 

Max. Sample 

Number 

Sample Number can be set to a constant or a variable 

value. 

When Sample Number is a constant:  

The sample number represents a curve which is 

composed of the data of several addresses 

(registers). When the sample number exceeds the 

width range that the element can draw, the following 

warning dialog box will display.  

  

It means that if the allowable width range of the 

created element is 10 sample numbers, when the 

sample number set by the user is higher than 10, the 

warning dialog box above will display. 
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Property Description of X-Y Chart Elements 

Sample Number 

Max. Sample 

Number 

 

Please note that when the sample number is a 

constant, the Max. Sample Number option is 

disabled.  

When Sample Number is a variable value: 

When the sample number is set to the address 

(register), the sample number is a variable value. The 

user can change the value of the address to modify 

the sample number at the same time. When the 

sample number is a variable value, the Max. Sample 

Number option must be set. If the read value is more 

than the set Max. Sample Number, the system will 

take the set Max. Sample Number as the actual 

maximum sample number. 

Data Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Setting 

Horiz. Read 

Address 

The address can be internal memory or the controller 

address. (Please refer to Table 3.2.2 Property 

Description of General Buttons.) 

The X-Y chart will continuously read numbers of 

addresses from the horizontal read address set by 

the user, convert the read data into the points of 

X-axis and display on HMI screen. The numbers of 

the addresses is determined by the setting of 

“Sample Number”. 
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Property Description of X-Y Chart Elements 

Vert. Read 

Address 

The address can be internal memory or the controller 

address. (Please refer to Table 3.2.2 Property 

Description of General Buttons.) 

The X-Y chart will continuously read numbers of 

addresses from the vertical read address set by the 

user, convert the read data into the points of Y-axis 

and display on HMI screen. The numbers of the 

addresses is determined by the setting of “Sample 

Number”. 

Sample Flag 

It is used to set trigger and clear flag. When sample 

flag is triggered, it will start to read data and draw 

the X-Y chart. This sample flag is located within the 

control block 2. Please refer to Chapter 5 for the 

settings of the control block. 

Horiz. Minimum 

Horiz. Maximum 

It is used to set the minimum and maximum value of 

the horizontal display data, i.e. the minimum and 

maximum value of X-axis. If the read value is more 

the maximum or less than the minimum, the system 

will display the minimum and maximum value still.  

Vert. Minimum 

Vert. Maximum 

It is used to set the minimum and maximum value of 

the vertical display data, i.e. the minimum and 

maximum value of Y-axis. If the read value is more 

the maximum or less than the minimum, the system 

will display the minimum and maximum value still. 

Line Size 
Used to the display line width. The range is within 1 

~ 8 and the unit is pixel. 

Setting 

Line Color Used to set the display line color. 

Grid Line Color 

Horiz. Line 

Number 

Vert. Line 

Number 

Please refer to the figure below. The grid color is set to red and the 

grid numbers in horizontal and vertical direction are both set to 2.  

 
X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.11.3 X-Y Distribution 

Property Description of X-Y Distrubution Elements 

HMI will read and convert non- consecutive or consecutive data of the setting 

addressto a X-Y distribution graph on the screen. This function is used to read the 

values of the internal memory addresses and display on HMI screen statically. After 

setting, the user needs to set the specific address of the control block to trigger the 

drawing and clear operation of the trend graph, i.e. Trend Draw and Trend Clear. For 

the settings of the control block, please refer to section 3.4 in Chapter 3. 

Border Color 

Background 

Color 

The background color of the element below is set to green and its 

border color is set to gray.  

 
Standard Raised Sunken 

Style 

 

 

  
Sample 1~4 X-Y distribution point display can be set. 

Setting 
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Property Description of X-Y Distrubution Elements 

Control 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.). The user 

can set the function is to sample or clear. 

When BIT 0 is turned ON (OFF ON)→ , it indicates 

that HMI will read the sampling points.  

When BIT 1 is turned ON (OFF ON)→ , it indicates 

that HMI will clear the sampling points.  

Auto Clear 

When this option is selected, HMI will disable the 

control address (ON→OFF) after reading the 

sampling points.  

Continuous 

Address 

When this option is selected, the system will regard 

read address X as the starting address and 

designate the consecutive read addresses from 

read address X automatically. Doing this can save 

the communication time of the controller.  

For example, when read address X is set to 

1@D301, if this option is selected, HMI will take 

1@D302 as read address Y, 1@D303 as color 

address, 1@D304 as conjunction address. If this 

option is not selected, they can be specified to 

other kinds of addresses. 

Read Address X 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.) 

When the data is read, it will be converted to X 

distribution points and display on the screen.  

Read Address Y 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.) 

When the data is read, it will be converted to Y 

distribution points and display on the screen. 

Setting 

Color 

Used to determine the color of the sampling points 

(distribution points). It can be an internal memory, 

PLC address or constant. The range is from 

0~65535. 
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Property Description of X-Y Distrubution Elements 

Conjunction 

Used to determine if a line is connected between 

the distribution points. It can be an internal 

memory, PLC address or constant.  

0: Without a line; 1: With a line 

X Min. 

X Max. 

Used to set the minimum and maxmum value of 

X-axis. If the read value is more the maximum or 

less than the minimum, the system will display the 

minimum and maximum value still. 

Setting 

Y Min. 

Y Max. 

Used to set the minimum and maxmum value of 

Y-axis. If the read value is more the maximum or 

less than the minimum, the system will display the 

minimum and maximum value still. 

Grid Line Color 

Horiz. Line 

Number 

Vert. Line 

Number 

Please refer to the figure below. The grid color is set to red and the 

grid numbers in horizontal and vertical direction are both set to 2. 

 
X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.12 Sampling Elements 

 
Fig. 3-8-29 Sampling Elements 

 

3.8.12.1 Historical Trend Graph 

Property Description of Historical Trend Graph Elements 

Property Description of Historical Trend Graph Element 

Border Color 

Background 

Color 

The below element background color is set to black and its border 
color 

 
Curve Field Total 1~8 curves can be set and displayed. 

  

Setting 

Buffer ID 

Use this option to set the number (No.1 ~ No.12) of 

history buffer for reading the data of PLC corresponding 

address. The user can press the History Buffer Setup 

button or click Option > History Setup (Choosing 

History Setup command from menu bar) to set the PLC 

corresponding address.  
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Property Description of Historical Trend Graph Elements 

Data 

Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Floating 

Please note that if the data format is selected as 

Floating, the Data Length option in the History Setup 

dialog box must be greater than or equal to 2words 

or the following warning message dialog box will 

display on the screen. 

 

Integral 

Digits 

Fractional 

Digits 

Use this option to determine the digit number of integer 

and decimal fraction. The digit number is not a real digit 

number value. It is only the display format. The digit 

number will be a real decimal number only when the 

data format is selected as “Floating”. 

Global 

Range 

When this option is selected, it indicates that the user 

can set the minimum and maximum value of the history 

data. If this option is not selected, each curve can have 

its own minimum and maxmum value.  

Minimum 

Maximum 

It is used to set the minimum and maximum value of the 

display data, i.e. the minimum and maximum value of 

Y-axis. If the read value is more the maximum or less 

than the minimum, the system will display the minimum 

and maximum value still. 

Time/Date 

Time 

Format 

Provide HH:MM:SS, HH:MM two kinds of formats. 

Date 

Format 

Provide MM/DD/YY, DD/MM/YY, DD.MM.YY, 

YY.MM.DD, YY/MM/DD, MM.DD, MM/DD seven kinds 

of formats. 

Setting 

Color 
When time or date format is selected, the user can use 

this option to designate the display color. 
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Property Description of Historical Trend Graph Elements 

Enable 
If this option is selected, the following curve options are 

enabled and can be set. 

Data No. 

It is used to set the reading Word data when triggering 

every time. For example, if the Data Length option in the 

History Setup dialog box is set to 3words, there are 0 ~ 

2 data numbers can be selected in this option.  

Please note that if the data format is selected as 

“Floating”, and the Data Length option in the History 

Setup dialog box is an odd numbers of words, ensure 

to set the Data No. as an even number. 

Line Size 
Used to the display line width. The range is within 1 ~ 8 

and the unit is pixel. 

Line Color Used to the display line color. 

Setting 

Min. Value 

Max. Value 

Each display line (curve) can have its min. and max. 

values. If there are 8 lines in this history data, there will 

be 8 groups of min. and max. values 

Grid Line Color 

Grid Number in 

Horiz. 

Please refer to the figure below. The grid color is set to red and the 

grid number in horizontal direction is set to 3. 

 
X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.12.2 Historical Data Table 

Property Description of Historical Data Table Elements 

Convert the history data to numeric data and display on HMI screen by a data table. 

The read address in the History Setup dialog box needs to be set and its data length 

should be in several words. The range of data length is within 1 ~ 8words. The Data 

No. in History Data Detail dialog will also correspond to the selected Data Length in 

Buffer Properties of History Setup. 

Border Color 

Background 

Color 

The below element background color is set to green and its border 

color is set to gray. 

 
Data Field 

Number 

1~8 data fields can be set. 

Setting 

 

Setting Buffer ID 

Use this option to set the number (No.1 ~ No.12) of 

history buffer for reading the data of PLC corresponding 

address. The user can press the History Buffer Setup 

button or click Option > History Setup (Choosing 

History Setup command from menu bar) to set the PLC 

corresponding address. 
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Property Description of Historical Data Table Elements 

Time/Date 

Time 

Format 

Provide HH:MM:SS, HH:MM two kinds of formats. 

Date 

Format 

Provide MM/DD/YY, DD/MM/YY, DD.MM.YY, 

YY.MM.DD, YY/MM/DD, MM.DD, MM/DD seven kinds 

of formats. 

Color 
When time or date format is selected, the user can use 

this option to designate the display color.  

Date 

Length 

There are 16bits Word and 32bits Double Word two 

options. 

There are following data format provided: 

Data 

Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

7. Floating 

Data No. 

It is used to set the reading Word data when triggering 

every time. For example, if the Data Length option in the 

History Setup dialog box is set to 3words, there are 0 ~ 

2 data numbers can be selected in this option.  

Please note that if the data format is selected as 

“Floating”, and the Data Length option in the History 

Setup dialog box is an odd numbers of words, ensure 

to set the Data No. as an even number.   

Display 

Color 

It is used to the display data color.  

Setting 

Integral 

Digits 

Fractional 

Digits 

Use this option to determine the digit number of integer 

and decimal fraction. The digit number is not a real digit 

number value. It is only the display format. The digit 

number will be a real decimal number only when the 

data format is selected as “Floating”. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.12.3 Historical Event Table 

Property Description of Historical Event Table Elements 

Property Description of Historical Event Table Element 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided by 

Windows® to determine the text display on the element (Please refer 

to Table 3-8-2 Property Description of General Buttons.)  

It will show the input history message of every state. HMI system will 

list all input history messages in the event table. If there is no input 

history message, “?” will display. 

Border Color 

Background 

Color 

The below element background color is set to light yellow and its 

border color is set to black. 

 

Word It can have 256 states. 
Data Length 

LSB It can have 16 states.  

Data Format 

This option can be set only when the data length is selected as Word. 

It provides BCD, Signed Decimal, Unsigned Decimal and Hex four 

kinds of data format to define the read memory content. 

Add/Remove 

State 

It is used to set the state numbers of historical event table element. 

If the data length of the value is in Word, 1~256 states can be set. If 

the data length of the value is in LSB, 16 states can be set. If the data 

length of the value is in Bit, only 2 states can be set. 

Setting 
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Property Description of Historical Event Table Elements 

Buffer ID 

Use this option to set the number (No.1 ~ No.X) of 

history buffer for reading the data of PLC 

corresponding address. The user can press the 

History Buffer Setup button or click Option > History 

Setup (Choosing History Setup command from menu 

bar) to set the PLC corresponding address. 

Data No. 

It is used to set the reading Word data when triggering 

every time. For example, if the Data Length option in 

the History Setup dialog box is set to 3words, there are 

0 ~ 2 data numbers can be selected in this option. 

Time/Date 

Time Format Provide HH:MM:SS, HH:MM two kinds of formats. 

Date Format 

Provide MM/DD/YY, DD/MM/YY, DD.MM.YY, 

YY.MM.DD, YY/MM/DD, MM.DD, MM/DD seven kinds 

of formats. 

Setting 

Color 
When time or date format is selected, the user can use 

this option to designate the display color.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.13 Alarm Elements 

 

Fig. 3-8-30 Alarm Elements 

3.8.13.1 Alarm History Table 

Property Description of Alarm History Table Elements 

HMI will monitor and read the read address in a fixed time automatically. If some 

certain Bit contact of the address is ON or OFF, the alarm message will be converted to 

Alarm History Table element and display on the screen. 

Background 

Color 

The background color of the following two elements is set to white and 

blackish green respectively. 

 The background color is set to white. 

 The background color is set to blackish green. 

 
Time Format Provide HH:MM:SS, HH:MM two kinds of formats. 

Setting 

Date Format 

Provide MM/DD/YY, DD/MM/YY, DD.MM.YY, 

YY.MM.DD, YY/MM/DD, MM.DD, MM/DD seven kinds of 

formats. 
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Property Description of Alarm History Table Elements 

If this option is selected, when the alarm occurs, the 

alarm number that is designated in Alarm Setup dialog 

box will also be shown in front of the alarm message. 

Please refer to the figures below: 

 

Alarm 

Number 

 

Setting 

Color 
When time or date format is selected, the user can use 

this option to designate the display color.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.13.2 Active Alarm List 

Property Description of Active Alarm List Elements 

HMI will only display the current alarm message by using Active Alarm List element on 

the screen. 

Background 

Color 

The background color of the following two elements is set to white and 

yellow respectively.  

 The background color is set to white. 

 The background color is set to yellow. 
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Property Description of Active Alarm List Elements 

 
Time Format Provide HH:MM:SS, HH:MM two kinds of formats. 

Date Format 

Provide MM/DD/YY, DD/MM/YY, DD.MM.YY, 

YY.MM.DD, YY/MM/DD, MM.DD, MM/DD seven kinds 

of formats. 

Alarm 

Number 

If this option is selected, when the alarm occurs, the 

alarm number for the alarm message will always be 

shown ahead. Please refer to the figures below: 

 

Setting 

Color 
When time or date format is selected, the user can use 

this option to designate the display color.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.13.3 Alarm Frequency Table 

Property Description of Alarm Frequency Table Elements 

HMI will monitor and read the read address in a fixed time automatically. If some 

certain Bit contact of the address is ON or OFF, the ON or OFF frequency of the contact 

will be converted to Alarm Frequency Table element and display on the screen. 

Background 

Color 

The background color of the following two elements is set to white 

and yellow respectively. 

  The background color is set to white. 

 The background color is set to yellow. 

 

Time Format Provide HH:MM:SS, HH:MM two kinds of formats. 

Date Format 
Provide MM/DD/YY, DD/MM/YY and DD.MM.YY three 

kinds of formats. 

Alarm 

Number 

If this option is selected, when the alarm occurs, the 

time and date when the alarm occurred will also be 

shown in front of the alarm message. Please refer to the 

figure below: 

 

Display for 

Counting 

Zero 

Use this option to decide if show the message on the 

Alarm Frequency Table element or not when the 

occurring times of the alarm message is zero. 

Setting 

Color 
When Time and Date these two options are selected, the 

user can designate the display color by using this 

option.  
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Property Description of Alarm Frequency Table Elements 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.13.4 Alarm Moving Sign 

Property Description of Alarm Moving Sign Elements 

HMI will monitor and read the read address in a fixed time automatically. If some 

certain Bit contact of the address is ON or OFF, the current alarm message will display 

on the screen via Alarm Moving Sign element. 

Border Color 

Background 

Color 

The background color of the element below is set to blue green and its 

border color is set to red. 

 

Standard Raised Sunken Transparent 

Style 

    

Moving Points 
It is used to set the movement of the moving sign. The unit is Pixel and 

the range is within 1 ~ 50 Pixels. 

Interval(ms) 
It is used to set the interval time between two movements. The unit is 

ms and the range is within 50 ~ 3000 ms. 

 

Time Format Provide HH:MM:SS, HH:MM two kinds of formats. 

Setting 

Date Format 
Provide MM/DD/YY, DD/MM/YY and DD.MM.YY three 

kinds of formats. 
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Property Description of Alarm Moving Sign Elements 

Alarm 

Number 

If this option is selected, when the alarm occurs, the 

alarm number that is designated in Alarm Setup dialog 

box will also be shown in front of the alarm message. 

Please refer to the figures below: 

 
Setting 

Color 
When Time and Date these two options are selected, the 

user can designate the display color by using this 

option.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.14 Keypad Elements 

 
Fig. 3-8-31 Keypad Elements 

 

Property Description of Keypad (1) / (2) / (3) Elements 

Provide three kinds of default keypad elements for selection. The user can select 

decimal, hexadecimal or character these three kinds of keypad according to difference 

application requirement. 

                  

        Keypad (1) Decimal Keypad            Keypad (2) Hexadecimal Keypad  

 

Keypad (3) Character Keypad 

The user can redefine the display text of each button shown on the keypad. The other 

buttons, such as <ESC> (Escape),  <ENT> (Enter), <CLR> (Clear), <DEL> (Delete) and 

<ASCII> (Input Character) can also be renamed flexibly. Please refer to the following 

figure below: 
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Property Description of Keypad (1) / (2) / (3) Elements 

When the “Text” option is inputted as number “1”, the display text on the button will be 

“1”. If the user refines it as number “2”, the display text will be changed to “2”. If it is 

refined as character “A”, the display text will be changed to “A”. If it is changed to 

character “%“, the display text will be changed to “%” and vise versa. 

 

The keypad is displayed in a “Group” on the screen. The user can use “Ungroup” 

command from “Edit” menu bar to ungroup all the buttons. Then, the user move and 

change the button size freely. At this time, the user can redefine the display text 

shown on the button in the property table.  

 

The keypad element should be used with the Numeric / Character Entry elements. For 

these two kinds of elements, the user has to set the Input Mode as “Active Non-Popup” 

and “Touch Non-Popup” and InterLock Address should be set also. Please refer to 

section 3.8.8.1 and 3.8.8.2 for the property description of Numeric / Character Entry 

elements. (The difference between “Active Non-Popup” and “Touch Non-Popup” is that 

when InterLock Address is set, the element will twinkle automatically if its input mode 

is set to “Active Non-Popup”; however, when InterLock Address is set, if its input mode 

is set to “Touch Non-Popup”, the element will not twinkle until the user touches the 

element.) 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided 

by Windows® to determine the text display on the element. 

The user can set the text, text size, font and text color that 

provided by Windows® to determine the text display on the 

element. When the user press  button next to Font, the 

following Font Detail Setting dialog box will display.  

 

In Font Detail Setting dialog box, the user can select Font Name, 

Font Size and Ratio of the text and view the text format from the 

Preview window in advance. If the multi-language function is 

used, the user can see different language tabs and edit different 

language font setting in Font Detail Setting dialog box. Please 

refer to the example figure above. 
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Property Description of Keypad (1) / (2) / (3) Elements 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

Style 

There are Standard and Raised these two options. 

 
(When the style is selected as Standard and the foreground color 

is set to green.) 

 
(When the style is selected as Raised and the foreground color is 

set to red.) 

The user can redefine the buttons of the keypad. 

 

Setting 

Display: Display text or character 

Mode: 

The are following modes provided:: 

1. <ESC> Escape/Cancel (If the keypad is put on the sub 

window, this key can be used to close the sub window. 

2. <ENT>  Enter 

3. <CLR>  Clear 

4. <DEL>  Delete 

5. <ASCII> Character 
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3.8.15 Drawing Elements 

 
Fig. 3-8-32 Drawing Elements 

3.8.15.1 Line 

Property Description of Line Drawing Elements 

Left-click the mouse to draw and edit the line graphic element. The user can click 

where the user wants to start the line and drag across the work place on the screen. 

Then, release the mouse to finish the line. When selecting this line graphic element, 

the user can see a rectangle range and this is designed for the user to move and adjust 

the line more quickly and conveniently. The user can set line color, size and style in 

property table freely. The range out of the line graphic element itself will be displayed 

in transparent color. 

           

 Line Direction            Line Size (from 1 to 8) 

Curve Color It is used to set the display color of the line element. 

Line Size The unit is Pixel and the range is within 1 ~ 8. 

Line Style 

There are following line styles can be selected. 

 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.15.2 Rectangle 

Property Description of Rectangle Drawing Element 

Left-click the mouse to draw and edit the rectangle graphic element. The user can drag 

the mouse across work place on the screen until the rectangle is the size that the user 

wants. Then, release the mouse to finish. The user can import the picture into the 

rectangle from picture bank and set rectangle color, size and style in property table. 

Curve Color It is used to set the display color of the rectangle element. 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 
It is used to set the display color of the rectangle graphic 

element. 

Line Size The unit is Pixel and the range is within 1 ~ 8. 

Transparent 

When this option is selected, the element will display only with 

the border and there is no color in the element. The Foreground 

Color option will be disabled also. 

Round Radius 

0~38 pixels round radius are provided for selection.  

 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.15.3 Circle 

Property Description of Circle Drawing Element 

The user can draw an ellipse or circle by using this option. The user can drag the 

mouse across work place on the screen until the ellipse or circle is the size that the 

user wants. Then, release the mouse to finish. If the width and height of the circle 

graphic element are the same size, the circle graphic element will be a round shape 

circle. If the width and height of the circle graphic element are not the same size, it will 

be an ellipse element. When selecting this circle graphic element, the user can see a 

rectangle range and this is designed for the user to move and adjust the circle more 

quickly and conveniently. Changing the size of the rectangle range is changing the 

size of circle graphic element directly. The range out of the circle graphic element 

itself will be displayed in transparent color. There is a “Transparent” option in the 

element property table. Once Yes is selected, the element will display only with the 

border and there is no color in the element. If there is any other element under this 

circle graphic element, it will show up and can be viewed on the screen. 

  An ellipse that its “Transparent” setting in the property table is 
set to “No” 

 

  An circle that its “Transparent” setting in the property table is 
set to “No”. 

 

  An circle that its “Transparent” setting in the property table is 
set to “Yes”. 
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Property Description of Circle Drawing Element 

  An ellipse that its “Transparent” setting in the property 
table is set to “Yes”. 

 

Curve Color It is used to set the line color of the circle graphic element.  

Foreground Color It is used to set the display color of the circle graphic element. 

Line Size The unit is Pixel and the range is within 1 ~ 8. 

Transparent 

When this option is selected, the element will display only with 

the border and there is no color in the element. The Foreground 

Color option will be disabled also.  
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3.8.15.4 Polygon 

Property Description of Polygon Drawing Element 

Left-click the mouse to determine each node of the polygon graphic element. The user 

can click where the user wants to place the first node and drag the mouse across work 

place on the screen until the next node is decided and left-click the mouse again to 

determine the position of the next node. Repeat the above action until the polygon is 

the size that the user wants. Then, right-click the mouse the mouse to finish. When 

selecting this polygon graphic element, the user can see a rectangle range and this is 

designed for the user to move and adjust the polygon more quickly and conveniently. 

Changing the size of the rectangle range is changing the size of circle graphic element 

directly. The range out of the circle graphic element itself will be displayed in 

transparent color. There is a “Transparent” option in the element property table. Once 

Yes is selected, the element will display only with the border and there is no color in 

the element. If there is any other element under this circle graphic element, it will 

show up and can be viewed on the screen. 

Curve Color It is used to set the line color of the polygon graphic element. 

Foreground Color 

It is used to set the display color of the polygon graphic element. 

Please refer to the figures below: 

   The foreground color is set to blue. 

   The foreground color is set to turquoise. 

Line Size The unit is Pixel and the range is within 1 ~ 8. 

Transparent 

When this option is selected, the element will display only with 

the border and there is no color in the element. The Foreground 

Color option will be disabled also. Please refer to the figures 

below: 

 A polygon that its “Transparent” setting in 

the property table is set to “No”. 

 A polygon that its “Transparent” setting in 

the property table is set to “Yes”. 
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3.8.15.5 Arc 

Property Description of Arc Drawing Element 

Left-click the mouse to draw and edit the arc graphic element. The user can click where 

the user wants to start the arc and drag across the work place on the screen. Then, 

release the mouse to finish the arc. When selecting this arc graphic element, the user 

can see a rectangle range and this is designed for the user to move and adjust the arc 

more quickly and conveniently. Changing the size of the rectangle range is changing 

the size of arc graphic element directly. There is a “Transparent” option in the element 

property table. If this option is set to Yes, it indicates that this element is an arc. If this 

option is set to No, it indicates that this element is a sector. The range out of the circle 

graphic element itself will be displayed in transparent color. 

               

When “Transparent” is set to “No”          When “Transparent” is set to “Yes”. 

Curve Color It is used to set the line color of the arc graphic element.  

Foreground Color It is used to set the display color of the arc graphic element. 

Line Size The unit is Pixel and the range is within 1 ~ 8. 

Transparent 

When this option is selected, the element will display only with 

the border and there is no color in the element. The Foreground 

Color option will be disabled also.  

 



Chapter 3 Creating and Editing Screens  

3-200 Revision May, 2010 

3.8.15.6 Text  

Property Description of Text Drawing Element 

This text graphic element is used to create a text frame, and add and edit the text on 

the screen. The user can drag the mouse across work place on the screen until the text 

frame is the size that the user wants and release the mouse to finish. Then, add and 

edit the text in the text frame. The foreground color is the color of the text frame. 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided 

by Windows® to determine the text display on the element. 

The user can set the text, text size, font and text color that 

provided by Windows® to determine the text display on the 

element. When the user press  button next to Font, the 

following Font Detail Setting dialog box will display.  

 

In Font Detail Setting dialog box, the user can select Font Name, 

Font Size and Ratio of the text and view the text format from the 

Preview window in advance. If the multi-language function is 

used, the user can see different language tabs and edit different 

language font setting in Font Detail Setting dialog box. Please 

refer to the example figure above. 

Foreground Color 

It is used to set the text frame color. Please refer to the figure 

below. The foreground color of this text graphic element is set to 

blue. 

 

Transparent 

When this option is selected, the element will display the text 

only and there is no color in the element. The Foreground Color 

option will be disabled also. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.15.7 Scale 

Property Description of Scale Drawing Element 

The user can change the scale direction, main and sub scale number, and grid color in 

the property table to create a special and unique scale graphic element. The “Display 

Mark” option can be used to determine if the scale value display next to the scale or 

not. The minimum and maximum of the scale value can be set in “Detail Setup” option. 

Text Size 

Text Color 

The user can set the text size and text color that provided by HMI to 

determine the text display on the element. HMI provides 8~64 kinds of 

default text font for the user to use. 

Standard Rotation 90 Rotation 180 Rotation 270 

Style 

    

Main Scale 

Please refer to the figures below:： 

   When main scale number is set to 2 

 

   When main scale number is set to 3 

 

Setting 

Date Length 
There are 16bits Word and 32bits Double Word two 

options. 
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Property Description of Scale Drawing Element 

Data Format 

There are following data format provided: 

Word/Double Word 

1. BCD 

2. Signed Decimal 

3. Unsigned Decimal 

Minimum 

Maximum 

The user can set the minimum and maximum of input 

setting value to determine the range of input setting 

value.  

Integral 

Digits 

Fractional 

Digits 

Use this option to determine the digit number of 

integer and decimal fraction. The digit number is not a 

real digit number value. It is only the display format. 

The digit number will be a real decimal number only 

when the data format is selected as “Floating”. 

Setting 

When the user have input the minimum and maximum value, after 

pressing OK button, HMI will examine the value by referring to the 

selected data length, data format, integral and fractional digits. 

SubScale 

Number 

When the main scale number is set to 3 and the subscale number is 

also used, the scale graphic element will display as the figures below: 

   When subscale number is set to 1 

   When main scale number is set to 2 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.15.8 Table 

Property Description of Table Drawing Element 

The user can change the cell numbers of the table, appearance and color in the 

property table to create a special and unique table graphic element. If it is used with 

other elements, each element will display more completely on the screen. 

Background 

Color 

It is used to set the display color of the table scale element.  

 

Row Header 

It is used to the color of the first row of the table. 

The user can enable or disable this option by 

checking the check box next to “Row Header”. 

Col umn Header 

It is used to the color of the first column of the 

table. The user can enable or disable this option by 

checking the check box next to “Column Header”. 

Rows 

It is used to the color of the interlacing rows of the 

table. The user can enable or disable this option by 

checking the check box next to “Rows”. 

Columns 

It is used to the color of the interlacing rows of the 

table. The user can enable or disable this option by 

checking the check box next to “Rows”. 

Setting 

Row Header 

It is used to the color of the interlacing row header 

of the table. The user can enable or disable this 

option by checking the check box next to “Row 

Header”. 
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Property Description of Table Drawing Element 

Columns Header 

It is used to the color of the interlacing column 

header of the table. The user can enable or disable 

this option by checking the check box next to 

“Columns Header”. 

Sep. Rows Evenly It is used to distribute rows of the table evenly. 

Setting 

Sep. Col Evenly It is used to distribute columns of the table evenly. 

Border Color It is used to set the border color of the table.  

Grid Line Color It is used to set the grid color of the table.  

Number of 

Rows 
The range is within 1 ~ 99. 

Number of 

Columns 
The range is within 1 ~ 99. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.9 Menu Bar and Toolbar (Screen) 

 
In Screen options, ScrEdit provides some screen editing functions. 

3.9.1 New Screen 

Create a new screen. The user can choose Screen > New Screen or click the New Screen icon 

, or press Shift + N to open a new editing screen. The new screen can be named and 

numbered by the user. The setting dialog box is shown as Fig. 3-9-1.  

 
Fig. 3-9-1 New Screen dialog box 

 

3.9.2 Open Screen 

Open an old screen. The user can choose Screen > Open Screen or click the Open Screen 

icon , or press Shift + O. When choosing open screen, the user can preview each screen 

in Open Screen dialog box (Fig. 3-9-2).  
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Fig. 3-9-2 Open Screen dialog box 

 

3.9.3 Screen Management 

When Screen Management function is enabled (Fig. 3-9-3), the user can duplicate, paste and 

cut the screen using the mouse, just like the function of Windows Explorer in Windows® 

operating system. In Screen Management dialog box, the user can right click the mouse to 

manage all of the screens (Fig. 3-9-4). Please note that the user cannot undo the action of cut 

screen. It is the same as delete screen that screen will be lost but it can be pasted to get the 

same screen (Fig. 3-9-5). Besides, right-click the mouse to select the Edit Save Screen 

function, and then the user can drag the mouse to determine the screen saver display (Fig. 

3-9-6). For the setting of screen saver, please click Options > Configuration > Other. 
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Fig. 3-9-3 Screen Management dialog box 

 

Fig. 3-9-4 Right-click the mouse 
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Fig. 3-9-5 Warning message after screen is cut 

 

Fig. 3-9-6 Drag the mouse to determine the screen saver display 

 

3.9.4 Cut Screen 

Cut whole screen to clipboard, just like the Microsoft Office Clipboard function. The 

difference is that Microsoft Office Clipboard allows the user to cut text and graphic items and 

the Cut Screen function only allows the user to cut a whole screen. The user can execute this 

function by choosing Screen > Cut Screen, or pressing Shift + T. 

Please note that the user cannot undo the action of cut screen. It is the same as delete 

screen that screen will be lost but it can be pasted from the clipboard to recover 

(Fig.3-9-7). 

 
Fig. 3-9-7 Cut Screen message 
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3.9.5 Copy Screen 

ser can execute this function by clicking Screen > Copy Screen or 

Shift + C

 

3.9.6 Paste Screen 

en by clicking Screen > Paste Screen or pressing Shift + P. The 

screen settings are the same as the original screen, except for the new screen name. Screen 

Editor gives a screen name automatically. 
 

3.9.7 Delete Screen 

creen or element. The user can delete a screen by clicking Screen 

> Delete Screen or pressing Shift + D.  

e 

Delete comman ll see th alog box below. Make sure that the user selects 

a correct screen before deleting it.  

Copy whole screen. The u

use keyboard shortcuts by pressing . 

The user can paste a scre

 

Delete the current editing s

Please note that It is not possible to undo the delete operation. After selecting th

d, the user wi e di

 
Fig. 3-9-8 Delete Screen Message 

 

3.9.8 Export 

o BMP format. The user can execute this function by clicking Screen > Export an project t

Export or clicking the Export icon  , or pressing Shift + E.  
 

3.9.9 Import 

orts a picture to be the ground of the editing screen. Please note that the 

ground of the editing screen is different than the base screen. The nature of an imported 

 of 

s 

 

This command imp

picture differs greatly from that of the base screen. The imported picture cannot exist in 

ScrEdit as an element. However, the base screen can be regarded as an element and then 

exist in the editing screen after a compile operation is completed (The definition and usage

the base screen will be introduced more in the section of “Screen Properties”). The file type

of available imported picture can be BMP, JPG and GIF, etc. The user can execute this function 

by clicking Screen > Import or pressing Shift + I. 
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3.9.10 Clear Import Data 

r pace by clearing the imported data that the user does not want 

 

3.9.11 Screen Open Macro 

r tion is selected, the Macro will be executed automatically 

e 

The use can free more disk s

to use. Execute this function by clicking Screen > Clear Import Data.  

When Sc een Open Macro func

once opening screen occurs. The user also can click the Screen Open Macro, Screen Clos

Macro and Screen Cycle Macro options from the Property Table to enter intro Screen Open 

Marco editing environment (Fig. 3-9-9). For details on how to use and edit macro commands, 

refer to section 3.1.14.  

 
Fig. 3-9-9 Screen Open Macro dialog box 

 

.9.12 Screen Close Macro 

ion is selected, the Macro will be executed automatically 

3

When Screen Close Macro funct

once the screen is closed. For details on how to use and edit macro commands, refer to 

section 3.1.14. 
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3. 13 Screen Cycle Macro 

r tion is selected, the Macro will be executed continuously once 

ent 

.9.14 Auxiliary Key 

ser to determine the function of auxiliary keys in each screen. 

Screen > Auxiliary Key

9.

When Sc een Cycle Macro func

the screen is displayed. (Macro will be executed continuously by the cycle time setting) For 

details on how to use and edit macro commands, refer to section 3.1.14. 

The user also can click the Screen Open Macro, Screen Close Macro and Screen Cycle 

Macro options from the Property Table to enter intro Screen Open Marco editing environm

(Fig. 3-9-9).  

 

3

DOP-B series HMI allows the u

The user can execute this function by clicking . Auxiliary key setup for 

each screen can be completed by pressing the auxiliary keys on HMI panel or on the screen 

(Fig. 3-9-10). 

 
Fig. 3-9-10 Auxiliary Key setup 
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3.9.15 Screen Properties 

This function sets the properties of the current screen. The user can view and choose the 

properties of the current editing screen by selecting Screen > Screen Properties or choosing 

Screen Properties from docking windows (Fig. 3-9-11, 3-9-12）. 

 

Fig. 3-9-11 Choosing Screen Properties 

 

Fig. 3-9-12 Screen Properties dialog box 
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Function Description 

Screen Number 
The range is between 1 and 65535. Each screen number must 

be unique. The user cannot use the same number two times. 

General View 

Screen 

Regarded as general view screen.  

Screen 

Application Apply Print 

Screen 

1. Regarded as print screen. The printer can print the 

element created by the user after a compile operation. 

This option is only available in DOP-B series HMI which 

supports printer function.  

2. When Apply Print Screen function is selected, the editing 

range will be scaled to the actual paper size of the printer. 

The user can only print the elements within the range of 

the paper size. This option is usually used for print 

typesetting (print layout management function).  

For the setting of print function, please click Options > 

Configuration > Printer Setup.  
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Function Description 

Sub-screen 

setting 

The check box next to “This screen is a sub-screen” can be 

checked only when General View Screen option is selected. 

Therefore, before setting sub-screen function, ensure the 

General View Screen option is selected.  

 

Screen Width Set the width of sub-screen and the unit is Pixel. 

Sub-screen 

Screen Height Set the height of sub-screen and the unit is Pixel. 

Sub-screen 

Position 

This option can show the sub-screen on the center of 
the HMI screen or on a position you specify. 
To specify the position, 
‧ input the coordinate value directly (X and Y axis) or 

‧ press the  icon to drag the sub-screen.  

 

Sub-screen 

Title Bar The user can select this option to display the title bar on the 

screen. 
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Function Description 

Cycle Macro Delay Time 

Sets Macro Cycle Delay time every time this screen is executed. 

The range of the macro cycle delay time is between 100ms to 

5s.  

Fast Refresh Rate 

There are three levels of the Fast Refresh Rate and they are 

High, Medium and Low. The purpose of this function is used to 

make some elements be displayed immediately when switching 

screens.  

Please note that this function is designed to provide fast 

value refresh speed for the element which performs 

communication frequently. Therefore, it only allows four 

elements that can be renewed immediately in each screen. If 

the user uses this function on too many elements, it may 

affect the normal speed of HMI operation. So, we 

recommend the user not to activate this function if not 

necessary.  

Setting 

The user can find this function only in DOP-B series HMI which 

supports printer function. If the user wants to enable this 

function, setting the printer in advance is necessary. Please go 

to Option > Configuration > Printer Setup and select the 

printer first. When this function is enabled, if one report list 

button is created and its assigned output device is a printer, 

once the user presses the report list button, HMI will refer to 

the setting in Hard Copy Region option and execute the 

screen-printing.  

Top-Left 

Hard Copy 

Region 

Right-Bottom 

Set the region of HMI printing area (also called Hard Copy 

Region) and the unit is Pixel.  

Need Base 

Screen 
Setting 

Every screen can specify any one of the editing screens as a 

base screen. When the check box next to Need Base Screen is 

checked, the base screen will be moved to the back (behind all 

other elements) as a ground picture. After compile operation is 

completed and the screen data is downloaded to HMI, HMI will 

execute all of the elements on the base screen correctly.  
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3.10 Menu Bar and Toolbar (Tools) 

 

 

3.10.1 Compile 

It is used to compile editing screen to the format for HMI. During compiling, all of the 

compiling messages, including any errors, will be written to output field. When there is any 

error occurs, system will remind the user. If there was no error during compiling process, an 

object file would be produced.  

To compile the editing screen, select Tools > Compile or click icon  directly or press Ctrl 

+ F7. If this project is a new project, it will remind the user of saving before compiling. If this 

project has been saved or it is an old project, it will compile directly without prompt. After 

compile operation is finished, ScrEdit will save the file again automatically. 

 

Debug Compiling Error during Compiling Process 

1. Create a new project. 

2. Create a button element and a numeric entry element on HMI screen and do not 

change the element default property as the figure below. 
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3. When pressing  icon to execute compile operation, the error message dialog box 
will pop up to warn the user of compiling error and show how many errors there are. In 

the following figure, we can see that there are two errors occurred and they are all 

displayed in the output window.  
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4. Once error occurs, the correspondent message will display in output window. The 

user can click the error message and ScrEdit will switch to error element window 

automatically.  

 

3.10.2 Download Screen & Recipe 

The user can download screen data and recipe to HMI by clicking Tools > Download Screen 

& Recipe or clicking  icon directly or pressing Ctrl + F8.  

If PC cannot connect to HMI, the error messages will be displayed and warn the user (Fig. 

3-10-1, Fig. 3-10-2, Fig. 3-10-3 and Fig. 3-10-4). The user can set download interface by using 

the following methods: 

1. Clicking Options > Configuration or  

2. Clicking Options > Environment. The download interface can be USB or RS-232.  

 

Fig. 3-10-1 Start download (the progress will be from 0 to 100%)  

     

Fig. 3-10-2 USB open error message 

3-218 Revision May, 2010 



 Chapter 3 Creating and Editing Screens 

 

Fig. 3-10-3 USB disconnect error message 

 

Fig. 3-10-4 Incorrect model name error message 

 

3.10.3 Upload Screen & Recipe 

After clicking File > Upload Screen & Recipe, the password dialog box will show up first (Fig. 

3-10-5), the user needs to input password (the password is the highest priority saved in HMI, 

which is set by clicking Options > Configuration > General > Security). When entering the 

correct password, the user can get save as dialog box (Fig. 3-10-6). After inputting project file 

name, the uploading will start (Fig. 3-10-7). The user can get the progress with progress box 

and stop uploading by clicking Stop button. When progress goes to 100%, it indicates that the 

uploading is complete. The user can press Stop button to exit the dialog box. The file that is 

uploaded from HMI can be restored to original editing file for user to edit. This option is to 

avoid losing the original editing file. If the user wants to upload data with pictures also, just 

select the Include Picture Data when uploading in Environment dialog box by clicking 

Options > Environment. 

 

Fig. 3-10-5 Password dialog box 
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Fig. 3-10-6 Save as dialog box 

 
Fig. 3-10-7 Upload screen and recipe data 
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Fig. 3-10-8 Environment dialog box 

 

3.10.4 Download Screen 

To download screen data to HMI, select Tools > Download Screen or click icon directly 
or press Ctrl + F9. The download process is the same as the function of Download Screen & 

Recipe. The only difference is that the function of Download Screen & Recipe allows the user 

to download the screen data and recipe data both but the function of Download Screen allows 

the user to download screen data only.  

 

3.10.5 Upload Recipe 

To upload the recipe data only, select Tools > Upload Recipe. Then, the password dialog box 

is displayed. The user must enter a password to access the HMI (the password is the highest 

priority saved in HMI, which is set by clicking Options > Configuration > General > Security). 

Enter the name of the recipe to start the upload. When the progress goes to 100%, the upload 

is complete. To monitor the progress of the upload, access the progress box. To stop the 

upload, click the Stop button.  
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3.10.6 Download Recipe 

To download the recipe data only, select Tools > Download Recipe. The file extension name 

of a recipe file is .rcp (Fig. 3-10-9). 

 
Fig. 3-10-9 Download the designated recipe data 

 

3.10.7 On Line Simulation 

This command simulates DOP-B series HMI by computer but HMI should also connect to PLC 

first to drive PLC by PC simulation through PC communication port. Therefore, the user 

cannot execute the function of On Line Simulation without connecting PLC. But the user can 

execute the function of Off Line Simulation without connecting PLC. On Line Simulation 

function can execute by clicking Tools > On Line Simulation or clicking icon  directly or 
pressing Ctrl + F4. Before executing On Line Simulation, the system will ask the user to set 

the communication port for connecting to PLC first (Fig. 3-10-10). For On Line Simulation 

Screen, the user can refer to Fig. 3-10-11.  

 
Fig. 3-10-10 COM Settings 
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Fig, 3-10-11 On Line / Off Line Simulation Screen 

 

3.10.8 Off Line Simulation 

To test the editing screen, the read/write addresses and the macro command to see if they 

are correct, the user can run an off-line simulation. To enable the off line simulation, select 

Tools > Off Line Simulation or click  icon directly or press Ctrl + F5 (Fig. 3-10-11).  

 

3.10.9 Upgrade Firmware 

This option is for upgrading HMI firmware or adding function for HMI. Keeping HMI firmware 

version to be the most updated version can optimize HMI operation. Ensure that the software 

version of ScrEdit matches the firmware version. The user can get the firmware information 

by clicking Tools > Get Firmware Information (Fig. 3-10-12). Regarding the software version 

of ScrEdit, the user can find it by clicking Help > Help (Fig. 3-10-13). For the screen of 

upgrading the firmware please refer to Fig. 3-10-14. 
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Fig. 3-10-12 Get Firmware Information 

 

Fig. 3-10-13 About Screen Editor 
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Fig. 3-10-14 Upgrade Firmware 

 

3.10.10 Get Firmware Information 

Connects to the HMI over the USB connection or via the communication (COM port) and 

provides the current firmware version. 

 

Fig. 3-10-15 Get Firmware Information screen 
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3.11 Menu Bar and Toolbar (Options) 

 

3.11.1 Configuration 

To access the configuration options, select Options > Configuration. This dialog box is 

divided into six tabs: General, Control Block, COM Port, Printer Setup, Default and Other. 

These tabs are covered in detail in the following sections. 

General tab in Configuration option 
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General tab in Configuration option 

Project Name Enter the name of the file for the project. 

HMI Type 

Select DOP-B series HMI type for 

different functions and 

requirements  

 

Non-volatile data 

location 

The backup memory data (non-volatile data) can be saved in HMI 

and USB disk. The user can select one of them from the Location 

drop-down list. However, USB disk selection is available in some 

HMI types. Therefore, it depends on which HMI the user select. 

The setting of non-volatile data location is shown as the figure 

below. After pressing Setting button, Retained Area dialog box will 

pop up and the user can set the storage location of alarm, recipe 

and history data in this dialog.  

  

Password 

Used to set the highest priority password. There are 8 levels for 

the password. Meanwhile, this password is also the protection 

password for the file (project). Please note that the password 

format is in hexadecimal (0 ~ F). 

Starting Level 
Used to set start-up priority. The highest level is 7 and the lowest 

level is 0.。 

Insufficient password 

level reminder 

When this check box is checked, if the priority for the element that 

is not equal to or higher than the current setting,  will display 

to remind the user.  

Buzzer ON When this check box is checked, the function of Buzzer is enabled. 
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General tab in Configuration option 

Upload/Download 
The user can select USB or PC communication port (i.e. RS-232) or 

Ethernet to upload and download.  

Startup Delay Time 
Use to set delay time for waiting the startup of external controller 

(i.e. PLC). The range is between 0 ~ 255 seconds. 

Clock Macro Delay Time 
Use to set interval time when executing clock macro. The range is 

100 – 65535 ms. 

Clock Macro Priority 
Used to set the priority when executing clock macro. Setting this 

option can ensure the more correct clock macro delay time.  

Background macro 

update cycle 

Used to set the executing lines when executing background macro 

for one cycle. The range is 1~512 lines. 

Show disk access error 

message 

When this option is set, if an error occurred when accessing the 

alarm, history buffer, and recipe data via USB disk, an error 

message will show up on the screen to alert the user.  

 

Control Block tab in Configuration option 

 
Control Address Use to set the starting address of system control block. 

Length 

The length of control block will be different depending on 

different function. (For example, the length should be at least 8 

Words when using multi-language function.)  

For more detailed information of system control block, refer to 

section 3.4.  

Please note that the when the control block size is set to 0, 

the control block function is disabled.  
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Control Block tab in Configuration option 

Auto Reset Flag 

If the Auto Reset Flag box is checked, the register in the control 

block is cleared to 0 when any operation is finished in the 

control block.  

Status Address 

Use to set the starting address of system status block. The 

length is constant 8 words. Each word indicates the different 

status value of HMI system. For more detailed information of 

system status block, refer to section 3.4.  

 

COM Port tab in Configuration option 

 

Add/ 

Delete/ 

Modify 

Add 

Press Add button to determine the connecting device name and the 

controller. Please refer to the figure below: 

 

Available connecting PLC will be different depending on HMI type. 

(DOP-B series HMI can support up to three different controllers 

simultaneously.) 
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COM Port tab in Configuration option 

Delete 
Delete the existed connecting controller (one application needs to 

connect at least one controller). 

Add/ 

Delete/ 

Modify Modify Modify the connecting controller or change the controller name. 

COM Port Set the COM port that communicates with HMI 

PLC 

Station 

Set PLC station number. If PLC does not set station number, it will 

use this default setting. The range is between 0 ~ 255. 

Password 
Passwords are necessary for some connecting controllers before 

communication. 

Comm. 

Delay 

Time 

Set delay time for waiting the startup of external controller 

(i.e. PLC). The range is between 0 ~ 255 ms.  

Timeout 
Set communication time out time when communicating with the 

external controller. The range is between 10 ~ 65535ms. .  

Retry 

Count 

HMI will try to send a communication command to the external 

controller repeatedly if the external controller does not respond 

during communication. This option is used to set the number of 

retry count times. A communication error dialog box will not appear 

unless the number of retry count times is reached. The range is 

between 0 ~ 255 times. 

Controller 

Settings 

Optimize 

When Optimize box is checked, optimization function is enabled. If 

optimization function is enabled, all read addresses of all related 

elements will be optimized. 

When Communication Interrupt times then ignore box is checked, HMI stops 

communicating with the PLCs after the communication interrupt time is reached. The 

purpose of this function is to avoid the communication error dialog box will always show 

on the HMI screen when the communication error occurs after HMI has retried. The range is 

between 1 ~ 255 times. 

If the user wants to recover the communication between HMI and PLCs again when HMI 

stop communicating with the PLCs after the communication interrupt times are reached, 

the user can use Bit 0 of the control block D1 (suppose that the stating address is D0) to 

control HMI communication. When Bit 1 is set to ON, it will disable HMI communication. 

When Bit 1 is set to OFF, it will enable HMI communication.  

HMI 

Station 

Set HMI station number. The range is between 0 ~ 255. 

Interface 
Set communication interface. There are three options RS232, RS422 

and RS485. 

Data Bits There are two options 7 Bits and 8 Bits. 

Comm. 

Parameter 

Stop Bits There are two options 1 Bits and 2 Bits. 
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COM Port tab in Configuration option 

Baud Rate 

Communication baud rate. There are 4800, 9600, 19200, 38400, 

57600 and 115200 these options. The users can enter the setting 

value directly also but the maximum. setting value can not exceed 

187500. 

Comm. 

Parameter 

Parity There are three options: None, Odd and Even. 

HMI 
 

1. Choose Ethernet and the user can set the Ethernet setting. 

2. If Overwrite IP function is enabled, HMI will update the Ethernet 

setting after the screen data is download. 

3. If Obtain IP address automatically box is checked, HMI will get the 

IP address automatically. But before enabling this function, 

ensure that DHCP server is connected. 

4. If Obtain IP address automatically box is not checked, the user 

must set Ethernet setting, i.e. HMI IP address, Subnet Mask, 

Gateway IP, etc. manually. 

Ethernet 

Setting 

PLC 

 
Click the node under Etherent option and the communication 

parameter setting will display. Each external controller, i.e. PLC has 

its own communication parameter setting. 
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Printer Setup tab in Configuration option 

 
HMI provides two print options, one is Hard Copy function, which can print the current 

screen and print one page one time. The other is Print Typesetting function. If Print 

Typesetting function is selected, no only the screen data but also all history data can be 

output to the printer directly. For more description of print setting method, please refer to 

the introduction of Print Typesetting function. 

Printer 

Set the connecting printer. The users can use the drop-down list to 

specify the printer. The printers in the list are sorted by 

manufacturer and the users can find the printer easily. 

Paper 

The users can use the Paper drop-down list to select the paper size. 

The only predefined paper sizes in the list are A4, Letter and 

Custom. 

Standard 

Quality Only 72 DPI option is provided. 

Margin 
The users can determine the blank space (margins). Users can specify the top, 

bottom, left and right margins and the unit is mm. 

Print Size 
When Custom is selected, Print Size option is enabled and the user can 

determine the paper size manually. The unit is mm.  

Interface 
Interface is used to set the printer interface. The users can specify the 

communication port of the printer. There are COM Port and two USB options.。 

Auto Next 

Page 

When the “Auto Next Page” option is selected, the printer will print the next 

page automatically. If the checkbox next to “Auto Next Page” is not checked, 

the printer will print continuously without breaking for different pages. 

Direction 
Direction is used to set printing orientation. There are two options: Vertical 

(Portrait) and Horizontal (Landscape). 
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Default tab in Configuration option 

 

Start up Screen 
Set the first display screen when HMI is powered on and 

started up.  

Default Format Set the default value format when creating elements. 

Default Screen 
When a new editing screen is created, the users can use 

this option to set the default screen background color. 

System Error 

Display Time 

Set the display time of system error message dialog box. 

The range is 0 ~ 5 seconds. 

Please note that if the setting value is set to 0, the 

system error message dialog box will not display on 

the screen.  

System 

Default 

Value 

System Key Use 

Mode 

Set the system key action when the users press the key. 

There are three options: Disable, Check Password and 

Unchecked Password.  

Element Font Size 
Specify the default element font size when creating an 

element. 

Element Font Name 
Specify the default element font name when creating an 

element. 

Element 

Default 

Value 

Element Font Color 
Specify the default element font color when creating an 

element. 
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Default tab in Configuration option 

Blink Time 
Specify the default element blink rate when creating an 

element. The range is between 00 ~ 5000ms。 

Element 

Default 

Value 

Scroll Size  

(if element has 

Scroll Size) 

(Customer will enter text here)  

This option is available for the element that has scroll 

function, e.g. Alarm History Table, etc. There are 20 

pixels, 30 pixels and 40 pixels three options. The default 

setting is 20 pixels. 

 

Other tab in Configuration option 

 

Enable touch cursor

When this option is enabled, the HMI mouse function is 

activated. When touching HMI screen, a mouse will 

display on the screen for the user to use.  

It will display initial 

screen at start 

When this option is enabled, the default startup screen 

will display when HMI is powered on and started up. General 
Setting 

Blue Led mode 

This option determines when the blue LED indicator will 

be lit. There are three options: none (not be lit), COM 

(during communication), Access data (when 

accessing data) and Ethernet (communicating via 

Etherent).  
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Other tab in Configuration option 

General 
Setting 

Blue Led mode 

 

In Screen Management option (Screen > Screen Management), there is a more 

detailed description for introducing how to drag the mouse to determine the 

screen saver display. 

Enable Screen 
Saver 

This option should be selected when the users want to use 

Edit Save Screen function in Screen Management option. If 

this option is not selected, even though the users have 

chosen the Edit Save Screen function, the screen saver will 

not be started. 

1. The users can use this option to enable the screen saver. 

When the setting value is 0, it indicates that the screen saver 

function is disabled. If the setting value is a non-zero value, 

it indicates that the screen saver function is enabled. When 

the users touch the screen, the screen saver function is 

ineffective. 

2. If this option is not selected, the screen saver will be 

enabled automatically when the Screen Saver Time set in 

HMI is reached. If the screen saver function is enabled, the 

users can touch the screen to disable it. 

Screen 
Saver 

Read Controller 
Address 

  

Revision May, 2010   3-235 



Chapter 3 Creating and Editing Screens  

3-236 Revision May, 2010 

Other tab in Configuration option 

Transition Time 
Set the interval time between two screen savers. 

The range is between 1 – 255 seconds. 

Screen 
Saver After screen saver 

program ends 

1. Return to Original: Return to the original screen at that 

time when the screen saver is enabled 

2. Choose screen: Specify the screen that will show after 

the screen saver program ends. 

Insert 

Press the Insert button to add a language option. 

 
As shown as the figure above, the users have to enter the 

language name and setting value. The setting value will be 

referred by the system when setting multi-language. The 

range of the setting value is between 0 ~ 255. Setting 

language name is easy for text editing. The user can press 

 button to change the flag color on the language name 

tab. 

Enable/Disable 

Delta DOP-B series HMI allows the user to edit 

multi-language screen, however the user can use this option 

to determine which languages are supported (enabled) or 

not supported (disabled) when downloading data to HMI. 

Delete 
Delete the existing language. HMI requires at least one 

language for one project. 

Modify Modify the existing language name and setting value. 

Default Set to the default language setting.  

Multi- 
Language 

Enable Edit 

Multi-Language 

User Interface 

Use this option to enable multi-language user interface. The 

user can view the multi-language display in the property 

table. The editing interface is displayed in the figure below: 
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3.11.2 Alarm Setup 

The user can set alarm by clicking Options > Alarm Setup. The alarm setup should set with 

the alarm function in element settings. HMI will execute alarm function automatically if both 

settings are all set. When the specified conditions are matched (If condition occurs in specific 

address, ON enabled or OFF enabled) after setting, HMI will display an Alarm Setup warning 

dialog box automatically. In this dialog box (Fig. 3-11-1), there are Delete, Modify, Import, 

Export and OK buttons for the user to use. 

 

Fig. 3-11-1 Alarm Setup dialog box 

 
Alarm Setup Dialog Box 

Address 

Use this option to set the alarm starting address. It provides 

512 alarms, 32 Words. Please note that the unit of this 

address is Word. If the connecting controller is Delta PLC, 

when the register type is M or S, the address must be 0 or 

the multiple of 16, i.e. M0 and M16. If the address is M1, 

system will determine it is an invalid address.  

Alarm Setting 

Scan Time 

(second)（秒） 

Set how long it takes for the HMI to scan one time. The unit 

is seconds. 
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Alarm Setup Dialog Box 

Max. Records 

Use this option to retain a specific number of records. When 

the number of records exceeds this setting value, HMI will 

delete the first record and insert the new record into the 

last address. For example, if the setting value is set to 100 

and the number of records in history exceeds 100, the first 

record is deleted and the second record will become to the 

third record, the third record will become to the forth 

record…and the 100th record will become to 99th record. 

The new record (101st record) becomes the 100th record.  

Hold 

(Non-volatile) 

Using this option saves data in SRAM when the power is 

turned off. The capacity for saving alarm data of DOP-B 

series is 4Kbytes. The battery of the SRAM provides power 

when the power is turned off. (In some DOP-B series 

models, the user can save data in USB disk or CF card when 

the power is turned off and the capacity for saving alarm 

data depends on the capacity of the USB disk or CF card.)  

CSV Format Using this option saves data in CSV format.  

Alarm Setting 

Alarm Property 

Setup 

The user can double click a row of the alarm message 

contents table to edit the alarm property and press Modify 

button to change it.  

(Please note that there are three languages tabs in Alarm 

Setup dialog box as the multi-language function is also 

supported here. The user can click the tab to edit the alarm 

message contents according to the user’s requirement.) 
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Alarm Setup Dialog Box 
The following Alarm Property Setup dialog box will display 

after double clicking the row. 

 
Message Display message when an alarm occurs. 

Color 
Display message color when an alarm 

occurs. 

Alarm Property 

Setup 

Use this option to determine if the Bit is 

On or Off when an alarm occurs. 

Alarm Property 

Setup 

Goto Screen Display screen when an alarm occurs.  

Delete Delete the alarm message contents. 

Modify 
Modify the alarm message contents. The user also can 

double click the mouse to perform this function. 

Import 
Import the Alarm Describe File into the alarm message 

contents table.  

Export 
Export the alarm message contents from HMI and convert 

them to be Alarm Describe File.  

OK End the editing of alarm message contents. 

Alarm Setting 

 

The calculation method of the size of the alarm history file is as follows: 

   BytesdBytescNbBytesaBytes   Size File Actual626  )()()()(  
 
a Time and Date Data 

b Alarm Data 

c Sampling Points  

d Data File Symbol 
 
Example: 

If Max. Records is set to 100, and the time and date is recorded, the 

required capacity for saving alarm data is: 

[(6 Bytes + 2 Bytes) × 100] + 6 Bytes= 806 Bytes 

If Max. Records is set to 100, and the time and date is not recorded, the 

required capacity for saving alarm data is: 

(2 Bytes × 100) + 6 Bytes = 206 Bytes 
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Alarm Setup Dialog Box 

Alarm Setting 

The calculation method of the size of the alarm frequency table is as 

follows: 

BytesbNaBytes  Size File Actual2  )()(  
 
a Alarm Frequency Data 

b Alarm Type 
 
Example: 

If there are five alarm types, the required capacity for saving alarm data is: 

2 Bytes × 5 = 10 Bytes 

When Alarm Moving Sign is enabled, if a fault message is detected by HMI, 

an alarm moving sign will show and run on the HMI. 

Enable Enable the alarm moving sign. 

Position 
Determine the display position of alarm moving sign.  

It can be Top or Bottom. 

Left 
Alarm message will move from right to left 

(Move to left). 

Right 
Alarm message will move from left to right 

(Move to right). 

Up 
Alarm message will move from bottom to top 

(Move to Up). 

Direction 

Down 
Alarm message will move from top to bottom 

(Move to Down). 

Moving Points 
Set the moving points every time for the alarm moving sign. 

The unit is Pixel and the range is between 1 ~ 50 points. 

Interval (ms) 
Set the interval time every time for the alarm moving sign. 

The unit is ms and the range is between 50 – 3000 ms. 

Alarm Moving 

Sign 

Background 

Color 

Set the background color of the alarm moving sign. 
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3.11.3 History Buffer Setup 

History Buffer Setup Dialog Box 

 

Add 

Pressing Add button can add a history data. A maximum of 12 history data can 

be added. After an internal memory address is entered, the following Buffer 

Properties dialog box is displayed.  

  

Read Address Set the starting address for sampling the history data. 

Buffer 

Properties 
Data Length 

(Word) 

Set the length of the Word the user wants to sample. The range 

is between 1 ~ 13 continuous words. It indicates that a 

maximum of 13 continuous words can be sampled.  
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History Buffer Setup Dialog Box 

Sample Cycle 

(ms) 

Set the sampling cycle time for reading the address (how long it 

takes to read the address one time). If the Trigger option is PLC, 

this option will be unavailable. The range of the sampling cycle 

time for one day is 0 – 86400000 ms. 

Sample 

Number 

This option is used with the Auto Stop option. If the Auto Stop 

option is selected, HMI stops recording the data after the 

numbers of records have reached the setting value of Sample 

Number option. If the Auto Stop option is not selected, when 

record number of data exceeds the setting value of Sample 

Number option, it will delete the first record and insert the new 

record into the last address.  

For example, if the setting value is set to 100 and the number of 

records in history exceeds 100, the first record will be deleted 

and the second record will become the third record, the third 

record will become the forth record…and the 100th record will 

become the 99th record. Therefore, the new record (101st 

record) will become the 100th record.  

The record data will be name as “History.dat” and the user 

needs to use the software, FlashTransfer which is attached in 

the HMI editing software, to open this file. FlashTransfer will 

sort and list the history data by record time automatically.   

Stamp Time 

and Date 

When this option is enabled, the time and date are also recorded 

during sampling operation. 

Auto Stop 
When this option is enabled, HMI stops recording when the 

maximum number of record data is reached.  

Buffer 

Properties 

Retained 

(Non-Volatile) 

Using this option can enable HMI to save sampling data in 

SRAM. The capacity for saving history data of DOP-B series is 

240 Kbytes. The battery of the SRAM provides power when the 

power is turned off. (In some DOP-B series models, the user can 

save data in USB disk or CF card when the power is turned off 

and the capacity for saving alarm data depends on the capacity 

of the USB disk or CF card.) In addition, the file name can also be 

user-defined. 

 

 

 

 

 

 

3-242 Revision May, 2010 



 Chapter 3 Creating and Editing Screens 

History Buffer Setup Dialog Box 

Retained 

(Non-Volatile) 

 

Buffer 

Properties 

Export CSV File 

The data can be exported to Windows Excel CSV files. The 

system allows the user to read max. 65536 rows and 256 

columns of data in the Windows Excel environment. If the 

sample number of the sampling data exceeds 65536, when the 

user opens Windows Excel CSV file, an error message will 

display. At this time, the user can use Notepad or other text 

editing tool to open the CSV file. 

 

This option is used with the Auto Stop option. If the Auto Stop 

option is selected, HMI stops recording the data after the 

numbers of records have reached the setting value of Sample 

Number option. If the Auto Stop option is not selected, when 

record number of data exceeds the setting value of Sample 

Number option, it will delete the first record and insert the new 

record into the last address. Then, the exported Windows Excel 

CSV file will not be sorted and listed by the record time. 
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History Buffer Setup Dialog Box 

Export CSV File 

The column name, i.e. Time, Date, Value 1 ~13 can be 

user-defined. Please refer to the following figure:  

 

Trigger 

There are two options: Timer and PLC. The sampling action is 

controlled by the Timer of the HMI or the external controller, i.e. 

PLC. When PLC option is selected, it indicates that the trigger bit 

designated by the register for sampling history buffer in the 

control block control the sampling action. Regarding the 

settings of the control block, please refer to section 3.4. 

Buffer 

Properties 

OK / Cancel 
Press OK button to save the data and exit. Press Cancel to exit 

without saving data. 

Delete Press Delete button to delete the history data. 

Modify Press Modify button to modify the history data. 

History 

Buffer 

Setup 

The calculation method of the size of the history data file is as follows: 

1. dat file 

Each history data will be saved as Hxxxx.dat. xxxx indicates that it is the xxxxth 

history data. 

  
MBytes

cNbBytesaBytes
 Size File Actual 

10241024
26




 )()()(
 

 

a Time and Date Data 

b History Data Length 

c Sampling Points 
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History Buffer Setup Dialog Box 

History 

Buffer 

Setup 

  
Extra history data will occupy the data file symbol. 
 
   BytesbNaBytes  Size File Actual8  )()(  

 

a Data File Symbol 

b Sampling Points 

 
Example:  

Suppose that the user adds two history data. The data length of the fist history 

data is set to 1 and the sample number of the first history data is set to 10000. 

The data length of the second history data is set to 2 and the sample number of 

the second history data is set to 20000. Both these two history data all have the 

time and date recorded, so the required dat file capacity for these two history 

data are:  

The file capacity of the first history data = [(6Bytes + 2Bytes) × 10000] = 

80000Bytes. 

The file capacity of the second history data = [(6Bytes + 2 × 2Bytes) × 20000] = 

200000Bytes. 

The capacity of Data File Symbol = 8Bytes × 2 = 16 Bytes 

Total require: 80000Bytes + 200000Bytes + 16Bytes = 280016Bytes = Approx. 

0.268Mbytes. 
 
2. csv file 

MBytes
BytesaN

 Size File Actual 
10241024

240



)(

 

 

a Sampling Points 

 
Example:  

Suppose that the user adds two history data. The data length of the fist history 

data is set to 1 and the sample number of the first history data is set to 10000. 

The data length of the second history data is set to 2 and the sample number of 

the second history data is set to 20000. Both these two history data all have the 

time and date recorded, so the required csv file capacity for these two history 

data are:  

The file capacity of the first history data = 10000 × 240Bytes = 2400000Bytes. 

The file capacity of the second history data = 20000 × 240Bytes = 

4800000Bytes. 

Total require: 2400000Bytes + 4800000Bytes = 7200000Bytes = Approx. 

6.8Mbytes. 
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3.11.4 Password Setting 

This function sets the password table and determines the security access level that can 

change users passwords.. There are 1 ~ 7 password security levels: 

Level 0: No security. No protection. Everyone can use this element. 

Level 1: Low security level. The user whose security level is equal to and higher than Level 1 

can use this element.  

Level 4: Medium security level. The user whose security level is equal to and higher than Level 

4 can use this element. 

Level 7: High security level. The user whose security level is equal to and higher than Level 7 

can use this element. 

The user’s highest security level, i.e. the password protection for the file (project) can not be 

set here. To set the highest priority password, click Options > Configuration > General > 

Security option. 

The password setting table can also be defined by using Screen Editor software program. The 

user can create a keypad element to edit and modify the password table. 

 

       
The password can be a 8-digit password that contains 0 ~ F characters regardless of 

uppercase/lowercase. 
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3.11.5 Tag Table 

Tag table is used to replace the specific address with the user-defined words or characters. 

For example, if the user wants to replace PLC address 1@Y0 with the word “OS”, just define it 

in Tag Table option in advance.  

Tag Table Dialog Box 

 
Open Click  to open a Tag file and import it into HMI. 

Save 
Click  to save the settings and changes made in Tag Table dialog box as Tag 

file. 

Add 

Select the Tag type first, Internal Memory and Base Port (If the user has three or 

above communication ports, the user will see Link2, Link3 …and vise versa). 

Then, click Add icon  to add and define Tag data. 

Delete 
The user can use the mouse to select one row of the Tag table, and then click 

Delete icon  button to delete it.  

OK Press OK button to save the settings and exit. 
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3.11.6 Print Typesetting 

This function provides more efficient print layout management function. Please refer to the 

descriptions and examples on the following pages. 

  

Print Function 

 Printer setup 

1. DOP-B series HMI supports the printer function via USB interface. 

2. Select the connecting printer.  

The user can click File > New to get into the New Project dialog box and select 

the printer using the Printer drop-down list in New Project dialog box. Or click 

Options > Configuration > Printer Setup to select a printer.  

 

3. Printer Setup Configuration 

Select Options > Configuration > Printer Setup to open the Printer Setup tab. 

Use Printer Setup tab to configure the settings of printer, paper, quality and 

margin, etc. 

3-248 Revision May, 2010 



 Chapter 3 Creating and Editing Screens 

 

 

Print Typesetting Function 

The user can print many pages one time and arrange the layout of the print screen by using 

Print Typesetting function. The history data also can be printed at the same time. Please pay 

particular attention to the following notes when using Print Typesetting function. 

1. The screen cannot be designated to print typesetting screen when switching HMI 

screen. 

2. Print typesetting screen cannot be the default HMI screen. 

3. Print typesetting screen cannot be the base screen. 

4. Print typesetting screen cannot be the screen saver. 

5. Print typesetting screen cannot be the sub-screen.  
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 Create a Printed Report 

Step 1. Create a new screen by selecting Screen > New Screen and set it as Apply 

Print Screen in Screen Properties tab (Screen > Screen Properties). Then, click 

Options > Print Typesetting and drag the mouse to decide which screen 

needs to be typeset. The selected screens will become the print screen 

automatically. 

       

Step 2. Create the element that the user wants to print. For example, if the user wants 

to print a Historical Trend Graph and a X-Y Chart, the user needs to create a 

Historical Trend Graph (Element > Sampling > Historical Trend Graph) and a 

X-Y Chart (Element > Curve > X-Y Chart) first and then set their properties in 

the Property table. The Property table provides the element property setting for 

each element. For information about each element property settings, refer to 

section 3.8. 

 

Step 3. Choose Yes or No using the Print Successive Data drop-down list to determine 

whether the Print Successive Data function is selected or not. When Yes is 

selected, it indicates that Print Successive Data function is enabled, and all the 

sampling records and data for the element will be printed.  

3-250 Revision May, 2010 



 Chapter 3 Creating and Editing Screens 

 
 

 Print Screen Layout and Output 

Step 1. Select Options > Print Typesetting. Drag the mouse to decide which screen 

needs to be typeset and printed. The screens on the left are all created screens 

and the screens on the right are the selected screens. If a General View Screen 

is dragged to the right, it will become Apply Print Screen (Screen Properties) 

automatically.  
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Step 2. Right click the mouse or use the function key to create a Report List button on 

a General View Screen. Use this Report List button to enable the print 

function. 

Step 3. Set the properties of the Report List option. The Report Device can be USB disk 

or Printer. If the user select USB disk, the data will not be printed out, but the 

data will be saved in USB disk. 

 
 

Step 4. Connect HMI to the printer and press Report List button, and the data will be 

printed out. 
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Hard Copy Function 

This function is available only when the screen is a General View Screen. If HMI 

detects the Print Typesetting function is already set for the editing screen, the Hard 

Copy function will be ineffective. 

Step 1. Set the Hard Copy Region in Screen Properties dialog box. 

 

Step 2. Enable Print Function 

Create a Report List button on a General View Screen. Use this Report List 

button to enable the print function. 

Step 3. Connect HMI to the printer and press Report List button, and the printer will 

start to print data out.  
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3.11.7 Recipe 

The Recipe function provides the controller a convenient parameter input method. The 

user can transmit the designated parameter to the controller by using HMI recipe after 

finishing editing recipe. Bread making is an example. When making different bread, baking 

time control is very important. The user can use Recipe function to meet the different time 

requirements for making different bread. The purpose of this function is to reduce the 

loading of the controller and make the register of the controller to be more flexible in use. 

Recipe function provides an easy and quick parameter input method for the connected 

controller. When completing the recipe editing, the user just needs to use the recipe 

register in control block and the designated corresponding parameters can be transmitted 

into the internal memory addresses of the controller. 

The recipe can be set and modified through the recipe dialog box and can be saved and 

used independently without the project, allowing recipes to be used for all brands of 

models. In addition, the recipes can be saved in Windows Excel CSV file for the user to edit 

recipes more quickly. Before using a recipe, the user should enable the recipe function first 

by selecting Options > Recipe. After the recipe function is enabled, the Recipe Setup 

dialog box pops up and the user can start to edit the recipe. 

 

Fig. 3-11-2 Recipe Setup dialog box 

Recipe Setup dialog box 

Enable Recipe 

When the check box next to Enable Recipe is checked, the recipe function 

is enabled. If the users do not enable this function, the users cannot do 

this function even if the users have downloaded recipe data.  
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Recipe Setup dialog box 

Recipe 

Retained 

(Non-volatile) 

Using this option can enable HMI to save recipe data in SRAM when the 

power is turned off.  

The user can input the starting address of recipe data here. It can accept 

the address in PLC input format and internal memory format. (Please note 

that if the recipe address is set to D4095, the recipe address plus the data 

length cannot exceed D4095.) The user also can click  button to get 

the following address input dialog box to input the starting address. 

Address 

 

Length 

Set the recipe length. The unit is Word and it should be set to more than 0. 

Otherwise, the following dialog box will display on the screen. 

 

Grroup 

Set group number of recipe. It is convenient for the user to use recipe by 

switching. The group number should be set to more than 0. Otherwise, 

the following dialog box shown as Fig. 2.8.14 will display on the screen. 
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Recipe Setup dialog box 

After setting length and group number of recipe, the user can click Input 

button to edit the recipe data. The memory size for recipe is limited and 

the memory size for recipe is 64K. It indicates that the total recipe size 

should be less than 64K (The number of Length x Groups should be less 

than 65536). If the total recipe size exceeds the limit, the user will see a 

warning message displayed on the screen. 

 Input 

The above-mentioned memory indicates the non-volatile memory of HMI, 

i.e. SRAM. Some DOP series HMI, which supports USB host function, allows 

the user to use more recipe data via this USB host interface. Supporting 

USB host function means it has a built-in USB host interface. The user can 

connect HMI to a USB disk via this USB host interface and input more 

recipe data. However, there is still a limit for the input value of recipe 

length and groups. When Recipe Retained (non-volatile area) is selected 

as USB disk, the length x groups should be less than 4096K (The number 

of Length x Groups should be less than 4194304). The user can change 

the non-volatile data location by clicking Options > Configuration > 

General.  

Open 

The user can load recipe data by clicking Open button. The loaded recipes 

do not contain the starting address of recipes. Therefore, regardless of 

which brand of the controller connecting to HMI, they all can use the same 

recipe file. There are two recipe file types provided in Delta DOP series 

HMI, one is 16bits recipe file (*.rcp) and the other is 32bits recipe file 

(*.csv) that can be opened in Windows® Excel environment. Please pay 

close attention to the format of recipe file and make sure that the recipe 

file is a 16bits data or a 32bits data. Do not select the incorrect data 

format; otherwise the program will not work normally.  

Save 

When Save button is pressed, HMI will save the editing recipe data as a 

file, click When saving the recipe file, the starting address will not be 

saved. This lets the user use the same recipe file in the different PLC 

brand. The user can save the recipe file as Windows Excel CSV file. 

Reset 

When Reset button is pressed, all related recipe settings and input recipe 

data are deleted. There is no other method to retrieve the recipe except 

for using Import function to import the saved recipe data again. 
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Recipe Setup dialog box 

Clear 

When Clear button is pressed, all input recipe is cleared to 0 (zero).  

 

Print 
When Print button is pressed, all recipe data on the current screen will be 

printed out. 

OK  

After inputting the recipe data, the users can click OK button to save the 

recipe data for transmitting or modifying. At the same time, HMI will 

check the validity of all input recipe data. If there is invalid input recipe 

data value, the OK function is not executed successfully. For example, in 

the figure below, HMI found an error and a warning message dialog box 

displays on the screen as no input address was entered.  

 

Cancel 
When Cancel button is pressed, HMI will exit the Recipe Setup dialog box 

without saving. 
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3.11.8 32 bits Recipe 

32 bits recipe function provides the user to save 32 bits data. The data format includes 

Signed Decimal, Unsigned Decimal and Floating (The total of Integral and fractional digits 

cannot exceed 7 digits). To enable this function, the user can click Options > 32 bits 

recipe.  

 

Fig. 3-11-3 32 bits recipe dialog box 

 

32 bits recipe dialog box 

 

New: Create a new 32 bits floating recipe file 

Press  to create a new 32 bits floating recipe. After clicking , a 32 

bits recipe setup dialog box will display and the user can use it to set the 

settings of a 32 bits recipe. The user can determine the recipe storage 

address, the length and group number of the recipe, the memory format, 

and the integer & fractional digit number of the recipe data. There are three 

kinds of memory format provided, including Unsigned Decimal, Signed 

Decimal and Floating. Integer and fractional digit number cannot be 

selected when the memory format is set to Unsigned Decimal and Signed 

Decimal. These two options are only available when the memory format is 

set to Floating. But the total of the Integer and fractional digit number 

cannot exceed 7 digits. For the number of the 32 bits recipe, up to 255 

recipes can be set in a 32 bits recipe file. 
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32 bits recipe dialog box 

   

 

 

Open: Open a 32 bits recipe file 

Press  to open a 32 bits recipe file. The file format can be Recipe 32 bits 

File (*.rcp) and Windows Excel CSV File (*.csv). Please pay close attention to 

the format of recipe file and make sure that the recipe file is a 16bits data or 

a 32bits data. Do not select the incorrect data format; otherwise the 

program will not work normally. 
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32 bits recipe dialog box 

 

 

 

Save: Save a 32 bits recipe file 

Press  to save a 32 bits recipe file. The default file format of a 32 bits 

recipe file is a Windows Excel CSV file (*.csv). 

 

 

Delete: Delete a 32 bits recipe 

Press  to delete unnecessary 32 bits recipe. 

 
Recipe Storage Address :  

Display the storage address of a 32 bits recipe. 

 

Setup: 32 bits recipe setup 

When clicking , a 32 bits recipe setup dialog box will display and the 

user can use it to change the settings of a 32 bits recipe. 
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32 bits recipe dialog box 

Enable: Enable 32 bits recipe function  

This function should be selected when the user wants to use 32 bits recipe 

function. The non-volatile area location is the same as the location of 16 bits 

recipes.  
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3.11.9 Picture Bank 

The user can use this function to import various pictures to enrich the screens selection. 

Click Options > Picture Bank to execute this function.  

Picture Bank dialog box 

 

Click the Picture Bank option to browse all pictures saved in Picture Bank. When one picture 

is selected, the user can see the picture in the preview window. Double left-clicking the 

mouse on the selected picture will display the picture in an actual size view.  

New 

Create a new picture bank. After clicking New icon, the New 

Picture Bank dialog box is displayed on the screen. 

 
Install Open a picture bank file (*.pib file). 

Uninstall 
Uninstall the selected picture bank. The uninstalled picture bank 

will be moved to Recycle Bin. 

Import 

Import pictures into the designated picture bank. The formats of 

the pictures in the picture bank can be BMP, JPG, GIF and ICON 

pictures. Please note that if the imported GIF file is an animation 

file, the imported animation files will be divided into several 

segments. When selecting this function, the dialog box shown 

will be displayed.  
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Picture Bank dialog box 

Import 

The users can then convert the picture color in advance to speed 

the compile time or choose No changed option to retain the 

original color.  

 

Update 

After editing the picture every time (execute Inverse, Grayscale, 

etc. functions), the user needs to click Update button so that the 

the status of the picture can be changed and updated.  

Export Export pictures in BMP format from the picture bank. 

Inverse 
Inverse the picture color - 

negative effect  

Grayscale 
Convert the color picture to 256 

color grayscale  

Horizontal Mirror Horizontal mirror effect 
 

Vertical Mirror Vertical mirror effect 
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Picture Bank dialog box 

Shortcut Menu 

The users can right-click the mouse to display a shortcut menu 

shown on the figure below. This shortcut menu shows a list of 

commands relevant to the picture bank option. This allows the 

users to manage the pictures in the picture bank more quickly 

and efficiently.  
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3.11.10 Text Bank 

Input common or frequently used text and terms into Text Bank. The user can select the 

text from the Text Bank and enter them on the element more easily and quickly if 

necessary.  

Text Bank dialog box 

 

Add 

Press the Add button to add the text into the Text Bank. The multi-language 

editing is supported in the Text Bank option. The user can input the text or 

terms in different language and save them in the Text Bank.  

The multi-language font can also be set at the same time.  

Delete Press Delete button to remove the input text or terms in Text Bank.  

Open Press Open button to open and import the text or terms into Text Bank.  

Save Press Save button to save and export the text file.  

Close Press Close button to close and exit the text bank dialog box. 
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3.11.11 Submacro 

Use this option to edit sub-macro and to be called by other Macros. For the Macro function, 

please refer to section 3.14. 

 

3.11.12 Initial Macro 

Use this option to edit initial macro. The initial macro will be executed automatically after the 

power is applied to HMI (power on). For the Macro function, please refer to section 3.14. 

 

3.11.13 Background Macro 

Use this option to edit background macro. For the Macro function, please refer to section 

3.14. 

 

3.11.14 Clock Macro 

Use this option to edit clock macro. After HMI is turned on starting initial setup will run and 

the clock macro will be executed automatically by the clock setting time. For the Macro 

function, please refer to section 3.14.  
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3.11.15 Environment 

Use this option to complete the environment settings of Screen Editor. 

Environment Dialog Box 

 

System 

Path 

Set the location where HMI saves the system files, including some system 

reference data and dynamic link library (*.dll) files. To avoid a system error and 

failure to find the file, we recommend the users not change this setting if it is not 

necessary. (This option is disabled by default.)  

Output 

Path 

Set the location where HMI saves the output file after compile operation. Some 

functions, such as on-line simulation, off-line simulation, file download and 

upload all refer to the files in this location. To avoid a system error and failure to 

find the file, we recommend the users not change this setting if it is not necessary. 

Toolbars / 

Windows 

Set the option to display or not display toolbars or docking 

windows. 

Language 
Choose English, Turkish, Traditional Chinese or Simplified 

Chinese from the Language drop-down list.  

Upload / Download 
Determines the communication interface for upload and 

download. It can be USB, Ethernet or PC COM Port.  

Options 

Auto Saving… Time 

Interval 

When this option is selected, HMI will automatically save the 

file every specified number of minutes. The unit is M (minute) 

and the setting range is between 0M ~ 120M. 
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Environment Dialog Box 

Auto open last file 

when starting 

ScrEditor 

When this option is selected, HMI will automatically open the 

last saved file every time when the user starts HMI. 

Center Drawing 

Area 

When this option is selected, the editing screen will be placed 

in the center position.  

 

Include picture data 

for uploading 

If this option is selected, all pictures are also uploaded when 

the HMI upload function is enabled. All uploaded pictures are 

saved in a file named as _LocalTemp01.pib. The “Picture 

Bank Name” and the “Picture Name” (set in Property docking 

window) of the editing elements will refer to and link to this 

file. If HMI ends the editing abnormally, the file name will be 

named as _LocalTemp02.pib, _LocalTemp03.pib …, and 

vise versa when uploading is executed the next time. The last 

two numbers at the end of the file name will increase 

progressively. 

Auto convert input 

address to tag name 

For example, if the user wants to replace PLC address 1@Y0 

with the word “OS”, define it in Tag Table option in advance. 

When this option is selected, HMI will automatically convert 

input address 1@Y0 to the word “OS”.。 

Options 

Auto reboot after 

firmware upgrading 

When this option is selected, HMI will automatically restart 

(power off and then on) after the firmware upgrading is 

completed. 

Driver 
Reinstall HMI USB Drive: Press it to reinstall the HMI USB driver 

Uninstall HMI USB Drive: Press it to uninstall the HMI USB driver  

OK 
Press OK button to save the modified settings and exit the Environment dialog 

box. 

Cancel Press Cancel button to exit the Environment dialog box without saving. 
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3.12 Menu Bar and Toolbar (Window) 

 

 

3.12.1 Close Window 

It is used to hide the current window, NOT exit the current window. The users can execute 

this function by clicking Window > Close Window. If the user wants to display the hidden 

window, please click Screen > Open Screen to open an old screen.  

 

3.12.2 Close All Windows 

It is used to hide all windows, NOT exit all windows. The user can execute this function by 

clicking Window > Close All Windows. If the user wants to display the hidden window, 

please click Screen > Open Screen to open old screens.  

 

3.12.3 Next Window 

It is used to switch the current window to the next window. If the current window is the last 

window, the current window will not be changed even if this function is executed.  

 

3.12.4 Previous Window 

It is used to switch the current window to the previous window. If the current window is the 

first window, the current window will not be changed even if this function is executed.  
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3.12.5 Cascade 

Cascade display. Display all editing windows so that they overlap. The title bar of each 

window is visible but only the top window is fully visible. The user can execute this function 

by clicking Window > Cascade. The opened windows are displayed in an overlapped pattern 

as shown as Fig. 3-12-1.  

 
Fig. 3-12-1 Screen display after choosing Cascade command 
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3.12.6 Title Horizontal 

Display all editing windows from top to bottom. The user can execute this function by 

clicking Window > Title Horizontal. The opened windows are displayed horizontally as 

shown as Fig. 3-12-2.  

 
Fig. 3-12-2 Screen display after choosing Title Horizontal command 
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3.12.7 Title Vertical 

Display all editing windows from left to right. The user can execute this function by clicking 

Window > Title Vertical. The opened windows are displayed vertically as shown as Fig. 

3-12-3.  

 
Fig. 3-12-3 Screen display after choosing Title Vertical command 
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3.12.8 Window Summary 

ScrEdit shows a list of all opened screens at the bottom of “Window” pull-down menu for 

quick access. Just click the file name to open the file and view the screen directly (Fig. 3-12-4). 

 
Fig. 3-12-4 Window Summary 
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3.13 Menu Bar and Toolbar (Help) 

 

3.13.1 Help 

Display the version information of Screen Editor and the firmware information of HMI (Fig. 

3-13-5). 

 
Fig. 3-13-1 Screen Editor Version 
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3.14 Macro Function 

Delta DOP-B series HMI provides various kinds of macro commands, including Arithmetic, 

Logical, Data transfer, Data conversion, Comparison, Flow control, Bit setting, Communication 

(COM port) and drawing, etc. for user’s selection (Fig. 3.14.1).  

 
Fig. 3-14-1 Macro Commands 

 

There are many advantages of using macro commands, such as: 

1. It can optimize the screen data.  

2. It can reduce the PLC program editing efficiently. 

3. It can overcome the limit on the hardware and software design. 

Therefore, Macro is a very convenient function for the HMI user to use. After editing a Macro, 

you can test the Macro validity via either an on-line or off-line simulation on the PC before 

downloading the results to HMI.  

 

3.14.1 Macro Type 

There are eleven kinds of macro commands and they are divided into four categories. 

Please refer to the following: 

1. On / Off Macro: It is provided for each Bit element that can be input, such as button 

element, i.e. Maintained and Momentary button. 

2. Before / After Execute Macro: It is provided for all elements, such as numeric / character 

entry element and all button elements (including system button). 

3. Screen Open / Screen Close / Cycle Macro: Use screen as a unit. Each screen has an 

individual screen macro. 

4. Initial / Background / Clock / Sub Macro: Use system as a unit. Each project, i.e. each 

program, has its individual screen macro. 
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Table 3-14-1 Macro Command Table 

Macro Name Descriptions 

On Macro 

The user can use the On Macro for each specific button element (Bit). 

It is called the On Macro because the Macro is executed once upon 

the button element (Bit) changing from OFF to ON.  

Off Macro 

The user can use the Off Macro for each specific button element 

(Bit). It is called the Off Macro because the Macro is executed once 

upon the button element (Bit) changing from ON to OFF. 

Before Execute 

Macro 

The user can use the Before Execute Macro for all button elements 

and numeric / character entry element. One element has one Before 

Execute Macro. 

After Execute Macro 

The user can use the After Execute Macro for all button elements 

and numeric / character entry element. One element has one After 

Execute Macro. 

Screen Open Macro 

The Screen Open Macro will be executed only ONCE when the user 

open a screen (or switch to a new screen) and the screen elements 

will not be displayed until after the Screen Open Macro has 

completed execution. Therefore, it is important that the user pay 

close attention when designing the Screen Open Macro to avoid 

infinite loops (programs that cannot be ended) as it may cause a 

system delay or even prevent executing the screen’s elements 

permanently. Writing long macros is not recommended and should 

be avoided if at all possible. Pay close attention on using loops and 

make sure to test the Macro with on-line/off-line simulation before 

downloading to HMI to ensure expected performance and operation. 

Screen Close Macro 

The Screen Close Macro will be executed only ONCE when the user 

close the screen and no other macros will be executed until the 

Screen Close Macro is completed. Therefore, it is important that the 

user pay close attention when designing the Screen Close Macro to 

avoid infinite loops (programs that cannot be ended) as it may cause 

a system delay.  

Screen Cycle Macro 

The macro will be executed continuously when the screen is open. 

Therefore, writing long macros is not recommended and should be 

avoided for this type of macro. 

Initial Macro 

There is only one Initial Macro in a program and it is executed just 

prior to the startup screen being displayed. This macro is very useful 

when setting initial values in the HMi or in a PLC.  
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Macro Name Descriptions 

Background Macro 

The purpose of the Background Macro is to execute one or more 

commands simultaneously since it runs in a separate task. If another 

Macro is executed, such as the Cycle Macro, it will not have any 

influence on the Background Macro although they appear to be 

executed almost simultaneously. This type of macro does not 

require to be run in a loop since it will operate continuously. 

Clock Macro 

The Clock Macro will be executed continuously, finish the executed 

ONCE, and then will be executed again at the Clock cycle time set in 

the Standard tab of the Configuration window under Options. This 

type of macro is similar to a Cycle Macro therefore, writing long 

macros is not recommended and should be avoided.  

Sub-macro 

There are 512 sub-macros for editing that can be used to write 

repeated actions or functions to save macro editing time. To call a 

sub-macro simply, use a CALL command from within a macro; an 

example would be CALL 1 to call the first sub-macro. 
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3.14.1.1 On Macro 

This macro is attached to a button element. The user can use On Macro for each 

specific button (Bit). It is called the On Macro because the Macro is executed once upon 

the button element (Bit) changing from OFF to ON. When the button is set to be ON, ON 

Macro will be executed ONCE. After execution, this macro will not be executed until 

the button is set to be ON again. However, On Macro only can be executed when the 

corresponding Bit for the button is triggered to be ON through the action of pressing 

the button, i.e. the Bit is set to be ON and the pressed button is ON also. ON Macro will 

not be executed if the Bit is set to be ON only.  

If there is a Monmentary button created on the screen and On Macro is used, when the 

button is pressed, the procedure is as follows:  

 
Monmentary 

Button  

 
When the button is pressed 

(Set to be ON) 

Monmentary 
Button is ON 

Execute ON 
Macro 

Monmentary 
Button is ON 

When the button is pressed 
(Set to be OFF) 

 

 

 

 

 

 

 

 

 
Set to be ON again 
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3.14.1.2 Off Macro 

This macro is attached to a button element. The user can use Off Macro for each 

specific button (Bit). Same as ON Macro, Off Macro is started via setting this button. 

When the button is set to be OFF, Off macro will be executed ONCE. After execution, 

this macro will not be executed until the button is set to be OFF again. However, OFF 

Macro only can be executed when the corresponding Bit for the button is triggered to 

be OFF through the action of pressing the button, i.e. the Bit is set to be OFF and the 

pressed button is OFF also. OFF Macro will not be executed if the Bit is set to be OFF 

only.  

If there is a Monmentary button created on the screen and On Macro is used, when the 

button is pressed, the procedure is as follows:  

 
Monmentary 

Button  

 
When the button is pressed 

(Set to be ON) 

Monmentary 
Button is ON 

Monmentary 
Button is OFF 

Execute OFF 
Macro

When the button is pressed 
(Set to be OFF) 

 

 

 

 

 

 

 

 

 
Set to be OFF again 
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3.14.1.3 Before Execute Macro 

This macro is attached to a button element or numeric / character entry element. One 

element has one Before Execute Macro. The operation is that when the button element 

is pressed, the sysem will execute the command of this macro first and then perform 

the operation of this button. But, if the state of the button is not triggered by pressing 

the button (via macro or external signal), the command of this macro will not be 

executed. 

If there is a Monmentary button or numeric entry element created on the screen and 

Before Execute Macro is used, when the button is pressed, the procedure is as follows:  

 

 
Monmentary button or numeric entry element 

When the button is pressed 
(Set to be ON) or when the 
value of the numeric entry 

element is entered 

Monmentary button is ON or  
Numeric Entry Element is written 

Perform Before Execute Macro 

Monmentary button is OFF or  
Numeric Entry Element is written 

When the button is pressed 
(Set to be OFF) or when the 
value of the numeric entry 

element is entered Set to be ON or  

Perform Before Execute Macro Enter the value again 
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3.14.1.4 After Execute Macro 

This macro is attached to a button element or numeric / character entry element. One 

element has one After Execute Macro. The operation is that when the button element is 

pressed, the sysem will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not triggered by pressing the 

button (via macro or external signal), the command of this macro will not be executed. 

If there is a Monmentary button or numeric entry element created on the screen and 

Before Execute Macro is used, when the button is pressed, the procedure is as follows:  

 

 
Monmentary button or numeric entry element 

When the button is pressed 
(Set to be ON) or when the 
value of the numeric entry 

element is entered 

Perform After Execute Macro 

Monmentary button is ON or  
Numeric Entry Element is written 

Monmentary button is OFF or  
Numeric Entry Element is written 

When the button is pressed 
(Set to be OFF) or when the 
value of the numeric entry 

element is entered 

Perform After Execute Macro 

 

 

 

 

 

 

 

 

 

 

 

 

 Set to be ON or  
 Enter the value again 
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3.14.1.5 Screen Open Macro 

The user can use Screen Open Macro to open each screen. Each screen has a Screen 

Open Macro. Screen Open Macro will only be executed ONCE when the user open a 

screen or switch to a new screen. The screen elements will be displayed and executed 

after finishing executing Screen Open Macro.  
 

Open a New Screen 

Execute  
Screen Open Macro 

After Screen Open Macro 
is executed. 

Perform other ations on 
the screen 

 

 

 

 

 

 Open a screen or 
switch to a new 

screen 
 

 

 

 

 

3.14.1.6 Screen Close Macro 

The user can use Screen Close Macro to close each screen. Each screen has a Screen 

Close Macro. Screen Close Macro will only be executed ONCE when the user close a 

screen or switch to a new screen. The same as Screen Open Macro, the screen elements 

on new screen will be displayed and executed after finishing executing Screen Close 

Macro.  
 

Close the screen 

Execute  
Screen Close Macro 

Open a New Screen 

After Screen Close 
Macro is executed 

Perform other ations on 
the screen 

 

 

 

 

 

 

 

Execute  
Screen Open Macro 

 

 

 After Screen Open 
Macro is executed 

Open a screen or 
switch to a new 

screen 
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3.14.1.7 Screen Cycle Macro 

The user can use Screen Cycle Macro to cycle each screen. Each screen has a Screen 

Cycle Macro and it can be executed repeatedly for a specified period of cycle time. The 

user can set the Macro Cycle Delay Time, i.e. the delay time every time between the end 

and restart of Screen Cycle Macro in Screen Properties dialog box (See Fig. 3-14-2). The 

system default setting is 100ms.  

 
Fig. 3-14-2 Macro Cycle Delay Time 

 

 

 

 

 

 

 

 

 

Open the Screen (Execute Screen Open Macro) 

Execute Screen Cycle Macro 

Set cycle delay time to 100ms 
 (This setting can be user-defined) 

After Screen Close 
Macro is executed 

Open a screen or 
switch to a new 

screen 

After Screen Open 
Macro is executed 

 

Perform other ations  

on the screen 

When the user wants to 
close or switch the screen 

Repeat After Screen Cycle Macro 
is executed 

Close the Screen (Execute Screen Close Macro) 
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3.14.1.8 Initial Macro 

There is only one initial Macro in a program. It is executed first at the beginning of a 

program. So, the user can preset some necessary initial values in this macro to omit 

step-by-step settings and also control initial settings to avoid unexpected problem by 

an unknown initial value. If the user needs to setup any special setting in the special 

address of the external controller, the user can use initial macro to set it. It saves time 

with a well-designed initial macro.  

 
When HMI is powered on or when the user exits 
the system menu to activate the Screen Editor 

(Execute Initial Macro) 

 

 

 
Execute Initial Macro 

 

After Screen Open Macro 
is executed 

Execute Open Macro  

 

 

 
Open the Screen  

 

3.14.1.9 Background Macro 

There is only one background Macro in a program. It always exists in a program and is 

executed continuously like background during HMI operation. But the execution of a 

Background Macro is to execute one or more commands at a time, not finish the 

execution ONCE. After the last macro command is executed, the system will start to 

execute this macro again from the first macro command. The user can click Options > 

Configuration > General tab and use Background macro update cycle option to 

determine the lines of the background macro commands (see Figure 3-14-3) 

 
Fig. 3-14-3 Background macro update cycle 
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For example, suppose that there are 25 element addresses on the screen and 

Background is used (5 lines of macro commands), if the setting value of background 

macro update cycle is set to 2, when background macro is executed, HMI will first read 

25 element addresses and then execute 2 lines of background macro in sequence.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Read 25 element addresses 

Execute 1st and 2nd line commands 
of Background Macro 

Read 25 element addresses 

After execution 

After read operation 

After read operation 

Execute 5th line commands of 
Background Macro 

After read operation

After execution 

Execute 3rd and 4th line commands 
of Background Macro 

Read 25 element addresses 

After execution 

 Execute  
Background Macro 

again 
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3.14.1.10 Clock Macro 

There is only an Clock Macro in a program or a machine. Similar to Screen Cycle Macro, 

it can be executed repeatedly for a specified period of preset clock time. The user can 

set Clock Macro Delay Time, i.e. the delay time every time between the end and the 

restart of Clock Macro in General tab of Configuration dialog box (See Fig. 3-14-4). 

The system default setting is 100ms.  

 

Fig. 3-14-4 Clock Macro Delay Time option 

 

 

 

 

 

 

 

 

 

Power on the HMI 

Execute Clock Macro 

Set cycle delay time to 100ms 
(This setting can be user-defined) 

After Clock Macro is 
executed 

Power on the HMI 
iagain 

Power off the HMI 

Repeat 
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3.14.1.11 Sub-Macro 

Each project (Screen Editor program) is capable of containing 512 sub-macros which is 

labeled from 1 to 512 by default (Fig. 3-14-5, Fig. 3-14-6). Sub-macro is similar to the 

subroutine in the in program. The user can write repeated action or function in 

sub-macro to save macro editing time and easy maintain. For example, a function is 

written named sub-macro 2, the user only needs to write “CALL 2” in Macro whenever it 

is used. In the sub-macro program, the user can also call other submacro. However, in 

order to keep sufficient memory, the levels for CALL sub-macro must be less than 6 

levels. In addition, as the sub-macro are named 1 through 512 by default, when the 

user wants to change the name of the sub-macro to a more user-friendly description, 

the user can rename the sub-macro freely.  

 
Number of the Sub-macro Name of the Sub-macro 

 

         

             Fig. 3-14-5 Sub-macro Screen I             Fig. 3-14-6 Sub-macro Screen II 

 

To call a specific sub-macro, a CALL command is used.  

For example: 

Create a Screen Open Macro command and a Sub-Macro first (Fig.3-14-7, Fig. 3-14-8). 

The execution process of the Screen Open Macro will be shown as the Fig. 3-14-9. 

          

Fig. 3-14-7 Screen Open Macro             Fig. 3-14-8 Sub-Macro 1 
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$0 = 10  

 

$1 = 1 

CALL 1($0 = 0) 

 

 

 

 

 

 

 

  Fig. 3-14-9 Execution process of Screen Open Macro 

 

When CALL 1 is executed, it means that Sub-Macro 1 is called and executed. After 

executing Sub-Macro, the system will continue to execute Sceen Open Macro till it ends. 

At this time, 0 = 0 and $1 = 1. 

 

NOTE   

When editing any macros, please pay close attention to the logicality of macro command, 

especially the usage of loop and program. If the user write an infinite loop (i.e. program cannot 

be ended) in the macro or write a program which will not be executed until some certain 

condition is satisfied, it may make HMI work abnormally. Therefore, it is recommended that the 

user should use simulation function to verify the macro and check if HMI operation is correct or 

not after macro editing is completed. 
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3.14.2 Macro Editing 

3.14.2.1 Macro Editing Widow and Toolbar 

After choosing the desired Macro command from the menu bar, the user can start 

editing the Macro by clicking any line in the editing window shown in Fig. 3-14-10. 

Please note that Each macro is capable of containing 512 lines of code with a 

maximum of 128 characters per line.  

 
Fig. 3-14-10 Macro Editing Window 

 

he user can also use the icons on the toolbar (Fig. 3-14-11) for Macro editing.  

 

 

T

 

 

 

Fig. 3-14-11 M cro Toolbar a

 

 

 

 

 

 

 

 

 

 

Macro Editing Area 

Open Macro 

Save Macro 

Cut 
Syntax Check 

Update 

Copy 

Paste 

Wizard 
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Open 

 This command opens macro files.  

The necting to different external controllers. This  user can open these files when con

reduces the time to edit macros. To open a macro file, click the Open icon and the the 

following dialog box will show up (Fig. 3-14-12).  

 

Fig. 3-14-12 Open Macro 

Save 

 This command saves macro files.  

The fference between the new file and others.  user can give a new name to tell the di

This helps the user to backup and save reinput time of other macro commands (Fig. 

3-14-13). 

 
Fig. 3-14-13 Save Macro 
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Cut 

 This command cuts macro files.  

The ute this function. 

 

 user can also press Ctrl+X to exec

Copy 

 This command copies macro files. 

The te this function. 

 

 user can also press Ctrl+C to execu

Paste 

 This command pastes macro files. 

The te this function.  user can also press Ctrl+V to execu

 

Wizard 

 This command shows the Macro Command Dialog Box.  

Aft ill pop up. The user can er clicking on the Wizard icon and the following dialog box w

use this dialog box to edit macro. If an address of the external controller is used in the 

macro, the address will be in brackets to distinguish it from internal memory. 

 

The user can enter the macro commands directly or click on the Command button to 

choose the command needed for the macro. For more details on macro commands, 

refer to the following section 3.14.2.2. 
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Syntax Check 

 This command examines if the macro syntax is correct. 

The x is correct or not. If the  user can use this function to examine if the macro synta

macro syntax is in error, the following error message dialog box will pop up to alert 

the user. At this time, please examine the macro syntax again.  

 

Please note that the operation of Syntax Check is different than the compile operation 

of macro files. The compile operation of macro file is performed when the compile 

operation of HMI program is executed. The compile operation of the macro file and 

HMI program is executed simultaneously.  

 

Update 

 This command updates macro files. 

The date button is not pressed after editing. This 

 screen.  

 modification will not be updated if Up

gives user a second chance to decide if modify the macros or not. Therefore, if the user 

forgets to press Update button after editing, the user should re-do it again. 

When Update button is pressed, the following dialog box will show up on the

 

After Yes button is pressed, the system will examine if the macr  syntax is correct. If o

the macro syntax is correct, the update function will be executed and the macro files 

will be updated. However, if the macro syntax is not correct, the following error 

message dialog box will pop up on the screen to alert the user to examine the macro 

syntax again.  
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3.14.2.2 Macro Command Dialog Box 

After clicking on  icon on the toolbar, the Macro Command Dialog Box will display 

automatically (Fig. 3-14-14). 

 

              

 

 

 

Fig. 3-14-14 Macro Command Dialog Box 

dit 

he user can edit the macro files via the edit option in the Macro Command dialog box 

ig. 3-14-15) or from the toolbar (Fig. 3-14-16).  

 

 

 

 

 

E

T

(F

  

     Fig. 3-14-15 Edit options from menu bar   Fig. 3-14-16 Edit option from toolbar 

Previous 

 

 
This command moves up the selected line by one line. 

Next 

 

 
This command moves down the selected line by one line. 

Macro Editing Toolbar
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Update 

 

 

This command updates macro files. If this function is not used after 

editing a macro, changes are not updated. With this function, the user 

can know if it is necessary to change the macro or not. If the macro is not 

updated. When this icon is clicked, the system will perform the 

examination of macro syntax. If the macro syntax is correct, the update 

function will be executed and the macro files will be updated. When the 

user tries to close Macro Command dialog box without pressing this 

Update button, the following dialog box will show up on the screen to 

alert the user.  

 
After Yes button is pressed, the system will examine if the macro syntax 

is correct. If the macro syntax is correct, the update function will be 

executed and the macro files will be updated. However, if the macro 

syntax is not correct, the following error message dialog box will pop up 

on the screen to alert the user. At this time, please examine the macro 

syntax again. 

 

Insert 

 

 

This command inserts a macro between two lines. The lines below will 

move down by one line. 

Delete 

 

 

This command deletes the selected line. The lines below will move up by 

one line.  

Comment 

 

 

To write comments in programs, the user can put a comment mark (#) in 

front of sentences. The sentences from the comment mark to the end are 

comments. Please note that the content of the comments will not be 

ecuted. 

 

ex
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Command 

The user can

typed directl

Command bu

 use commands to edit the macro. The command and equation can be 

, or chosen from the menu bar (Fig. 3-14-17) or selected by clicking the 

tton (Fig. 3-14-18).  

y

 

Fig. 3-14-17 Command options from menu bar 

 

 
 

Fig. 3-14-18 Command options from drop-down list 
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Fig. 3-14-20 ~ Fig. 3-14-29 show all the macro commands. For more details, please 

refer to the section 3.14.3. 

    

Fig. 3-14-19 Commands 

options 

Fig. 3-14-20 

Arithmetic 

Fig. 3-14-21 

Logical 

Fig. 3-14-22 

Data 

Transfer 

 
   

Fig. 3-14-23  

Data Conversion 

Fig. 3-14-24 

Comparison 

Fig. 3-14-25 

Flow Control 

Fig. 3-14-26 

Bit Setting 

    

Fig. 3-14-27  

COM Port 

Fig. 3-14-28 

Drawing 

Fig. 3-14-29 

Others  



 Chapter 3 Creating and Editing Screens 

Revision May, 2010   3-297 

After macro command is selected, the user can click on Variable button to determine 

the necessary variables (Var1 ~ Var4) (Fig. 3-14-30, Fig. 3-14-31).  

 

 

Fig. 3-14-30 Fig. 3-14-31 

 

Fig. 3-14-32 Double Word and Signed options 

 

Unsigned A unsigned value is a numeric value without polarity, 

Signed A signed value is a numeric value with polarity, which 
is used to represent both positive and negative values. 
A byte, word or double-word can be signed.  

WORD A word consists of 16 bits of continuous data. This is 
used to represent 16 bits of data or 0x0000 to 0xFFFF 
hexadecimal or 0 to 65535 decimal. 

DW, DWORD 

(DOUBLE WORD, DWORD) 

A double-word consists of 32 bits of continuous data. 
This is used to represent 32 bits of data or 0x000000 
to 0xFFFFFF hexadecimal or 0 to 4,294,967,295 
decimal. 

Table 3-14-2 Macro Definition 
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If DW shows after the macro command, it i cates that the command is 32 Bit data, if 

D display, it indicates  

format of the device as Double W

tha e user set the format o

data. If Signed shows after the and is a 

n alue with polarity. If 

value without polarity. 

For example, when the macro command is set to $0 = $2(DW), i.e. make $2 a double 

w e Word memory

P he 

shown as Fig. 3-14-33. 

ndi

W doesn’t  that the command is 16 Bit data. When the user set the

ord, there will be two registers used actually. It means 

f $0 as Double Word, $0 and $1 will be used for storing 

 macro command, it indicates that the comm

t if th

umeric v Signed doesn’t display, it indicates that it is a numeric 

ord, as Doubl  will take two registers; it will assign register $2 and $3. 

macro command will be input in the editing window ress Update button and t

 

Fig. 3-14-33 Input Macro Command 

k function, please refer to section 3.14.2.1.  

 

 

After complete macro command editing, the user needs to perform Syntax Check and 

Update function to makes sure that the macro syntax is correct. For more details on 

Update and Syntax Chec
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3.14.2.3 Keypad Entry 

For the convenience of editing the macro, the system allows the user to edit the macro 

commands by keying in the commands manually. The system will check the validity 

automatically, if there are any errors, a warning dialog box will pop up to alert the user.  

It is not critical that the user place the correct amount of spaces between commands 

and operands, when the line is updated the system will automatically adjust the 

spacing and warn of formatting errors. In addition, a list of the macro commands will 

appear automatically when the user keys in the commands manually (Fig. 3-14-33). It is 

easy for the user to select the required command quickly.  

 

Fig. 3-14-33 

After the macrom command is entered, the user’s screen will look like Fig. 3-14-34 

below.  

 

Fig. 3-14-34 

After complete macro command editing, the user needs to perform Syntax Check and 

Update function to makes sure that the macro syntax is correct. For more details on 

Update and Syntax Check function, please refer to section 3.14.2.1.  
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3.14.3 Macro Operation 

3.14.3.1 Arithmetic Operation 

 

 

There are two Arithmetic Operations, which include Integer Operation and 

Float Operation. 

Each operand can be the internal memory or constant. The operands that store output 

results must be the internal memory. For details, refer to this table and examples 

below. 

 

 + (Addition) 

Equation 

Var1 = Var2 + Var3 

 

Explanation 

Perform the addition on Var2 and Var3, and store the addition result in Var1. 

 

Remark 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

When the data exceeds the length of designated unit, the data out of range will 

be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 
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Example 

Add a value of 1 to $0 and store the value in $0 (this is an operation of unsigned 

16-bit data). 

 
Add a value of $1 to $2 and store the value in $3 (this is an operation of signed 16-bit 

data). 

 
Add a value of $4 to $6 and store the value in $8 (this is an operation of signed 32-bit 

data). 
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 raction) 

 

 

he subtraction of Var2 and Var3, and store the subtraction result in Var1. 

 

result can be stored as signed or unsigned WORD and DWORD. 

ll 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

tant. 

 

Subtract a value of 1 from $0 and store the value in $0 (this is an operation of 

unsigned 16-bit data). 

 - (Subt

Equation 

Var1 = Var2 - Var3 

Explanation

Perform t

Remark 

 The calculation 

When the data exceeds the length of designated unit, the data out of range wi

be discarded. 

cons

Example 

 

Subtract a value of $1 from $2 and store the value in $3 (this is an operation of 

signed 16-bit data). 
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Subtract a value of $4 from $6 and store the value in $8 (this is an operation of 

signed 32-bit data). 

 
 

 iplication) 

Var1 = Var2 * Var3 

 

 the multiplication of Var2 and Var3, and store the multiplication result in 

Var1. 

 

exceeds the length of designated unit, the data out of range will 

e internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

y $0 by 2 and store the value in $0 (this is an operation of unsigned 16-bit 

data). 

* (Mult

Equation 

Explanation 

Perform

Remark 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

When the data 

be discarded. 

 Var1 can b

Example 

Multipl
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Multiply the value of $1 by $2 and store the value in $3 (this is an operation of signed 

16-bit data). 

 
Multiply the value of $4 by $6 and store the value in $8 (this is an operation of signed 

32-bit data). 

 
 

 sion) 

Var1 = Var2 / Var3 

 

Perform the division of Var2 and Var3, and store the division result in Var1.  

 

exceeds the length of designated unit, the data out of range will 

e internal memory only. Var2 and Var3 can be internal memory or 

 The value contained within Var3 cannot be equal to 0 (zero). 

 

/ (Divi

Equation 

Explanation 

Remark 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

When the data 

be discarded. 

 Var1 can b

constant. 
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Example 

Divide $0 by the value of 2 and store the value in $0 (this is an operation of unsigned 

16-bit data). 

 
Divide $1 by $2 and store the value in $3 (this is an operation of signed 16-bit data). 

 
Divide $4 by $6 and store the value in $8 (this is an operation of signed 32-bit data). 
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 inder) 

 Var3 

 

 

he division of Var2 and Var3, and store the remainder in Var1.  

 

result can be stored as signed or unsigned WORD and DWORD. 

ll 

rnal memory or 

constant. 

e contained within Var3 cannot be equal to 0 (zero). 

 

Divide $0 by the value of 2 and store the remainder value in $1 (this is an operation 

of unsigned 16-bit data). 

 % (Get Rema

Equation 

Var1 = Var2 %

Explanation

Perform t

Remark 

 The calculation 

When the data exceeds the length of designated unit, the data out of range wi

be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be inte

 The valu

Example 

 
Divide $2 by $3 and store the remainder value in $4 (this is an operation of signed 

16-bit data). 
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Divide $5 by $7 and store the remainder value in $9 (this is an operation of signed 

32-bit data). 

 
 

 64-bit Multiplication) 

Var1 = MUL64 (Var2, Var3) 

 

 the multiplication of Var2 and Var3, and store the multiplication result in 

Var1.  

 

ORD.  

e internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

0 by $2 and store the value in $4 (this is an operation of 

unsigned 32-bit data). 

MUL64 (

Equation 

Explanation 

Perform

Remark 

 This is the operation of 32 Bit data. 

 The calculation result can be stored as signed or unsigned DW

 Var1 occupies 4 Words. Var2 and Var3 occupy 2 Words. 

 Var1 can b

Example 

Multiply the value of $
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Multiply the value of $8 by $10 and store the value in $12 (this is an operation of 

signed 32-bit data). 

 
 

 Repeated Addition) 

Var1 = ADDSUMW (Var2, Var3) 

 

ive registers starting at register Var2 and store 

the repeated addition result in Var1. 

 

n the 

s the length of designated unit, the data out of range will be 

ar2 can be internal memory only. Var3 can be internal memory or 

constant. 

 

rand total is stored in the address $5 (this is an operation of unsigned 

16-bit data). 

ADDSUMW (

Equation 

Explanation 

Perform the addition on Var3 consecut

Remark 

 This is the operation of unsigned data. 

 The calculation result can be stored as unsigned WORD and DWORD. Whe

data exceed

discarded. 

 Var1 and V

Example 

Add up the values contained within the internal memory address $0, $1, $2, $3 and 

$4, and the g
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Add up the values contained within the internal memory address $6, $8 and $10, and 

the grand total is stored in the address $12 (this is an operation of unsigned 32-bit 

data). 

 
 

 FADD (Floating Addition) 

Equation 

Var1 = FADD (Var2, Var3) 

 

Explanation 

Perform the addition on Var2 and Var3, and store the addition result in Var1. 

 

Remark 

 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Add a value of 1.0 to $0 and store the value in $0 (this is a floating point operation of 

signed 32-bit data). 
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Add a value of $4 to $2 and store the value in $6 (this is a floating point operation of 

signed 32-bit data). 

 
 

 FSUB (Floating Subtraction) 

Equation 

Var1 = FSUB (Var2, Var3) 

 

Explanation 

Perform the subtraction of Var2 and Var3, and store the subtraction result in Var1. 

 

Remark 

 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Subtract a value of 1.0 from $0 and store the value in $0 (this is a floating point 

operation of signed 32-bit data). 
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Subtract a value of $2 from $4 and store the value in $6 (this is a floating point 

operation of signed 32-bit data). 

 

 

 FMUL (Floating Multiplication) 

Equation 

Var1 = FMUL (Var2, Var3) 

 

Explanation 

Perform the multiplication of Var2 and Var3, and store the multiplication result in 

Var1. 

 

Remark 

 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 
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Example 

Multiply the value of $0 by 2.0 and store the value in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Multiply the value of $2 by $4 and store the value in $6 (this is a floating point 

operation of signed 32-bit data). 

 
 

 FDIV (Floating Division) 

Equation 

Var1 = FDIV (Var2, Var3) 

 

Explanation 

Perform the division of Var2 and Var3, and store the division result in Var1. 

 

Remark 

 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 The value contained within Var3 cannot be equal to 0 (zero). 
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Example 

Divide the value of $0 by 2.0 and store the value in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Divide the value of $2 by $4 and store the value in $6 (this is a floating point 

operation of signed 32-bit data). 

 
 

 FMOD (Get Floating Remainder) 

Equation 

Var1 = FMOD (Var2, Var3) 

 

Explanation 

Perform the division of Var2 and Var3, and store the remainder in Var1.  

 

Remark 

 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 The value contained within Var3 cannot be equal to 0 (zero). 
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Example 

Divide $0 by the value of 2.0 and store the remainder value in $2 (this is a floating 

point operation of signed 32-bit data). 

 
Divide $4 by $6 and store the remainder value in $8 (this is a floating point operation 

of signed 32-bit data).  

 
 

 SIN (Sine Function) 

Equation 

Var1 = SIN (Var2) 

 

Explanation 

Perform the sine function of the value within Var2, and store the result in Var1.  

 

Remark 

 The definition of Var2 is an angle, not radius.  

 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 
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Example 

Perform the function of SIN30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Perform the sine function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 

 
 

 COS (Cosine Function) 

Equation 

Var1 = COS (Var2) 

 

Explanation 

Perform the cosine function of the value within Var2, and store the result in Var1.  

 

Remark 

 The definition of Var2 is an angle, not radius.  

 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 
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Example 

Perform the function of COS30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 

Perform the cosine function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 

 

 

 TAN (Tangent Function) 

Equation 

Var1 = TAN (Var2) 

 

Explanation 

Perform the tangent function of the value within Var2, and store the result in Var1.  

 

Remark 

 The definition of Var2 is an angle, not radius.  

 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 
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 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 

 

Example 

Perform the function of TAN30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Perform the tangent function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 

 
 

 COT (Cotangent Function) 

Equation 

Var1 = COT (Var2) 

 

Explanation 

Perform the cotangent function of the value within Var2, and store the result in Var1.  

 

Remark 

 The definition of Var2 is an angle, not radius.  

 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 
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 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 

 

Example 

Perform the function of COT30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Perform the cotangent function of $2 and store the result in $4 (this is a floating 

point operation of signed 32-bit data). 

 
 

 SEC (Secant Function) 

Equation 

Var1 = SEC (Var2) 

 

Explanation 

Perform the secant function of the value within Var2, and store the result in Var1.  

 

Remark 

 The definition of Var2 is an angle, not radius.  

 This is the operation of signed 32-bit data. 
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 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 

 

Example 

Perform the function of SEC30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Perform the secant function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 

 
 

 CSC (Cosecant Function) 

Equation 

Var1 = CSC (Var2) 

 

Explanation 

Perform the cosecant function of the value within Var2, and store the result in Var1.  

 

Remark 

 The definition of Var2 is an angle, not radius.  
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 This is the operation of signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 

 

Example 

Perform the function of CSC30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 

Perform the cosecant function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 
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3.14.3.2 Logical Operation 

 
There are six logical operations which include OR, AND, XOR, NOT, Shift-left and 

Shift-right. There are three operands for each operation and each operand can be 

internal memory or constant, but it is internal memory only when outputting. The unit 

can be Word and Double Word. 

 

 | (Logical OR operation) 

Equation 

Var1 = Var2 | Var3 

 

Explanation 

Perform the logical OR operation on Var2 and Var3, and save the result of this 

calculation in Var1.  

 

Remark 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Perform the logical OR operation on $0 and $1, and save the result in $2 (this is an 

operation of unsigned 16-bit data) 

 
$2 = $0 | $1 Store the result of $2. $0 = F000H, $1 = 0F00H, then $2 = FF00H.  

Perform the logical OR operation on $3 and $5, and save the result in $7 (this is an 

operation of unsigned 32-bit data) 
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$7 = $3 | $5 (DW) Store the result of $7. $3 = F000F000H, $5 = 0F000F00H, then $7 

= FF00FF00H.  

 

 && (Logical AND operation) 

Equation 

Var1 = Var2 && Var3 

 

Explanation 

Perform the logical AND operation on Var2 and Var3, and save the result of this 

calculation in Var1.  

 

Remark 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Perform the logical AND operation on $0 and $1, and save the result in $2 (this is an 

operation of unsigned 16-bit data) 

 

$2 = $0 && $1 Store the result of $2. $0 = F000H, $1 = 0F00H, then $2 = 0000H. 
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Perform the logical AND operation on $3 and $5, and save the result in $7 (this is an 

operation of unsigned 32-bit data) 

 
$7 = $3 && $5 (DW) Store the result of $7. $3 = F000F000H, $5 = 0F000F00H, then 

$7 = 00000000H.  

 

 ^ (Logical XOR operation) 

Equation 

Var1 = Var2 ^ Var3 

 

Explanation 

Perform the logical XOR operation on Var2 and Var3, and save the result of this 

calculation in Var1.  

 

Remark 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Perform the logical XOR operation on $0 and $1, and save the result in $2 (this is an 

operation of unsigned 16-bit data) 
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$2 = $0 ^ $1 Store the result of $2. $0 = F100H, $1 = 0F00H, then $2 = FE00H.  

Perform the logical XOR operation on $3 and $5, and save the result in $7 (this is an 

operation of unsigned 32-bit data) 

 
$7 = $3 ^ $5 (DW) Store the result of $7. $3 = F100F100H, $5 = 0F000F00H, then $7 

= FE00FE00H.  

 

 NOT (Logical NOT operation) 

Equation 

Var1 = NOT Var2 

 

Explanation 

Perform the logical NOToperation on Var2, and save the result of this calculation in 

Var1.  

 

Remark 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

Perform the logical NOT operation on $0, and save the result in $1 (this is an 

operation of unsigned 16-bit data). 
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$1 = NOT $0 Store the result of $1. $0 = F100H, $1 = 0EFFH. 

Perform the logical NOT operation on $2, and save the result in $4 (this is an 

operation of signed 32-bit data). 

 

$4 = NOT $2 (Signed DW) Store the result of $4. $2 = F100 F100H, $4 = 0EFF 0EFFH. 

 

 << (SHL, Logical Shift-left operation) 

Equation 

Var1 = Var2 << Var3 

 

Explanation 

Shift Var2 (WORD/DWORD) data to left (number of bit is Var3). The result of this 

calculation is stored in Var1. 

 

Remark 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

$0 = F100H  

Shift-left 4 bits and becomes $1 = 1000H (this is an operation of unsigned 16-bit 

data). 
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$2 = F1000000H 

Shift-left 4 bits and becomes $4 = 10000000H (this is an operation of unsigned 

32-bit data). 

 
 

 >> (SHR, Logical Shift-right operation) 

Equation 

Var1 = Var2 >> Var3 

 

Explanation 

Shift Var2 (WORD/DWORD) data to right (number of bit is Var3). The result of this 

calculation is stored in Var1. 

 

Remark 

 The calculation result can be stored as WORD and DWORD. 

 If the shift number of bit is more than the address itself, the number out of 

range will be discarded.  

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 
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Example 

$0 = F100H  

Shift-left 4 bits and becomes $1 = 0F10H (this is an operation of unsigned 16-bit 

data).  

 
$2 = F1000000H  

Shift-left 4 bits and becomes $4 = 0F100000H (this is an operation of unsigned 

32-bit data).  
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3.14.3.3 Data Transfer 

 

There are five commands for data transfer, including MOV, BMOV, FILL, FILLASC and 

FMOV. 

 MOV (Transfer Data) 

Equation 

Var1 = Var2 

 

Explanation 

Transfer data from Var2 to Var1. No data change within Var2 after executing MOV 

command. 

 

Remark 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

$0 = 0  

The data within the internal memory address $0 is assigned to the constant 0 (this is 

an operation of unsigned 16-bit data).  

 
$1 = 99999 (Signed DW) 

The data within the internal memory address $1 is assigned to the constant 99999 

(this is an operation of signed 32-bit data).  
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 BMOV (Block Move Copy Block) 

Equation 

BMOV (Var1, Var2, Var3) 

 

Explanation 

BMOV (Var1, Var2, Var3) means to move sequential data of Var3 in length from 

address Var2 to address Var1 in block.  

 

Remark 

 The calculation result can be stored as unsigned WORD. 

 If the block length is more than internal memory or max number of PLC register, 

there will be an error when compiling. 

 Var1 and Var2 can be controller address or internal memory. Var3 can be 

internal memory or constant. 

 

Example 

Move the data in $0, $1, $2, $3, $4 to $10, $11, $12, $13 in order (this is an 

operation of unsigned 16-bit data). 
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 FILL (Fill the Memory) 

Equation 

FILL (Var1, Var2, Var3) 

 

Explanation 

FILL (Var1, Var2, Var3) means to fill address Var1 with data in address Var2 for a 

sequential V3 number of registers.  

 

Remark 

 The calculation result can be stored as unsigned or signed WORD. 

 If the block length is more than internal memory or max number of PLC register, 

there will be an error when compiling. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Executing FILL command to fill $0, $1, $2, $3, $4 with constant 0 (this is an 

operation of unsigned 16-bit data). 

 
 

 FILLASC (Convert Text to ASCII code) 

Equation 

FILLASC (Var1, “Var2”) 

 

Explanation 

FILLASC (Var1, “Var2”) means to convert text in address V2 to ASCII code and store in 

V1. 

 

Remark 

 The calculation result can be stored as unsigned WORD. 

 The max length is 128 words. 
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 One address can store up to two words. The excess word will be stored in next 

address in order. The low and high bit of the converted ASCII code will be 

exchanged. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

After executing FILLASC command, 4241H will be stored in $0 and 3130H will be 

stored in $1 (this is an operation of unsigned 16-bit data). 

 
 

 FMOV (Transfer Floating Point Data) 

Equation 

Var1 = FMOV (Var2) 

 

Explanation 

Transfer floating point data from Var2 to Var1. No data change within Var2 after 

executing FMOV command. 

 

Remark 

 The calculation result can be stored as signed DWORD. 

 Var1 can be controller address or internal memory. Var2 can be controller 

address, internal memory or constant. 

 

Example 

Transfer constant 44.3 to the internal memory address $0 (this is an operation of 

signed 32-bit data). 
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Transfer the same data of PLC 1@C200 to the internal memory address $2 (this is an 

operation of signed 32-bit data). 
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3.14.3.4 Data Conversion 

 
 

There are various kinds of commands for data conversion. For more details, please 

refer to the following sections.  

 

 BCD (Convert BIN Data into BCD Value) 

Equation 

Var1 = BCD (Var2) 

 

Explanation 

The binary data in Var2 is converted into a BCD value and stored in Var1. 

 

Remark 

 The calculation result can be stored as unsigned WORD or DWORD. 

 Var1 and Var2 can be internal memory only. 

 

Example 

After executing BCD command, the binary data in $0 is converted to a BCD value and 

stored in $1 (this is an operation of unsigned 16-bit data). 
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 BIN (Converts BCD Data into BIN Value) 

Equation 

Var1 = BIN (Var2) 

 

Explanation 

The BCD data in Var2 is converted into binary value and stored in Var1. 

 

Remark 

  The calculation result can be stored as unsigned WORD or DWORD. 

 Var1 and Var2 can be internal memory only. 

 

Example 

After executing BIN command, the BCD data in $0 is converted to a binary value and 

stored in $1 (this is an operation of unsigned 16-bit data). 

 
 

 TODWORD (Convert WORD to DWORD) 

Equation 

Var1 = TODWORD (Var2) 

 

Explanation 

The WORD value in Var2 is converted into DWORD value and stored in Var1. 

 

Remark 

 The calculation result can be stored as unsigned WORD or DWORD. 

 Var1 and Var2 can be internal memory only. 
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Example 

After executing TODWORD command, the WORD value in $0 is converted to a D 

WORD value and stored in $1. As it is in DWORD format, it indicates that the value 

has occupied $1 and $2 these two addresses. (this is an operation of unsigned 16-bit 

data). 

 
 

 TOWORD (Convert BYTE to WORD) 

Equation 

Var1 = TOWORD (Var2, Var3) 

 

Explanation 

Convert Var3 number of BYTE data from Var2 to Var3 number of WORD values and 

start storing the result in Var1.The high byte will be filled with 0. 

 

Remark 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 The unit of Var2 is WORD. Each WORD of Var2 can be converted to two WORDs. 

 After data conversion is completed, the low and high bit of the converted WORD 

data will be exchanged. 

 

Example 

Assume that the value of $0 is 12, this will convert 12 BYTES (6 WORDS) to 12 WORDS 

starting at $4 and store the result in $10 to $12 (this is an operation of unsigned 

16-bit data). 
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 TOBYTE (Convert WORD to BYTE) 

Equation 

Var1 = TOWORD (Var2, Var3) 

 

Explanation 

Convert Var3 number of WORD data from low-byte of Var2 to BYTE format and store 

the result in Var1. This will discard high-byte of Var2. 

 

Remark 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 After data conversion is completed, the low and high bit of the converted WORD 

data will be exchanged. 

 

Example 

Assume that the value of $0 is 12, this will convert 12 WORDS starting from the 

low-byte of $4 and convert these 12 WORDS into 12 BYTES (6 WORDS) and store the 

result in $10 to $16 (this is an operation of unsigned 16-bit data). 
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 SWAP (Swap High-Byte and Low-Byte Data) 

Equation 

SWAP (Var1, Var2, Var3) 

 

Explanation 

Swap high-byte and low-byte of Var3 number of words starting at Var2 and save it in 

memory starting at Var1. 

 

Remark 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 

Example 

Swap the high-byte and low-byte of $11 and store the result in $2 (this is an 

operation of unsigned 16-bit data). 

If $11 = 1234H, after executing SWAP command, $2 = 3412H. 

 
 

 XCHG (Exchange Data) 

Equation 

XCHG (Var1, Var2, Var3) 

 

Explanation 

Exchange Var3 number of words of data starting at Var2 with the same number of 

words starting at Var1. 

 

Remark 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 
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 The data of V1 and V2 will be exchanged after executing XCHG command. 

 

Example 

Exchange the data of $11 and $2 (this is an operation of unsigned 16-bit data). 

If $11 = 1234H and $2 = 5678H, $2 = 1234H and $1 = 5678H after executing XCHG 

command. 

 
 

 MAX (Get Maximum Value of a Range of Data) 

Equation 

Var1 = MAX (Var2, Var3) 

 

Explanation 

Get the maximum value from Var2 and Var3 and store the result in Var1. 

 

Remark 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Get the maximum value from $0 and $1 and store the result in $2 (this is an 

operation of unsigned 16-bit data). 

If $0 = 2 and $1 = 10, $2 = 10 after executing MAX command. 
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 MIN (Get Minimum Value of a Range of Data) 

Equation 

Var1 = MIN (Var2, Var3) 

 

Explanation 

Get the minimum value from Var2 and Var3 and store the result in Var1. 

 

Remark 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Get the maximum value from $0 and $1 and store the result in $2 (this is an 

operation of unsigned 16-bit data). 

If $0 = 2 and $1 = 10, $2 = 2 after executing MAX command. 
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 TOHEX (Convert 4 ASCII Code to a Four-Digit Integer in Hexadecimal Format) 

Equation 

Var1 = TOHEX (Var2) 

 

Explanation 

Convert a single ASCII code of Var2 and the next 3 words (4 WORDS) to a hex value 

and stores the result in Var1. 

 

Remark 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only.  

 

Example 

Convert a single ASCII code of $0 and the next 3 words (4 WORDS) to a hex value and 

stores the result in $10 (this is an operation of unsigned 16-bit data). 

$0 = 0034H (ASCII 4), 

$1 = 0033H (ASCII 3), 

$2 = 0036H (ASCII 6), 

$3 = 0038H (ASCII 8), 

$10 = TOHEX ($0)  

After executing TOHEX command, the data in $10 will be converted to 4368H. 
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 TOASC (Convert a Hexidecimal Value Var2 to Four Single ASCII Values (4 

WORDS) Starting at Var1.) 

Equation 

Var1 = TOASC (Var2) 

 

Explanation 

Convert Var2 (1 WORD in hexadecimal format) to the ASCII (4 WORDS) code and store 

the result in Var1. 

 

Remark 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only.  

 

Example 

Convert $0 (1 WORD in hexadecimal format) to the ASCII (4 WORDS) code and store 

the result in $10 (this is an operation of unsigned 16-bit data). 

$0 = 1234H 

$10 = TOASC ($0) 

After executing TOASC command, 

$10=0031H (ASCII 1) 

$11=0032H (ASCII 2) 

$12=0033H (ASCII 3) 

$13=0034H (ASCII 4) 
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 FCNV (Convert Integer to Floating Point Value) 

Equation 

Var1 = FCNV (Var2) 

 

Explanation 

Convert an integer in Var2 to floating point value and store in Var1. 

 

Remark 

 The calculation result can be stored as signed DWORD. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

Convert an integer in $0 to floating point value and store in $2 (this is an operation 

of signed 32-bit data). 

If $0 = 100, $2 = 100.0 after executing FCNV command. 

 
 

 ICNV (Convert Floating Point Value to Integer) 

Equation 

Var1 = ICNV (Var2) 

 

Explanation 

Convert a floating point value in Var2 to an integer and store in Var1. 

 

Remark 

 The calculation result can be stored as signed DWORD. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

Convert a floating point value in $0 to an integer and store in $2 (this is an operation 

of signed 32-bit data). 
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If $0 = 100.0, $2 = 100 after executing ICNV command. 

 
 

 

3.14.3.5 Comparison 

 

There are various kinds of commands for comparison. For more details, please refer to 

the following sections. 

 IF…THEN GOTO … 

Equation 

IF expression THEN GOTO LABEL identifier 

 

Explanation 

If the command of expression is true, then it will go to LABEL identifier and perform 

the program. 

 

Remark 

 Please refer to the following Comparison command table for the command of 

expression. 

 

Example 

If the value in $2 is equal to or greater than 10, it will go to LABEL 1 and perform the 

program. 
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Equation 

IFB expression THEN GOTO LABEL identifier 

 

Explanation 

If the command of expression is true, then it will go to LABEL identifier and perform 

the program (for PLC register). 

 

Remark 

 Please refer to the following Comparison command table for the command of 

expression. 

 

Example 

If 1@M0 is ON, it will go to LABEL 1 and perform the program. 

 
 

Equation 

IF expression THEN CALL sub-macro 

Explanation 

If the command of expression is true, then it will call sub-macro and perform the 

program. 
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Remark 

 Please refer to the following Comparison command table for the command of 

expression. 

 

Example 

If the value in $2 is equal to 10, it will call sub-macro 1 and perform the program. 

 
 

 

Equation Explanation Remark 

Var1 == Var2 Var1 is equal to Var2  

Var1 != Var2 Var1 is not equal to Var2 

Var1 > Var2 Var1 is greater than Var2 

Var1 >= Var2 Var1is equal to or greater than Var2 

Var1 < Var2 Var1 is smaller than Var2 

Var1<= Var2 Var1 is equal to or smaller than Var2 

Var1 && Var2 == 0 

Perform AND command on V1 and V2 

and the result of AND operation is 

equal to 0. 

Var1 && Var2 != 0 

Perform AND command on V1 and V2 

and the result of AND operation is not 

equal to 0. 

Var1 and Var2 can be 

internal memory or 

constant. 

Var1== ON Var1 is ON 

Var1== OFF Var1 is OFF 

Var1 can be the 

controller address or 

internal memory (BIT)。 

Table 3-14-3 Comparison command table 
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 IF…ELSEIF…ELSE…ENDIF 

Equation 

IF expression1 

Statement1 

ELSEIF expression2 

Statement2 

ELSE 

Statement3 

ENDIF 

 

Explanation 

This is logical determination from multiple conditions. If expression1 is true, 

Statement1 will be executed. If expression1 is false, it will run expression2. If 

expression2 is true, Stemenent2 will be executed. If both expression1 and 

expression2 are false, Statement3 will be executed. ENDIF should be placed in the 

end of the IF comparison command 

 

Remark 

 Please refer to the Comparison command table on previous page 3-343 for the 

command of expression. 

 

Example 

 

IF $0 == 0 

$10 = 0 

ELSEIF $0 ==1 

$10 = 1 

ELSE 

$10 = 2 

ENDIF 

If $0 is equal to 0,  

$10 is equal to 0; 

If $0 is equal to 1, not equal to 0,  

$10 is equal to 1; 

If $0 is equal to neither 0 nor 1,， 

$10 is equal to 2. 
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 FCMP (Floating Point Value Comparison) 

Equation 

Var1 = FCMP (Var2, Var3) 

 

Explanation 

Compare the floating point value in Var2 and Var3 and store the result in Var1. 

The comparison methods include: 

Var1=0, Var2 = Var3 

Var1=1, Var2 > Var3 

Var1=2, Var2 < Var3 

 

Remark 

 The calculation result can be stored as signed DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Compare the floating point value in $0 and $2 and store the result in $4 (this is an 

operation of signed 32-bit data). 
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3.14.3.6 Flow Control 

 

 

There are various kinds of commands for flow control. For more details, please refer to 

the following sections. 

 

 GOTO (Unconditionally Go To a Specific Label. GOTO command will jump to 

designated label like Label Var1 unconditionally) 

Equation 

GOTO LABEL Var1 

 

Explanation 

Go to the internal designated Label Var1 in the program unconditionally. 

 

Remark 

 Var1 can be constant only.  

 

Example 

Go to the position of designated Label 1 and continue to execute the program 

unconditionally. 
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 LABEL (Label such as Label Var1) 

Equation 

LABEL Var1 

 

Explanation 

GOTO statement shifts the program execution to the position of LABEL 

unconditionally. 

 

Remark 

 Var1 can be constant only.  

 A label value is unique per macro and it cannot be used more then once in a 

single macro. The user can only use LABEL 1 once per individual macro. 

 

Example 

LABEL 1. 

 
 

 CALL..RET (Call Sub-Macro Program) 

Equation 

CALL Var1…RET 

 

Explanation 

“CALL Var1” is to call sub-macro Var1. Var1 represents the sub-macro number.  

“RET” is to exit sub-macro Var1. It should be placed in the end of the Var1 sub-macro 

command. 

 

Remark 

 The sub-macro number could be 001 – 512.  

 Var1 can be internal memory or constant. 
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Example 
CALL

RET

Main
Macro

Sub-Macro
A1

 
The rights of macro control will be transferred to sub-macro when executing CALL 

Var1 command. After CALL Var1 command is executed and completed, Var1 needs 

to return through RET command. RET command will transfer the rights of macro 

control to the next command of CALL command. The sub-macro number could be 1 

~ 512. Regarding the comment name of the sub-macro, the user can name it freely. 

In the sub-macro program, the users also can CALL another sub-macro but the levels 

for CALL submacro should be less than 6 levels due to memory limit and also for 

avoiding unexpected error. 

 

 FOR…NEXT (Program Loop) 

Equation 

FOR Var1 Statement NEXT  

 

Explanation 

It is for nested loops. ”FOR” is the start of the loop and “NEXT” is the end of the loop. 

When this command is executed, the number of Var1 Statement will be executed 

continuously. The users can change the Var1 value through command, but the 

number of times cannot be changed. 

 

Remark 

 The nested loop can be up to 3 levels max.  

 Var1 can be internal memory or constant. 

 Statement is the combination of a section of macro commands and also can be 

within the nested loop. 

 

Example 

 If $10=10, $0=0, after the operation, the result is $0 = 10 

If a $10 = 2 is inserted between the FOR and the NEXT in the above macro, the FOR … 

NEXT loop will still loop 10 times even though $10 is changed to a value of 2 the first 

pass through the loop. 

3-350 Revision May, 2010 



 Chapter 3 Creating and Editing Screens 

 END (End the Macro) 

Equation 

Statemenets1 END Statements2  

 

Explanation 

End command is used to end the macro program and all statements after the END 

command will not be executed. If this command is in a main macro then the program 

will go to the first line again and begin execution, if this command is in a sub-macro 

then the sub-macro will end and the program will return to the previous program. 

 

Remark 

 It executes the Statemenets1 and then ends the macro executing. It does not 

execute the Statements2.  

 Statement is the combination of a section of macro commands and also can be 

within the nested loop. 

 If there is END command in sub-macro, the program ends here. If the user 

wants to return to the previous macro program, please user RET command. 

 

Example 

 

After the operation, the result is $1 = 11, not $1 = 12 as the END command has 

ended the macro program. 

 

 

3.14.3.7 Bit Setting 

 

There are various kinds of commands for Bit setting. For more details, please refer to 

the following sections. 

 BITON (Set Specific Bit to be ON) 

Equation 

BITON Var1 

 

Explanation 

This command sets Var1 bit to be ON. 
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Remark 

 Var1 can be the controller address or internal memory (BIT). 

 

Example 

Set the 5th Bit within the internal memory $0 to be ON. 

If $0 = 0000000000000000, after the operation, $0 = 0000000000010000 

 
 

 BITOFF (Set Specific Bit to be OFF) 

Equation 

BITOFF Var1 

 

Explanation 

This command sets Var1 bit to be OFF. 

 

Remark 

 Var1 can be the controller address or internal memory (BIT). 

 

Example 

Set the 5th Bit within the internal memory $0 to be OFF. 

If $0 = 1111111111111111, after the operation, $0 = 1111111111101111 
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 BITNOT (Set Specific Bit to be Inversed. ON to OFF, OFF to ON) 

Equation 

BITNOT Var1 

 

Explanation 

This command sets the specific Bit to be inversed. ON to OFF, OFF to ON 

 

Remark 

 Var1 can be the controller address or internal memory (BIT). 

 

Example 

Set the 5th Bit within the internal memory $0 to be inversed. 

If $0 = 1111111111111111, after the operation, $0 = 1111111111101111 

 

 

 GETB (Get Bit value) 

Equation 

Var1 = GETB Var2 

 

Explanation 

This command gets Var2 Bit value and store in Var1 

 

Remark 

 Var1 and Var2 can be the controller address or internal memory (BIT). 

 

Example 

Get the 5th Bit value within the internal memory $0 and store it to the 5th Bit value 

within the internal memory $1. 

If $0 = 1111111111111111 and $1 = 0000000000000000, after the operation, $1 

= 0000000000010000. 
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3.14.3.8 Communication 

 

There are various kinds of commands for communication. For more details, please 

refer to the following sections. 

 INITCOM (Initial setup COM port) 

Equation 

Var1 = INITCOM (Var2) 

 

Explanation 

This command uses initial setup COM port to start communication and set 

communication protocol. After the user sets each COM port, this command starts 

communication and stores the result in Var1. 

 

Remark 

 Var1: Response value after communication 

1: Completed normally 

0: Failed 

 For the settings of Var2, please refer to the following table of Var2 Settings in 

INITCOM (Communication Protocol). 
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Var2 Settings in INITCOM (Communication Protocol) 

Item Type Code Remark 

COM1 0 

COM2 1 COM Port 

COM3 2 

RS232 0 

RS422 1 
Communication 

Interface 
RS485 2 

7 Bits 0 
Data Bit 

8 Bits 1 

None 0 

Odd 1 Parity Bit 

Even 2 

1 Bits 0 
Stop Bit 

2 Bits 1 

300 0 

600 1 

900 2 

1200 3 

2400 4 

4800 5 

9600 6 

14400 7 

19200 8 

28800 9 

38400 10 

57600 11 

Baud Rate 

115200 12 

 

No Flow Control 0 

CTS RTS Flow 

Control 
1 

DTR DSR Flow 

Control 
2 

Flow Control 

Xon Xoff Flow 

Control 
3 

Please refer to the 

following descriptions. 
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No Flow Control: Flow control function is disabled. 

Flow Control: The transmission speed and communication validity are enhanced during 

communication due to new transmission technology, such as compress immediately, 

debug,…etc. But the new technology also makes the transmission speed between HMI 

and PC will be longer than the actual transmission speed. Therefore, ensure the data 

security and transmit complete data between computer and HMI, when transmitting data 

through serial communication port, the flow control is necessary. 

To make sure that data transmit between computer and HMI is completed, the user can 

use Flow Control functions. 

CTS / RTS: Flow control for hardware. It uses handshaking signal to control receiving 

and sending data. The control is achieved via internal modem or external modem 

that connects to HMI by a connecting cable. 

DSR / DTR: Flow control for hardware also. It is used when PC and HMI are connected 

directly by a cable. 

XON / XOFF: Flow control for software. Only used for 2400bps modem. The control 

method is to generate control code by software and add it in the transmission data. 

 

Example 

When the communication protocol is set to COM1, RS232, 7, Even, 1, 9600, and No 

Flow Control, if the response value is stored in $0, the user’s screen will look like the 

following figure.  

 
 

 ADDSUM (Use Addition to Calculate Checksum) 

Equation 

Var1 = ADDSUM (Var2, Var3) 

 

Explanation 

This command uses addition to calculate checksum. Var1 is the value after 

calculation, Var2 is the starting address for calculation and Var3 is data length. 
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Remark 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 

Example 

The starting address is for calculation $0, the data length is set to 2. After the 

communication, the calculated checksum through addition calculation is stored in 

$2 (this is an operation of unsigned 16-bit data). 

 
 

 XORSUM (Use XOR to Calculate Checksum) 

Equation 

Var1 = XORSUM (Var2, Var3) 

 

Explanation 

This command uses XOR to calculate checksum. Var1 is the value after calculation, 

Var2 is the starting address for calculation and Var3 is data length. 

 

Remark 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 

Example 

The starting address is for calculation $0, the data length is set to 2. After the 

communication, the calculated checksum through XOR calculation is stored in $2 

(this is an operation of unsigned 16-bit data). 
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 PUTCHARS (Output Characters by COM Port) 

Equation 

Var1 = PUTCHARS (Var2, Var3, Var4) 

 

Explanation 

This command outputs characters by COM port. Var1 is the response value after the 

communication, Var2 is the starting address of transmission data, Var3 is the data 

length, and Var4 is the allowance communication time (unit is ms). The result will be 

stored in Var1. 

 

Remark 

 Var1: Response value after communication 

1: Completed normally 

0: Failed 

 Var1 and Var2 can be internal memory only. Var3 and Var4 can be internal 

memory or constant. 

 

Example 

Output three consecutive WORD data starting from $1 and store the result in $0. 
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 GETCHARS (Get Characters by COM Port) 

Equation 

Var1 = GETCHARS (Var2, Var3, Var4) 

 

Explanation 

This command gets characters by COM port. Var1 is the response value after the 

communication, Var2 is the starting address of transmission data, Var3 is the data 

length, and Var4 is the allowance communication time (unit is ms). The result will be 

stored in Var1. 

 

Remark 

 Var1: Response value after communication 

1: Completed normally 

0: Failed 

 Var1 and Var2 can be internal memory only. Var3 and Var4 can be internal 

memory or constant. 

 

Example 

Get three consecutive WORD data starting from $1 and store the result in $0. 

 
 

 SELECTCOM (Select COM Port) 

Equation 

SELECTCOM (Var1) 

 

Explanation 

This command is used to select COM port. When not connecting to the external 

controller (set PLC to NULL) in Options > Configuration in Screen Editor software 

program, the user can use two COM ports (0:COM1, 1:COM2, 3:COM3 (for some 

models only)) at the same time.  
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Remark 

 Var1 can be constant only.  

 All communication commands will be processed via the COM port that the user 

selects after executing this command. Different macros will not support each 

other or have any interference. 

 

Example 

Select COM1 port. 

 
 

 CLEARCOMBUFFER (Clear the COM Port Buffer) 

Equation 

CLEARCOMBUFFER (Var1, Var2) 

 

Explanation 

This command is used to clear COM port buffer.  

Var1 is the number of communication port. It represents as constant 0(COM1), 

1(COM2) or 2(COM3). 

Var2 is the type of buffer area. It represents as constant 0 (receiving buffer area) or 1 

(sending buffer area). 

 

Remark 

 Var1 and Var2 can be constant only.  

 

Example 

Clear the sending buffer area of COM2. 
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 CHRCHKSUM (Calculate Data Length of Texts or Characters and Checksum) 

Equation 

Var1 = CHRCHKSUM (“Var2”, Var3, Var4) 

 

Explanation 

This command is used to calculate the data length of texts or characters and 

checksum. 

Var1 is the internal memory address that stores the text length of Var2. 

Var2 is the string of text. 

Var3 is the internal memory address that stores the checksum of Var2. 

Var4 is the data length of the checksum that stores in Var3. 1 represents Byte and 2 

represents Word. 

Operation of checksum: 

Convert format of each data characters to ASCII code and add them up. For example, 

convert ’2’ to ASCII code ‘31H’, convert ’4’ to ASCII code ‘34H’ and the checksum is 

31Hex + 34Hex = 65H. 

 

Remark 

 Var1 and Var3 can be internal memory only. Var2 can be a string of texts only. 

Var4 can be constant only.  

 

Example 

Calculate the data length of "24" and checksum 

$0 = CHRCHKSUM("24", $10, 2) 

After the above operation, 4 is stored in $0 and 4 represents the data length is 2 

WORDS. The checksum stored in $10 is 65H. 
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 LOCKCOM / UNLOCKCOM (Lock COM Port / Unlock COM Port) 

Equation 

Lock COM Port 

Var1 = LOCKCOM (Var2, Var3) 

 

Unlock COM Port 

Var1 = UNLOCKCOM (Var2) 

 

Explanation 

LOCKCOM command locks COM port. Var1 is the response value after the 

communication, Var2 is the COM port and represents as constant 0(COM1), 1(COM2) 

or 2(COM3). Var3 is the communication time out time (unit is ms). When the specified 

communication time out time is reached, if the COM port cannot be locked, an error 

will be responsed. When Var3 is set to 0, it indicates that HMI will continuously wait 

without time limit. 

UNLOCKCOM command unlocks COM port. Var2 is the COM port and represents as 

constant 0(COM1), 1(COM2) or 2(COM3).  

 

Remark 

 Var1: Response value after communication 

1: Completed normally 

0: Failed 

 Var1 can be internal memory only. Var2 and Var3 can be constant only. 

 When the communication commands are used in different macros, such as 

Screen Cycle Macro, Clock Macro, Background Macro, Befor/After Execute 

Macro, ON/OFF Macro, if LOCKCOM and UNLOCKCOM commands are not used, 

the different macros may have interferences and causes the error result. To 

ensure the correct communication and not to interrupt the communication at 

the same time, it is recommended to use these two commands. 
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 When Var3 is set to 0, it indicates that LOCKCOM command will be executed 

twice and HMI will continuously wait without time limit. At this time, HMI may 

have no response at all. 

Example 

 
 

Explanation of LOCKCOM Command 

 

 

 

 

 

 

 

In the above macro commands, the communication commands are all used. When 

Background Macro is executed first, COM1 will be locked. At this time, the 

execution of ON Macro and Screen Cycle Macro commands will stop when 

reaching LUCKCOM (0,0) this command. After UNLOCKCOM command in 

Background Macro is executed, the execution of ON Macro and Screen Cycle 

Macro command will be activated again. This can avoid the interference and 

incorrect calculation or communication result.  

$0 = LOCKCOM(0,0) 

$1 = PUTCHARS($1, 3, 

300) 

 

Background 

Macro 

 

$0 = LOCKCOM(0,0) 

$1 = PUTCHARS($1, 

3, 300) 

Screen Cycle 

Macro 

$0 = LOCKCOM(0,0) 

$1 = GETCHARS($1, 

3, 300) 

Macro 

 

On 

 

Explanation of UNLOCKCOM Command 

 

 

 

 

 

 

If the macro commands is set as shown as the above, the user can lock the COM 

port and transmission data by using Background Macro, and unlock the COM port 

by using ON Macro. It means that the actions of locking COM port and unlocking 

COM port can be separated. 

$1 = PUTCHARS($1, 3, 300) 

Macro 

 

$0 = LOCKCOM(0,0) 

Background 

UNLOCKCOM(0) 

 

On 

Macro 
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 STATIONON (Station ON) 

Equation 

STATIONON (Var1, Var2) 

 

Explanation 

This command is used to enable the Var2 number of station of Var1 COM port. 

Var1 represents as constant 0(COM1), 1(COM2) or 2(COM3, for some models only). 

 

Remark 

 Var1 and Var2 can be internal memory or constant.  

 This macro command cannot be used When Communication Interrupt times 

then ignore box is checked (Options > Configuration > COM Port). 

 

Example 

Enable the first station of COM1 port. 

 
 

 STATIONOFF (Station OFF) 

Equation 

STATIONOFF (Var1, Var2) 

 

Explanation 

This command is used to disable the Var2 number of station of Var1 COM port. 

Var1 represents as constant 0(COM1), 1(COM2) or 2(COM3, for some models only). 

 

Remark 

 Var1 and Var2 can be internal memory or constant.  

 This macro command cannot be used When Communication Interrupt times 

then ignore box is checked (Options > Configuration > COM Port). 
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Example 

Disable the first station of COM1 port. 

 

 

 

3.14.3.9 Drawing 

 

There are various kinds of drawing commands. For more details, please refer to the 

following sections. 

 RECTANGLE (Draw a Rectangle) 

Equation 

RECTANGLE (Var1) 

 

Explanation 

This command is used to draw a rectangle on the screen. 

Var1 is the upper-left X-coordinate 

Var1+1 is the upper-left Y-coordinate 

Var1+2 is the width of the rectangle 

Var1+3 is the height of the rectangle 

Var1+4 is the color of the rectangle  

 

Remark 

 Var1 can be internal memory only.  
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Example 

When the Screen Open Macro command is set as  

 

and the Screen Cycle Macro is set as 

 

the user’s screen will look like the figure shown below. 

 

 

 LINE (Draw a Line) 

Equation 

LINE (Var1) 

 

Explanation 

This command is used to draw a line on the screen. 

Var1 is the starting X-coordinate 

Var1+1 is the starting Y-coordinate 

Var1+2 is the ending X-coordinate 

Var1+3 is the ending Y-coordinate 

Var1+4 is the width of the line 

Var1+5 is the color of the line 

 

Remark 

 Var1 can be internal memory only.  
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Example 

When the Screen Open Macro command is set as  

 
and the Screen Cycle Macro is set as 

 

the user’s screen will look like the figure shown below. 

 

 

 POINT (Draw a Point) 

Equation 

POINT (Var1) 

 

Explanation 

This command is used to draw a point on the screen. 

Var1 is the X-coordinate 

Var1+1 is the Y-coordinate 

Var1+2 is the color of the point 

 

Remark 

 Var1 can be internal memory only.  

 

Example 

When the Screen Open Macro command is set as  
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and the Screen Cycle Macro is set as 

 

the user’s screen will look like the figure shown below. 

 

 

 CIRCLE (Draw an Ellipse) 

Equation 

RECTANGLE (Var1) 

 

Explanation 

This command is used to draw an ellipse on the screen. 

Var1 is the X-coordinate of the center of the ellipse 

Var1+1 is the Y-coordinate of the center of the ellipse 

Var1+2 is the length of the ellipse 

Var1+3 is the width of the ellipese 

Var1+4 is the color of the ellipse  

 

Remark 

 Var1 can be internal memory only.  

 

Example 

When the Screen Open Macro command is set as  

 

and the Screen Cycle Macro is set as 
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the user’s screen will look like the figure shown below. 

 

 

 

3.14.3.10 Others 

 

For more details of other macro commands, please refer to the following sections. 

 Time Tick (Get the Time from System Startup to Present) 

Equation 

Var1=TIMETICK 

 

Explanation 

This command is used to get the time from system startup to present and save into 

the specified address. The time unit is ms. 

 

Remark 

 Var1 can be internal memory only.  

 

Example 

Get the time from system startup to present and save into $0. 

Revision May, 2010   3-369 



Chapter 3 Creating and Editing Screens  

 
 

 GETLASTERROR (Get the Last Error Value) 

Equation 

Var1 = GETLASTERROR 

 

Explanation 

This command is used to get last error value. If there is no error, the result of 

GETLASTERROR will be 0. Even if each Macro is executed simultaneously, the error 

messages will not affect the macro. For more details on error code information, refer 

to section 3.14.4 Macro Error Messages on page 3-374. 

 

Remark 

 Var1 can be internal memory only.  

 

Example 

Get the last error value and save into $0. 
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 # (Comment) 

Equation 

# Statement 

 

Explanation 

This command is used to insert macro descriptions and make the macro readable. 

Using this command will not affect the macro function. The user only need to put # 

symbol in front of the equation and the macro will become readable. To change the 

comment to be back to the equation, just remove the # symbol. 

 

Remark 

 Statement can be a string of texts or macro commands.  

 

Example 

When the comment is a string of texts:  

When the comment is a string of macro commands:  

 

 Delay (System Delay) 

Equation 

Delay (Var1) 

 

Explanation 

This command is used to delay the user setting time by system. Because DOP-B series 

HMI is a multiplexer system, a system delay may occur. Therefore, time set will be 

increased due to a System Busy condition and the condition that setting the time 

forward will not happen. Please note that too long delay time may result in slow 

response of HMI. The unit of delayed time is ms. 

 

Remark 

 Var1 can be internal memory or constant.  

 After Delay command is executed, HMI will stop the operation. The operation 

will resume after the delay time has elapsed (expired). 

 

Example 

Delay two seconds. 
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 GETSYSTEMTIME (Get System Time) 

Equation 

Var1 = GETSYSTEMTIME 

 

Explanation 

This command is used to get the system time. Var1 is the starting address of 

continuous 7Words in the internal memory address. 

Var1 represents Year 

Var1 + 1 represents Month 

Var1 + 2 represents Date 

Var1 + 3 represents Week 

Var1 + 4 represents Hour 

Var1 + 5 represents Minute 

Var1 + 6 represents Second 

 

Remark 

 Var1 can be internal memory or constant.  

 

Example 

Now the system time is 2009/02/27 FRI 13:20:06.  

This command gets the current system time, and stores it in $0 to $6. 

The user’s screen will look like the figure shown as below. 
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 SETSYSTEMTIME (Set System Time) 

Equation 

SETSYSTEMTIME (VAR1) 

 

Explanation 

This command is used to set the system time. Var1 is the starting address of 

continuous 7Words in the internal memory address. 

Var1 represents Year 

Var1 + 1 represents Month 

Var1 + 2 represents Date 

Var1 + 3 represents Week 

Var1 + 4 represents Hour 

Var1 + 5 represents Minute 

Var1 + 6 represents Second 

 

Remark 

 Var1 can be internal memory or constant.  

 The input number should be a valid number or the system will not allow the 

user to set the system time. For example, if a number of 8 is entered into the 

address of Var1+3 which represents Week, the system will determine the 

number of 8 is an invalid number and does not allow the user to change it. This 

is because the valid number for this address is from 1 to 7 (Monday to Sunday). 

 

Example 

Suppose that now the system time is set to 2009/02/27 FRI 13:25:34. 

The user’s screen will look like the figure shown as below. 

 

 

 

 

 

 

 

 

 

Revision May, 2010   3-373 



Chapter 3 Creating and Editing Screens  

 GETHISTORY (Get History Data) 

Equation 

Var1 = GETHISTORY (Var2, Var3, Var4, Var5, Var6) 

 

Explanation 

This command is used to get the history data.  

Var1 is the internal memory address where the data length is storeed. 

Var2 is the internal memory, constant, the buffer number of history buffer area. 

Var3 is the internal memory, constant, the starting address for sampling. 

Var4 is the internal memory, constant, the points for reading. 

Var5 is the internal memory, external controller address where the data is stored. 

Var6 is the internal memory, constant, the data type for reading. 

 

Remark 

 Var1 can be internal memory only. 

 Var2, Var3 and Var4 can be internal memory or constant. 

 Var5 can be the external controller address or internal memory. 

 Var6 can be internal memory or constant. 

0: Data, 1: Time, 2: Time and Data 

 

Example 

When the equation is set to $0 = GETHISTORY ($1, $2, $3, $4, $5), HMI can get the 

history data.  
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 EXPORT (Output Data) 

Equation 

EXPORT (Var1) 

 

Explanation 

This command is used to output the data to the external interface. The function of 

EXPORT macro command is the same as the function of Report List button element. 

Var1 represents the output interface: 

0: SD card 

1: USB disk 

2: Printer 

 

Remark 

 Var1 can be internal memory only. 

 

Example 

When the equation is set to EXPORT(0), HMI can export the data to a SD card. 
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3.14.4 Macro Error Messages 

When compiling, it will shows errors in output window for user to find out easily. The users 

can read error messages by macro. Once there is an error and the users execute a correct 

command before reading error messages, the error message will be overwritten. When 

executing each macro, each Macro error message will not be influenced by other macros.  

Error Messages While Editing 

 Code – 100 LABEL cannot be found 

There is no such LABEL that GOTO designates. 

 Code – 101 Recursion occurs 

This error message usually shows in sub-macro. The function of a sub-macro to call is 

called recursion whether the HMI calls it directly or not. Basically, recursion cannot be 

adopted for a sub-macro. You can use GOTO or FOR (infinite times) to replace it. 

 Code – 102 More than 10 nested FOR is used  

This error message statement is to warn the user not to use more than 10 nested FOR 

commands. The purpose is to avoid insufficient memory. The users can use GOTO or 

IF to replace it.  

 Code – 103 Sub-macro does not exist 

This error message means that there is no sub-macro in the program. For example, 

CALL 5 means CALL sub-macro 5. If the user does not edit sub-macro 5 in the program, 

this error message will display to warn the users. The purpose is to warn the users to 

be more careful when editing (reduce input error or avoid forgetting to edit the 

corresponding sub-macro) and prevent unexpected error 

 Code – 104 Number of NEXT is less than the number of FOR 

Numbers of NEXT and FOR should match. This error code is used to remind the user to 

find out the missing NEXT.  

 Code – 105 Number of FOR is less than the number of NEXT 

Numbers of FOR and NEXT should match. This error code is used to remind the user if 

there is any missing FOR.  

 Code – 106 Repeated LABEL 

This error message means that there are repeated LABELs in the same Macro. The 

program will be confusing with that. This may be caused by carelessness (an input 

error or forgetting to edit the corresponding sub-macro), and the user will get an error 

message during editing to help the user avoid unexpected error.  
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 Code – 107 There is RET in Macro 

This error message means that there is RET command in Macro. The RET command 

should be used for sub-macro to return program. But in Macro, it should use END not 

RET.  

 

HMI Macro Error Messages 

The users can read error messages by macro files. Once there is an error and the users 

execute a correct command before reading error messages, the error message will be 

overwritten. When executing each macro, each Macro error message will not be influenced 

by other macros.  

 Code – 10 GOTO Error 

This message means that there is a GOTO error in the macro.  

 Code – 11 Stack Overflow 

This message means that the stack in the macro is full. This may be caused by using 

too many sub-macros or executing different macros at the same time. This message 

appears to help avoid insufficient memory.  

 Code – 12 Empty Sub-macro 

This is a CALL sub-macro error. The sub-macro that is called should not be an empty 

sub-macro. This message is to avoid unexpected errors.  

 Code – 13 Data Read Error 

This is a data read error. Sometimes this may be caused by a memory data error, but 

most of the time it is an external controller data read error. 

 Code – 14 Data Write Error 

This is a data write error. Sometimes this may be caused by a memory data error, but 

most of the time it is an external controller data write error. 

 Code – 15 Divisor is 0 

This error message means that the devisor is 0 when performing a division operation. 
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Chapter 4 Examples 

4.1 How to Create a 16bits Recipe Data 

Create a new project first. After pressing  or click File > New, it can create a new project 

and the user will get a dialog box as shown in the following. 

 

 

Enter the project name, screen name, screen No. and select connected HMI, controller or printer. 

Then, click OK. It can create a new project in Screen Editor software program as shown in the 

following. 
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Click Options > Recipe, it can open Recipe Setup dialog box. Enable the recipe function and set 

the non-volatile area to HMI. In this example, the Length is set to 5, Group is set to 3 and 

Address is set to 1@D100. After pressing Input button, the user’s screen will look like the figure 

shown below.  

 
Then, press OK button to complete the Recipe settings.  

 

Next, click Options > Configuration, select Control Block tab. To control the read and write 

operation of recipes, in this example, Control Address is set to 1@D0 and the Length is set to 8. 

After complete the above settings, the user’s screen will look like the figure shown below. 
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Then, press OK button to complete the Control Block settings.  

 

In the editing area of HMI, create Numeric Entry elements to indicate recipe buffer (RCP0~RCP4), 

recipe table (RCP5~RCP19) and recipe write addresses (1@D100~1@D104). In addition, create 

three registers, Recipe Number Designation Register (RCPNO), Recipe Write (1@D5=2) Register 

and Recipe Read (1@D5=4) Register by using Numeric Entry elements as shown as the figure 

below.  

 

Perform Compile operation and download the screen data into HMI.  
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Then, user’s HMI screen will look like the figure shown below. As the default value of RCPNO is 

1, the history buffer RCP0~RCP4 will display the 1st number of recipe data. At this time, the 

recipe data has not been written into PLC address 1@D100~1@D104. Therefore, the display 

values of 1@D100~1@D104 are all 0. 

 
Press Write button on the screen and HMI will write the 1st number of recipe data into PLC 

address 1@D100~1@D104. At this time, the display value of 1@D100~1@D104 will become 1 

shown as the figure below. 
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Set RCPNO = 2 and the display value of history buffer RCP0~RCP4 will change to 2.  

 
 

Press Read button on the screen and HMI will read the recipe data in PLC and save the data in 

the 2nd number of recipe data.  

 
Then, the value of 2nd number of recipe data will be changed. 
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4.2 How to Create a 32bits Recipe Data 

Create a new project first. After pressing  or click File > New, it can create a new project 

and the user will get a dialog box as shown in the following 

 

Enter the project name, screen name, screen No. and select connected HMI, controller or printer. 

Then, click OK. It can create a new project in Screen Editor software program as shown in the 

following. 
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Click Options > 32bitss recipe, it can open 32bits Recipe Setup dialog box. In this example, 

two recipe tables are created, the write address is set to 1@D100 and the non-volatile area is set 

to HMI. In the 1st recipe table, set the Length to 5 and set the Group to 5. In the 2nd recipe table, 

set the Length to 5 and set the Group to 3.  

After pressing OK button, the user’s screen will look like the figure shown below.  

 

 

Then, click Save icon to complete the settings.  

 

Next, click Options > Configuration, select Control Block tab. To control the read and write 

operation of recipes, in this example, Control Address is set to 1@D0 and the Length is set to 8. 

After complete the above settings, the user’s screen will look like the figure shown below. 

Revision May, 2010   4-7 



Chapter 4 Examples  

 

Then, press OK button to complete the Control Block settings.  

 

In the editing area of HMI, create Numeric Entry elements to indicate recipe buffer (RCP0~RCP4), 

recipe table (RCP5~RCP19) and recipe write addresses (1@D100~1@D108). In addition, create 

three registers, Recipe Group Designation Register (RCPG), Recipe Number Designation Register 

(RCPNO), Recipe Write (1@D5=2) Register and Recipe Read (1@D5=4) Register by using Numeric 

Entry elements as shown as the figure below.  

 
Perform Compile operation and download the screen data into HMI.  
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Then, user’s HMI screen will look like the figure shown below. As the default value of RCPG is 0 

and RCPNO is 1, the value of history buffer RCP0~RCP4 and recipe table RCP5~RCP19 will be 

shown as 0. At this time, the recipe data has not been written into PLC address 

1@D100~1@D108. Therefore, the display values of 1@D100~1@D108 are all 0. 

 

Set RCPG=2, the recipe table RCP5~RCP19 will display the data of the 2nd group of the recipes 

and the history buffer RCP0~RCP4 will display the data of the 1st group of the recipes. The HMI 

screen will be shown as the figure below.  

 

At this time, the recipe data has not been written into PLC addresses 1@D100~1@D108, 

therefore, the display value will be 0 still.  
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Press Write button on the screen and HMI will write the 1st group of recipe data into PLC 

address 1@D100~1@D108. At this time, the display value of 1@D100~1@D108 will become 

111 shown as the figure below. 

 

Set RCPNO = 2, the 2nd group of recipe data will be displayed in RCP0~RCP4 as shown as the 

figure below.  

 
Press Read button on the screen and HMI will read the recipe data in PLC and save the data in 

the 2nd group of recipe data.  
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Then, the value of 2nd group of recipe data will be changed. 
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4.3 How to Use Windows Excel CSV File 

There are two kinds of format accepted by recipe editor. One is RCP file and the other is CSV file. 

RCP file can be opened and edited in Screen Editor software program only and CSV file can be 

created and edited in Microsoft Windows Excel environment. The following section describes 

how to create and edit the CSV file in Microsoft Windows Excel environment. 

 

After finishing the editing of the recipe data, the user can save the recipe file as Windows Excel 

CSV file. 

 

16bits Recipe 

When the user opens a 16bits recipe CSV file in Microsoft Windows Excel environment, the first 

row shows the setting value of data length and group, and the other rows shows the recipe data 

value. In this example, the Length is set to 5 and the Group is set to 3, i.e. it is a 5 x 3 recipe 

data.  
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32bits Recipe 

When the user opens a 32bits recipe CSV file in Microsoft Windows Excel environment, the first 

row shows the version of 32bits recipe data, i.e. RCP32-1.0.  

 

In the figure above, the left size shows the editing environment of Microsoft Windows Excel and 

the right size shows the 32bits recipe setup dialog box in Screen Editor software program. The 

1st group of the recipe data will be located in the upper area and the 2nd group of the recipe 

data will be located in the lower area. Please note that there must be a blank row between 

the data of two recipe table. 

For the settings, please refer to the following cross reference. 

Column of Excel File Setting Value of Recipe Data 

A Length 

B Group 

C 
Integral Digits (The digit number will be a real 
decimal number only when the data format is selected as 
Floating.) 

D 
Fractional Digits (The digit number will be a real 
decimal number only when the data format is selected as 
Floating.) 

E 

Data format: 
2：Signed Decimal 

3：Unsigned Decimal 

6：Floating 
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4.4 How to Use Multi-Language Function 

Create a new project first. After pressing  or click File > New, it can create a new project 

and the user will get a dialog box as shown in the following. 

 

Enter the project name, screen name, screen No. and select connected HMI, controller or printer. 

Then, click OK. It can create a new project in Screen Editor software program as shown in the 

following. 
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Click Options > Configuration, select Control Block tab. To control the multi-language 

selection, in this example, Control Address is set to $0 and the Length is set to 8. After 

complete the above settings, the user’s screen will look like the figure shown below. 

 

Then, press OK button to complete the Control Block settings.  

 

Next, click Options > Configuration, select Other tab (refer to the figure below). 
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Press Insert button to Add Chinese (ROC), English (english), Japanese (japan). The setting 

values are 1, 2 and 3 for each language respectively. 

     

 

In this example, the default setting is set to Chinese and all the language settings will also be 

shown in the window.  

 

Then, press OK button to complete the settings. 
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Create a Text element on the screen. Then, set the display text of Text element in different 

languages. 

     

The user can define the font, text size and text color by preference. 

 

In addition, create an Increment button element on the screen. In property setting of Increment 

button element, set the write address as the internal memory $7.  

 
In this example, we use three kinds of languages so the value of Limit should be set to 3. 

 

Set the setting value of Before Execute Macro as follows. This is a logical determination from 

multiple conditions. After switching to the last language, it will return to the first language.  

 

 

 

Revision May, 2010   4-17 



Chapter 4 Examples  

In property setting of the Increment button element, double click the tabs and enter the text in 

different languages. 

     

 

After complete the above settings, the user’s screen will look like the figure below. 

 

Select the Compile command and perform Compile operation to download the data into HMI.  
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Then, user’s HMI screen will look like the followings. The default display language is Chinese. 

The text of the Text element is changed to a different language by pressing the Increment 

button element. 
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4.5 How to Use Flash Transfer Function 

Flash Transfer is a program which is used to read the data of Historical Trend Graph, Historical 

Data Table and Alarm data. In this case, Historical Trend Graph and Alarm Historical Table are 

used for explanation.  

Create a new project first. After pressing  or click File > New, it can create a new project 

and the user will get a dialog box as shown in the following 

 

 

Enter the project name, screen name, screen No. and select connected HMI, controller or printer. 

Then, click OK. It can create a new project in Screen Editor software program as shown in the 

following. 
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Click Options > History Buffer Setup to add a history buffer data for reading the data of PLC 

corresponding address. Set the Read Address to $0 and select non-volatile area (Retained) to 

HMI shown as the figure below. 
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After OK button in History Setting dialog box is pressed, a history buffer is created shown as 

the figure below. 

 

Press OK button in History Buffer Setup dialog box to complete the settings. 

 

Next, click Options > Clock Macro to edit clock macro. After HMI is turned on and starting the 

initial setup, the clock macro is be executed automatically by clock setting time.  

 
 

Then, click Options > Alarm Setup to set the alarm. Two alarms are added. The trigger 

addresses are Internal Memory Address $100.0 and $100.1, and the non-volatile area is set to 

HMI shown as the figure below. 
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Press OK button to complete the alarm settings. 

 

Create a Historical Trend Graph element and an Alarm Data Table element on the screen. 

Complete the settings of Historical Trend Graph element shown as the figure below. Please 

make sure that the Buffer ID is selected.  
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Next, create two Momentary button elements in order to trigger ALARM 1 and ALARM 2. The 

addresses of ALARM 1 and ALARM 2 are $100.0 and $100.1 respectively. Then, create a Report 

List element and a Remove storage element on the screen. After complete the above settings, 

the user’s screen will look like the figure below. 

 
Click Tools > Compile command to perform Compile operation and download the screen data 

into HMI.  

 

At this time, user’s HMI screen will look like the figure below. Because the Clock Macro 

command ($0 = $0 + 1) is set, the user can see that there are some changes in Historical Trend 

Graph.  
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The user can press two Momentary button elements to enable and disable the alarms. The 

alarm data will be recorded in Alarm Data Table for user’s reference.  
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After Report List button is pressed, HMI will transfer the history buffer data and alarm data 

saved in non-volatile area into the connecting USB disk. When all of the data has been 

transferred into USB disk, the user can press Remove storage button to remove the USB disk. 

 

Connect the USB disk to user’s computer and open it. The user will find an auto-generated file, 

DopFlash.dft in the USB disk. The user only can use Flash Transfer function to open it.  

 

 

To execute Flash Transfer, select Start >Programs > Delta Industrial Automation > HMI > 

Screen Editor 2.00.07 > Flash Transfer and the following window will open. 
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Press  Open icon and the following dialog box will show up on the screen.  

 

Select the folder where DopFlash.dft is located. 

 

After OK button is pressed, the user’s screen will look like the figure below. 

 
The user can read the exported data from HMI by using Flash Transfer function. 
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4.6 How to Use Real Image Element 

Create a new project first. After pressing  or click File > New, it can create a new project 

and the user will get a dialog box as shown in the following. 

 

 

Enter the project name, screen name, screen No. and select connected HMI, controller or printer. 

Then, click OK. It can create a new project in Screen Editor software program as shown in the 

following. 
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Create a Real Image element on the screen. 

 
 

In property settings of the element, set the COM port to COM1 and the interface to RS232.  

 
After completing the property settings of the element, click Tools > Compile command to 

perform Compile operation and download the screen data to HMI. 
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Select the picture that the user wants to transfer shown as the figure below. 

 

To transfer the graphic file to HMI, a specified program, TestTransfer.exe is needed. Execute 

the TestTransfer.exe located at the default directory: 

C:\Program Files\Delta Industrial Automation\Screen Editor 2.00.07\Utility\ImgTrans 

 

 

After double-clicking TestTransfer.exe, the following dialog box will appear. 
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Select the communication protocol and interface, and set the file path of the image. Then, press 

Transfer button to transfer the image. 

 

If the image has been transferred successfully, the words, Connect Success will show in the 

dialog box. 

 

 

If the transmission has failed, the following error messages will pop up on the screen. At this 

time, please examine the settings and check if all wirings are well-connected.  
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When the image has transferred into HMI successfully, the user’s HMI screen will look like the 

figure below. 
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4.7 How to Create a Curve Element 

Create a new project first. After pressing  or click File > New, it can create a new project 

and the user will get a dialog box as shown in the following. 

 

 

Enter the project name, screen name, screen No. and select connected HMI, controller or printer. 

Then, click OK. It can create a new project in Screen Editor software program as shown in the 

following. 
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Click Options > Configuration, select Control Block tab and enable Auto reset flags function. 

To control the element, in this example, Control Address is set to $0 and the Length is set to 8. 

After complete the above settings, the user’s screen will look like the figure shown below. 

 

Ensure to check the Auto reset flags box. If this box is unchecked, the user will be required to 

reset the flags. 

 

Create a trend graph element. Set the Sample Flag to 1, Sample Number to 5, and Read Address 

to $100. The user’s screen will look like the figure shown below. 
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As the read address is set to Internal Memory $100, the sampling point will be $100、$101、

$102、$103 and $104. When Sample Flag is set to 1, it indicates that the sampling is enabled by 

the Control Block $2.0. 

 

Next, create five numeric entry elements which are used to input the value into $100~$104. 

Then, create a Set ON button element (Draw button) to trigger the sample flag of the trend 

graph.  

 

Click Tools > Compile command to perform Compile operation and download the screen data 

into HMI.  
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When sampling operation is performed, after the value is input into $100~$104, the HMI screen 

will look like the figure below. 
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Then, the user can press Draw button to get the Trend Graph shown in the following figure. 
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5.1 System Menu Introduction 

 Access System Menu 

1. Press SYS key on HMI panel for two seconds. 

2. Then press the display area on HMI screen 

3. The System Menu will then be displayed as shown the figure below.  

 

 
 

 Exit System Menu 

Press SYS button again for two seconds and the user can exit the system menu and return 

to the user screen.  

 

 Operating Methods 

1. The user can touch the icon on the screen directly to bring up the selected function 

screen.  

2. The user can press the function keys on HMI panel to select the desired function. 

Pressing  is able to select the desired icon. Pressing  is able to 

enter into the selected option. 

If the system menu is not selected, the ground color of the icon will be white color, e.g. 

. If the system menu is selected, the ground color of the icon will be changed to 

yellow color, e.g. . 
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 System Menu Flowchart 

 
TP Delay  

Set delay time of touch screen 

 
TP Force 

Set pressing force of touch screen 

 
Touch Panel 

 
TP Calibrate  

Touch screen calibration 

 
Date 

Set the date 

 
Time  

Set the time 
 

Date/Time 

 
Alarm Clock 

Set the alarm clock (Reserved) 

 
Contrast  

Adjust the contrast (Reserved) 

 
Brightness  

Adjust the brightness (Reserved) 
 

Display 

 
Gamma  

Adjust LCD Gamma value 

 
HMI 

Format HMI 

 
USB Disk 

Format USB disk 
(Reserved) 

 
CF Card 

Format CFcard 
(Reserved) 

 
Formatting 

 
SD Card 

Format SD card 
(Reserved) 

 
System Setting 

 
File Manager 

 
Copy File  

Copy the screen data file 

5-2 Revision May, 2010 



 Chapter 5 System Menu 

 
File Manager 

 
Multi-Screen File 

Multi boot display setting  

 
MISC.  

Miscellaneous settings 

 
Security 

Password table setup 

 
Volume 

Volume adjustment (Reserved) 

 
Audio 

 
Buzzer 

Buzzer sound effect 

 
System Setting 

 
COM Port 

Communication port 

 
COM1 

COM1 upload/download 

 
Standard Mode  

COM2 
COM2 upload/download 

Mode 1 COM1  COM2 Bypass 

Mode 2 COM1  COM3 Bypass 

 
Up/Download 

 
Bypass Mode Mode 3 COM2  COM1 Bypass 

 
Next Page 

 
System Info 

System Message 

 
Previous Page 

 
White Screen Test  

 
Black Screen Test  

 
Red Screen Test 

 
Green Screen Test  

 
HMI Doctor 

 
Blue Screen Test 
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Draw Line Test 

 
Buzzer/LED Test  

 
ADC Test  

 
USB Test 

 
Key Test 

 
HMI Doctor 

 
Color Screen Test 
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5.2 System Setting Menu 

When the ground color of the screen is in 

grayscale, it indicates that this is a preview 

window and it displays the setting screen. 

Clicking the icon directly is able to enter into 

the menu. After clicking the desired icon, a 

menu bar in blue ground color will show up at 

the bottom of the screen immediately. 

 

 

 

 

Return to System Menu  

 

 

 

 
 

 

Pressing   can switch the menu options. When the ground 

color of the option is in yellow, it indicates that this option is 

selected, e.g. . When the ground color of the option is in 

blue, it indicates that this option is not selected, e.g. . 
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1.  Touch Panel 

 The Touch Panel option under System Setting menu provides Set delay time of 

touch screen, Set pressing force of touch screen and Touch screen calibration, 

etc. functions as the figure shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 

      

 

 

 

 

 

This is the function menu bar.  is used to recover the default 

setting,   options are used to cycle through the options,  

 are used to change the setting values of the selected option and 

 is to exit this setting page.  
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1.1  TP Delay – Set delay time of touch screen  

This option is used to set the sensitivity of the touch screen. This means that the user 

can speed it up or slow it down, based on user’s own preference. Touching RIGHT 

icon is to decrease the delay time and speed the screen sensitivity up. Touching LEFT 

icon is to increase the delay time and slow it down. 

1.2  TP Force – Set pressing force of touch screen 

This option is used to set the pressing force of the touch screen. Touching LEFT icon 

is to reduce the pressing force to allow the user to enable the icon more easily. 

Touching RIGHT icon is to strengthen the pressing force to make the user not to 

enable the icon so easily. 

1.3  Calibrate – Touch screen calibration 

This option is used to calibrate the touch screen to ensure accuracy of the touch 

areas. There are three points on the touch screen that the calibration is based around. 

When entering into the Calibrate function, the user will find three front sight icons  

on the top-left, bottom-right, and the center of the screen. Please touch these three 

icons in turn to calibrate the touch panel. 

NOTE   

Please note that if the user does not touch the  on the center of these three 

calibration positions, a bigger position error may occur. Therefore, we recommend 

the user to use the specified touch pen to perform the calibration. Please refer to the 

following figures for correct calibration steps. 

Step 1 

 

Step 2 

 

Step 3 
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2. Date/Time 

 Set the date and time of HMI. Each touch of Up and Down icons is to increment 

and decrement the value by 1. Please note that the selected option will be lit in 

red color as shown the figure below.  

 
 

 

 

 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
CANCEL 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 

      
 

2.1  Date – Set the date 

 Set the values for the calendar fields Year, Month, Day of Month in 

order by touching UP and DOWN icons.  

This is the function menu bar.   are used to cycle 

through the date and time settings,   are used to change 

the setting values of the date and time,  is used to cancel 

the setting,  and  is to exit this setting page. 
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2.2  Time – Set the time 

 Set the values for the clock fields Hour, Minute, Second in order by 

touching UP and DOWN icons. 

2.3  Alarm Clock – Set the alarm clock (Reserved) 

 

3.  Display (LCD Display) 

 This option is used to set the LCD display settings. When the ground color of the 

option is in black, it indicates that this option is reserved and cannot be set. 

Please refer to the figure below: 

 
 

 

 

 

 

 

 

  

 are used to cycle through the options,   are used to change 

the setting value, and  is used to exit this setting page. 

  is used to recover the default setting, This is the function bar. 

 

 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 
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3.1  Contrast – Adjust the contrast (Reserved) 

3.2  Brightness – Adjust the brightness (Reserved) 

3.3  Gamma – Adjust LCD Gamma value 

 

4. File Manager 

 For the functions provided by File Manager, please refer to the figure below: 

 
 

 

 

 

 

 

 

 

 

 

This is the function bar.   are used to cycle through the 

functions,  is used to choose the desired functions, and  is 

used to exit this setting page. When the ground color of the option 

is in yellow, it indicates that this option is selected, e.g. . 

 

 Cross Reference of Function Keys and Screen Icons 

 
LEFT 

 
RIGHT 

 
CLICK 

 
BACK 
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4.1  Formatting  

This option is used to format the HMI internal memory or external memory. If the 

ground color of the icon on the screen is in black, it indicates that this option is 

reserved and cannot be set.  

 

 

 Cross Reference of Function Keys and Screen Icons 

 
HMI 

 
USB 

 
CF 

 
SD 

 
BACK 

     

4.1.1  HMI – Formatting HMI 

Touching  icon or press  function on HMI panel, a confirm dialog box 

will display on the screen to ask if the user wants to format HMI memory. Press 

Sure button is to format HMI memory directly and press Cancel is to cancel the 

formatting operation.  

4.1.2  USB Disk – Format USB disk (Reserved)  

4.1.3  CF Card – Format CF card (Reserved) 

4.1.4  SD Card – Format SD card (Reserved) 

 

 

Revision May, 2010   5-11 



Chapter 5 System Menu  

4.2  Copy File – Copy the screen data file 

This option is used to copy the files between internal and external memory. When 

using this option, entering a highest priority password is needed.  

 

 

 

Designation Directory Location 

 
Source Directory Location 

 

 

 

 

 

 

 

 

  are used to move the disk,  is used to accept the changes,  

is used to copy the files, and  is used to exit this setting page. 

 are used to cycle through the source/designation directory location,  

 

 Cross Reference of Function Keys and Screen Icons 

 
UP 

 
DOWN 

 
CLICK 

 
LEFT 

 
RIGHT 

 
COPY 

 
BACK 

       

 

 Notes 

 HMI does not allow the user to copy the disk directly.  

 Regarding the file directories, only HMI-000 ~ HMI255 are provided.  

 When copying the files, it is recommended to remove the designation 

directory first and then copy the file source directory. 
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 When New… is selected, HMI will search the unused directory from HMI-000 

and HMI-255 and create a designation directory for use.  

 If the screen data file in the source directory is password protected, HMI will 

ask the user to enter the highest priority password or the copy function 

cannot be executed.  

 

 

4.3  Multi-Screen File – Multi boot display setting 

This option is used to set the boot display of the screen data files saved in HMI 

internal and external disk. 

 

 

 

Screen data file directory Preview window 

 

 

 

 

 

 

 

 

 

  are used to cycle through the file directories,  is used to 

select the desired directory,  is used to determine the setting, i.e. 

set the selected directory to be the directory of boot display, and  

is used to exit this setting page. 
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 Cross Reference of Function Keys and Screen Icons 

 
CLICK 

 
UP 

 
DOWN 

 
ENTER 

 
BACK 

     

 

 Notes 

 Regarding the file directories, only HMI-000 ~ HMI255 are provided.  

 When HMI is powered on and started, if the directory of the boot display is 

missing, HMI will automatically use the screen data file but will not change 

the file directory of the boot display. Therefore. If the directory of the boot 

display is found at next startup, HMI will use it as the default boot display 

still. 

 When the directory of the boot display is stored in the external memory, the 

non-volatile data will be saved in the directory of the boot display no matter 

the non-volatile data is set to be saved in internal or external memory. 

 

5.  MISC (Miscellaneous settings) 

 The settings include the followings: 

 Touch Cursor 

 ScreenSaver Time 

 Boot Delay Times 

 Default Language 

 Blue LED Function Mode 

 Boot Display 
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 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 

      

 

6. Security (Password table setup) 

 This option is used to set HMI password security level. The highest level is 7 and 

the lowest level is 0. When this password table is opened, the user can only view 

or change passwords with security levels lower than the user’s. Users cannot 

change or view those passwords with higher security settings. However, if the 

user has the highest priority password, then he/her can view and change all the 

password settings.  

 

 are 

used to move the 

password security 

level. 

 

 

 

 

 

 

  are used to move the selected button,  is used to 

press the button, and  is used to exit this setting page. 

 

 Cross Reference of Function Keys and Screen Icons 

 
LEFT 

 
RIGHT 

 
CLICK 

 
BACK 
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7. Audio 

 For the functions provided by this option, please refer to the figure below: 

 
 

 

 

 

 

 

 

 

 are used to cycle through Volume and Buzzer options,   are 

used to change the setting values, and  is used to exit this setting page. 

  is used to recovery the default setting, This is the function bar. 

 

 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 

      

 

7.1  Volume – Volume adjustment (Reserved) 

This option is used to adjust the volume. Touching LEFT icon is to decrease the 

volume and touching RIGHT icon is to increase the volume. 

 

7.2   Buzzer – Buzzer sound effect 

This option is used to adjust the buzzer sound. Touching LEFT icon is to decrease 

the buzzer sound and touching RIGHT icon is to increase the buzzer sound. 
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8.  COM Port 

 For the functions provided by this option, please refer to the figure below: 

 

 are used to cycle through the options,   are used to change 

the setting value, and  is used to exit this setting page. 

  is used to recover the default setting, This is the function bar. 

 

 

 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 
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5.3 Up/Download Menu 

 There are two kinds of communication modes when connecting HMI to PC through COM 

serial port. 

1. Standard Mode 

2. Bypass Mode 

 
 

 Cross Reference of Function Keys and Screen Icons 

 
LEFT 

 
RIGHT 

 
CLICK 

 
BACK 

    

 

1.  Standard Mode 

 When this mode is selected, COM serial port is connected to PC directly and the 

data upload and download is performed through Screed Editor software 

program. There are COM1 and COM2 two communication ports for selection.  
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 Cross Reference of Function Keys and Screen Icons 

 
COM1 

 
COM2 

 
BACK 

   

 

1.1  COM1 (COM1 upload/download) 

When COM1 is set, it indicates that the data transfer will be accessed through this 

COM serial port via the settings of Screen Editor software program.  

 

1.2  COM2 (COM2 upload/download) 

When COM2 is set, it indicates that the data transfer will be accessed through this 

COM serial port via the settings of Screen Editor software program.  

 

2.  Bypass Mode -  

 Using the Bypass mode, the data transferred by the PC can be received by the HMI 

COM ports and then sent to another COM port of the HMI to the PLC. When 

planning the system, the user can use this function to update the program of the 

PLC immediately. For example, when COM1 port of the HMI is connecting to the 

PLC, and the PLC program needs to be updated during operation, the user can 

select Bypass mode to transfer the new PLC program in the PC to the HMI via the 

COM2 port of the HMI and then download the new PLC program to the PLC via the 

COM1 port of the HMI. 
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 Cross Reference of Function Keys and Screen Icons 

 
1  2 

 
1  3 

 
2  1 

 
LEFT 

 
RIGHT 

 
ENTER 

 
BACK 

       

 

2.1 Mode 1 – COM1  COM2 Bypass 

When this mode is selected, it indicates COM2 port of HMI is connected to the PLC, 

the user can transfer the data in the PC to the HMI via COM1 port of the HMI and then 

transfer the data to the PLC via the COM2 port of the HMI (COM1 is the data source 

port and COM2 is the data transfer port).  

 

2.2 Mode 2 – COM1  COM3 Bypass 

When this mode is selected, it indicates COM3 port of HMI is connected to the PLC, 

the user can transfer the data in the PC to the HMI via COM1 port of the HMI and then 

transfer the data to the PLC via the COM3 port of the HMI (COM1 is the data source 

port and COM3 is the data transfer port).  

 

2.3 Mode 3 – COM2  COM1 Bypass 

When this mode is selected, it indicates COM1 port of HMI is connected to the PLC, 

the user can transfer the data in the PC to the HMI via COM2 port of the HMI and then 

transfer the data to the PLC via the COM1 port of the HMI (COM2 is the data source 

port and COM1 is the data transfer port).  
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5.4 System Info Menu 

 For the functions provided by this option, please refer to the figure below: 

 

 

 

 

CPU Clock 
Model Type 

Firmware Version 

Flash ROM Sixe 

Current Date 

and Time 

Connecting 

External 

Controller 

Battery Capacity 

No Information about the USB device 

Connecting USB 

Interface 

 

 

 Function Keys 

PREVIOUS PAGE NEXT PAGE EXIT 
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5.5 HMI Doctor Menu 

This option provides simple text programs to help the user perform simple and easy hardware 

testing. There are seven options available: LCD, Touch Panel, Buzzer, LED, USB, ADC Channel, 

and Hot Key. Please refer to the figure below. 

 

 

 

 

 

 

When the ground color of the screen is in 

grayscale, it indicates that this is a preview 

window and it displays the setting screen. 

Clicking the icon directly is able to enter into 

the menu.  

Return to System Menu 

 

 

 

 

 

 

 

 

 
 can switch the menu options.  . Pressing 

When the ground color of the option is in yellow, it indicates that this 

option is selected, e.g. . When the ground color of the 

option is in blue, it indicates that this option is not selected, e.g. 

 

 Function Keys 

 are used to cycle through the options,  is used to enter into the 

selected option, and  is used to implement HMI Doctor setup. 
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1.  White Screen Test 

 This option is used to test and detect if there is any dark pixel (unlit pixel) or the 

similar defect shown on the screen.  

 

2.  Black Screen Test 

 This option is used to test and detect if there is any red, blue, green, or white 

bright pixel shown on the screen.  

 

3.  Red Screen Test 

 This option is used to test and detect if there is any dark pixel (unlit pixel) or the 

similar defect shown on the screen.  

 

4.  Green Screen Test 

 This option is used to test and detect if there is any dark pixel (unlit pixel) or the 

similar defect shown on the screen.  

 

5.  Blue Screen Test 

 This option is used to test and detect if there is any dark pixel (unlit pixel) or the 

similar defect shown on the screen.  

 

6.  Draw Line Test 

 This option is used to test and detect the displayed drawing line position on the 

screen and the actual drawing line position of the touch screen. If there is 

deviation and the deviation is excessive, please use Touch Screen Calibration 

function to calibrate it. 

 

7.  Buzzer/LED Test 

 Test if a buzzer sound is heard or not. 

 Test if red, blue and green LEDs is lit or not. 
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8.  ADC Test  

 Test if ADC channel changes correctly or not. It includes pressing force, system 

voltage and temperature, etc. settings. 

 

9.  USB Test 

 Test if USB disk is connected correctly. Ensure to switch USB Device and USB Host 

when testing.  

 

10.  Key Test 

 Test if the function keys are pressed normally. When pressing ~  keys on 

HMI panel, the corresponding icons will show on the screen. If there is no 

corresponding icon shown on the screen, it indicates this key is damaged.  

 

11.  Color Screen Test 

 Color level and saturation test 
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Appendix A List of Functions Added 

A.1 New Macro Commands  

 EXPORT 

The function of EXPORT macro command is the same as the function of Report List button 

element.  

Equation: EXPORT(Var1) 

Var1: It can be an internal memory or a constant. 

0: Export the data to SD card 

1: Export the data to USB disk 

2: Export the data to the printer for printing it out 
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 IMRCP16/32, EXRCP16/32  

 
IMRCP16/32 and EXRCP16/32 macro commands are used to import and export the recipe data. 

Export 16bits recipe 

Equation: Var1 = EXRCP16(Var2, Var3) 

Export the 16bits recipe data in Var2 to the external memory Var3 (in Windows Excel CSV 

file), and store the result in Var1. 

Import 16bits recipe 

Equation: Var1 = IMRCP16(Var2, Var3) 

Import the 16bits recipe data in Var2 from the external memory Var3 (in Windows Excel 

CSV file), and store the result in Var1. 

Export 32bits recipe 

Equation: Var1 = EXRCP32(Var2, Var3) 

Export the 32bits recipe data in Var2 to the external memory Var3 (in Windows Excel CSV 

file), and store the result in Var1. 

Import 32bits recipe 

Equation: Var1 = IMRCP32(Var2, Var3) 

Import the 32bits recipe data in Var2 from the external memory Var3 (in Windows Excel 

CSV file), and store the result in Var1. 

 

Explanation: 

Var1: Response value after communication 

1: Completed normally 

0: Failed 
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Var2: Address of import/export data 

Var3: External memory 

2: USB disk. 

3: SD card. 

 

For example: 

Suppose that the user needs to export a 16bits recipe data to the USB disk.  

First, click Options > Recipe command from the menu bar to create a 16bits recipe data shown 

as the figure below. 

 

Next, create a Momentary button on the screen. 
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In property setting of the button element, set On macro command as follows. 

 

 

FILLASC($100, “rcp”) Set the file name as RCP. 

$6789 = EXRCP16($100, 2) Export the recipe data in $100 to USB disk and store 

the result in $6789. 

 

Perform Compile operation and download the screen data to HMI screen. The user’s screen will 

look like the figure below. When the EXPORT button is pressed, the 16bits recipe data will be 

converted in Windows Excel CSV file and exported into USB disk immediately.  
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The recipe file which is exported to the USB disk. 

 
 

 

 STATIONON/STATIONOFF 

The user can use STATIONON / STATIONOFF macro commands to enable / disable the 

communication between HMI and the designated external controllers.  

Equation: STATIONON (Var1, Var2) 

 STATIONOFF (Var1, Var2) 

Var1 and Var2 can be an internal memory or a constant. 

Var1: Communication port 

0: COM1 

1: COM2 

2: COM3 

Var2: PLC Station number 
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A.2 Print Typesetting - Custom Print 

In Print Typesetting dialog box, Custom Print option is available to meet user’s total printing 

needs. 

 

The corresponding functions of each register addresses are described in the following table.  

$0 Read address of screen Designate the desired print screen. When the setting 

value is 0, all screens shown in the Print Typesetting 

dialog box will be printed out.  

$1 Left Set the print starting address of X coordinate  

$2 Top Set the print starting address of Y coordinate  

$3 Width Set the width of the printing range. 

$4 Height Set the height of the printing range. 

The user can use this function with the functions of printer flag, report list element and export 

macro command, etc.  
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A.3 New Button Elements  

 Calibration  

When the Calibration button element is pressed on the screen, the user is able to execute 

Calibration function directly and does not need to enter into system menu.  

 
 

 Language Changer  

When the Language Changer button element is pressed on the screen, the user is able to 

change the display language directly.  
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How to use Language Changer element: 

First, click Options > Configuration, select Other tab to enable multi-language user interface 

and add the display languages.  

 
 
After complete the above settings, create three elements on the screen. 

1. Create a Momentary button element. Double click the Chinese tab and enter “中文版” in 

Chinese. Double click the English tab and enter “ENGLISH VERS” in English. 

     

2. Create a Language Changer button element. In property setting of the Language Changer 

button element, specify the Language setting to “中文”. 

3. Create another Language Changer button element. In property setting of the Language 

Changer button element, specify the Language setting to “ENGLISH”. 
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Then, perform Compile operation and download the screen data to the user’s HMI screen 

shown as the figure below. 

 

When ENGLISH button is pressed, the above screen will display. 

 

 

When 中文 button is pressed, , the above screen will display. 
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A.4 New Input Element 

 Barcode Input 

This element is used to receive the barcodes which are scanned by a barcode reader through 

USB interface. There are two options, Touch and Active in Input mode drop-down list.  

When Input Mode is set to Touch: 

 

If Input Mode is set to Touch, when touching the barcode input element on the screen, it will 

enter into the waiting status to wait to receive the scanned barcodes. Touching the barcode 

input element again can release the waiting status. If there are more than one barcode input 

elements on the screen, after the first barcode input element receives the scanned barcode, the 

system will not receive the next scanned barcode automatically. To receive other scanned 

barcodes, the user needs to touch the other barcode input elements in sequence manually. 

If the user wants to modify the barcode data manually, the user must set Popup Bit option. Once 

the bit turned to ON, a keypad element will pop up on the screen for the user to enter the values 

manually. 

 

When Input Mode is set to Active: 
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If Input Mode is set to Active, it needs to trigger the InterLock Address first. After the InterLock 

Address is triggered, the barcode input element will enter into the waiting status to wait to 

receive the scanned barcodes. If there are more than one barcode input elements on the screen, 

after the first barcode input element receives the scanned barcode, the system will receive the 

next scanned barcode automatically. To release the waiting status, the user needs to reset the 

InterLock Address of the barcode input element. 

 

If the user wants to modify the barcode data manually, the user must create a keypad element 

on the screen first. Once the InterLock Address of the barcode input element is triggered, the 

user can use the keypad element to enter the values manually. 

Please note that the Popup Bit option is disabled when Input Mode is set to Active. 
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A.5 New Curve Element 

 Curve Input 

 

Create a Curve Input element on the screen. Set the Sample Number to 4, and Read Address 

to $0. When Read Address is set to$0, the addresses for each sample number are $0, $1, $2 and 

$3 respectively. 

 

Create four numeric entry elements on the screen and the addresses are $0、$1、$2 and $3 

respectively. After completing the property settings, perform Compile operation and download 

the screen data to the user’s HMI screen. To set the value, the user can select the desired value 

on HMI screen directly or use the numeric entry element to enter the setting value.  
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A.6 Show Disk Access Error Message 

When this option is set, if an error occurs when accessing the alarm, history buffer, and recipe 

data via USB disk, an error message will show up on the screen to alert the user.  
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A.7 Additional Internal Parameters 

There are several additional internal parameters in the drop-down list. When Device Type 

drop-down list is activated, it displays a list of internal parameters, from which the user may 

select one. 

   
 

 

 

Name Explanation Attribute 

TP_Status Touch Status Read only 

TP_X Touch X coordinate  Read only 

TP_Y Touch Y coordinate Read only 

Time_Year Year Read / Write 

Time_Month Month Read / Write 

Time_Day Day Read / Write 

Time_Hour Hour Read / Write 

Time_Minute Minute Read / Write 
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Name Explanation Attribute 

Time_Second Second Read / Write 

Battery_Voltage 
Remained voltage percentage of 

backup battery 
Read only 

NET_IP1 Read only 

NET_IP2 Read only 

NET_IP3 Read only 

NET_IP4 

HMI IP Address 

For example, if HMI IP address is 

set to 192.168.0.1, 

NET_IP1 = 192 

NET_IP2 = 168 

NET_IP3 = 0 

NET_IP4 = 1 
Read only 
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A.8 Invisible Address 

When this option is set to On, this button element will be invisible. The elements which support 

this function include: all button elements, multistate indicator element, numeric entry element, 

character element, and barcode input element. 
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A.9 Auto Reboot After Firmware Upgrading 

When this option is selected, HMI will automatically restart (power off and then on) after the 

firmware upgrading is completed. 
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A.10 USBCommMode (Data Transfer via USB Disk) 

USBCommMode is a new option provided in HMI System Menu and used to transfer (upload and 

download) the data via USB disk. After the firmware is updated, the user can press SYS key to 

enter into the System Menu. Touch System Setting icon on the screen to enter into System 

Setting Menu. In the System Setting Menu, choose MISC. icon shown as the figure below. Then, 

change the setting value of USBCommMode to 1 and connect HMI to PC USB port again.  

 

Touch MISC. icon 

 

 

Select USBCommMode option 
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When USBCommMode is set to 0, it indicates the traditional data transfer mode is selected. 

When USBCommMode is set to 1, it indicates the new data transfer mode via USB disk is selected. 

After setting USBCommMode to 1, connect HMI to PC USB port again. Then, double click “My 

Computer” icon on the desktop to see if a removable device named DELTA is connected or not. 

If it is connected, it means that the user can upload and download files from and to USB disk by 

using Screen Editor software program.  

This new function is compatible with Microsoft Windows XP, Windows Vista, and Windows 7 

operating systems. 
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B.1 Upload and Download DVP Series PLC Programs 

There is a new upload and download button provided on the system menu for upload and 

download the Delta DVP series PLC programs. The users can use this new function to upload 

and download the PLC programs directly. The following sections describe how to use this new 

function.  

 

1. Press SYS key for two seconds to enter into the system menu and touch Up/Download icon. 

 

 

2. Press  button to enter into Transfer Mode. 
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3. As shown as the figure below, to transfer PLC programs, the user should select the COM Port 

First. After COM port is selected, HMI will search the connecting DVP series PLC 

automatically.  

  

 
 

4. When the connecting DVP series PLC is found, the user can touch Upload icon to upload the 

PLC programs or touch Download icon to download the PLC programs.  
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Notes: 

1. The file name of PLC programs should be DVP-xxx.dvp (xxx must be a number between 000 

 to 999). 

2. If the PLC program is a new file, select New.. and then touch Upload icon on the screen to 

add it into the file directory. 

3. The supporting version and series of DVP series PLCs are listed in the table below:  

DVP Series  

PLC  

Support Password Examination 

Limit Function 

Support Verification Code Limit 

Function 

ES X X 

ES2 V1.0 and later version V1.0 and later version 

EX X X 

EC X X 

SS X X 

SA V 1.7 and later version V 1.7 and later version 

SX V 1.7 and later version V 1.7 and later version 

SC V 1.5 and later version V 1.5 and later version 

SV V 1.2 and later version V1.3 and later version 

EH X X 

EH2 V 1.1 and later version V1.3 and later version 

EH2-L V1.0 and later version V1.0 and later version 

 

4. HMI Transfer Mode is available for uploading and downloading DVP series PLC programs 

(*.dvp) only. It is not provided for the upload and download of the subroutine, ladder 

diagram, SFC chart, note of device name and row, non-volatile data, label structure, symbol 

structure, etc. data. 
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Appendix C Multi-Link Connection 

This chapter describes the connecting methods used to connect multiple HMIs to one or mor 

external controllers, i.e. PLCs.  

The connecting method for multi-link connection is shown as the figure below. The Ethernet 

and COM2 serial port of HMIs are used.  

 

HMI 1 

172.16.190.1 

 

HMI 3 

172.16.190.3 

 

 
Ethernet 

COM2 / RS-485 

HMI 2 reads the data of 

PLC 1 via Ethernet 

HMI 3 reads the data of 

PLC 1 via Ethernet 

Ethernet 

PLC 1 

HMI 2 

172.16.190.2 

 

 

 

 

 

 

 

 

 

 

 

 

 

In the figure above, three HMIs, HMI 1, HMI 2 and HMI 3 are connected via Ethernet.  

Only HMI 1is connected to PLC 1 by using COM2 serial port through RS-485 communication. 

HMI 2 and HMI 3 are not connected to any external controller. However, through 1:N connection, 

HMI 2 and HMI 3 are able to access the registers of PLC 1 via Etherent.  
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The methods for setting each unit are as follows: 

Setting Methods of HMI 1 

1. Click Options > Configuration > COM Port.   

2. Press Add button to add a PLC connection under COM2 Base Port 

3. Set HMI station number to 1, select RS-485 interface and set the communication protocol 

settings as [9600, 7, Even, 1]. 

4. In Multi-link option, set Active mode to Host.  
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5. Set HMI IP address for Ethernet to 172.16.190.1 and press OK to complete the settings.  

 

6. Create a Numeric Entry element on the screen so as to read the internal register D0 of PLC 1. 

 

7. After finishing the element settings, perform the compile operation and download the 

screen data to HMI 1. 
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Setting Methods of HMI 2 

1. Click Options > Configuration > COM Port.   

2. Press Add button to add a PLC connection under COM1 Base Port 

3. Set PLC station number to 1. 

4. In Multi-link option, set Active mode to Client and set IP address to 172.16.190.1 (IP 

address of HMI 1). 

 
 

5. Set HMI IP address for Ethernet to 172.16.190.2 and press OK to complete the settings.  
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6. Create a Numeric Entry element on the screen so as to read the internal register D0 of PLC 1. 

 

 

7. After finishing the element settings, perform the compile operation and download the 

screen data to HMI 2. 
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Setting Methods of HMI 3 

1. Click Options > Configuration > COM Port.   

2. Press Add button to add a PLC connection under COM3 Base Port 

3. Set PLC station number to 1. 

4. In Multi-link option, set Active mode to Client and set IP address to 172.16.190.1 (IP 

address of HMI 1). 

 
 

5. Set HMI IP address for Ethernet to 172.16.190.3 and press OK to complete the settings.  
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6. Create a Numeric Entry element on the screen so as to read the internal register D0 of PLC 1. 

 
 

7. After finishing the element settings, perform the compile operation and download the 

screen data to HMI 3. 

Then, connect PLC 1 to HMI 1, and connect HMI1 to HMI 2 and HMI 3. After power on all the 

connecting devices, a multi-link connection is established.  
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