How to use VNC Viewer to connect with HMI

VNC Viewer User Manual

VNC (Virtual Network Computing ) is a PC software used to help the
customers view and check the same screen shown on W series of HMI at the
production site, and control the manufacturing process via Ethernet. No matter
where you are, remote controlling is not an arduous task at all.

Support HMI of W Series, includes W105B, W127B and W157B.

l. Connection introduce for HMI

& Create HMI Project File
Start DOPSoft software program for w series and click File > New
or click New icon to create a new project. Then, click Element >
Input > Numeric Entry to create two numeric entry elements ($3
and $6) on the screen. In this case, W105B type DOP W series

HMI is used.
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Use Screen Cycle Macro and enter the following commands in macro
command window.

TEHEB % B B =3 @ | Sereen 1 [Screen Cycle Macro]

153 53 + 1
1] 56 + 3
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Click Options > Configuration > Network App > LocalHost, check the
Application (Net App VNC) function Enable. Then, press OK button to finish

the settings.

© ™y

L LocalHost | SMTP
Main
m] Localhost
EMI EMI
Contral Block
- upload/download port 12346 2 Interface
L .
ot Modbus TCP Server Port 302 2 Interface
rn
‘-—/_‘- Network App(eServer)
- Ensble Password 12345678
Default @?
% Scan Time 100 = (ms)
° Port 12343 T
Others
-

Network App
Net App (VNC)

Enable Password 12343678

Port 5900 < Interface

| ook [ caa |

After finishing above setting, please compile and download all screen data

to HMI.
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[I.  VNC Setting
There are three ways to use VNC Viewer to connect with HMI.

® Computer Software

® \Web Browser

® Android App

a. Computer Software

& Software installation
Please following the below URL link to download VNC software which
adapt the operating system.
http://www.realvnc.com/download/vnc/latest/
After double clicking VNC-5.2.0-Windows file downloaded from the
website exe file, the following dialog box will appear. Click on Run button
to install VNC.

Please click on Next.
(8] VNCrsetup [

n VNC?Setup Wizard
‘ This will install VMC 5.2.0 on your computer.

If & previous version is detected, and connections to VMNC
Server in Service Mode are currently in progress, users will be
temporarily disconnected. Users can immediately reconnect as
soon as VMG Server upgrades.

~

Users connected to VMG Server in User Mode will not be
disconnected. VNC Server in User Mode is not upgraded until
the next time it is started.

Click Mext to continue, or Cancel to exit Setup,

Mext = ] [ Cancel



http://www.realvnc.com/download/vnc/latest/
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Please choose | accept the agreement, and then click on Next.

i .’
iB) VNC?Setup [ESN AR

License Agreement n
Please read the following important information before continuing. c

Please read the following License Agreement. You must accept the terms of this
agreement before continuing with the installation.

WMC EMD LISER. LICEMSE AGREEMENT -

IN ORDER. TO INSTALL ANY PART OF THE SOFTWARE ({AS DEFIMNED BELOW),
AMDfOR TO RETAIM THE SERVICES OF REALVMC, YOU MUST FIRST ACCEPT

THE TERMS AMD COMDITIOMS OF THIS AGREEMENT. BY USING ALL OR ANY
PORTION OF THE SOFTWARE YOU ACCEPT ALL THE TERMS AMD COMDITIONS

OF THIS AGREEMENT. YOU AGREE THAT THIS AGREEMENT IS ENFORCEABLE

LIKE ANY WRITTEN NEGOTIATED AGREEMENT SIGMNED BY YOU. IF YOU DO

MOT AGREE THEM DO NOT INSTALL OR. USE ANY PART OF THE SOFTWARE. BY
INSTALLIMG AMY LUPDATED VERSION OF THE SOFTWARE WHICH MAY BE MADE =~ ™

i@ I accept the agreement

(7 I do not accept the agreement

[ < Back ][ Mext = ][ Cancel

Please check all components, and then click on Next.

i .’
iB) VNC?Setup o= |

Select components n
Which components should be installed? c

Select the compaonents you want to install; dear the components you want to
uninstall,
A separate installer will launch for each selected component,

Click Mext when you are ready to continue,

YMC Server
- [¥] WNC Mirrar Driver
i [#] WNC Printer Driver
WMC Viewer

< Back ][ Mext = ] [ Cancel
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Select the default directory C:\Program Files\RealVNC\VNC Server, and
click on Next button for the next step. To select a directory other than the
default directory, click Browse.

iB) VNC?Setup [ESNEE

Select VNC Server Location N
Where should YMC Server be installed? c
VMG Server will be installed in the following folder.

To continue, dick Mext, If you would like to select a different folder, didk Browse.
‘\Program Files\Real\NC\VNC Server
[ < Back ][ Mext = ] [ Cancel ]

Select the default directory C:\Program Files\RealVNC\VNC Viewer,
and click on Next button for the next step. To select a directory other
than the default directory, click Browse.
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p
i3 WNC?Setup =1L=

Where should YMC Viewer be installed?

Select VNC Viewer Location Vn

VMG Viewer will be installed in the following folder.

To continue, dick Mext, If you would like to select a different folder, didk Browse.

C:\Program Files\RealVMNCWHC Viewer

[ < Back ][ Mext = ][ Cancel ]

User could check create a VNC Viewer desktop icon option or not and
then click on Next.

.
i3 WNC?Setup =1L=

Which additional tasks should be performed?

Select Additional Tasks Vn

Select the additional tasks you would like Setup to perform, then dick Mext.

Additional icons:

[] Create a VMC Viewer desktop icon

< Back ][ Mext = ] [ Cancel

(o))
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Please check the Add an exception to the firewall for VNC Server,
and then click on Next.

i3 WNC?Setup = [

Firewall Configuration n
Add a WMC Server firewall exception

-

To enable users to connect, an exception must be added to the firewall, YNC Server
can attempt to add this exception, or you can configure the firewall yourself.

Mote that some firewalls may prevent YMC Server adding an exception. If users
experience connection problems, examine the firewall's settings.

Add an exception to the firewall for VMC Server

[ < Back ][ Mext = ][ Cancel ]

L

Please click on Install button to install VNC.

i3 WNC?Setup = [

Ready to Install n
Setup is now ready to begin installing YMC on your computer.

Click Install to continue with the installation, or dick Badk if you want to review or
change any settings.

Upgrading VMC Server (5. 2.0):
Install mirror driver B
Install printer driver
Add firewall exceptions

»

VMC Server destination location:
C:\Program Files\RealVMC\WHNC Server

m

pgrading YMC Viewer

VMC Viewer destination location:
C:\Program Files\RealvMC\WNC Viewer

< Back ][ Inztall ][ Cancel
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Click on Finish button to complete VNC setup.

rﬁ! WNC?Setup o=l

n VNC?Setup Wizard completed
‘ Setup has finished installing YMC on your computer.,

Click Finish to exit Setup,

& Start VNC Viewer

Start VNC Viewer and following as below setting, click on Connect.

# VNC Server : Please input VNC Server IP Address and

connection port. The IP Address is HMI IP Address and the
connection port is click Options > Configuration > Network
App > LocalHost of DOPSoft, set port of the Application (Net
App VNC) function. The connection example for HMI IP Address
is 192.168.123.26:5900. If DOPSoft software changed the port to
5902, the VNC Viewer must be input 5902 to connect.

# Encryption : Please select Let VNC Server choose.
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- B
V2 WNC Viewsr ==
VNCE® Viewer E
AL Ul 02 168,123 26:5900 -
Encryption: ’Let‘l.-'NC Server choose v]
[ About... ] [ Options... ]
L8 A

If connection is successfully, it will appear the following window
to remind user this connection is unencrypted. User could ignore
this warning and click on Continue.

i '
W2 VNC Viewer - Encryption ﬁ

0 Unencrypted connection

The connection to this VNC Server will not be encrypted.

WMC Server: 192.188.123 283900

Your authentication credentials will be transmitted securely, but all
subsequent data exchanged while the connection is in progress may
be susceptible to interception by third parties.

[[] Dan't warn me about this again.

[ Continue ] [ Cancel ]

But if connection is failed, it will appear the following window. It
means the IP address does not exist or the VNC network
application is not enabling.

' ™
VNG Viewer -

L A

After connection successfully, VNC will ask user to input the

°
9
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connection password for HMI and VNC. The password is DOPSoft
Network App password setting of VNC, default is 12345678.

-
V2 VMC Viewer - Authentication

[S5C)

VMNC Server: 192.168.123.26:5900

Password: @0000000|

[

Ok

][ Cancel ]

N T ———

D———

If type incorrect password, it will appear the following message.

'8 ™
VNG Viewer [

:I Authentication failure

L

A

After authentication pass, the connection is established.

V& WindowsCE - VNC Viewsr = | B3
SHEXEEH 9O
$3 44 H
$6 T H
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b. Web Browser

VNC Viewer also provide web browser, it is have an easy connection
way with typing HMI IP address and port number.

Note :

v" The default connection port number for web browser is 5800. Please
do not set the connection number port to 5800 in VNC network setting

; in DOPSoft. If user set to 5800, after download to HMI, it will appear

[ following as below message to inform user to change port number.

v" It needs to install JAVA to open the browser.
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Stepl. Open the web browser, for example is using Google Chrome.
& Google Chrome browser connection example:

Please type the IP address and port number:
http://192.168.123.48:5800/.

& |E browser connection example:

Please type the IP address and port number:
http://192.168.123.26:5800/.

& Firefox browser connection example:

If use Firefox browser to connect, please turn off the proxy at first.
Then type the IP address and port number:
http://192.168.123.26:5800/.

If type incorrect IP address, it will not display any content.

11 192.168.123.26:5800

Embedded

Ve

VMG Viewer Free Edition 4.1
Credits:
Feica Chen {China)
Johan Henning (Metherlands)
See hitpiiwanan 2fon.co for information on Y C.

After typing the correct IP address, it will appear following as below
window, please click on OK.

i 4
| £ VMC Viewer : Connection Details E@g

Server: IIIEIE. 163.123.26:0

Encryption: | Mot supported

About.. | Dptinns...l Ok Cancel



http://192.168.123.26:5800/
http://192.168.123.26:5800/
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Step2. Please input the password to connect with HMI, the default

password is 12345678 which set from DOPSoft VNC.

Password: |********|

LS

| £ VMNC Authentication [No Encrypti... l =HEC] ihj

A

If type incorrect password, it will display as below error message.

I"Iél — E |'\

rfb.AuthFailureException: Authentication failure

Step3. After authenticate successfully, the connection is established.

p
|£| VNC: WindowsCE

R\

$3 3303 H

$6 9912 H
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c. Android App
Please get the VNC Viewer App from Google play store at first.
After download, please execute the app to finish the following
steps.

Stepl. Please click on the bottom left corner [ + ] to add new

connection.

UNC Viewer

1G2.168.0.105:75G00

14



How to use VNC Viewer to connect with HMI

Step2. Input the connection IP address and connection name.
(1) Please input HMI IP address and port number.

(2) User could custom the connection name.

(3) Please do not check the save password option.

(4) After finishing above setting, please click on the below icon.

Details

@ 1G2.168.0.105:5G00

@ W10RB

® Save Password []

@

15
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Step3. Complete the setting, it will display as below figure.
Please click on Connect.

Ve

Connect
ADDRESS
1G2.168.0.105:5G00 s
NAME
.
w1058 P,
DETAILS

o

16
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If input the incorrect IP address, it will appear the following message.
: .. 8% | 1:0G

The computetr's IP address could not
be contacted.

17
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Step4. It will ask user to input the password to connect with HMI, the
default password is 12345678 which set from DOPSoft VNC.

4 79% 1 050

Cancel

18
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If input the incorrect connection password, it will appear the following
message.

= . 8@ | 1:0G

4

Invalid authentication credentials
supplied.

19
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Stepb. After authenticate successfully, the connection is established.

$6 ‘ 550

20
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VNC Viewer Detail Setting
After the VNC Viewer connected with HMI, move the mouse to the

upper window, it will appear the tool bar.

V2 WindowsCE - VNC Viewsr

The following table will introduce related function.

= | B3
BEHEAXEE 9 O
$3 44 H
$6 171 H

@ New

connection

Use new connection could operate multiple HMI.

1. Click on @ it will appear as below window to type another HMI IP
Address for operating.

-
V2 VMG Viewer

— \

VHNCE Viewer

Ve

VMNC Server: | [EErmmEE ]

-

Encryption: [Let WM Server choose

’)

About... ] [ Options... ]

L

HMIs.

-

2. After new connection establishing, the VNC Viewer is connecting with two

21
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VE WindowsCE - VNG Viewer

V2 WindowsCE - VNG Viewer

07:02:51 02/22/2006 11057 07:02:53 02/22/2006 11069 11070 g
" 07:02: 55 02/22/2006 11061 07:02:58 02/22/2006 11075 11076
07:02:56 02/22/2006 11063 v 07:03:00 02/22/2006 11077 11078

] > |ia »

Il ami 350 . 0.00 an

0 0 0.0000

0.0 0.00000
$3 7194 J —— 0.00 0.000000
0.000
SETHISTORY 1 1 1 $1721 2 0
$6 #ARE J [’:'\"‘"‘f 0 0 0 0 0 0 0 0 0
ata
0 0 0 0 0 0 0 0 0
Buffer 1 _GET. Glear Buffer 2 GET.. Clear Alarm
07:02:37 02/22/2006 11043 o 07:02:43 02/22/2006 11059 11060 - 0
07:02:41 02/22/2006 11047 07:02:47 02/22/2006 11063 11064
07:02:45 02/22/2006 11051 07:02:49 02/22/2006 11065 11066

DEFAULT

=

Connection

Save

The save connection function could save the
configuration for next time connection. User executes
connection without type IP address and password.

1. Click on E , it will appear as below two windows.

-

-
Passwaord Behavior ﬁ

What do you want to do with the VMC Server password for 192, 168,123,497

(71 Don't save VNC Server password
@) Save YMC Server password
(71 Encrypt WMC Server password {recommended)

[ Don't ask me this again

0K ] [ Cancel
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p
1B VNC Address Book

File Edit

View Toaols

Help

El 7. 2.9

Your address book is empty

Details

VNC Server:
Encryption:
Username:

Options:

0 entries

Master Password: Stored

L

A

Please choose Save VNC Server Password in Password Behavior
window, and then click on OK to save connection.
After saving, the configuration is saved as to VNC Address Book.

-
1B VNC Address Book

() [ |

File Edit View Tools Help
Alphabetic | Hierarchical
1 (1)
VB 192,168.123.26
Details
VMC Server: 192.168.123.26
Encryption: Let VMC Server choose
Username: TIMA.Q.LEE
Options:
1 entry haster Password: Stored
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User also saves multiple connections as below figure.

-
1B VNC Address Book = | (E] e
File Edit | View | Tools Help

B X &

12 4
VB 192.168.123.26
VB 192.168.123.49

Details
VNC Server: 192.168.123.49
Encryption: Let VMC Server choose
Username: TIMA.Q.LEE
Options:
2 entries Master Password: Stored

L -

Only start VNC Address Book and select the connected IP address when
next connection.

X Close Close connection will close VNC Viewer with HMI

Connection | connection

Click on =% | it will ask users the following question.

VMC Viewer l"'"*‘-""-]

| Are you sure you want to disconnect?

Yes l | Mo

L A

Click on Yes, it will close the connection.
Click on No, the connection is still connecting.

Detailed setting for VNC Display, Inputs,

% Options Troubleshooting, and Expert. All of these
configurations is VNC original setting, and use default

parameters to connect with HMI. Therefore, this part

24
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does not describe more explanation.
Full Screen L
The function is display full screen.
Mode
Connection . . .
ﬁ ) Get more connection information for VNC Viewer.
Information

-

V2 WMC Viewer - Connection Informaticn

S

Desktop name:
VMC Server:
Size:

Pixel format:

VMC Server default:

Requested encoding:

Last-used encoding:
Line-speed estimate:
Pratocol version:
Security method:
Connection type:

Extensions:

WindowsCE

192 168.123 265900

800« 600

depth 15 (16 bpp) little-endian rgb555
depth 15 (16 bpp) little-endian rgb555
TRLE

Hextile

20000 kbit/s (RTT ~0ms)

3.8

VnchAuth [no encryption]

Dhrect TCP
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